Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

TechEkspert 22 Paź 2020 19:31 4314 39
  • Wnętrze oscyloskopu 4 kanałowego Rigol DS1074
    Tym razem przy okazji usuwaniu kurzu zaglądamy do wnętrza oscyloskopu 4 kanałowego Rigol DS1074. Śruby i wkręty mocujące znajdują się na tylnej ścianie oraz pod górnym uchwytem. Na tylnej ścianie znajdziemy złącza zasilania, komunikacji oraz dodatkowe złącze BNC.




    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074 Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Po demontażu tylnej ścianki nie zobaczymy zbyt wiele, metalowa obudowa pełni także funkcję ekranującą. Włącznik pozwala na całkowite odcięcie zasilania sieciowego.

    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Zasilacz i ekranowanie oraz źródło szumu.


    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Wentylator jest całkiem dobrej jakości.

    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Odsunięcie go od kratki może nieco zmniejszyć hałas.


    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    W zasilaczu znajdziemy elementy filtrujące i zabezpieczające. Moduł zasilania dostarcza kilku napięć dla płytki głównej.

    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074


    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Oto płytka główna, pod metalową puszką znajdują się obwody wejściowe, tam nie zaglądałem.

    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Na płytce widoczne są puste miejsca wykorzystywane w wersji z analizatorem stanów logicznych, prawdopodobnie są to miejsca na FPGA i RAM.

    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074

    Oscyloskop pobiera ~20W mocy z sieci zasilającej.
    Na zdjęciach PCB (szczególnie po wybraniu opcji "oryginalne zdjęcie") zauważycie wiele krętych linii sygnałowych przeznaczonych do szybkich transmisji cyfrowych,
    jak myślicie czy jest to bardziej dopasowanie impedancji czy też wyrównanie długości torów transmisyjnych?

    Fajne! Ranking DIY
    [3.12.2020, webinar] Zagadnienia pomiarowe w nowoczesnej inżynierii materiałowej. Zarejestruj się
    O autorze
    TechEkspert
    Redaktor
    Offline 
    W moich materiałach znajdziecie testy i prezentacje sprzętu elektronicznego, modułów, sprzętu pomiarowego, eksperymenty. Interesuje mnie elektronika cyfrowa, cyfrowe przetwarzanie sygnałów, transmisje cyfrowe przewodowe i bezprzewodowe, kryptografia, IT a szczególnie LAN/WAN i systemy przechowywania i przetwarzania danych.
    Specjalizuje się w: elektronika, mikrokontrolery, rozwiązania it
    TechEkspert napisał 3189 postów o ocenie 2410, pomógł 10 razy. Jest z nami od 2014 roku.
  • #2
    Janusz_kk
    Poziom 29  
    Widzę że masz już wersję z radiatorem, ja mam bez i chyba go nakleję, wiatrak jest faktycznie wkurzający, zastanawiałem się jak go 1 raz rozbierałem czy naklejenie radiatorów pozwoli na wyeliminowanie wiatraka albo na znaczne ograniczenie jego mocy. Muszę zrobić eksperyment i zobaczyć co się mocno grzeje w środku.
  • #3
    adversus
    Poziom 31  
    TechEkspert napisał:
    Tym razem przy okazji usuwaniu kurzu zaglądamy do wnętrza oscyloskopu 4 kanałowego Rigol DS1047.

    Nie ma takiego modelu oscyloskopu :) Coś się koledze pokręciło :)
    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074
  • #4
    Janusz_kk
    Poziom 29  
    Teraz widzę że masz szybszą wersję, ja mam 1054 :) stąd zapewne różnice.
  • #5
    _siekier
    Poziom 22  
    Kręte ścieżki mają na celu głównie wyrównać długość linii transmisyjnych, tu już zależności czasowe mają coraz większe znaczenie, czasy propagacji sygnału są niewielkie, a zbocza strome. Zresztą widać, jak na dłoni, że takie kręte linie sygnałowe są zasadniczo potrzebne przy układach pamięci RAM - masa danych przy wysokiej częstotliwości taktowania magistrali.
  • #6
    TechEkspert
    Redaktor
    @Janusz_kk jakie są oznaczenia układu na którym u mnie jest radiator?

    @adversus tak czeski błąd w opisie chińskiego oscyloskopu, zmieniłem.

    @_siekier kręte ścieżki zauważyłem przy RAM i liniach cyfrowych do ADC.
  • #7
    Psiotrek
    Poziom 15  
    Hałas wentylatora można zmniejszyć poprzez wycięcie blaszanego ażuru zewnętrznego i zastąpienie go "bardziej ażurowym", drucianym. Dużo hałasu generuje zaburzenie strumienia powietrza na ostrych krawędziach blach. Można też całkowicie zrezygnować z ażuru zewnętrznego, dołożyć rezystor szeregowy, ale to może rodzić (słuszny skądinąd) opór purystów, którzy uważają, że jak fabryka zrobiła to lepiej nie grzebać...
    Czy ten wentylator ma regulację obrotów w zależności od temperatury?
  • #8
    Janusz_kk
    Poziom 29  
    TechEkspert napisał:
    @Janusz_kk jakie są oznaczenia układu na którym u mnie jest radiator?

    Nie pamiętam ale to chyba jakieś fpg-a, muszę rozebrać aby popatrzyć teraz nie mam za bardzo czasu, mam kilka pilnych rzeczy do naprawy..
    Ale sprawdzę bo jak widzę to muszę mu przykleić radiator bo ostatnio mu 'podkręciłem' pasmo.
  • #9
    Fimek
    Poziom 13  
    Czegoś tu brakuje.... a, wiem, schematu!
    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074DS1052E_HW...nt-end.jpg Download (397.63 kB)
    To jest schemat front-endu od 2-kanałowego brata DS1052E, ale o ile wiem, w 1074 projekt stopnia wejściowego jest ten sam. Jeśli ktoś chce, to sobie znajdzie schematy kilku pozostałych bloków oscyloskopu. Podrzucam front-end, bo jest moim zdaniem dobrze zaprojektowany i można się na nim wzorować w swoich konstrukcjach.

    Wg mnie 1074 (ten z wątku) jest mniej dopracowany od 1052E. Teoretycznie są 4 kanały, ale software zacina się trochę, jak również widoczne są zakłócenia z wewnętrznej przetwornicy, które przenikają na wejście, szczególnie do kanału 1. Mnie to bardzo drażniło. Czy potwierdzacie to w swoich egzemplarzach? Za to jestem pod wrażeniem 1052E. Ma bardzo dobrze dopracowane i responsywne oprogramowanie. Aczkolwiek 1074 potrafi dekodowac protokoły (z podmienionym firmware oczywiście) - to duży plus. Wentylator za głośny, do poprawki. Na podstawie czasu narastania impulsu mogę powiedzieć, że po "upgrade" mój oscyloskop ma 120 MHz pasma.

    Dave z EEVblog przedstawił problem z szumami fazowymi generatora PLL będącego wzorcem częstotliwości w 1054 (co prawda nie 1074, ale jest to raczej to samo). Na szczęście pokazał też, jak się z problemem uporać.

    Rigole to takie małe killery :) polecam zwrócić uwagę na model MSO5074. Na oficjalnej stronie Rigola kosztuje niespełna 5000 zł brutto. Prosty cyfrowy upgrade i pasmo rozrasta się do 350 MHz + odblokowane zostaje dekodowanie protokołów cyfrowych. To jest całkowicie poza konkurencją odnosząc się do bardziej markowych rywali.

    Pozdrawiam,
    Fimek
  • #10
    Janusz_kk
    Poziom 29  
    Fimek napisał:
    Dave z EEVblog przedstawił problem z szumami fazowymi generatora PLL będącego wzorcem częstotliwości w 1054 (co prawda nie 1074, ale jest to raczej to ramo). Na szczęście pokazał też, jak się z problemem uporać.

    Możesz dać linka do tego?
  • #12
    moze-byc
    Poziom 24  
    Fimek napisał:

    Wg mnie 1074 (ten z wątku) jest mniej dopracowany od 1052E. Teoretycznie są 4 kanały, ale software zacina się trochę, jak również widoczne są zakłócenia z wewnętrznej przetwornicy, które przenikają na wejście, szczególnie do kanału 1. Mnie to bardzo drażniło. Czy potwierdzacie to w swoich egzemplarzach? Za to jestem pod wrażeniem 1052E. Ma bardzo dobrze dopracowane i responsywne oprogramowanie. Aczkolwiek 1074 potrafi dekodowac protokoły (z podmienionym firmware oczywiście) - to duży plus. Wentylator za głośny, do poprawki. Na podstawie czasu narastania impulsu mogę powiedzieć, że po "upgrade" mój oscyloskop ma 120 MHz pasma.

    Mam DS1054Z, odblokowany na maxa niestety razem z pamięcią :/. No i softem od 1074. Przeróbka o jakiej piszesz zadziała też u mnie? Napiszesz coś więcej?
  • #13
    ^ToM^
    Poziom 38  
    moze-byc napisał:

    Mam DS1054Z, odblokowany na maxa niestety razem z pamięcią :/. No i softem od 1074. Przeróbka o jakiej piszesz zadziała też u mnie? Napiszesz coś więcej?


    Ja też mam odblokowany, ale poprzez kody. Prawdopodobnie może to nie nie mieć wpływu na możliwość update firmware.
  • #14
    moze-byc
    Poziom 24  
    Ja również. Niestety odblokowałem sobie też pamięć co sprawiło że całość działa mniej... dynamicznie. Musiałbym pokombinować nad downgradem. A soft od 1074Z wgrałem bo ma kilka opcji więcej, nie licząc tych od złącza stanów logicznych którego 1054 nie ma.
  • #15
    ^ToM^
    Poziom 38  
    moze-byc napisał:
    Ja również. Niestety odblokowałem sobie też pamięć co sprawiło że całość działa mniej... dynamicznie.


    Nie wiem co rozumiesz przez to, że odblokowałeś pamięć? Ja nie wgrywałem żadnego nowego softu, ale użyłem kodu wygenerowanego przez powszechnie znaną wszystkim rigolowcom stronę:

    http://www.gotroot.ca/rigol/riglol/

    Moim zdaniem odblokowywanie kodami nie powinno mieć żadnego wpływu na możliwość późniejszego apgrejdu firmłeru, natomiast jak wymieniłeś soft, to może być rzeczywiście problem. Przecież masz soft z innej maszyny i apgrejd może się wtedy nie powieść.
  • #16
    moze-byc
    Poziom 24  
    Również korzystałem z tej strony. Odblokowanie modelu DS1054Z przy użyciu kodów działa zarówno na sofcie z DS1054Z jak i DS1074Z.
    Ale jak pewnie wiesz masz różne kody do odblokowania różnych funkcji:
    Wnętrze oscyloskopu 4 kanałowego Rigol DS1074
    Teoretycznie wszystkie coś usprawniają, w praktyce kod odblokowujący 24M Memory ( jak i kod odblokowujący wszystko) sprawia że sprzęt działa bardziej ociężale, jakby z lagami. Chciałbym to cofnąć ale nie jestem pewien jak.
  • #17
    ^ToM^
    Poziom 38  
    moze-byc napisał:

    Teoretycznie wszystkie coś usprawniają, w praktyce kod odblokowujący 24M Memory ( jak i kod odblokowujący wszystko) sprawia że sprzęt działa bardziej ociężale, jakby z lagami. Chciałbym to cofnąć ale nie jestem pewien jak.


    Zrobiłem też opcję 24M ale nie zauważyłem żadnych negatywnych skutków tego. Może po prostu nie udało mi się jeszcze tego odkryć.
    Napisz co mam ma zrobić, aby doświadczyć tego co u Ciebie występuje. Jak będę w domu to sprawdzę czy aby mój nie zachowuje się podobnie do Twego.

    Jak cofnąć zmiany - możesz wypróbować to:
    Link

    Co jeśli chcesz odinstalować opcje i przywrócić domyślne ustawienia fabryczne? Czy to jest możliwe? Cóż, w rzeczywistości jest całkiem możliwe odwrócenie aktualizacji oprogramowania dokonanych w oscyloskopie Rigol. Aby to zrobić, podłącz zakres do sieci za pomocą wtyczki Ethernet z tyłu oscyloskopu. Aby sprawdzić, czy możesz połączyć się ze swoim zakresem, wypróbuj adres IP 192.168.1.102 (lub 192.168.0.102). Zwykle jest to ustawienie domyślne.
    Jeśli nie znasz adresu IP swojego zakresu, możesz się tego dowiedzieć, wykonując następujące czynności:


    Naciśnij przycisk Utility> Ustawienia we / wy> Konfiguracja sieci LAN.

    Spowoduje to wyskakujące okienko z oknem LXI pokazującym adres IP, maskę podsieci itp. Skopiuj ten adres IP i wprowadź go w przeglądarce. Jeśli widzisz interfejs Rigol web / LXI, masz prawidłowy adres IP. Następnie musisz połączyć się Telnet z oscyloskopem za pomocą programu takiego jak PuTTY lub Terminal. Będziesz musiał określić port 5555, aby połączyć się z oscyloskopem.

    Po nawiązaniu połączenia i wyświetleniu kursora, aby uruchomić polecenie odinstalowania, wpisz następujące polecenie i naciśnij Enter. Jeśli się powiedzie, Twój zakres będzie emitował sygnał dźwiękowy / brzęczenie.

    : SYStem: OPCJA: ODINSTALUJ

    Spowoduje to odinstalowanie wszystkich opcji z powrotem do domyślnych ustawień fabrycznych. Jeśli chcesz uruchomić Instalację z telnetu, wprowadź następujące polecenie, a następnie klucz aktualizacji oprogramowania (bez myślników) i naciśnij Enter. Jeśli celownik się powiedzie, powinien wydać sygnał dźwiękowy / buczeć.

    : SYStem: OPCJA: INSTall XXXXXXXXXXXXXX <- gdzie X to wygenerowany poprzednio klucz aktualizacji oprogramowania.
  • #18
    moze-byc
    Poziom 24  
    To od razu widać. Dłużej wszystko ładuje nawet przy przełączaniu podstawy czasu i rozdzielczości. Od razu po odblokowaniu rzuciło mi się to w oczy a po przeczytaniu w internecie odkryłem co za tym stoi.

    Dodano po 30 [minuty]:

    O proszę, ciekawy sposób. Sprawdzę potem.
  • #19
    ^ToM^
    Poziom 38  
    moze-byc napisał:
    To od razu widać. Dłużej wszystko ładuje nawet przy przełączaniu podstawy czasu i rozdzielczości.


    Jak wrócę do domu to sprawdzę jak długo ładuje. Choć gdybyś zmierzył jakąś powtarzalną nastawę stoperem to miałbym jak porównać. Bo jak mówię, mnie się nie rzuciło w oczy żadne spowolnienie.

    Można spróbować to cofnąć do ustawień fabrycznych i na nowo dodać kody z pominięciem opcji pamięci.
  • #20
    moze-byc
    Poziom 24  
    ^ToM^ napisał:
    Można spróbować to cofnąć do ustawień fabrycznych i na nowo dodać kody z pominięciem opcji pamięci.

    Sam będę cofał to spróbuję nagrać. Mój telefon nagrywa w 480fps także powinno się udać.
  • #21
    moze-byc
    Poziom 24  
    @^ToM^ Faktycznie za drugim azem dostałem potwierdzenie na oscyloskopie że wszystkie update'u zostały usunięte. Teraz kombinuję jak to sprawdzić :) Niby pokazuje wszędzie Trial i Trial Done, ale mądry ja nie sprawdziłem jak pokazywało przed downgradem.
  • #22
    Janusz_kk
    Poziom 29  
    Sprawdziłem, po odblokowaniu opcji w 1054 pokazuje ds1104z, a w opcjach pisze 'official'.
  • #23
    moze-byc
    Poziom 24  
    A ja potwierdzam, tamtym sposobem zrobiłem downgrade a potem przy użyciu tej samej konsoli bo szybciej, zrobiłem update wszystkich opcji prócz uwaga! nie 24M pamięci tylko 500uV. Pamiętałem że któraś opcja wprowadzała problemy. I faktycznie oscyloskop chodzi teraz zauważalnie szybciej.
  • #24
    Janusz_kk
    Poziom 29  
    Ustawiałeś adres ip czy wg 'fabrycznego', bo próbuję to samo zrobić i mi daje jakiś dziki spoza sieci, no i putty wywala błąd że nie odpowiada.
    No i podłączałeś przez ruter z kompem czy bezpośrednio?
  • #25
    moze-byc
    Poziom 24  
    Janusz_kk napisał:
    Ustawiałeś adres ip czy wg 'fabrycznego', bo próbuję to samo zrobić i mi daje jakiś dziki spoza sieci,

    Kliknij Utility na oscyloskopie, dalej nie pamiętam ale sprawdzisz tam adres IP. Jak wpiszesz go w przeglądarce to otworzy Ci się strona z oscyloskopem jeżeli IP jest poprawny.
    Potem łaczysz się prze putty podając IP, 5555 i rodzaj połączenia telnet.
    Janusz_kk napisał:
    No i podłączałeś przez ruter z kompem czy bezpośrednio?

    Tak.
  • #26
    Janusz_kk
    Poziom 29  
    moze-byc napisał:
    Kliknij Utility na oscyloskopie, dalej nie pamiętam ale sprawdzisz tam adres IP. Jak wpiszesz go w przeglądarce to otworzy Ci się strona z oscyloskopem jeżeli IP jest poprawny.

    Ale wiem gdzie tego szukać, tylko ip mam spoza sieci, dlatego pytam jakie Ty miałeś.
    Zmieniałem ip na pasujące do sieci ale niewiele to pomogło.

    Dodano po 52 [sekundy]:

    moze-byc napisał:
    Janusz_kk napisał:
    No i podłączałeś przez ruter z kompem czy bezpośrednio?

    Tak.

    Ale co 'tak'? uściślij.
  • #27
    moze-byc
    Poziom 24  
    Janusz_kk napisał:
    Ale wiem gdzie tego szukać, tylko ip mam spoza sieci, dlatego pytam jakie Ty miałeś.
    Zmieniałem ip na pasujące do sieci ale niewiele to pomogło.

    Press the Utility button > IO Settings > Lan Config.
    Wyświetli Ci się okno z logiem LXI, będziesz miał podany adres IP. Wpisz go w przeglądarkę na komputerze to otworzy ci się strona tego oscyloskopu.
    Janusz_kk napisał:
    Ale co 'tak'? uściślij.

    Właśnie zdałem sobie sprawę co napisałem :P Bezpośrednio.
  • #28
    Janusz_kk
    Poziom 29  
    moze-byc napisał:
    Właśnie zdałem sobie sprawę co napisałem Bezpośrednio.

    Ok, a resztę mojej odpowiedzi też nie zrozumiałeś bo znowu napisałeś to samo :(
    wiem gdzie, pytam jaki adres miałeś?

    Dodano po 2 [minuty]:

    Mi wyświetla ip 169.254.1.5 bez podłączonej sieci.
  • #29
    moze-byc
    Poziom 24  
    Janusz_kk napisał:
    pytam jaki adres miałeś?

    Nie pamiętam.
    Wszystko robisz wg instrukcji i działa.
  • #30
    Janusz_kk
    Poziom 29  
    No ok, zadziałało, a jak wprowadzałeś kody? czy między install a XX dawałeś spację?
    :SYStem:OPTion:INSTall XXXXXXXXXXXXXX

    bo mi cały czas wywala błąd