Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Integra 64 z modułem ETHM-1 i logowanie aplikacją na Androida Integra Control

unky 04 Jan 2021 21:09 1809 16
Optex
  • #1
    unky
    Level 18  
    Witam
    Mam zainstalowaną centralę Integra64, do niej podpiąłem moduł ETHM-1 Plus.
    W module skonfigurowałem adres IP, Brama etc. Ustawiłem klucze GuardX, DLoadx itp.
    Moduł spięty z centralą za pomocą KPD+,CKM,DTM,COM oraz podpięty RS.

    Na Androidzie zainstalowałem apkę Integra Control. Skonfigurowałem połączenie bezpośrednie - na razie łączę się z sieci wewnętrznej bez przekierowania portów. A apce wpisałem Adres, Port, klucz Guard X zgodnie z tym co mam zdefiniowane w centrali.
    Apka łączy się z centralą - wyświetla się okno logowania. Niestety wpisuję hasło administratora i nie działa. Próbowałem hasło instalatora - też nie działa. Które hasło (albo gdzie się je definiuje) muszą podać w tym oknie?

    Integra 64 z modułem ETHM-1 i logowanie aplikacją na Androida Integra Control

    Czy zgodnie z opisem tutaj:
    https://www.elektroda.pl/rtvforum/topic3589162.html#18005924
    Musze dla apki Integra Control również skonfigurować opcje dla DLoadX:
    Quote:

    Przy pomocy klawiatury ustawić/ uruchomić w centrali następujące funkcje:
    • W opcjach telefonowania zaznaczyć na tak:
    - odpowiadanie mod. zew.
    - modem zew.
    - modem ISDN/GSM
  • Optex
  • #2
    alster1
    CCTV and Stationary Alarms specialist
    Każde hasło zapisane w centrali powinno działać w aplikacji Integra Control, użytkownik, administrator, instalator, istotne jest aby nie ograniczać w centrali uprawnień użytkowników "24 Podgląd stanu systemu w programie GuardX".
  • #3
    unky
    Level 18  
    Jest jakaś metoda/test żeby mieć 100% pewności że połaczenie RS pomiędzy centralą a ethm jest prawidłowe?
  • #4
    alster1
    CCTV and Stationary Alarms specialist
    RS do aplikacji nie jest Ci potrzebny, to połączenie jest potrzebne przy zdalnym podłączeniu z DloadX.
    Wszystkie dane potrzebne do działania aplikacji centrala wymienia po szynie manipulatorów.
    Zakładkę z manipulatorem w aplikacji masz dostępną?
  • #5
    unky
    Level 18  
    alster1 wrote:
    RS do aplikacji nie jest Ci potrzebny, to połączenie jest potrzebne przy zdalnym podłączeniu z DloadX.
    Wszystkie dane potrzebne do działania aplikacji centrala wymienia po szynie manipulatorów.
    Zakładkę z manipulatorem w aplikacji masz dostępną?


    Mam problem z zalogowaniem się tak jak na zrzucie ekranu powyżej. Bez zalogowania się nie ma zakładki Manipulatora w aplikacji Integra Control.
  • Optex
  • #6
    alster1
    CCTV and Stationary Alarms specialist
    Odinstaluj tą aplikację i spróbuj zainstalować ją od nowa.
    Przed chwilą testowo dodałem sobie centralę po lokalnym IP i aplikacja przyjmuje wszystkie hasła, instalatora, administratora i użytkownika.
  • #7
    unky
    Level 18  
    Chyba faktycznie problem z aplikacją na Androida - pomimo że inny system alarmowy (Integra32) działa mi na niej prawidłowo.
    Udało mi się połączyć z centralą i ETHM za pomocą aplikacji GuardX - wpisałem hasło i pobrał dane z centrali. Tutaj jednak dziwna sprawa bo dane pobierają się KOSZMARNIE WOLNO.
    Zdecydowanie dużo wolniej niż jak łączę się z innym systemem (Integra32) który jest dużo dużo bardziej złożony. Co może być przyczyną tak wolnej transmisji danych w GuardX? Łącze się z sieci lokalnej bezpośrednio z IP centrali. Nie korzystam z połączenia przez serwery Satel'a.
    Dosłownie kilka dobrych minut trwa transmisja danych tak żeby można było korzystać z GuardX.
  • #8
    sosarek

    Level 43  
    Zaktualizuj FW Integry, na starych są problemy, także z Push chociażby - dla formalności FW Ethm także zaktualizuj.
  • #9
    unky
    Level 18  
    Moduł ETHM zgłasza się jako: ETHM-1 v 2.07
    Centrala po połączeniu GuardX: Wersja centrali 1.19, 2019-11-28

    Aktualizować?
  • #10
    alster1
    CCTV and Stationary Alarms specialist
    Firmware ETHM-a aktualne, do Integry jet teoretycznie z 13.12 2019 roku, ale to nie powinno mieć znaczenia, tak się zastanawiam czy nie masz jakiegoś problemu od strony informatycznej, spróbuj może zmienić adres IP centrali i sprawdź połączenie.
  • #11
    unky
    Level 18  
    Połączenie testowałem na dwóch różnych kablach LAN. Cała sieć LAN w domu b. szybka. Kabelek łączący ETHM z centralą to skrętka 6 żyłowa od instalacji alarmowej - podłączone 4 żyły: +KPD, COM, CKM, DTM.
    Moduł ETHM i centrala w tej samej obudowie.
    Sprawdzę z tym IP ale to raczej nie ma powinno mieć przecież znaczenia.

    PING do modułu:
    PING 192.168.0.150 (192.168.0.150) 56(84) bytes of data.
    64 bytes from 192.168.0.150: icmp_seq=1 ttl=255 time=0.321 ms
    64 bytes from 192.168.0.150: icmp_seq=2 ttl=255 time=0.265 ms
    64 bytes from 192.168.0.150: icmp_seq=3 ttl=255 time=0.196 ms
    64 bytes from 192.168.0.150: icmp_seq=4 ttl=255 time=0.227 ms
    64 bytes from 192.168.0.150: icmp_seq=5 ttl=255 time=0.264 ms
    64 bytes from 192.168.0.150: icmp_seq=6 ttl=255 time=0.230 ms
    64 bytes from 192.168.0.150: icmp_seq=7 ttl=255 time=0.248 ms
  • #12
    sosarek

    Level 43  
    unky wrote:
    podpięty RS

    Downloading wyłączyłeś?
  • #13
    unky
    Level 18  
    sosarek wrote:
    unky wrote:
    podpięty RS

    Downloading wyłączyłeś?

    Tak, wchodząc hasłem serwisowym włączyłem "Downloading"
  • #14
    sosarek

    Level 43  
    Masz go wyłączyć a nie włączyć...
    Sprawdź czy po odłączeniu kabelka RS po chwili pojawi się usterka.
    Pokaż zrzuty z ustawień modułu z DloadX.
  • #15
    unky
    Level 18  
    sosarek wrote:
    Masz go wyłączyć a nie włączyć...
    Sprawdź czy po odłączeniu kabelka RS po chwili pojawi się usterka.
    Pokaż zrzuty z ustawień modułu z DloadX.


    Kurcze byłem na budowie dzisiaj ale nie sprawdziłem elektrody i Twojej odpowiedzi.
    Jutro będę ponownie to sprawdzę. Pytanko - masz na myśli odpięcie RS'a od modułu ETHM?

    Dzisiaj natomiast zrobiłem kolejne testy i niestety z prędkością transmisji masakra. Mam 1 strefę, 1 czujkę, 1 użytkownika (Administrator) czyli w zasadzie zero danych. Łączę się GuardX bezpośrednio z sieci wewnętrznej LAN. Załadowanie całej konfiguracji po połączeniu GuwardX zajęło dokładnie 2.5 minuty. Dramat. No nic, myślę może coś z moim routerem, siecią LAN itp. No to wypiąłem laptopa i moduł z sieci LAN - połączyłem skrosowanym kablem LAN, nadałem sztywne IP modułowi ETHM i laptopowi. Łączę się i to samo. Po połączeniu pobieranie danych z centrali trwało koszmarnie długo. Postanowiłem zmienić kabel łączący moduł z centralą. Zamiast skrętki alarmowej podłączyłem po prostu 4 kabelki osobno wyciągnięte ze skrętki - +KPD, COM, CKM, DTM. Wszystko na osobnych kabelkach. Laptop podłączony bezpośrednio z modułem ETHM i nadal to samo :-( Po połączeniu ładowanie konfiguracji w GuardX trwało ok. 2.5 minuty. Już nie mam pomysły co by tu jeszcze zmienić.
  • #16
    sosarek

    Level 43  
    unky wrote:
    masz na myśli odpięcie RS'a od modułu ETHM?

    Tak, po chwili powinna pojawić się usterka.
    Masz plik z danymi systemu? Zamieść screena z ustawieniami ETHM bądź sprawdź czy masz tam zaznaczone GSM - bez tego także nie będzie działać.
  • #17
    unky
    Level 18  
    Problemy zostały rozwiązane.
    Zakupiłem oryginalny kabelek do połączenia ETHM z Centralą (PIN5<->RJ) i wszystko ruszyło z kopyta. Działa teraz tak jak powinno. GuardX pobiera dane szybko tak jak powinien a nie zamula i 3 minuty ściąga dane. Wcześniej ktoś pisał że transmisja ETHM<->Centrala z aplikacji GuardX idzie po linii DTM/CKM i faktycznie to mogło być powodem wolnego działania. Teraz po włożeniu oryginalnego kabelka komunikacja idzie przez RS'a stąd ten wzrost prędkości działania.
    Wcześniej kabelek miałem zrobiony samemu. Kabel pomierzony miernikiem, wszystkie przejścia prawidłowe i dobrze zarobione a i tak nie działało to jak należy. Dziwna sprawa. Niby kawałek kabelka, wszystkie wejścia zarobione a i tak nie działał prawidłowo. Coś w tym musi być że oryginalny kabelek to płaski przewód a nie skrętka.

    Z drugiej strony taka konkluzja odnośnie centralu Satel Integry i modułu ETHM. Te wszystkie kombinacje z kabelkami, płaski czy skrętka, oryginał czy samemu zarabiany, podłączenie modułu ETHM jako kolejny manipulator, łączenie modułu ETHM z centralą poprzez kombinacje z RS'em, czy też po linii DTM/CKM to wszystko jakiś dziwny archaizm wynikający chyba z rozbudowywania systemu archaicznego opartego o stare protokoły transmisji itd.

    Nie proście byłoby jak na centrali byłoby po prostu złącze ethernetowe i wiele problemów by zniknęło? Żadne kombinacje z modułami, kabelkami, identyfikacją modułu ETHM jako kolejny manipulator. To wszystkie kombinacje to pudrowanie trupa. Satel powinien zrobić po prostu złącze ETHERNET w centrali, wypuścić Centralę Integra 2.0 i byłoby po problemie. Tylko czy to im się opłaca?
    Wystarczyłoby podnieść cenę centrali do sumy zakupu Centrali 2.0 do kosztów zakupu modułu ETHM i centrali osobno. Dla Satela to większy zysk bo tylko jedna płytka a kasa ta sama.
    Kto chce się bawić w "pudrowanie trupa" kupuje osobno, kto chce mieć szybką i sprawną instalację kupuje centralę zintegrowaną z ETHERNETEM i po sprawie. No cóż...ale to polityka firmy wynikająca chyba z braku konkurencji na tym polu. Na dzisiaj integracja centrali z internetem to dla wielu podstawa przy instalacjach domowych i tutaj powinno być to zintegrowane dla chętnych.