Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] 600V (900V) za PFC na UC3854 - co serwis najlepszego zrobił?

Henry(k) 25 May 2021 21:06 306 3
  • #1
    Henry(k)
    Level 30  
    Witam serdecznie Panowie i Panie,

    Wstępnie linka do dokumentacji w PDF: TI UC3854.
    I teraz tak: datashhet strona 13, albo Application note U-134 strona 8 - chyba nawet lepiej tego AN, bo wzór jest na stronie 20 "Set DC output voltage".

    Pacjent - zasilacz do drukarki termicznej.
    Poszedł na taki jeden serwis, nie będę pisał który bo nie o to chodzi, ale metoda naprawy dla mnie wygląda na "wymienię jak leci elektrolity i scalaki a diody przedzwonię i zobaczymy". No i klient zobaczył - zasilacz zaraz po włączeniu wybuchł. To znaczy wyleciał w powietrze elektrolit 220uF/400V a następnie spalił się bezpiecznik.



    Reklamacja, ale po drodze zasilacz tym razem trafił w połowie drogi przypadkowo w moje ciekawskie łapska ;)
    Teraz tak. Padnięta przetwornica pomocnicza zbudowana na TOP switch. Widać była wymieniana ale nie wiem czy jak leci z resztą części, czy faktycznie padnięta była jak na serwis pojechała.
    TOP Switch wymieniłem, transoptor, sprawdziłem diody i odpalam z zasilacza regulowanego 0..400V. Przetwornica działa, napięcia wyjściowe 5V/12V/-12V wyglądają w normie, wszystko pracuje od jakichś 90V do 360V bez problemu.
    Sprawdzamy więc dalej.
    Na wejściu PFC, zasilane z tej przetwornicy pomocniczej. Widzę scalak PFC wymieniony był, UC3854N, nie ruszam go na razie, sprawdzam resztę, przetwornicę główną... wygląda dobrze. Zasilam wszystko najpierw po DC wstępnie a potem podaję 260VAC (a tyle mam po separacyjnym).
    Na kondensatorze 365V, przetwornica główna działa, PFC nie działa.

    Mierzę napięcia na UC3854N. ENA jest 3,5V więc git, Vref brak bo nie działa, Vcc 14,8V - za mało, trzeba 16V do startu. Napięcie te daje przetwornica pomocnicza. Kopię wokół niej i punktu zaczepienia brak. Wymieniam diodę prostowniczą jakąś szklaną Melf (lutowana, nie wiem czy oryginał czy tez na coś podmieniana w ramach "jak leci, życie zweryfikuje") na szybką ES1D - mam już 15,6V, ale nadal PFC milczy, za mało.
    Dolutowuję kondensator 1uF do tego obwodu prostownika (tu dziwnie zrobione, bo jest mały ceramiczny, a właściwe 47uF za rezystorami kilkanaście Ω które na scalaki PFC i przetwornicy głównej idą) i.... huraaa PFC ruszyło.
    Przez moment.
    Nie mam pojęcia czy było 16V czy 16,5V po wlutowaniu 1uF, wiem jedynie że zdążyłem odczytać ostatnie trochę ponad 600V na kondensatorze 220uF/420V. Zadziałały zabezpieczenia w moim zasilaczu separacyjnym, wszystko ładnie zgasło i wszystko dzięki temu żyje, ale musiałem po piwko skoczyć ;)
    Teraz wiem czemu wybuchło u klienta.
    No więc tak wygląda sytuacja z PFC:
    - mam UC3854N wstawiony zamiast czegoś co tam było;
    - mam mniej niż 16V na zasilaniu które jest potrzebne do rozruchu tego PFC;
    - i teraz hicior: wspomniany na początku schemat, notka aplikacyjna, wzór na rezystory do "DC Output Voltage" - rezystor Rvi to 1,19MΩ (tak, nie pomyłka, dwa szeregowo 680kΩ i 510kΩ) a Rvd katalogowe 10kΩ => przeliczyłem to ze wzoru na stronie 20 i napięcie mi wychodzi 900V na kondensatorze.

    Co tu się narobiło? Jakieś pomysły?
    - rezystory nie wyglądają na wymieniane - stara sucha cyna.
    - aplikację zrysowałem z płytki i wygląda referencyjnie (drobne różnice, pin 6 Ivac nie podciągnięte do Vref) z szeregowym dławikiem i równoległym mosfetem;
    - jest wersja UC3854BN która działa od 10,5V, ale czy ma inny wzór na rezystory pomiarowe napięcia za PFC?
    Nie pasują mi te rezystory...

    Pozdrawiam.

    PS. zmieniając rezystory jak do wzoru UC3854N jest ok, czyli scalak działa, napięcie reguluje. Coś innego siedziało tutaj więc...
  • #2
    User removed account
    Level 1  
  • #3
    Henry(k)
    Level 30  
    Zgadza się że nici. Oddali po prostu kasę.

    Ale temat jest inny, jak nakreśliłem i finalnie podpytuję:
    - co tam mogło siedzieć w PFC jeżeli dzielnik rezystancyjny do pomiaru napięcia DC ma 1190k/10k zamiast 511k/10k dla aktualnie wsadzonego UC3854N?

    Po zmianie rezystora 1190k na 511k całość pracuje poprawnie dając 400V, ale 511k nie jest wartością która tam oryginalnie była. Jest nią 1190k.


    PS. dokopałem się dzisiaj do dokumentu SLUA177A od Texas Instruments, nie wiem czemu nie udało się wczoraj. Wychodzi na to, że powinna tam siedzieć wersja A lub B, wtedy dzielnik się zgadza. A jeżeli napięcie 14,5V jest również prawidłowe to wersja B. Ale to jeszcze muszę jakoś potwierdzić zdobywając taki nie ruszany zasilacz albo fotki.
  • #4
    Henry(k)
    Level 30  
    Zgadza się że nici. Oddali po prostu kasę.

    Ale temat jest inny, jak nakreśliłem i finalnie podpytuję:
    - co tam mogło siedzieć w PFC jeżeli dzielnik rezystancyjny do pomiaru napięcia DC ma 1190k/10k zamiast 511k/10k dla aktualnie wsadzonego UC3854N?

    Po zmianie rezystora 1190k na 511k całość pracuje poprawnie dając 400V, ale 511k nie jest wartością która tam oryginalnie była. Jest nią 1190k.


    PS. dokopałem się dzisiaj do dokumentu SLUA177A od Texas Instruments, nie wiem czemu nie udało się wczoraj. Wychodzi na to, że powinna tam siedzieć wersja A lub B, wtedy dzielnik się zgadza. A jeżeli napięcie 14,5V jest również prawidłowe to wersja B. Ale to jeszcze muszę jakoś potwierdzić zdobywając taki nie ruszany zasilacz albo fotki.

    Dodano po 1 [godziny] 20 [minuty]:

    No więc udało się zdobyć fotki nie ruszanego.
    Siedzi tam oryginalnie UC3854BN.
    I temat rezystorów oraz napięcia zasilania się rozwiązał.


    PS.2. Właśnie przyuważyłem że jeszcze kondensatory elektrolityczne SMD w zasilaczu odwrotnie wlutowali jak podmieniali... nie zdążyły jeszcze wybuchnąć. Pięknie...