Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

P316 zasilacz - Niespójne działanie miernika i zachowanie zasilacza

minus3db 19 Aug 2021 01:39 360 5
  • #1
    minus3db
    Level 9  
    Cześć,

    Chciałbym zasięgnąć Waszej porady przy diagnozie usterki zasilacza P316 Meratronika (50V / 1A).

    Zanim opowiem, co mi nie pasuje, najpierw opowiem jak to powinno działać w sprawnym zasilaczu.

    Otóż sprawny zasilacz, po włączeniu i wybraniu napięcia oraz natężenia, działa w trybie źródła napięciowego (świeci zielona lampka), zaś miernik pokazuje % zadanego prądu (szczegóły pod podanym niżej linkiem). Dla przykładu, na zakresie 15mA, bez obciążenia, pokaże 25%. Jest tak dlatego, że sam stabilizator pobiera 5mA i tyle należy dodać do wyników (zgodnie z instrukcją), zatem: mamy 5mA / (15mA+5mA) = 5/20=25%. Na wyższych zakresach prądowych to 5mA w naturalny sposób "znika na skali" i wskazówka prawie się nie wychyla bez obciążenia. Podłączenie obciążenia spowoduje przepływ prądu i odpowiednie wychylenie wskazówki. Wskazania oczywiście zależą od wybrania zakresu prądowego.

    Instrukcja i schematy:
    https://delibra.bg.polsl.pl/dlibra/docmetadata?showContent=true&id=15641
    także tutaj (lepszej jakości schemat): http://docplayer.pl/4520478-Dane-techniczne-p-316.html

    Jeżeli przekroczymy zadane natężenie prądu, zasilacz wejdzie w tryb źródła prądowego (czerwona lampka) i miernik pokazuje spadek napięcia na obciążeniu.

    Tyle sprawny miernik.



    Trafił mi się miernik, który zachowuje się niespójnie z w/w opisem.

    Po włączeniu - wchodzi, jak należy, w tryb źródła napięciowego (zielona lampka). Napięcie daje się ustawiać Isostatami i regulować dodatkowym potencjometrem.

    A zatem działa przynajmniej układ wykonawczy i stabilizator napięcia.

    Po zwarciu (lub podłączenia opornika o małym oporze) wchodzi w tryb źródła prądowego - zaświeca się czerwona lampka. A zatem wydaje się działać też wewnętrzny komparator.

    Niestety, to, co pokazuje miernik, jest niespójne z trybem pracy.

    W trybie napięciowym - miernik pokazuje wybrane napięcie (a powinien pokazywać natężenie). Wskazania lampki NIE zależą od pozycji przełącznika prądów (a naturalnie powinny, przynajmniej na niskim zakresie 15mA).

    W momencie zwarcia - przełącza się do trybu CC, pokazuje > 100% i ze środka dobywa się zapach spalenizny (dalej nie testowałem - od razu wyłączyłem). Wskazania miernika nie zależą od ustawionego prądu.

    Kondensatory na wyjściu, diody zabezpieczające - są OK.

    Czy kojarzycie taką usterkę?
  • #2
    elktrod
    Level 27  
    Tak, usterka dotyczy tego elementu co czuć spaleniznę oraz ewentualnie elementów sterujących tym elementem...
    minus3db wrote:
    a powinien pokazywać natężenie

    A nie % ?
  • #3
    minus3db
    Level 9  
    Tak, % maksymalnego natężenia, tak jak to opisałem wcześniej. Po prostu użyłem skrótu myślowego. Zamiast pokazywać % pokazuje nadal napięcie na obciążeniu nawet w przypadku jego braku - tak, jak by jakieś było podłączone "wewnętrznie".

    Nie widać właśnie niczego spalonego. Czuć charakterystyczny zapach rozgrzewającego się elementu, ale jeszcze nie dym.

    Pomyślałem, że wpierw zasięgnę języka, bo może dla tych zasilaczy jest to typowa usterka i ktoś ją rozpozna z opisu. Jeśli nie, będę musiał szukać sam.
  • #4
    elktrod
    Level 27  
    Rozkręć urządzenie, włącz na sekundę, wyłącz i pomacaj co się grzeje, zrób fotkę, pokaż itd itp...
  • #5
    januszx3
    Level 31  
    Czy masz wykonane połączenia między zaciskami na płycie czołowej, dwoma oryginalnymi zworami, bez których w tych modelach zasilaczy, nie działa prawidłowo sensoryka. Najlepiej jak zamieściłbyś zdjęcie. Zasilacze te mają kilkudziesięcioletnią niechlubną historię. Bardzo dawno temu, kolega spalił układ projektowany i wykonany na układach TTL, a jak to jest możliwe w tych zasilaczach przy wyborze napięcia np. 5V, to już nie jest opisane w instrukcji, opisu nie zamieszczam bo wykracza poza Twój temat.
  • #6
    minus3db
    Level 9  
    Tak, zaciski są podłączone, przeczyszczone z rdzy i zabezpieczone "Kontaktem" do styków. Wyzwalanie tyrystora, a zatem i generator impulsów - wydają się działać, bo można ustawić napięcie (cicho piszczy, na granicy usłyszenia) i to dość stabilnie, w sensie, że nie pływa bez obciążenia. To, co mnie dziwi, to fakt, że miernik wskazuje (dość dokładnie) napięcie tak - jak gdyby były w trybie CC (wedle instrukcji wskazuje wtedy napięcie na obciążeniu). Ale ciągle świeci zielona lampka - CV (żródło napięciowe).

    Gdyby był w trybie CV, na najniższym zakresie prądowym (10mA) pokazałby tak z 30% skali (5mA "dla miernika" / (10mA + 5mA) = 1/3), a zmiana zakresu prądowego na coraz wyższe spowodowałaby coraz niższe wskazania. A tutaj - nic się dzieje, czy ustawię 10mA, 100mA czy 500mA. Lampka - wciąż zielona.

    Gdy zewrę wyjście opornikiem niskoomowym (6.8o) na zakresie 10mA i 2V, wymuszając "przeciążenie", przełącza się do trybu CC i zapala się czerwona lampka. No i właśnie TERAZ miernik powinien pokazywać napięcie - a tymczasem wskazówka opada niemal do zera. Zwiększenie natężenia prądu sprawia, że transformator zaczyna być "słyszalny" (ciche lecz wyraźnie zwiększone brzęczenie) i skądś czuję "zapach gorącej elektroniki", ale nie udało mi się namierzyć gdzie.

    Na razie wstrzymałem się z pracami, bo nie bardzo wiem od czego zacząć. Jeśli powyższy opis na nic nie naprowadza, tzn. że to nie jest "typowa usterka" (powszechnie znana i łatwa do zdiagnozowania z opisu) i muszę sprawdzić poszczególne wzmacniacze błędu dla części napięciowej i prądowej oraz "bramkę".

    Już myślałem, że te duże kondensatory na wyjściu (oraz na listwie z tyłu) mają zwarcie, ale nie. Widać, że w stosunku do tego o wyższym napięciu (p317) doszły dodatkowe diody na przełączniku natężeń i dodatkowe elementy (chyba jakaś Zenerka w obudowie metalowej jak w BC107, kondensator ceramiczny, rezystor) na bocznej płytce - tej bez transformatora impulsowego. Nie wiem, czy to dodatek Meratronika, czy "praca własna".

    No nic, odłożone na później.

    PS: tak dla ciekawostki - jego brat, P317 pomyślnie przeszedł test diody LED na zakresie 50V i 20mA. Diodzie nic się nie stało.