Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Wzmacniacz audio na bazie kitów z Chin, dziwne zakłócenia

hetm4n 01 Nov 2021 00:04 861 5
  • #1
    hetm4n
    Level 20  
    Witam! Kupiłem u Chińczyków kilka modułów do budowy wzmacniacza audio do użytku imprezowego w lokalach (urodziny/prywatki, sylwestry itp.), oraz aby spełniał funkcje wzmacniacza słuchawkowego na wieczorne seanse TV gdy wszyscy śpią.
    Zakupiłem:
    - Wzmacniacz mocy klasy D na układzie TDA 7498,
    - Przedwzmacniacz z regulacja barwy na układzie UPC1892,
    - Wzmacniacz słuchawkowy na układzie TPA6120
    - Zasilacz impulsowy AC230V> DC 36 V 6 A
    - przetwornica napięcia symetrycznego ustawiona na +-14 V

    Połączone wszystkie moduły wg schematu blokowego (przepraszam za kiepskie wykonanie, ale na szybko to kleiłem na telefonie). :)



    Wzmacniacz audio na bazie kitów z Chin, dziwne zakłócenia

    Wszystko gra fajnie, problem jest z zakłóceniami w tle o dziwnej wyższej częstotliwości falującej gdy podepnę równolegle sygnały wychodzące z przedwzmacniacza L R GND wejść Audio na wzmacniacze. Gdy odepnę któryś z wzmacniaczy z tego sygnału jest cisza, brak zakłóceń.
    Wstawiłem przełącznik który odłącza masę sygnałową wzmacniacza tda7498 lub TPA6120. Wtedy na TPA brak zakłóceń, zostają zakłócenia troszkę cichsze na wzmacniaczu TDA 7498 gdy masa od TPA jest odpięta.

    Jak rozwiązać ten problem zakłóceń?
  • #2
    puszak
    Level 28  
    Poczytaj o pętli masy i jak sobie z nią radzić, ja bym też sprawdził co wychodzi z tych przetwornic, ale to potrzeba oscyloskop.
  • #3
    hetm4n
    Level 20  
    Co do przetwornic gdy 1 z wzmacniaczy jest odpięty od sygnału wyjściowego przedwzmacniacza jest cisza, 0 zakłóceń. Masy audio w tych modułach są odseparowane od mas zasilania. Jeszcze co mi przychodzi do głowy by spróbować to przedwzmacniacz zasilić z osobnej przetwornicy stepdown podłączonej do zasilacza 36 V, bo aktualnie używa napięcie z przetwornicy zasilania symetrycznego wzmacniacza słuchawkowego na tpa.
  • #4
    viayner
    Level 42  
    Witam.
    Zauważyłeś, że masz w układzie 3 przetwornice napięcia, każda pracuje z inną częstotliwością i zapewne masz interferencje. Niby przetwornica ma na wyjściu filtry, ale jakiej są one jakości.
    Żadna z tych przetwornic nie była optymalizowana pod względem zastosowań audio i zasilania kolejnej przetwornicy.
    Jest jeszcze możliwość, że coś ci się indukuje w słabej jakości przewodach wejściowych, lub są źle poprowadzone/ekranowane.
    Pozdrawiam
  • #5
    mieczotronix
    Level 16  
    Widzę że przedwzmacniacz ma 7805 i 7812 do stabilizacji zasilania. Jeśli źródłem szumu jest moduł przedwzmacniacza (skoro całość nie szumi po odpięciu go od końcówki mocy), to może zasilanie przedwzmacniacza +14 V to za mało, żeby 7812 dobrze stabilizował i trzeba by dać większe napięcie (+15 V)?
  • #6
    hetm4n
    Level 20  
    Kombinowałem na różne sposoby, zmieniłem koncepcje, wywaliłem wzmacniacz słuchawkowy, w obudowie zostaje przedwzmacniacz z wzmacniaczem tda, natomiast wzmacniacz słuchawkowy robię w osobnej obudowie i domowiłem 2 przedwzmacniacz do tej konstrukcji.