Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] IGBT/falownik - przebiegi i zakłócenia

ebson1307 07 Nov 2021 13:40 423 25
Tespol
  • #1
    ebson1307
    Level 3  
    Witam, podobny post pisałem jakiś czas temu. Buduję prototyp falownika i podczas testów na oscyloskopie widoczne są przepięcia. Wcześniej miałem taki sam problem, ale teraz połączenia zostały zoptymalizowane, dodanana pojemność filtrująca ok 1mF a ścieżki i połączenia toru głównego możliwie szerokie i grube. Przebiegi na bramkach low side i high side są wręcz idealne. Niestety na wyjściu tranzystorów igbt już tak kolorowo nie jest. Widoczne są szpilki napięciowe, ale są one o tyle dla mnie dziwne, że nie występują na zboczach sygnału PWM tylko tak jakby w środku. Narazie testuję układ na zasilaczu laboratoryjnym przy napięciu max 31V ale chciałbym przeprowadzić testy przy pełnym wyprostowanym 400V AC z sieci. Niestety nie wiem czy gdy to zrobię nie uszkodzę układu. Załączam zdjęcia do oceny, czy jest się czego bać czy to tylko jakieś zakłócenia które zbiera sonda oscyloskopu? Dodam, że muduły prostownika jak i IGBT są na 1200V więc jest sporo "rezerwy" ale nie jestem pewny czy warystor którego napięcie to 750V nie będzie powodował zadziałania zabezpieczeń. Czy po podaniu takich przebiegów na silnik, owe szpilki zostaną odfiltrowane przez indukcyjnośc? IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia
  • Tespol
  • #2
    jarek_lnx
    Level 43  
    "Szpilki" maja inną częstotliwość - wniosek nie pochodzą z falownika.
  • Tespol
  • #3
    atom1477
    Level 43  
    Mogą pochodzić z falownika, ale nie z części mocy HV.
    Mogą to być np. szpilki z przetwornicy 12V (czy jaka tam jest).
  • #4
    ebson1307
    Level 3  
    A czy mogą pochodzić z sygnałów bramkowych IGBT? Jedyna przetwornica jaką stosuję to 15V, przy czym jest ona dobrej jakości. Ogólnie to zakłócenia i EMI to nie jest grunt na którym czuję się pewnie, więc zwrócę się do Panów z pytaniem czy to są szpilki przechwytywane przez oscyloskop czy szpilki zasiane w realnych przebiegach częsci mocy? Przykładowo zwiekszajac napięcie na zasilaczu proporcjonalnie rosną mi szpilki na ekranie, i teraz nie wiem czy jak nie dam wyprostowanego 560V DC to nie dostanę szpilek ok 700V. Czy jest to duże zagrożenie, czy raczej bez problemu mogę testować na napięciu znamionowym?
  • #5
    atom1477
    Level 43  
    ebson1307 wrote:
    A czy mogą pochodzić z sygnałów bramkowych IGBT?

    Z sygnałów bramkowych były by w fazie z prze biegami wyjściowymi.
    Czyli nie.

    ebson1307 wrote:
    Jedyna przetwornica jaką stosuję to 15V, przy czym jest ona dobrej jakości.

    Nawet jedna to może być o jedna za dużo.
    I co to znaczy dobrej jakości? Liczy się layout płytki.

    ebson1307 wrote:
    Ogólnie to zakłócenia i EMI to nie jest grunt na którym czuję się pewnie, więc zwrócę się do Panów z pytaniem czy to są szpilki przechwytywane przez oscyloskop czy szpilki zasiane w realnych przebiegach częsci mocy?

    Mogą też być z kiepskiej jakości sond oscyloskopowych albo z za długich przewodów masy z tych sond. Coś te szpilki i tak musi generować (czyli i tak tam jest jakieś źródło zakłóceń), no ale sondy mogą zawyżać ich poziom.

    [quote="ebson1307]Czy jest to duże zagrożenie, czy raczej bez problemu mogę testować na napięciu znamionowym?[/quote]
    Może to być zagrożenie.
    Lepiej się najpierw dowiedzieć skąd są te zakłócenia.
  • #6
    ebson1307
    Level 3  
    Ogólnie to wykorzystuję mały, markowy zasilacz impulsowy jako przetwornicę 15V, znajduje się on blisko płytki drivera gdzie poprzez krótkie przewody wchodzi on na piny zasilania 15V na płytce. Przy czym jest on dosyć oddalony od IGBT. Wstawiam zdjęcie ogólnego projektu płytki sterownika igbt z transoptorami (jest on lekko zmodyfikowany ale prawie identyczny co do wykonanego oryginału).IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia
  • #7
    atom1477
    Level 43  
    Nie wspomniałeś że jest to falownik 3-fazowqy.
    Wcześniej pytałeś o 1-fazowy.
    W takim razie te szpilki widoczne na danej fazie mogą pochodzić od pozostałych faz.
    Więc na próbę wyłącz 2 pozostałe fazy.
  • Helpful post
    #8
    jarek_lnx
    Level 43  
    ebson1307 wrote:
    Jedyna przetwornica jaką stosuję to 15V, przy czym jest ona dobrej jakości.
    Zobacz jej tętnienia wyjściowe i sprawdź czy są synchroniczne ze szpilkami.

    quote="atom1477"]Mogą też być z kiepskiej jakości sond oscyloskopowych albo z za długich przewodów masy z tych sond.[/quote]Warto na próbę podłączyć sondę z krótką masą.
    IGBT/falownik - przebiegi i zakłócenia
  • #9
    ebson1307
    Level 3  
    Posprawdziałem i chyba wychodzi na to że szpilki pochodzą od innych faz lub bramek innych faz. Po odłączeniu wtyku sterowania LO i HO do jednego z połmostków szpilki znacząco spadły. Przy czym analogicznie odpinając sterowanie półmostków i sprawdzając dwa aktualnie pracujące w każdym przypadku tych największych szpilek nie było. Czy można coś z tym zrobić? Czy to jest zakłocenie od fazy obok, czy od drivera innej fazy? Jeśli od drivera, to czy amplituda szpilek wzrastała by z wzrostem napięcia? Jedyne co mogę zrobić jeśli chodzi o drivery to skrócić do maksimum przewody łączące płytkę z modułami IGBT, które i tak są już krótkie i mają z 4cm ale do 2cm jeszcze da się je skrócić.
  • #10
    atom1477
    Level 43  
    Główną przyczyną może być layout płytki (tej co zamieściłeś).

    PS. A po co Ci tam 6N136, skoro i tak nie ma tam izolacji galwanicznej?
  • #11
    ebson1307
    Level 3  
    To 6N137 tylko domyślny footprint był jedynie dla 6N136. Czyli nic poza przeprojektowaniem płytki raczej nie wchodzi w grę?
  • #12
    atom1477
    Level 43  
    No to po co Ci 6N137 :D
    Na pewno trzeba mieć dobrze zaprojektowane wszystkie płytki.
    Póki co niewiele tych płytek widzieliśmy więc i niewiele możemy doradzić.
    Ta jedna na pewno mogła by być zrobiona dużo lepiej. W obecnej wersji może emitować dużo zakłóceń.
  • #13
    ebson1307
    Level 3  
    Ale tam jest izolacja galwaniczna, masa mikrokontrolera i płytki nie są wspólne, mam dwa osobne zasilania 5V. Poniżej zdjęcia tego wszystkiego, może nie jest idealnie bo termotransfer mnie trochę ogranicza i ciężko czasem wykonać tym sposobem skomplikowane i małe PCB, ale zależy mi na tym by wszystko było zrobione samodzielnie, bez gotowych zamówionych PCB. Jest tam płytka z kondensatorami, pod nią ta z softstartem, dodatkowo płytka z 2x 5V DC oraz sterująca, przetwornica 15V poza kadrem. Może to trochę dziwne że tyle płytek tam jest ale to ma być przede wszystkim w celach edukacyjnych dla mnie a także, gdy np będę chciał coś w przyszłości usprawnić to odkręcam starą plytkę i wymieniam na nowszą - tak to sobie wymyśliłem. IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia
    Edit: Podłączyłem do wyjść IGBT: krokodylek do L1 a pozostałe 2 sondy do L2 i L3 by dostać przebiegi 2ch faz przesuniętych względem siebie. Dostałem coś takiego. Dziwne, że zmiana stanu sygnału w fazie pierwszej wywołuje szpilkę w L2. Czym to jest spowodowane? IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia IGBT/falownik - przebiegi i zakłócenia
  • #14
    atom1477
    Level 43  
    ebson1307 wrote:
    Ale tam jest izolacja galwaniczna, masa mikrokontrolera i płytki nie są wspólne, mam dwa osobne zasilania 5V.

    No może i jest, ale jej wytrzymałość to z 50V. Bo wylałeś masę strony wtórnej po stronie strony pierwotnej, i dałeś bardzo mały clearance od ścieżek do tej masy.

    ebson1307 wrote:
    Poniżej zdjęcia tego wszystkiego, może nie jest idealnie bo termotransfer mnie trochę ogranicza i ciężko czasem wykonać tym sposobem skomplikowane i małe PCB, ale zależy mi na tym by wszystko było zrobione samodzielnie, bez gotowych zamówionych PCB.

    Fajnie że Ci się chce.
    W sumie da się to zrobić i lepiej i łatwiej.
    Żeby układ był lepszy, powinien mieć w miarę jednolitą płaszczyznę masę. Czyli maksymalnie dużo ścieżek na stronie Top, a jak najmniej po stronie Bottom.
    Trochę to utrudnia projektowanie, ale potem upraszcza wykonanie. Brak ścieżek po stronie Bottom oznacza że nie będziesz musiał robić dużej ilości przelotek.
    Obecnie masz ścieżki po obu stronach, a masa jest mocno poszatkowana.
    Zupełnie nie ma przejścia masy od środkowego Drivera bezpośrednio do wyjścia. Masa łączy tylko na około. Więc prądy płyną dużymi pętlami, co daje duże zakłócenia.
    Masy do sterowania dolnych tranzystorów pobierasz z jednego złącza, daleko od wyjść z Driverów. A powinno się pobierać z miejsca jak najbliżej Drivera. Czyli do każdego tranzystora z innego miejsca płytki.
    Pasowało by dać duży Clearance pomiędzy wyprowadzeniami Driverów Low Side i High Side.
  • #15
    ebson1307
    Level 3  
    No to spróbuję przeprojektować płytkę i zobaczę czy będą efekty. Tylko trochę nie rozumiem, jak np płytka może powodować sianie w przebiegach strony mocy, gdy na bramkach jest wręcz idealnie zarówno po stronie HO i LO, tam szpilek nie ma. Natomiast nagle się pojawia po stronie mocy, gdzie sciezki są szerokie i mają małą indukcyjność, do tego ścieżki mocy są oddalone od płytki driverów. Do tego te zbocza, przy danej fazie nie ma tam szpilek ale zmiana stanu w L1 tak jakby wywołuje szpilkę w fazie L2, mimo że przebieg L1 jest dość czysty (tak to rozumiem na podstawie przebiegów). Dodając do tego indukcyjność silnika, czy te szpilki na przebiegach L1,L2,L3 nie zostaną po prostu odfiltrowane przez uzwojenia silnika?
  • #16
    atom1477
    Level 43  
    ebson1307 wrote:
    Tylko trochę nie rozumiem, jak np płytka może powodować sianie w przebiegach strony mocy, gdy na bramkach jest wręcz idealnie zarówno po stronie HO i LO, tam szpilek nie ma.

    Jak mierzysz na bramce która ma jakąś pojemność, to nie zobaczysz zakłóceń bo ta pojemność je stłumi. A na stronie wtórnej wcale nie ma tak małej indukcyjności. Nawet te dwie grube szyny mają sporą indukcyjność.

    ebson1307 wrote:
    Podłączyłem do wyjść IGBT: krokodylek do L1 a pozostałe 2 sondy do L2 i L3 by dostać przebiegi 2ch faz przesuniętych względem siebie. Dostałem coś takiego. Dziwne, że zmiana stanu sygnału w fazie pierwszej wywołuje szpilkę w L2. Czym to jest spowodowane?

    Nie jest to dziwne. To jest klasyczny powód powstawania zakłóceń.
  • #17
    ebson1307
    Level 3  
    atom1477 wrote:

    Jak mierzysz na bramce która ma jakąś pojemność, to nie zobaczysz zakłóceń bo ta pojemność je stłumi. A na stronie wtórnej wcale nie ma tak małej indukcyjności. Nawet te dwie grube szyny mają sporą indukcyjność.

    A czy w takim razie pojemność od członu z kondensatorami strony wtórnej nic tu nie odliltruje? i co z tą indukcyjnością silnika która działa jak filtr dolnoprzepustowy? Nie odsieje szpilek?
    atom1477 wrote:

    Nie jest to dziwne. To jest klasyczny powód powstawania zakłóceń.

    Czyli jedynym i najlepszym wyjściem jest tu przeprojektowanie płytki drivera, czy są inne sposoby? Tylko co wtedy z przewodami pomiędzy modułami a płytką, mogą się lekko przeplatać i mieć z 2-3cm długości?
  • #18
    atom1477
    Level 43  
    ebson1307 wrote:
    i co z tą indukcyjnością silnika która działa jak filtr dolnoprzepustowy? Nie odsieje szpilek?

    Odfiltruje. Ale nie o silnik tu chodzi. Jemu te szpilki nie zaszkodzą.
    Ale skoro są szpilki, to z układem jest coś nie tak więc mogą się spalić tranzystory.

    ebson1307 wrote:
    Czyli jedynym i najlepszym wyjściem jest tu przeprojektowanie płytki drivera, czy są inne sposoby?

    Możesz poprawić podłączenia do tranzystorów. Masę brać bezpośrednio z Driverów.

    ebson1307 wrote:
    Tylko co wtedy z przewodami pomiędzy modułami a płytką, mogą się lekko przeplatać i mieć z 2-3cm długości?

    Mogą mieć kilka cm długości, ale muszą być poskręcane parami. Czyli masa skręcona z sygnałem bramkowym. Ale skręcania czy przeplatania z innymi masami i sygnałami nie powinno być.
  • #19
    ebson1307
    Level 3  
    Przylutowałem przewody masy bezpośrednio do wyprowadzeń przy driverach - bez zmian. Nie wiem czy to istotne ale gdy przyłącze krokodylka sondy oscyloskopu bezpośrednio do wyjścia tranzystora i sprawdzam przebiegi to przetwornica 15V tak dziwnie piszczy, im większa amplituda napięcia z zasilacza tym głośniejszy dźwięk. Sprawdzałem przebiegi na wyjściu 15V, praktycznie czysto, poza jakimiś ledwo zauważalnymi zakłóceniami, które są naprawdę minimalne.
  • #20
    atom1477
    Level 43  
    A skręciłeś przewody masy z przewodami sygnałowymi?
  • #21
    ebson1307
    Level 3  
    Tak, skręcone parami.
  • #22
    atom1477
    Level 43  
    No to po prostu zbierasz spadki napięcia powodowane przełączeniem innych tranzystorów, które występują z powodu jakichś indukcyjności na liniach zasilania wysokiego napięcia.
    Albo masz duże prądy Shot-Thru (czyli za małe DeadTime-y) które dają duże zakłócenia nawet przy małych indukcyjnościach.
  • #23
    ebson1307
    Level 3  
    Czas martwy - testowany i 7us i nawet 12us. Co do połączeń toru głównego to próbowałem nawet na krótko do zasilacza bez metrowych przewodów i nic, żadnych zmian. Nawet minimalnych. Przy 31V zasilania szpilki dochodzą do ok 45V. Czy hipotetycznie, jak podepne to pod silnik są duże szanse że upale tranzystory? Niby dioda zwrotna w modułąch to 1200V do tego przecież silnik wygładzi przebiegi więc powinno być w porządku.
  • Helpful post
    #24
    atom1477
    Level 43  
    Podpięcie silnika może trochę zmieni.
    Ale jakby się miało spalić to już by się spaliło.
    Więc możesz podpiąć.
    Co innego zwiększanie napięcia zasilania.
  • #25
    ebson1307
    Level 3  
    Spróbuję za jakiś czas przetestować pod obciążeniem, narazie jakiś mały silniczek 0,57kW. A RC snubber - pomoże zabezpieczyć moduły, czy raczej niepotrzebny wydatek?
  • #26
    ebson1307
    Level 3  
    Poradziłem sobie z problemem, jakby ktoś miał podobny to kondensator snubber 1uF na każdy półmostek załatwił sprawę na dobre.