Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

iphone - iPhone 7 Plus slow charging ic / U2101?

Dam_MS 14 Nov 2021 10:39 300 1
Computer Controls
  • #1
    Dam_MS
    Level 9  
    Witajcie, mam zagwozdkę z ładowaniem w iPhone 7+ (poza tym działa w nim wszystko poprawnie), mianowicie samo uruchomienie tel. (na rozładowanej baterii), trwa co najmniej 15 minut. Jak na złość przy ładowaniu iphone nie wykrywa zwykłych kabli podających normalny prąd, a reaguje jedynie na gówno kable szybko ładujące. Wymiana baterii na nową nie powoduje zmian - telefon z czasem wyładowuje się i wymaga tyle samo czasu na rozruch.. ( w samym trybie uruchomienia, naładowanie do 4% zajmuje mu ok. 30 minut).

    Przyglądając się schematom, za tą usterkę odpowiada charging IC U2101 znajdujący się na odwrocie płyty (pod ekranem), jedynie zastanawiam się czy od tego zacząć diagnozę?
  • Computer Controls
  • #2
    bert_studionapraw
    Level 23  
    Czołem, cześć.

    Długi proces uruchomieniowy w 7-kach ma związek z problemem nazwanym "audio". Sprawdź sobie na tę okoliczność działanie nagrywania i odtwarzania na wszystkich urządzeniach.
    Problem długiego ładowania może mieć związek z powyższym. Sprawdziłbym jednak (po udowodnieniu, że audio działa prawidłowo) prąd ładowania. Czy dokonałeś już pomiarów rezystancji ścieżek i prądu ładowania na głównej szynie ładowania? Może i od tego powinieneś zacząć.

    Masz kilka możliwości, zależnie czym dysponujesz diagnostycznie. Wyjąłbym płytę i uruchomił z pominięciem akcesoriów (płyta, ekran-bez guzika/F.cam i zasilacz laboratoryjny, choć ja osobiście często rezygnuję z ekranu). Parametry startowe prądu (obciążenia zasilacza) wskażą kierunek diagnostyczny.

    Jeśli problem zostanie potwierdzony - instrukcja serwisowa, na takie przypadki przewiduje wymianę głównego chargera (SN2400AB0) i tristara (1610A3B) w ciemno (jeśli nie ma innych wytłumaczalnych powodów, rzecz jasna), by wyeliminować uszkodzenie wewnętrzne, które dość często się przytrafia - w związku ze stosowaniem nieoryginalnych kabli i ładowarek (zwłaszcza ładowania w samochodzie - 6/6s i 7-ki nie posiadają sprzętowego zabezpieczenia upływu).

    Jeśli jednak płyta w powyższy sposób uruchamia się właściwie, potwierdzi to problem z akcesoriami. W takim przypadku diagnostyka zmienia kierunek i "przeżegnać się siekierą" można bo to trudna i kręta droga w niektórych przypadkach.

    - pozdrawiam,