Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Router TPlink Archer MR400 VPN problem.

fidel23 12 Jan 2022 21:41 255 2
  • #1
    fidel23
    Level 10  
    Witam wszystkich i proszę o podpowiedź.
    Router TPlink Archer MR400 z kartą SIM Orange z usługą stałego, publicznego adresu IP.
    Adres LAN routera to 192.168.1.1, serwer w sieci lokalnej ma adres 192.168.1.3
    VPN PPTP. Działa prawidłowo przy adresacji domyślnej wpisanej przez producenta w tym przypadku od 10.7.0.1, niestety połączenie w takiej puli adresowej powoduje brak dostępu do serwera. Kiedy próbuję zmienić adresację dostosowując ją do adresacji LAN otrzymuje komunikat "Adres IP klienta i adres IP LAN nie mogą być z tej samej podsieci".
    W urządzeniach które dotychczas konfigurowałem (np. ASUS, Draytek, itp.) można ustawić tą samą pulę adresową dla klientów VPN bez żadych problemów.
    Ktoś wie jak to ogarnąć?

    PS. OpenVPN skonfigurowany wg. instrukcji na stronie TPlink nie łączy się w ogóle.
  • #2
    tzok
    Moderator of Cars
    Między VPN a LANem jest routing, więc w przypadku tego routera klienty VPN muszą mieć adresy z innej sieci niż LAN. Może to kwestia konfiguracji serwera, że nie przyjmuje żądań od klientów z sieci 10.0.0.0/8? W moim Asusie RT-AC1200G+ konfiguracja serwera VPN wygląda identycznie i wszystko działa jak trzeba (poza ciągłymi atakami na serwer VPN).
  • #3
    fidel23
    Level 10  
    Po kontakcie z supportem TP-Link, uzyskałem informację że połączenie VPN realizuje routing do sieci LAN i powinienem mieć dostęp do komputerów w sieci lokalnej. Jeśli tak nie jest to wina leży zapewnie po stronie firewall-a.
    Niestety, sprawdziłem jeszcze ustawienia zapory na serwerze ale tam wszystko jest odblokowane, a dostęp do sieci LAN nie działa.
    Na szczęście udało mi się połączyć po przez OpenVpn który działa bardzo dobrze, zapewniając dostęp do zasobów sieci LAN.