Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] Odcinanie obrazu przez komputer do monitora.

ikubiq2791 18 Jan 2022 23:44 402 16
  • #1
    ikubiq2791
    Level 3  
    Mam problem z odcinaniem obrazu do monitora przez komputer podczas włączania różnych gier. Czasami dzieje się to również podczas jego włączania, kilka sekund po uruchomieniu wyskakuje na monitorze: Brak Sygnału. Dźwięk nadal jest słyszalny.
    Specyfikacja komputera:
    Intel Core i7 11700F - Procesor
    Gigabyte B560 AORUS PRO AX - Płyta główna
    16 GB RAM DDR4 GOODRAM
    Gigabyte Geforce RTX 3060Ti Eagle - Karta graficzna
    BeQuiet 600W - Zasilacz
    Monitor to Acer Nitro VG271USBMIIPX
    Cały Komputer to gotowiec ze sklepu X-KOM
  • #2
    safbot1st
    Level 43  
    Na innym monitorze problem jest? Np. na tv? Jak podłączone do pc, jakim kablem?
    ikubiq2791 wrote:
    Cały Komputer to gotowiec ze sklepu X-KOM

    Złożyli bubel, to niech naprawią.
    Zapewne uszkodzenie wyjścia sygnałowego w gpu lub kabel.
  • #3
    Gelip
    Level 33  
    safbot1st wrote:
    Złożyli bubel, to niech naprawią.
    Zapewne uszkodzenie wyjścia sygnałowego w gpu lub kabel.

    Hymm... Nie sądzę aby to było uszkodzenie wyjścia. Mam taki sam problem, monitor i kabel DP-DP nowe tylko karta używana ale w bardzo dobrym stanie poleasingowa, wyciągnięta z komputera DELL. Połączenia kablem robiłem kilka razy i zawsze robię to delikatnie. Komputer o wiele starszy - platforma SandyBridge. W temacie Irytujące wady i cechy... wspominałem o tym problemie.

    W czasie używania systemu lub programów nic się nie dzieje i obraz jak żyleta. To się dzieje tylko przy zmianie rozdzielczości tj. przy uruchamianiu komputera nie widać logo z płyty głównej, uruchamianie gry ale nie z Windows tylko jak już jesteśmy w MENU gry czyli pomiędzy menu a rozgrywką. LOGO płyty głównej widać jak zrobimy restart systemu Windows.
    U mnie rozdzielczość ekranu to 2K - 2560x1440 a system zapewne starszy niż u autora tematu. Jakby było uszkodzone złącze sygnałowe to obrazu by było brak non-stop a nie tylko przy zmianie rozdzielczości. Mi się wydaje iż przy takiej dużej rozdzielczości coś nie nadąża - za duża przepływność danych i zanim załapie pojawia się brak sygnału na 2-3 sekundy. Nie wiem, może to wina kabla - ale nie wersji tylko jakości wykonania bo już wersja DP 1.0 obsługuje rozdzielczość 2K przy 75Hz
    Odcinanie obrazu przez komputer do monitora.


    @ikubiq2791
    • Jakiego kabla używasz?
    • Jak jest podłączona karta do monitora, jakie wyjście w karcie i wejście w monitorze?
    • Jaki system operacyjny?
    • Jaka rozdzielczość ekranu (pulpitu) w Windows?
    • Jakiego trybu używasz - Legacy CSM czy UEFI?

    Dzisiaj zabieram się za testy. Obstawiam iż to może być też wina biosu płyty głównej i jego ustawień i/lub biosu GOP karty graficznej. Ja używam trybu pełny UEFI bez CSM i właśnie karty graficznej z GOP.

    Dodano po 2 [godziny] 18 [minuty]:

    No i porobiłem testy i dużo wiem :-)

    Najpierw próbowałem różnych opcji w biosie ale pomogło chyba tylko rozwiązać problem braku sygnału przy włączaniu komputera - chyba opcja Boot logo - Disabled nie wymusza zmiany rozdzielczości ekranu i nie widać problemu. Natomiast w Windows przy wychodzeniu z gry nadal problem i nie pomaga na to zmiana trybu z UEFI na Legacy czy opcja FastBoot On/Off

    Okazuje się iż problem braku sygnału występuje tylko przy zmianie rozdzielczości ekranu - przeważnie z wyższej na niższą bez względu na to czy robi to gra czy sami zmienimy ręcznie w Windows w ustawieniach ekranu.

    Konfiguracja testowa:
    • połączenie karty i monitora DP-DP
    • gra Worms World Party Remastered w której menu działa zawsze w 640x480x60Hz a rozgrywkę można ustawić nawet na 2560x1440

    Test nr.1 - pulpit Windows i rozgrywka gry - 2560x1440 - brak sygnału przy wyjściu z rozgrywki do menu gry czyli zmiana z 2560x1440 na 640x480

    Test nr.2 - pulpit Windows i rozgrywka gry - 640x480 - żadnych problemów z brakiem sygnału ponieważ wszystko działa w tej samej rozdzielczości - pulpit, menu gry i rozgrywka gry

    Test nr.3 - ręczna zmiana rozdzielczości pulpitu w Windows z 2560x1440 na 640x480 - brak sygnału - tak samo jak w Test nr.1

    Wnioski:
    ======

    Jeśli menu gry i rozgrywka działa w takiej samej rozdzielczości co pulpit Windows to nie zaobserwujemy tego problemu.

    Podsumowanie:
    ===========

    Problem braku sygnału występuje tylko przy zmianie rozdzielczości ekranu

    Dodano po 22 [minuty]:

    Test z inną grą - NFS3 Modern Patch 1.6.1

    Tak samo jak w WWP menu gry działa w 640x480 i przy wyjściu z rozgrywki FullHD do menu jest problem z brakiem sygnału i dodatkowo ginie dźwięk - brak muzyki w menu gry (pulpit Windows ustawiony na FullHD)

    Ten patch ma taką funkcję iż można wymusić menu gry aby działało w takiej rozdzielczości co pulpit Windows - w pliku thrash.ini ustawiamy:
    Code:
    NGLIDE_RESOLUTION=1

    i od tej pory żadnych problemów z brakiem sygnału :-) :-)

    Dodano po 17 [minuty]:

    Do testów można sobie dodatkowo w monitorze włączyć menu OSD aby wyświetlał jak najdłużej (u mnie 60s) i wybrać menu Informacje, wtedy monitor pokazuje w jakiej rozdzielczości działa ekran i widać co się dzieje w czasie jak pokazuje pulpit Windows, włączenie gry, menu, rozgrywki i wyjście z gry - menu monitora nie znika jeśli rozdzielczość nie jest zmieniana.

    P.S. Przy każdej zmianie rozdzielczości menu monitora znika.
  • #4
    ikubiq2791
    Level 3  
    Kabel to najprawdopodobniej DisplayPort 1.3 lub 1.4 (karta graficzna jest w stanie wysłać 170Hz to monitora.
    DisplayPort monitor, DisplayPort karta
    Windows 11
    2560x1440 170Hz
    UEFI
  • #5
    Gelip
    Level 33  
    ikubiq2791 wrote:
    2560x1440 170Hz

    Czy ta rozdzielczość jest ustawiona zarówno na pulpicie Windows i w grze - w menu gry i podczas rozgrywki? Przeczytaj dokładnie mój poprzedni post.
  • #6
    ikubiq2791
    Level 3  
    Jest ona ustawiona wszędzie.
  • #7
    Gelip
    Level 33  
    ikubiq2791 wrote:
    Jest ona ustawiona wszędzie.

    Czy menu gry też działa w tej samej rozdzielczości? W momencie jak jesteś w menu gry włącz menu monitora i sprawdź jaką monitor pokazuje rozdzielczość.
  • #8
    ikubiq2791
    Level 3  
    Menu gry działa w tej samej rozdzielczości jak i pulpit oraz gra.
  • #9
    Gelip
    Level 33  
    @ikubiq2791
    I wtedy masz brak sygnału?

    Może na pulpicie masz inną częstotliwość odświeżania niż w menu gry i w grze?

    Jak to sprawdzasz? Czy tak jak pisałem za pomocą menu monitora?
  • #10
    ikubiq2791
    Level 3  
    Wszędzie ta sama częstotliwość. Tylko podczas ładowania gry do tzw. drugiego menu Hz spadają do 49.
    Rozdzielczości nie sprawdzałem, bo mój monitor takiej opcji nie ma, ale patrząc po wyglądzie menu, pulpitu, i samej gry wydaje się, że jest taka sama.
    Gra to ETS2.
  • #11
    Gelip
    Level 33  
    ikubiq2791 wrote:
    Tylko podczas ładowania gry do tzw. drugiego menu Hz spadają do 49.

    I tu jest właśnie pies pogrzebany - następuje zmiana rozdzielczości.
    ikubiq2791 wrote:
    Rozdzielczości nie sprawdzałem, bo mój monitor takiej opcji nie ma, ale patrząc po wyglądzie menu, pulpitu, i samej gry wydaje się, że jest taka sama.

    Nie wierzę! Podaj dokładny model monitora.
  • #13
    Gelip
    Level 33  
    No jak nie ma jak jest, wciśnij przycisk (i) na monitorze - strona 29 w pliku instrukcji PDF:
    Odcinanie obrazu przez komputer do monitora.

    Dokumenty -> Instrukcja użytkownika
  • #14
    mariusz.lubicz
    Level 24  
    Prawdopodobnie przy zmianie rozdzielczości następuje zapalenie się bitów statusu np. OVP, OCP i wszystkich podobnych i kontroler przechodzi do trybu defence. Wyłącza napięcia do GPU i przez to gaśnie monitor. Trzeba przestudiować schemat i dokumentację i odczytać z rejestrów status. Następnie usunąć usterkę, charakterystyki filtrów są rozjechane, bo jeden z elementów nie działa. To jest RTX więc układ jest nieco skomplikowany i jego przeregulowanie to powoduje, jak w sterowniku PID. Trzeba naprawić kartę, no chyba że tranzystorek przy wejściach właśnie zionie ducha.
  • #15
    Gelip
    Level 33  
    Od jakiegoś roku mam podobne problemy przy połączeniu kablem DP-DP i jak widać w poście #3 doszedłem w jakich okolicznościach i co się dzieje. Dziś trafiłem na ten temat: Asus H110M-K/GTX 1050 Ti - Nietypowe zachowanie komputera.
    Użytkownik MiroLord w #11 dał linka do tematu na forum pclab.pl Jaki kabel DisplayPort? z którego wynika iż podobno problemem może ale nie musi być pin20 we wtyczce DP. Wielu użytkowników pisze na tamtym forum, że po zmianie kabla na 19-pin "jak ręką odjął":
    Quote:
    Po zmianie kabla na Delocka z odłączonym pinem 20 wszystkie moje ww. kłopoty z DP zniknęły, także podłączony pin 20 (3.3v) może (choć nie musi) powodować problemy.

    Wiedziałem iż są różne wersje kabli potrafiące wyświetlać jakąś max rozdzielczość ale nie wiedziałem, że kabel DP może robić takie problemy i że są wersje 19-pin i 20-pin 8-O

    P.S. Pisałem o podobnych problemach tutaj na forum kilka razy na przełomie 2021/2022 ale nikt nie napisał iż problemem może być kabel DP 20-pin a wątek na pclab.pl istnieje od 2016 więc problem powinien być znany:

    Irytujące wady i cechy współczesnego sprzętu RTV/AGD 2
    Kabel Display Port blokuje możliwość uruchomienia komputera

    Sprawdziłem swój kabel DP-DP miernikiem (ciągłość obwodu i dwie igły) i okazuje się iż na pinach 20 nie ma połączenia więc jest to wersja 19-pin a mimo to problemy były na tym kablu :-? Czyli w moim przypadku to nie wina kabla ???
  • #16
    Gelip
    Level 33  
    Edytowałem "są" na "były" bo dzisiaj testuję ten sam kabel DP-DP i wszystko jest OK - zmieniam rozdzielczość i żadnego braku obrazu? Od samego początku miałem kabel 19-pin tylko wcześniej były problemy a teraz jest OK. Nic z tego nie rozumiem.

    Ostatnio uaktualniałem GOP w karcie graficznej ale okazało się iż z nowym GOP nie działa opcja Aspect Ratio w monitorze więc wróciłem do oryginalnego wsadu, którego kopię zrobiłem przed aktualizacją. Więc to nie powinno mieć wpływu na zmianę zachowania przy zmianie rozdzielczości ekranu.
  • #17
    ikubiq2791
    Level 3  
    Sprawa zamknięta, karta oddana do serwisu, po wymianie karty na nową problem zniknął. Najprawdopodobniej z kartą było już coś nie tak gdy wyjechała z fabryki.