Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Tartarini LPG Fiat brak połączenia

wosk1 19 Feb 2022 16:46 591 27
  • #1
    wosk1
    Level 3  
    Witam.
    Mam problem z komunikacją poprzez program diagnostyczny z instalacją gazową Tartarini.
    Posiadam program Tartarini Seq Gas Inj oraz kabel firmy Projekt Tech oraz klucz do uruchomienia programu.
    Jednak jest problem z komunikacją. W menedżerze urządzeń kabel jest wykrywany. Ale po uruchomieniu programu cały czas jest informacja o szukaniu portu com i nie może nawiązać połączenia. Czy to przy wpiętym kablu pod sterownik czy na pusto bez podłączonego sterownika LPG.
    Instalowałem sterowniki do kabla i próbowałem na kilku programach.
    Czy wina leży może po stronie samego kabla? Mam też program do testowania portu bez podłączenia do sterownika i w tym programie wygląda że wszystko jest ok.
    Próbowałem na odpalonym silniku oraz na zgaszonym. Zauważyłem że nawet na wyłączonym zapłonie we wtyczce diagnostycznej są napięcia więc teoretycznie komputer nawet wtedy powinien chyba połączyć się ze sterownikiem.
    W czym może być problem?



    Dodano po 7 [minuty]:

    Dodam jeszcze że po podłączeniu interfejsu świeci czerwona dioda.
    Przy szukaniu portu miga żółta
  • #2
    diablo23248
    Level 27  
    Na którym COM masz interfejs?
    Niektóre programy do LPG nie szukają powyżej COM4
    Ewentualnie sprawdź czy w programie możesz ręcznie ustawić port COM
  • #3
    wosk1
    Level 3  
    Port com ustawiony jest na com1 a w programie nie można zmienić. Sam szuka sobie
  • #5
    wosk1
    Level 3  
    Tak. I za każdym razem tak samo. A ma znaczenia czy silnik uruchomiony czy nie??
  • #6
    diablo23248
    Level 27  
    Jeśli masz zasilanie na złączu na samym zapłonie to nie powinno mieć znaczenia. Czy na Rx i Tx masz jakieś napięcia?
  • #7
    wosk1
    Level 3  
    Tak. Na jednym jest 5.05 a na drugim 5.02 ale teraz nie pamiętam dokładnie na którym było więcej a na którym mniej.

    Dodano po 1 [minuty]:

    Mierzone miernikiem za 30 zł więc wynik może nie być dokładny tylko przybliżony.

    Dodano po 1 [minuty]:

    Jak dla mnie powinno się łączyć bez problemu. Jest opcja że interfejs jest uszkodzony? Bo sam teraz nie wiem gdzie szukać przyczyny.
  • #8
    diablo23248
    Level 27  
    Czyli transmisja jest. W menadżerze urządzeń zmień port na com 3 lub 4. Prędkość transmisji ustaw na 9600 data 8 stop 1
    I zobacz czy zadziała.
  • #9
    wosk1
    Level 3  
    To poza numerem portu pozostałe ustawienia są takie same. Na tygodniu po pracy jeszcze będę próbował- zamienię ten numer portu i zobaczę czy będzie jakaś róznica.
  • #10
    wosk1
    Level 3  
    Zmieniłem port COM. Dalej to samo. Cały czas w programie pisze szukanie portu COM.
    Na panelu na kablu świeci czerwona dioda READY i miga żółta OUT. I nic więcej się nie dzieje.
  • #11
    wosk1
    Level 3  
    Temat po dłuższej przerwie wraca. Sprawdziłem dzisiaj jeszcze raz. Czy to kabel podłączony do samochodu czy nie pisze w programie szukanie portu COM. Więc zakładam że to może być coś z kablem. Czy miał ktoś podobny problem? Czy kupować kolejny interfejs czy szukać gdzie indziej problemu. Pomierzyłem napięcia we wtyczce w samochodzie. Pomiędzy czerwonym i czarnym napięcie akumulatora. Pomiędzy masą a białym 5,03V i pomiędzy masą a zielonym również 5,03V.
  • #12
    psooya
    Level 38  
    Skoro masz klucz oryginalny na USB to poproś firmę AGŚ (auto gaz śląsk) o udostępnienie oprogramowania i aktualizacji klucza. Klucz jest potrzebny do sterownika EVO1 w czarnej obudowie, w starszych sterownikach soft jest dostępny bez klucza i nie łączy się na kluczu.
  • #13
    wosk1
    Level 3  
    Licencja na klucz jest aktualna. Inaczej program by się nie uruchomił.
    Kombinowałem w ustawieniach portu Com i dalej nic. Zakupiłem nowy kabel i nadal to samo. Cały czas brak komunikacji.
  • #15
    wosk1
    Level 3  
    Gaz był montowany w 2019 roku. Złącze jest 4 pinowe. Skąd mam wiedzieć jaki soft jest potrzebny do mojej instalacji? Na sterowniku pisze EVO 01
  • #16
    psooya
    Level 38  
    Czyli potrzebujesz softu z kluczem na USB. Sprawdź napięcia na kostce sterownika ma być 12V 5V 5V i masa. Sprawdź czy jak w interfejsie zewrzesz linie które mają 5V ze sobą i uruchomisz terminal czy da się zrobić ECHO na twoim komputerze. Musi do połączenia świecić się centralka gazu. Spróbuj odłączyć akumę może sterownik się zawiesił i dlatego nie łączy.
  • #17
    wosk1
    Level 3  
    A co to takiego to ECHO? Pierwszy raz słyszę o takim czymś.

    Dodano po 1 [minuty]:

    Napięcia na kostce sterownika są poprawne. 12V, na dwóch pinach po 5 i masa.

    Dodano po 1 [godziny] 43 [minuty]:

    Po zwarciu dwóch pinów które mają po 5V i uruchomieniu programu nadal to samo. Cały czas szuka portu COM. i nie może znaleźć.
  • #19
    wosk1
    Level 3  
    Tartarini LPG Fiat brak połączenia

    Tartarini LPG Fiat brak połączenia
    Sterowniki do kabla są zainstalowane. Nie wiem gdzie sprawdzić czy wirtualny port COM jest zainstalowany. Nigdy do tej pory nie miałem takich problemów z jakimkolwiek interfejsem.
  • #20
    psooya
    Level 38  
    Skoro wisi jako port com1 to znaczy, ze jest zainstalowany. Zainstaluj putty np jako terminal i sprawdz czy dla portu com1 po zwarciu txd z rxd da sie zrobic echo. Terminal dziala tak ze wysyla znaki z klawiatury linia txd i odbiera linia rxd. Wiec bedziesz widzial czy znaki sie pojawiaja czy nie. Kabel jest na chipie FTDI?
  • #21
    wosk1
    Level 3  
    Zainstalowałem putty. Rozumiem że jak wpiszę jakiś znak to po wciśnięciu enter program odpisze tym samym. Jak tak to ma działać to działa i w tym czasie co wcisnę enter to mrugną dwie diody na interfejsie. Kabel jest na chipie FTDI. Jeszcze zostaje mi odpiąć akumulator i zobaczyć czy to coś pomoże. Bo na razie innych pomysłów nie mam
  • #22
    psooya
    Level 38  
    Bez entera, naciskasz znak i ma wyskoczyc w oknie terminala jak na maszynie do pisania. Musza byc tylko fizycznie zwarte linie txd z rxd.

    Dodano po 2 [minuty]:

    Pytanie czy jak odpalasz soft do tartarinii czy jak szuka portu i próbuje się połączyć to mrugnie choc raz jakas dioda na kabelku?
  • #23
    wosk1
    Level 3  
    Tak. Jak odpalę program to jak szuka portu to mruga dioda na kablu. Mruga dioda z opisem OUT

    Dodano po 3 [minuty]:

    Ale w tym programie putty jak tylko wcisnę jakiś znak to wyskoczy to co napisałem i tyle. Nie ma powtórzenia drugi raz

    Dodano po 2 [minuty]:

    Ale jak wpisuję coś to mrugną obie diody OUT i IN
  • #25
    wosk1
    Level 3  
    Jak zamienię te kable to mrugają obie diody i dalej się nie łączy

    Dodano po 38 [minuty]:

    Odpiąłem akumulator na 10 minut i nadal to samo. 2 laptopy, 2 kable i za każdym razem to samo.
  • #26
    psooya
    Level 38  
    Wstępnie pachnie uszkodzonym sterownikiem gazu. Napięcia w kostce ok. Albo jakas inna wersja softu sterownika albo cos padlo? Czy instalacja pracujęme poprawnie? Przelacza na gaz? Pomysły mi się skończyły. Jeszcze sprobuj wyszukac w sieci wersji softu z tzw witaminka która pozwala ominac klucz usb moze ta zaskoczy.
  • #27
    wosk1
    Level 3  
    Tak. Instalacja pracuje poprawnie. Chcę podpiąć bo piszczy przy odpaleniu że minął termin przeglądu. Jak nie wymyślę nic to podjadę na serwis. Wtedy dowiem się czy sterownik jest ok. Jak sterownik będzie ok to będę szukał przyczyny u siebie.