Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

ASUS DDNS nie działa mimo przekierowanych portów.

csvrbntyu 20 Nov 2022 15:04 804 60
  • #31
    csvrbntyu
    Level 18  
    Znalazłem jeszcze w ustawieniach netgeara coś takiego:
    ASUS DDNS nie działa mimo przekierowanych portów.
    Tryb mostka mnie zainteresował, bo z tego co się naczytałem w necie brzmi to jak wyłączenie routera w LBR20 i zostawienie samego modemu. Wtedy Asus miałby publiczne IP na WANie i sporo rzeczy by się rozwiązało. Dobrze kombinuję?
    Tymczasem dłubię dalej w ustawieniach LBR20. I muszę poczytać jak działa DMZ.
  • #32
    jimasek
    Moderator of Networks, Internet
    Co do zasady tak, wtedy Netgear powinien działać jako modem ale tak jak powiedziałem nie znam tego urządzenia żeby potwierdzić jego możliwości na 100%, może @matek451 coś podrzuci w tym temacie.
  • #33
    csvrbntyu
    Level 18  
    Nie ma problemu by testować ustawienia "na pałę". Mam backup ustawień. Nie rozumiem tylko co te opcje oznaczają, także jakbyś podpowiedział co oznaczać mogą to byłbym wdzięczny.
    Do matka pisałem niedawno, ale to z innym problemem. Ogólnie chciałem zapytać na forum bez-kabli, ale jest popsute. Nie przychodzą maile aktywujące konto (na wielu kontach, od tygodnia), kontakt z administracją jest na stronie wyłaczony... generalnie trochę jak z moją siecią - internet jest, ale nic nie działa jak powinno :P
  • #34
    jimasek
    Moderator of Networks, Internet
    DMZ przerzuca (przekierowuje) wszystkie zapytania z zewnątrz (z internetu) na wszystkich portach na host który jest wpisany. To tak jak byś wszystkie porty przekierował na dane IP.
  • #35
    csvrbntyu
    Level 18  
    I nie ma wtedy znaczenia, że router Asus widzi własne WAN IP jako wewnętrzne LAN?
    Właczyłem VLAN na Netgearze, ustawiłem WAN IP na automat. Nie mam intermetu. Do Netgeara się nie zaloguję, Asus twierdzi że DHCP na ISP nie działa.
  • #36
    jimasek
    Moderator of Networks, Internet
    csvrbntyu wrote:
    I nie ma wtedy znaczenia, że router Asus widzi własne WAN IP jako wewnętrzne LAN?

    Tego nie rozumiem, na wanie wtedy musisz mieć wpisanie recznie (static) lub dynamic (automat) IP publiczne od dostawcy.
    csvrbntyu wrote:
    Właczyłem VLAN na Netgearze

    Po co ci VLAN-y?
  • #37
    csvrbntyu
    Level 18  
    jimasek wrote:
    Tego nie rozumiem, na wanie wtedy musisz mieć wpisanie recznie (static) lub dynamic (automat) IP publiczne od dostawcy.

    Netgear ma publiczne dynamiczne WAN IP od dostawcy, i LAN IP 1.1 . Asus ma statyczne WAN IP 1.2, i na głównym ekranie podaje stoje własne WAN IP właśnie jako 1.2. Rozumiem że DMZ przekierowuje wszystkie porty z publicznego IP na 1.2, ale wydaje mi się, że ddyby w jakiś sposób zmusić sieć by Asus miał WAN IP jako adres od dostawcy, wszelkie problemy by zniknęły. Ale do tego trzebaby przekonać Netgeara by stał się samym modemem.
    I tu płynnie przechodzimy do tego po co właczyłem VLAN na Netgerze. Pisało tam coś o połaczeniu mostkowym. Liczyłem że to właśnie opcja wyłaczeniq routingu w Netgerze i będzie robił jako goły modem LTE, podając IP od ISP na Asusa. Albo źle myślałem, albo źle ustawiłem bo sieć padła. Właśnie kończę ustawiać.
  • #38
    jimasek
    Moderator of Networks, Internet
    DMZ to właśnie obejście routingu na Netearze i puszczenie całego ruchu z zewnątrz na Asusa.
  • #39
    csvrbntyu
    Level 18  
    jimasek wrote:
    DMZ to właśnie obejście routingu na Netearze i puszczenie całego ruchu z zewnątrz na Asusa.

    Rozumiem co do mnie piszesz, ale nie rozumiem dlaczego mi nie działa, co mi nie działa (czy to przypadkiem DMZ nie działa), i nie mam jak go sprawdzić.
    ...
    Kurde. Śmieszna sprawa. Generalnie nie wiem co zrobiłem (przywróciłem ustawienia z pliku z kilku dni, dodałem DMZ... Polecenie ping DDNS z telefonu, na internecie mobilnym, odpowiedziało mi pingiem około 100ms i ttl 46.
    Także... No nie wiem co się stało. Teraz trzeba podjąć spokojne kroki by tego nie spieprzyć.
  • #40
    jimasek
    Moderator of Networks, Internet
    Sorry ale nie widzę twojej konfiguracji więc trudno mi coś powiedzieć.
  • #41
    csvrbntyu
    Level 18  
    Ping z zewnątrz działa!
    Jednakże po wpisaniu w przeglądarkę adresu XXXX.asuscomm.com (tego samego którego ping ożył), nic się nie otwiera. Zarówno przy próbie wejścia z zewnątrz, jak i z sieci LAN. Nie powinno tam być przypadkiem jakiegoś interfejsu konfiguracyjnego?
  • #42
    jimasek
    Moderator of Networks, Internet
    Pytanie czy jest włączona funkcja dostępu z zewnątrz przez WAN. Zwykle to trzeba "zaptaszkować"
  • #43
    csvrbntyu
    Level 18  
    To powoli muszę pokombinować, bo ostatnio jak to włączyłem to uznało, że po WAN tylko przez HTTPS, a HTTPS się wysypał :)

    Dodano po 29 [minuty]:

    jimasek wrote:
    Pytanie czy jest włączona funkcja dostępu z zewnątrz przez WAN. Zwykle to trzeba "zaptaszkować"

    Mam tak: ASUS DDNS nie działa mimo przekierowanych portów.
    Generalnie z sieci LAN działa i http://router.asus.com/ po HTTP, jak i http://router.asus.com:8443/ po HTTPS (tylko certyfikat jest podpisany przez router i Chrome twierdzi że jest nieważny). Natomiast z sieci WAN, konkretniej z telefonu z LTE, adres XXXX.asuscomm.com nadal odpowiada na ping, ale nic nie ładuje, tak samo jak XXXX.asuscomm.com:8443 też nic nie ładuje.
  • #44
    jimasek
    Moderator of Networks, Internet
    Zrobiłeś dla pewności restart prądowy tego asusa po zmianie konfiguracji?

    Wygląda że zapytania trafiają na Netgeara. To DMZ włączyłeś? Spróbuj też konfiguracji na odwrót wyłączyć DMZ na netgera i przekierować tylko ten port 8443 na 192.168.1.2
  • #45
    csvrbntyu
    Level 18  
    jimasek wrote:
    Zrobiłeś dla pewności restart prądowy tego asusa po zmianie konfiguracji?

    Zawsze. Całą szafę resetuję.
    jimasek wrote:
    To DMZ włączyłeś?

    Tak.
    jimasek wrote:
    Spróbuj też konfiguracji na odwrót wyłączyć DMZ na netgera i przekierować tylko ten port 8443 na 192.168.1.2

    Efekt jest taki, że ping na XXXX.asuscomm.com przestał odpowiadać.
  • #46
    jimasek
    Moderator of Networks, Internet
    Zgadza się ale czy coś się zmieniło z dostępem?
  • #47
    csvrbntyu
    Level 18  
    Nie, nadal nie działa.
  • #48
    jimasek
    Moderator of Networks, Internet
    To inaczej, włącz ponownie DMZ na Netgear no i postaw na komputerze podłączonym do asusa jakąś prostą usługę/serwer działająca w sieci np. jakiś ftp czy web no i przekieruj ten port na asusie na adres IP komputera z tą usługą. Sprawdź czy usługa działa lokalnie w sieci LAN a potem przez WAN.
  • #49
    csvrbntyu
    Level 18  
    Za chwilkę. Na razie pracuję nad przywróceniem stanu poprzedniego.
    Jednakże mam pytanie - czy ustawione na sztywno adresy DNS 8.8.8.8 i 8.8.4.4 mogą powodować takie problemy?
  • #50
    jimasek
    Moderator of Networks, Internet
    DNS-y służą do tłumaczenia nazw domenowych na adresy ip więc nie sądzę. To są działające DNS-y. Choć najlepiej zastosować te najbliższe czyli od twojego dostawcy internetu.
  • #51
    csvrbntyu
    Level 18  
    Nie udało mi się ponownie sprawić, by sieć odpowiadała na ping z zewnątrz. Adres IP w DDNS odświeżył się prawie od razu, ale odpowiedzi na ping nie ma.
    Cały weekend się z tym bawię. Przerwa. Mam jeszcze parę spraw do załatwienia.
  • #52
    csvrbntyu
    Level 18  
    Zapytałem support asus co o tym myślą.
    "Szanowny Kliencie ASUS,
    Przykro nam ale w obecnej konfiguracji DDNS nie będzie u Pana działał. Wymaga on publicznego adresu IP a podpinając Router za routerem automatycznie ASUS otrzymuje IP prywatne. Żadne przekierowanie portów tego nie zmieni.".
    Czyłi chyba koniec zabawy...
  • #53
    jimasek
    Moderator of Networks, Internet
    Kwestia ustawienia jakiejś domeny na Netgeare
  • #54
    csvrbntyu
    Level 18  
    Dostałem kolejną informację od supportu:
    "Szanowny Kliencie ASUS,
    Niestety DMZ i przekierowywanie nie zadziała. Urządzenie musi dostawać IP publiczne od operatora. Może być ono zmienne ale musi być publiczne. Wszelkiego rodzaju podpięcie za routerem z automatu powoduje zmianę IP z klasy publicznej na prywatną i to temat nie do obejścia.".
    Czyli tak jak mi się wydawało.
    jimasek wrote:
    Kwestia ustawienia jakiejś domeny na Netgeare

    Musiałbym spróbować ustawić DNS na netgearze, może serwer VPN też by szło. Nie pamiętam jakie tam ma opcje.
  • #55
    jimasek
    Moderator of Networks, Internet
    Powinno być Settings > Advanced Settings > Dynamic DNS
    ale netgear nie ma chyba swojej domeny więc trzeba by wykupić coś na no-ip
  • #56
    csvrbntyu
    Level 18  
    Zastanawiam się tylko nad jednym.
    Router Asusa ma tylko port WAN RJ45. I kilka lanów z udziwnieniami. Co można podłączyć do tego portu WAN, by asus miał publiczne IP? Modem bez funkcji routera? Są takie które przekazują publiczne IP na wyjście?
  • #57
    csvrbntyu
    Level 18  
    jimasek wrote:
    ale netgear nie ma chyba swojej domeny więc trzeba by wykupić coś na no-ip

    Ma. Tzn, ma partnerstwo z No-IP i udostępnia domenę za darmo, jakby w cenie sprzętu.
  • #58
    jimasek
    Moderator of Networks, Internet
    No to poszukaj czy jest ta funkcja w Netgear i konfiguruj.
  • #59
    siewcu
    Level 34  
    Z tego co widzę to nie osiągniesz pożądanej funkcjonalności - LBR20 nie ma trybu bridge i Asus może być jedynie klientem. Nie przerzucisz na niego całego ruchu sieciowego - jest to klient w sieci i z Netgeara nie zrobisz modemu. Nie ten sprzęt.

    A przy okazji, możesz wytłumaczyć topologię tej sieci? LBR20 jest routerem mesh i jeśli oba są w tej samej lokalizacji(a jeśli dobrze rozumiem to tak jest) to jest to pozbawione sensu.
  • #60
    jprzedworski
    Network and Internet specialist
    csvrbntyu wrote:
    Wydaje mi się, ze problem leży w adresie WAN routera Asus. Router łączący się z internetem (LBR20 przypomnę), ma IP WAN publiczne. LAN IP 192.168.1.1. Podłączony do routera Asus RT-AX86U o IP WAN 192.168.1.2, adresie LAN 192.168.2.1. I wydaje mi się że wytłuszczone generuje problemy. Musiałbym sprawić, by Asus miał publiczne IP WAN, a nie z LANu Netgeara.
    Ciepło! System DDNS składa się z serwera DDNS gdzieś w internecie i klienta siedzącego w routerze. Ten klient pilnuje, jaki jest adres WAN (tego routera) i w przypadku zmiany natychmiast powiadamia serwer o nowym adresie. Klient uruchomiony w Asusie nie ma pojęcia o adresie WAN Netgeara. On pilnuje tylko swojego adresu WAN, a tam jest adres prywatny. DMZ czy przekierowania nie załatwią tego, bo drugi router nie "widzi" adresu WAN tego pierwszego.
    Czyli klient DDNS powinien być uruchomiony w ORBI LBR20. Potem trzeba się pobawić w przekierowania.
    https://youtu.be/3D-FoSzqv24