Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ISP i pony prog co jest nie tak??

28 Lis 2005 01:03 2929 7
  • Poziom 15  
    Witam. Mam problem z programatorem ISP ....programator jakis czas temu zrobiłem sobie w pająku ze znalezionego w internecie standardowego schematu ...i programator ten chodził mi idealnie z pony porgiem...i prockiem Atmega 16 jak również 90C2313 ...aż pewnego dnia nie mogłem się skątaktowac z atmegą16 (pony prog wywalał błąd -21)...i wtedy "ignore" program czytał...ale to co ukazywało się w buforze były bzdury...najciekawsze to to że w buforze układały się dziwne kombinacje liczb i cyfr....naprzykład był zały alfabet liter od "a" do "z" zarówno z małej litery jak i z dużej , czyfry od '0' do '9' i inne znaki.....zrobiłem wiec na płytce uniwersalnej ponownie programator ale efekt był ten sam...wiec zmieniłem 74HC244 i to samo teraz .....
    Dodam jeszcze że korzystam z zewnętrznego zasilacza 5V.
    W zasadzie wykluczam uszkodzenie portu LPT bo Willem chodzi bez problemu...
    Dziekuje za wszelką pomoc.

    Dodano po 1 [minuty]:

    a zapomniałem używam sytemu XP
  • Poziom 24  
    90C2313?? masz chyba na myśli AT90S2313?

    A programuje tego 2313? Bo jak tak, to może ATmega padł?
  • Poziom 15  
    Oczywiscie chodziło mi o 90s2313 ;)....i tego procka też nie czytał do dziś .... zmieniłem kwarc i chodzi!!!! po południu zobacze jak z tą Atmega16 bedzie.
  • Użytkownik usunął konto  
  • Poziom 15  
    Panowie mam jeszcze jedno pytanie...pierwszys raz chciałm podlączyc ISP do Bascoma AVR i iak ustawiam w bascomie programator ukazuje mi sie to co na zdjęciu czy ktos miał podobny problem??
  • Poziom 14  
    wg etykiety to program czepia się że nie posiada aktualnie zainstalowanej drukarki domyślnej :)
  • Poziom 15  
    no własnie dla czego się doczepia do drukarki??musi być drudarka zainsatowana??bo nie kumam co ma piernik do wiatraka
  • Poziom 14  
    kiedyś to przerabiałem. to podobna sytuacja jak w ms ofiice z podglądem wydruku. bez drukarki nie potrafi formatować tekstu, i nie ma się dziwić. zainstaluj jakąś pierwszą lepszą z listy i tyle. powinno byc po problemie.