Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zasilacz warsztatowy 0-30V/2mA-3A

zasoby 13 Mar 2008 21:25 1389494 3210
Bosch
  • #1351
    joozwa
    Level 31  
    Witam
    Koledzy, ja też mam pytanie, pozornie nie na temat.
    Jak to jest z wytrzymałością mechaniczną wyprowadzeń diod w obudowach DO201 i P600 (AG) ? Czy dopuszczalne jest ciasne zaginanie ich zaraz przy obudowie? Nie grozi pęknięcie obudowy/uszkodzenie złącza? Ostatnio natrafiłem na diody (P600M) w których te wyprowadzenia są koszmarnie sztywne...

    Dziękuję i pozdrawiam
  • Bosch
  • #1352
    wie8
    Level 16  
    aprogips wrote:
    zrób dokładne zdjęcia i pokaż co tam masz coś się wymyśli


    Witam, a czy nie wystarczy opis ? Myślę, że problem opisałem w właściwy sposób, tu pomoże tylko teoretyzowanie nad schematem...

    Dlatego zwracam się z uprzejmą prośbą, do tych co mają jakieś pojęcie nt działania tego układu...

    Pozwolę sobie zacytować samego siebie, bo nie każdemu może się chcieć przewijąć wątek:

    Quote:

    Problem: Na wyjściu gdy mamy ustawione dowolne napięcie np 12V, po wyłączeniu zasilacza dzieje się coś niedobrego... Następuje coś w rodzaju Delty Diraca, gwałtowny impuls napięcia - który potrafi wzrosnąć i do 20kilku woltów, jeżeli mamy nastawione inne wyższe napięcie, to ten dirac wynosi jeszcze więcej.

    Moje rozumowanie:
    Po wyłączeniu, energia zgromadzona w kondensatorze filtrującym zostaje oddawana na resztę układu. Jak zlikwidować ten efekt ?

    Myślę o zwiększeniu pojemności zaznaczonych kondensatorów (C3 i C7), czy to rozwiąże problem ?

    Takiego spostrzeżenia w tym wątku raczej nie było, więc proszę o jakieś informacje, ewentualne testy zasilaczy. Dodam że w sumie zasilacz mój działa, ale ta delta utrudnia życie Smile

    Dodatkowo:
    W bloku ograniczenia prądowego upala mi tranzystor gdy zjadę potencjometrem do minimum. Zapala się wtedy LED i już nie gaśnie. Ja wiem, że tranzystor ten w stanie normalnej pracy jest zatkany, dopiero otwiera się w momencie zadziałania ogranicznika prądowego. Jednakże mi się on upala (przebity jest), LED nie gaśnie, a regulacja potencjometru od prądu nic już nie daje. ... Trzeba wymienić tranzystor.

    Zastosowałem BD140. Pytanie więc brzmi, jak to usprawnić ? Być może problem tkwi w tych rezystorach R19, R20, R22 ?


    Oczywiście tranzystor pracujący z tranzystorem mocy w ukł darlingtona jest BD139, natomiast BD140 mam przy ledzie w obwodzie ogranicznika prądowego.

    C3 myślałem by zwiększyć do 100uF, a C7 do 470uF...
    To odnośnie likwidacji zjawiska Delty diraca.
    Pytanie czy pomoże ?

    No i pozostaje sprawa ogranicznika

    Serdecznie pozdrawiam i proszę o pomoc.

    *dam 15 punktów za opis problemu, chociaż diraca :)
  • #1353
    dominium
    Level 10  
    Witaj

    > Problem: Na wyjściu gdy mamy ustawione dowolne napięcie np 12V, po > wyłączeniu zasilacza dzieje się coś niedobrego... Następuje coś w
    > rodzaju Delty Diraca, gwałtowny impuls napięcia - który potrafi
    > wzrosnąć i do 20kilku woltów, jeżeli mamy nastawione inne wyższe
    > napięcie, to ten dirac wynosi jeszcze więcej.
    Jestes pewien, ze wystepuje ci takie zjawisko? Najlepiej sprawdz na oscyloskopie. Z tego co rozumiem mierzysz zwyklym woltomierzem.
    Ale zakladajac, ze obserwujesz to na zwyklym voltomierzy, czyli musi to trwac co najmniej kilka sekund (Dirac w teorii jest zerowego trwania), wiec przypuszczam ze obserwujesz jakies ladowanie i rozladowanie kondensatora.
    Czy C7 masz malutki? Czy dales wiekszy? Zakladam, ze oberwujesz ladowanie i rozladnowanie na C7. Mozesz go wyciac i zobaczyc co sie wowczas dzieje.
    Drugim pytanie jest, skad sie bierze prad ktory laduje C7.
    Masz racje co do C3. Wg teorii napiecie na nim powinno trwac ciut dluzej niz napiecie na C1. (Sprawdz R1, czy sie grzeje? moze sie przepalil? Musisz dac tak jak w schemacie 2W, sprawdz po wylaczeniu zasilania, jak dlugo utrzymuje sie napiecie na C1, jesli jestes zaobserwowac voltomierzem tzn, ze uklad rozladowujacy (R1) cos nie tak).

    Sadze, ze moze miec miejsce taka sytuacja:
    R1 spalony, C3 rozladowal sie, C1 ma ladunek.
    Dopoki C3 ma ciagle napiecie ujemne, Q1 powinien przewodzic (sprawdz co sie dziej na Collectorze Q1 - jak dlugo po wylaczeniu zwiera !).

    Poniewac C1 ma ciagle ladunek, C3 rozladowal siw, wiec Q1 przestaje zwierac. Wowczas byc moze Q2,Q4 przewodza i laduje sie C7. (Nie jestem pewien co jest na wyjsciu U2 po wylaczeniue).
    Jesli mieszysz napiecie tylko woltomierzem (Rez wej > 1Mom), mozesz obserwowac rozladowywanie sie C1 poprzez Q4, i jednoczesne ladowanie C7.
    Daj jakis rezystor np 1K na wyjscie, i wowczas mierz napiecie.

    > Moje rozumowanie:
    > Po wyłączeniu, energia zgromadzona w kondensatorze filtrującym
    > zostaje oddawana na resztę układu. Jak zlikwidować ten efekt ?
    To co opisalem jest zgodne z twoim zdaniem.

    > Myślę o zwiększeniu pojemności zaznaczonych kondensatorów (C3 i
    > C7), czy to rozwiąże problem ?
    Zwiekszenie C3 wydluzy czas utrzymywanie sie napiecia ujemnego, ale to tylko workaround.



    > W bloku ograniczenia prądowego upala mi tranzystor gdy zjadę
    > potencjometrem do minimum. Zapala się wtedy LED i już nie gaśnie. Ja > wiem, że tranzystor ten w stanie normalnej pracy jest zatkany, dopiero > otwiera się w momencie zadziałania ogranicznika prądowego. Jednakże > mi się on upala (przebity jest), LED nie gaśnie, a regulacja
    > potencjometru od prądu nic już nie daje. ... Trzeba wymienić tranzystor.
    Ja mam zwykly tranz. jakis tam BC... (pnp), BD jest o wiele mocniejszy,
    Pomierz napiecia wokol Q3 i podaj je tu. W stanie normalnym, i w stanie zadzialania ogranicznika.

    > Być może problem tkwi w tych rezystorach R19, R20, R22 ?
    Chyba tak, sprawdz je



    Jestem ciekaw twojego R1,
    Pozdrawiam
    Dominium
  • #1354
    markovip
    Level 34  
    Witam

    Mam pytanie co do modyfikacji Szopler`a:
    Zasilacz warsztatowy 0-30V/2mA-3A
    Jakie moze byc maksymalne napiecie transformatora? Poniewaz moj ma 28VAC co po wyprastowaniu daje 41VDC-1,5V na mostku prostowniczym = ~39V, i teraz sie nasuwaja kolejne pytania...

    1. Stabilizatory napiecia lm7824 moga miec napiecie wejsciowe = 27V do 38V i napiecie wyjsciowe ~24V i op-ampy UA741 VCC chodza na ±22V, niespala sie?

    2. Mozna zamiast dwoch KD502 uzyc jednego 2N3055 (jest mi tak wygodniej bo mam radiator na obudowe TO3)
    Nierozumie dlaczego zostaly uzyte dwa tranzystory na 20A, kiedy mamy tylko 3-5A. Podlaczajac je rownolegle musimy je 'zsynchronizowac' trymerem co nie jest takie latwe.

    3. Czy uzycie tego rezystora na emiteze Q4 jest konieczne, i co moze sie sac gdy go niezamontuje?

    Zmodyfikowalem troche schemat usuwajac drugi Q4:
    Zasilacz warsztatowy 0-30V/2mA-3A
    Czy niewplynie to jakos na jego poprawne dzialanie?

    4. Jak wspomnialem wczesniej mam juz obudowe na zasilacz od innego zasilacza w ktorym na wyjsciu podaje nawet 7A. Obudowa tranzystowa jest taka sama jak moja czyli z montarzem nie bedzie problemu. Jednak moze byc problem z odprowadzaniem ciepla bo nie wiem czy ten radiator wystarczy, wiec chce zrobic chlodzenie aktywne dwoma mini wentylatorami (4cm x 4cm) i teraz mam wybor jak sterowac nimi: a) na NTC i lm317 wiec gdy temperatura radiatora wzrasta wentylatory sie kreca szybciej. b) im wiekszy limit pradowy tym szybciej sie kreca (uzywajac tego samego potencjometra sterowac innym tranzystorem na wentylatory) -> dolo by sie??

    I oto zdjecia radiatora:
    Zasilacz warsztatowy 0-30V/2mA-3A Zasilacz warsztatowy 0-30V/2mA-3A

    Byl bym bardzo wdzieczny jak byscie mogli odpowiedziec na moje pytania.

    Pozdrawiam
  • #1355
    wie8
    Level 16  
    dominium - dzięki za obszerne wyjaśnienia i sugestie.
    30punktów leci na twoje konto.

    Będe kombinował z układem.
    odpowiadając na pytanie - tak, c7 narazie jest taki jak autor zasilacza przewidział, 100uF o ile pamiętam.

    Pozdrawiam :)
  • Bosch
  • #1356
    telemah
    Level 27  
    Kol Markovip - co do tego radiatora to zapomnij :!: on jest za mały nawet z wiatrakami nie da rady.Tamten zasilacz jeśli nawet miał te 7A - w co osobiście trochę wątpie to sprawa jest i tak innego typu.Tutaj nie chodzi tylko o prąd wyjściowy zasilacza - bo nie do niego dobiera się chłodzenie tranzystora wykonawczego.Pod uwagę bierze się przede wszystkim MOC jaką w najbardziej krytycznych warunkach ma być TRACONA na tranzystorze końcowym czym ustawiony większy prąd i mniejsze napięcie tym straty na tranzystorze większe a za tym idzie większa wydajność chłodzenia !! Załóżmy że ten zasilacz po którym masz obudowę dawał 15V z wydajnością 7A , jeśli założymy że naddatek napięcia potrzebny do stratnego wystabilizowania (a każdy stabilizator jest stratny - mniej lub więcej) wynosi powiedzmy 5V czyli napięcie podawane na płytkę zasilacza to ok 22v.Jednak układ stabilizujący traci w sobie niewielką moc gdyż niewielka jest różnica napięcia podawanego na stabilizator względem wynikowego napięcia wyjściowego.Niewielka moc tracona nie wymaga ani kilku tranzystorów końcowych ani wydajnego chłodzenia więc można zastosować mały radiator i pojedynczy tranzystor, bo moc tracona w nim
    to "raptem" ok 35Watt i to w przypadku gdy zasilacz jest obciążony maxymalnym dopuszczalnym prądem ! Jeśli zasilacz działał by "na pół gwizdka" to moc tracona na radiatorze nie wyniosła by więcej niż 15Watt!
    a żeby stracić taką moc wystarczy naprawdę skromne chłodzenie.

    Teraz Ci powiem skąd takie założenia.Każdy kto projektuje zasilacz który
    ma mieć tylko jedno stabilizowane napięcie - lub regulowane wąskim zakresie to zawsze dobiera się w taki sposób transformator zasilający
    aby naddatek napięcia w stosunku do żądanego napięcia wyjściowego zasilacza był jak najmniejszy i wynosił jedynie "kapkę" więcej niż to co potrzeba do stracenia w układzie stabilizatora.Robi się to celowo właśnie dlatego żeby moc tracona w układzie wykonawczym była jak najmniejsza !
    m.in po to aby nie musieć stosować wydajnego i co za tym idzie drogiego i nieporęcznie dużego chłodzenia.

    Co innego zasilacz o sporej wydajności prądowej i o szerokim zakresie regulacji.Załóżmy że napięcie stałe docierające do modułu zasilacza
    to 30V ,maxymalny prąd - 3A a maxymalne napięcie wynikowe możliwe do osiągnięcia już na stabilizowanym wyjściu zasilacza to ok 25v(straty , spadki na półprzewodnikach etc...) .Teraz załóżmy że ustawiamy napięcie wyjściowe na 20v i max prąd jaki da się uzyskać moc tracona na tranz. wykonwawczym to ok. 30 watt.Jednak gdy ustawimy napięcie 3V przy max prądzie wynoszącym 3A to moc tracona na tranz. końcowym to PONAD 80 WATT ! spróbuj wytracić taką moc a co za tym idzie taką ilość ciepła na maleńkim radiatorku - ręcze że nawet te wiatraki Ci nie pomogą.Na zwarciu trzeba wytracić już 90WATT mocy -zrozumiałeś już dlaczego tak ważne jest w tym przypadku solidne chłodzenie :?:
  • #1357
    markovip
    Level 34  
    I stosujac ten radiator?
    Zasilacz warsztatowy 0-30V/2mA-3A Zasilacz warsztatowy 0-30V/2mA-3A
    Tylko bede musial zmienic tranzystor z inna obudowa, lub uciac zeberka.
  • #1358
    telemah
    Level 27  
    Ten radiator jest konkretny :D taki ma właśnie być :!: nie męcz się z chlastaniem żeberek kup tranzystor w innej obudowie jak kupisz dobry-mocny tranzystor to wystarczy tylko 1 szt tanie i dobre są np. TIP35c są w dużej obudowie podobnej do TO220 ale dużo większej, jeśli chcesz mieć "total wypas" to zakup sobie jakieś tranzystory typu MJ albo np takie jak ja kupiłem - są droższe bo po kilkanaście zeta za sztukę ale za to mają dużą powierzchnie odprowadzania ciepła i są naprawdę mocne. Jeszcze niektóre wysokonapięciowe tranzystory się nadają o ile do tego są w stanie pochłonąć duży prąd np. niektóre BUV były by niezłe, wiele tranzystorów się nadaje. Te 2N3055 możesz zamocować na tym radiatorze bez cięcia żeber trzeba tylko pomyśleć , jeśli koniecznie chcesz wykorzystać posiadane tranzystory to mogę Ci napisać jak go zamocować bez cięcia żeber.

    Pozdrawiam :D
  • #1359
    markovip
    Level 34  
    Podaj prosze pelna nazwe tego MJ, cena nie gra roli... mieszkam w Hiszpani i tutaj ceny sa inne bo euro jest drozsze od zlotowki :D
  • #1360
    User removed account
    User removed account  
  • #1361
    radziejsz
    Level 16  
    Witam wykonalem plytke zasilacza tego z elektronik labs , czy to mozliwe ze pomiedzy sciazkami jest opro 5Mohm , mozliwe ze poprostu sie nie wytrawilo do konca i jest jaka mini warstwa ?? bo nie moge tego pojac ;)
  • #1362
    markovip
    Level 34  
    Witam

    @aprogips dziekuje bardzo za liste tranzystrow ;) Obejrzalem je i mam juz kilku wybrancow:

    1. BU2520AF + za to ze ma odizolowana obudowe, - mala powierzchnia odprowadzania ciepla 3.15cm²

    2. 2SC5144 5.2cm²

    3. 2SC3858 ma duza powiezchnia opdrowadzania ciepla 7.5cm² <- i na tego sie zdecydowalem, jutro pójde do sklepu i go zamowie chyba kosztuje 4€.
    (w nocie katalogowej jest napisane ze to jest tranzystor do audio, ma to jakies znaczenie czy jest to plus dla konstrukcji?)

    Ten radiator jest troszke za duzy do tej obudowy co mam :D :
    Zasilacz warsztatowy 0-30V/2mA-3A
    Jednak znalazlem juz na to rozwiazanie:
    Zasilacz warsztatowy 0-30V/2mA-3A

    Jedyne co moze sprawic mi problem to to:
    Zasilacz warsztatowy 0-30V/2mA-3A
  • #1363
    User removed account
    User removed account  
  • #1364
    radziejsz
    Level 16  
    plytka jest bez zadnych elementow dlatego mnie to martwi jest czysta plytka dopiero po wytrawieniu nie musze patrzec na wykaz elementow bo ich nie ma , bez przesady taki laik nie jestem :)
  • #1366
    dominium
    Level 10  
    radziejsz wrote:
    Witam wykonalem plytke zasilacza tego z elektronik labs , czy to mozliwe ze pomiedzy sciazkami jest opro 5Mohm , mozliwe ze poprostu sie nie wytrawilo do konca i jest jaka mini warstwa ?? bo nie moge tego pojac ;)


    Czy przypadkiem przy pomiarze nie trzymasz koncowek palcami?

    Pzdr
    Dominium
  • #1367
    telemah
    Level 27  
    Ja też mam tranzystory w obudowie MT i też są polecane do zastosowań audio w przypadku zasilacza nie jest to ani wada ani zaleta tak samo jak rodzaj op-ampów też nie gra tu większej roli - byle pojedyncze :D .
  • #1368
    radziejsz
    Level 16  
    Trójchlorek zelaza , nie nie trzymam palcami tak to wyglada:
    Zasilacz warsztatowy 0-30V/2mA-3A
  • #1369
    telemah
    Level 27  
    A czy mi się wydaje czy przed mierzeniem pomalowałeś czymś płytkę ?
  • #1370
    radziejsz
    Level 16  
    oj jest zabezpieczona przed utlenianiem sie roztworem z kalafoni , ale przed tym było to samo grr mówicie o problemach których nie ma , ;) płytka zabezpieczona bez elementów i ma opór pomiędzy scieżkami ktore nie sa w żaden sposób połączone . Zaniosłem dzisiaj na pracownie to i pokazałem nauczycielowi (technikum) i powiedział ze nie będzie z tym problemu , tylko czy można mu wierzyc ;)
  • #1371
    elek555
    Level 37  
    radziejsz -czy możesz wyjawić o czym piszesz używając określenia "opro miedzy sciazkami" ? To jakiś nowy parametr czy masz coś z klawiaturą?
    Śledzę ten temat od dawna ale jeszcze nikt o żadnym opro nie pisał!
  • #1372
    User removed account
    User removed account  
  • #1373
    radziejsz
    Level 16  
    Niech Ci bedzie , rezystancja pojawia się między dwoma ścieżkami , jest ona chyba nie pożądana , a czy moze tak zostać o to pytam Was bo nie wiem. Oczywiście ścieżki nie są połączone ze sobą pojawia się rezystancja od 2 do 4 Mohm. Czy teraz dość jasno napisałem czy mam cos jeszcze wyraźniej napisac ??
  • #1374
    elek555
    Level 37  
    Jest zdecydowanie lepiej i aż mnie zatkało że pojawiły się polskie znaki :), przecinki i duże litery. Mam chyba jakąś cudowną moc...i sprawię że jak wciśniesz zmień to reszta też wyjdzie super..

    Myślę że możesz śmiało potraktować taką oporność jako izolację (może lekko niedoskonałą np. z powodu resztek wytrawiacza)
  • #1375
    telemah
    Level 27  
    A słyszałeś o takim czymś jak "Rezystancja izolacji" :?: z doświadczenia wiem że pozostałości niektórych past lutowniczych mogą spowodować takie objawy , nie wiem czy kalafonia daje takie efekty...zmyj kalafonię i zmierz później napisz co wyszło
  • #1377
    telemah
    Level 27  
    elek555 wrote:
    Kalafonia jest OK ale pasty i wytrawiacze-przewodzą


    Akurat kalafonii nigdy nie sprawdzałem pod tym kątem , ale że pozostałości niektórych past przewodzą - to wiem bo się kiedyś na to "nadziałem" :D
  • #1378
    radziejsz
    Level 16  
    Napisałem wcześniej , że przed nałożeniem kalafoni było tak samo. Dziekuję za pomoc skoro może zostać to tak zostanie ;)
  • #1379
    elek555
    Level 37  
    dlatego żadnych past w lutowaniu obwodów WN czy odchylania. A jeśli -to później dokładne mycie porządnym spirytusem
  • #1380
    User removed account
    User removed account