Elektroda.pl
Elektroda.pl
X
Arrow Multisolution Day
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zasilacz warsztatowy 0-30V / 2mA-3A

zasoby 15 Paź 2017 11:28 1279703 3121
  • #3061 15 Paź 2017 11:28
    SubFire
    Poziom 7  

    Okej, dzięki ;)
    Dodano po 32 [minuty]:
    Na pinie 7 w U1 i U2, mam napięcie ~35V
    Na 6 pinie U1 brak napięcia, a na pinie 2 i 3 tez brak.
    Na pinie 3 U2 regulując P1 nic się nie dzieje, dalej 0V
    Na D7 brak napięcia.
    Wszystko mierzone względem masy C1.

    Wyciągnąłem układy ponieważ nie mogłem ich dotknąć, a nie chciałem się poparzyć przy mierzeniu. Powinny być wpięte w układ, kiedy mierzyłem, czy nie?
    Dodano po 19 [minuty]:
    Sprawdziłem jeszcze tranzystor mocy(Q4). Chyba coś nie gra.
    Baza(czerwony) - Emiter(czarny) -> 0,48V
    Baza(czerwony) - Kolektor(czarny) -> 0,5V
    Baza(czarny) - Emiter(czerwony) ->0,5V
    Baza(czarny) - Kolektor(czerwony) -> napięcie rośnie do 0,9V i wyskakuje OL
    Jakbym nie podłączył miernika to zawsze coś wskażę.
    Dodatkowo sprawdziłem drugi taki sam, nowy i tam wszystko wygląda okej.

  • Arrow Multisolution Day
  • #3062 16 Paź 2017 12:20
    nwcnwc
    Poziom 5  

    @tomas1991
    "Jeżeli tranzystory będą z jednej serii i w dodatku (czy przede wszystkim) na wspólnym radiatorze, to taki zabieg może być wystarczający (przy pełnym obciążeniu zasilacza mierzymy na obu rezystorach napięcia miliwoltomierzem - powinny być identyczne).
    Jeżeli tranzystory będą się różnić (a ten efekt może potęgować umieszczenie na osobnych radiatorach), wtedy czeka Cię dobieranie wartości co najmniej jednego z tych rezystorów tak, aby wartości napięć przy maksymalnej mocy strat się zrównały, lub (bardziej prawdopodobne) stosunek tych napięć był wprost proporcjonalny do stosunku ich rezystancji. "
    Pozbądź się R16 też.

    a nad tą dioda sygnalizująca CV jeszcze sie zastanowie i napisze :)

  • #3063 17 Paź 2017 18:16
    SubFire
    Poziom 7  

    Można prosić o dalsze wskazówki? Wertowałem strony i dalej nic... A zasilacz jest mi potrzebny na następny wtorek :/

  • Arrow Multisolution Day
  • #3064 17 Paź 2017 20:04
    juniorK123
    Poziom 17  

    Na PW koledze wszystko wysłałem. Skrzynkę sprawdz.

  • #3065 18 Paź 2017 16:39
    SubFire
    Poziom 7  

    O kurcze, dzięki wielkie! Zaraz wezmę się do pracy i zacznę wszystko sprawdzać. Odezwę się!
    Pozdrawiam.

  • #3066 15 Lis 2017 14:27
    jacekczel
    Poziom 9  

    Czy Q1 BC557 i Q3 BC547 aby na pewno poprawnie są lutowane? Chcę je wlutować ale patrząc na schemat wychodzi mi że powinno być wlutowane w odbiciu lustrzanym?

  • #3067 14 Gru 2017 01:51
    pawel.skiba
    Poziom 12  

    Interesuje mnie kwestia napięcia odniesienia w tym układzie.

    W zamkniętym wątku z odpowiedziami https://www.elektroda.pl/rtvforum/topic1187095.html

    Cytat:
    Źródło napięcia odniesienia.
    Tworzą je elementy: U1, D8, R4, R5, R6
    Źródłem napięcia odniesienia jest dioda Zenera 5,6V.
    ....
    Po włączeniu zasilania napięcie na wyjściu wzmacniacza U1 będzie rosło,


    Dlaczego po włączeniu zasilania napięcie będzie rosło? Przecież wtedy na wejściach U1 jest 0 i powinno tak pozostać.?
    Poza tym chciałbym wiedzieć jaka jest jakość takiego napięcia odniesienia? (dokładność)
    Dlaczego w projekcie zastosowano układ napięcia odniesienia ze wzmacniaczem i diodą zamiast dedykowanego elementu napięcia odniesienia?
    Czy ten układ jest lepszy czy gorszy od TL431, albo lm 4040.
    Załóżmy że zamiast układu z diodą i wzmacniaczem użyjemy dedykowanego układu o powiedzmy 2.5V . Czy ~4 razy mniejsze Vref wpływałoby na pogorszenie dokładność regulacji. Z jednej strony intuicja podpowiada że tak bo operuje się na mniejszych różnicach napięć. Z drugiej strony opAmp i tak działa gdy różnica na wejściach dąży do 0.

  • #3068 20 Gru 2017 21:24
    Mad Jaro
    Poziom 16  

    Witam, mam pewien nietypowy problem z tym zasilaczem, mianowicie nie mogę ustawić wartości ograniczenia prądowego mniejszego jak 0,33A i od takiego też zaświeca się dioda mimo skręconych potencjometrów natężenia na minimum.

    W górę tj. powyżej 0.33A wszystko działa idealnie.

    Jaki element odpowiada za dolny zakres ograniczenia ?

  • #3069 21 Gru 2017 08:58
    pawel.skiba
    Poziom 12  

    Za ograniczenie prądowe odpowiada wzmacniacz U3.
    Powinno się sprawdzić elementy na jego wejściach.
    W kolejności
    R17 , P2 , R18 - to jeden dzielnik napięcia odniesienia
    Mniej prawdopodobne
    C8, R21.

  • #3070 21 Gru 2017 10:58
    Mad Jaro
    Poziom 16  

    Dzięki uszkodzony okazał się U3 (swoją drogą dziwne bo w górę działał normalnie)

  • #3071 22 Gru 2017 15:38
    zamela
    Poziom 14  

    Cześć
    kiedyś wykonałem płytkę zasilacza i z braku czasu rzuciłem w kąt a teraz nadszedł czas dokończenia projektu tak więc podłączyłem układ z 2 tranzystorami 2n3055 na wspólnym radiatorze , rezystorami na emiterach i przy obciążeniu zasilacza wyraźnie czuć że jeden tranzystor grzeje się bardziej od drugiego a są tej samej firmy.

    Sprawa nr 2 - trafo mam 1x24V ( na luzie daje 27V ) 8,3A i tak myślę żeby aż tak mocno nie grzały się tranzystory końcowe to uzwojenie wtórne podzielić na 2x12 lub inaczej i dołożyć automatyczne dołączenie II uzwojenia przy wyższym napięciu na wyjściu .
    Czy takie coś ma sens i jest trudne do wykonania ?

  • #3072 23 Gru 2017 13:03
    mateusz25109
    Poziom 10  

    Nie szukałbym błędu w sposobie zasilania płytki, a raczej skupiłbym się na sposobie odprowadzania ciepła z tranzystorów na radiator. To będzie bardziej prawdopodobną przyczyną tego co kolega opisuje. Może jest zbyt mało pasty, może tranzystor jest słabo dokręcony, może powierzchnia radiatora nie jest płaska.

  • #3073 23 Gru 2017 21:54
    zamela
    Poziom 14  

    OK będę miał to na uwadze a co z podzieleniem uzwojenia na 2x12V i zrobienie bajeru z przkekaźnikiem ?

    Ogólnie chcę zrobić z całego zasilacza dodatkowe wyjścia2x12V przemiennego lub 1x24V jeśli nie będę dzielił uzwojenia - dlaczego takie coś bo często potrzebuję właśnie prąd AC a dzięki temu nie będę musiał kombinować z trafami .

  • #3074 26 Gru 2017 14:32
    Arek1410
    Poziom 5  

    Zasilacz warsztatowy 0-30V / 2mA-3A
    Witam, zrobiłem wstępny schemat zasilacza, mógłby ktoś sprawdzić czy wszystko jest ok?

  • #3075 27 Gru 2017 15:53
    mateusz25109
    Poziom 10  

    Zobacz czy poprawnie podłączyłeś wyjście 6 wzmacniacza U3, porównaj ze schematem ze strony ElectronicsLab (połączenie R20 i C8).

    Druga sprawa: czytelność schematu. Aż oczy bolą jak patrzę na to, jak połączyłeś U1. Proponuję to obrócić, stosując polecenie mirror. Dlaczego u Ciebie połączenia przechodzą przez środek elementu? Też bym to poprawił :)

    Trzecia sprawa: proponuję przeczytać (bądź chociaż uważnie przejrzeć :D ) ten temat od początku i ten schemat troszkę zmodyfikować. Ja na Twoim miejscu wymieniłbym wzmacniacze TL081 i na ich miejsce wstawił ua741. Tranzystory mocy Q4 użyłbym dwa i połączył równolegle, dodając na ich emiterach rezystory 0R1. Moc rezystora R7 zwiększyłbym na 10W, a rezystor R18(56k) zamieniłbym na potencjometr 100k, którym to można ustalać maksymalny prąd wyjściowy.

    A po za tymi kilkoma uwagami życzę powodzenia w konstruowaniu zasilacza

  • #3076 28 Gru 2017 13:01
    pawel.skiba
    Poziom 12  

    Czy minimalny prąd podano poprawnie?
    Przy Vref 11.2v względem pkt4. Minimalne napięcie z dzielnika R17 , P2 R18 to ~ 5.6mV.
    By ograniczenie prądowe zadziałało spadek na R7 powinien być większy od tej wartości. a to się stanie gdy prąd będzie 12mA.

    Poza tym czy w tym układzie zastosowane wzmacniacze nie działają poza dopuszczalnym napięciem zasilania? u3, u2 mają ekstra 5.6V na zasilaniu.

  • #3077 28 Gru 2017 23:58
    Arek1410
    Poziom 5  

    Zasilacz warsztatowy 0-30V / 2mA-3A
    Zmieniłem to co zasugerowałeś, jak teraz?
    Od razu mówię, że za potencjometry i tranzystory mocy dałem złącza, przez które połączę te elementy :)

  • #3078 29 Gru 2017 11:21
    yogi009
    Poziom 42  
  • #3079 29 Gru 2017 18:23
    mateusz25109
    Poziom 10  

    Zasilacz warsztatowy 0-30V / 2mA-3A

    Jednak na samym początku polecam przerobić porządnie schemat, bo naprawdę jest bardzo słabo czytelny. Może zacznij od jakiegoś poradnika na YT. I nie mówię tego złośliwie.

    Mam pytanie do miejsca gdzie dałem wykrzykniki. Jakim poleceniem dokonujesz połączeń między elementami? Węzły dodajesz osobno? Tutaj na schemacie nie ma węzła, więc mam rozumieć, że nie jest to połączone? Jak będzie wyglądać to połączenie na płytce PCB?

    I kolejne pytanie: nie rozumiem dlaczego tak połączyłeś potencjometr P3. Możesz to wyjaśnić?

  • #3080 31 Gru 2017 14:20
    Arek1410
    Poziom 5  

    Zasilacz warsztatowy 0-30V / 2mA-3A
    Dzięki za wszelkie uwagi, poprawiłem to co zasugerowaliście. Co jest jeszcze do poprawy/zmiany w schemacie?:)

  • #3081 31 Gru 2017 16:32
    yogi009
    Poziom 42  

    Jest tego jeszcze cała masa.

    Zasilacz warsztatowy 0-30V / 2mA-3A

    Popatrz na zaznaczone punkty, to nie jest szczyt elegancji i czytelności.

    Zasilacz warsztatowy 0-30V / 2mA-3A

    Tutaj wystarczy przesunąć nieco w lewo pionową, zieloną linię oraz obrócić rezystor tak, żeby go włączyć wprost do wyjścia opamp'a. Możesz też użyć symboli zasilania i masy, wtedy odpadnie konieczność łączenia punktów zasilania i masy na cały schemacie. Trochę prostych zabiegów i schemat stanie się czytelniejszy.

  • #3082 01 Sty 2018 00:21
    Arek1410
    Poziom 5  

    Dzięki, poprawiłem. A co do samego schematu ideowego to wszystkie połączenia i elementy są dobre? :)

  • #3083 01 Sty 2018 12:01
    yogi009
    Poziom 42  
  • #3085 01 Sty 2018 19:08
    yogi009
    Poziom 42  

    Będę skrupulatny :-) Przyjrzyj się jeszcze kilku punktom schematu, dwa oznaczają brak fizycznego połączenia sygnałów, reszta to kosmetyka (ale taka przydatna). Jeszcze jedno pytanko, patrzę tak na całość i zastanawiam się, czy wszystkie Twoje linie połączeń i same połączenia wypadają dokładnie na liniach przyjętego rastra? Niedopilnowanie tego szczegółu często owocuje trudnymi do wychwycenia brakami w połączeniach. Zazwyczaj sygnał nie dociera do nóżki symbolu elementu (jest tuż, tuż, ale jednak obok, z winy przyjętego, innego rastra).

    Zasilacz warsztatowy 0-30V / 2mA-3A

  • #3086 06 Sty 2018 00:08
    zamela
    Poziom 14  

    Czy jest możliwość i ew jak to zrobić by podczas pracy w trybie C.V. świeciła się np zielona dioda bo przy C.C wiadomo jest czerwony led i gdy zasilacz przejdzie w tryb źródła prądowego załączył się buzer na 2 sekundy .

    Czy dioda sygnalizująca ograniczenie prądowe działa 0-1 ? bo u mnie gdy przy podłączonym obciążeniu obniżam ograniczenie prądowe to dioda w pewnym momencie lekko świeci nie działa zero jedynkowo czy tak to ma działać ? ew gdzie szukać przyczyny tego stanu ?

  • #3087 06 Sty 2018 10:55
    adversus
    Poziom 24  

    Koledzy na znanym polskim portalu aukcyjnym można kupić zestaw części z płytka i dokumentacją za śmieszne pieniądze, nie wiem czy nawet wartość części kupionych osobno nie będzie większa od wartości zestawu a i płytka pcb wygląda na solidnie wykonaną jak za tę kasę (powoli zaczyna się nie opłacać wykonywanie niektórych układów bo pojawiają się gotowce za śmieszną kasę) nie podaję linku itp by nie byc posądzonym o reklamę :)

    Zasilacz warsztatowy 0-30V / 2mA-3A

  • #3088 06 Sty 2018 11:00
    goldi74
    Poziom 43  

    Te zestawy od dosyć dawna są dostępne na ebay lub aliexpress za jeszcze mniejsze pieniądze. Schematowo jest to dokładna kopia zasilacza opisywanego w tym temacie, jedynie płytka drukowana jest zaprojektowana inaczej.

  • #3089 06 Sty 2018 12:24
    kkknc
    Poziom 42  

    Dokładnie czasem robienie czegoś dziś jest nieopłacalne finansowo. Ceny części większa od gotowego produktu.
    Zasilacz warsztatowy 0-30V / 2mA-3A

  • #3090 06 Sty 2018 12:34
    Mad Jaro
    Poziom 16  

    Czy, ktoś z Was spotkał się z takim problemem mianowicie, po włączeniu ("na zimno") świeci od razu ograniczenie prądowe mimo ustawienia wszystkich potencjometrów na 0.

    Dodatkowo napięcie powoli zaczyna rosnąć od 8,8V, pomimo ustawienia napięcia na maks (28,6V)
    Jak zostawię zasilacz włączony na jakiś czas, to napięcie urośnie do maks 28,6V, ograniczenie prądowe gaśnie i wszytko wydaje się być tak jak powinno.
    Nie mam pojęcia gdzie szukać przyczyny, na płytce nie mam żadnego zwarcia. Ale zauważyłem, że mocno grzeje się R1 2k2



    Korzystałem z tego schematu ze stabilizatorem -5V oraz stabilizatorem 24V + zener 6V2
    Zasilacz warsztatowy 0-30V / 2mA-3A