Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

linux i dwa dyski nie moge skonfigurowac

03 Lut 2006 19:47 1093 8
  • Poziom 14  
    witam

    mam nastepujacy problem mam dwa dyski na pierwszym zainstalowalem debiana :)

    a na drugim dysku mam cztery partycje windowsa FAT

    na poczatek przy ladowaniu debiana widac ze wykrywa drugi dysk hdd...

    i nie moge skonfigurowac

    zawatwosc /etc/mtools.conf
    Code:

    # Debian default mtools.conf file.
    # "info mtools" or "man mtools.conf" for more detail.
    # # Linux floppy drives


    drive a: file="/dev/fd0" exclusive
    drive b: file="/dev/fd1" exclusive


    drive c: file="/dev/hdd1"
    drive d: file="/dev/hdd2"
    drive e: file="/dev/hdd3"
    drive f: file="/dev/hdd4"

    # # dosemu hdimage.
    drive m: file="/var/lib/dosemu/hdimage.first" partition=1 offset=128

    # # dosemu floppy image
    drive n: file="/var/lib/dosemu/fdimage"

    # # SCSI zip disk
    # drive z: file="/dev/sda4"
    # # uncomment the following line to display all file names in lower
    # # case by default
    # mtools_lower_case=1


    i nie dziala :|

    jeszcze posprawdzam wszystko czy dyski sa napewno tak popodlaczane
    ale raczej na 100% bo sprawdzalem jzu kilka razy

    z gory dziekuje
  • VIP Zasłużony dla elektroda
    Po co Ci do obsługi partycji FAT32 mtools ??

    Można je bezproblemowo zamontować pod Linux'em

    mount -t vfat /dev/hdda /mnt/c

    Albo odpowiednie wpisy w pliku /etc/fstab - to mogą się automatycznie montować partycje.
  • Poziom 14  
    :)) no i prawie dobrze ale :))

    jak wykonalem polecenie
    mount -t vfat /dev/hdda /mnt/c
    wyskoczyla mi wiadomosc
    /mnt/c nie istnieje

    jak wpisalem do pliku /etc/fstab recznie z podaniem systemu plikow czyli FAT

    wyskoczyla mi taka sama wiadomosc jak probowalem otworzyc /mnt/c


    a jak wpisalem w /etc/fstab automatyczne wyszukiwanie systemu plikow to ;)
    napisalo mi ze nie moze rozpoznac wlasnie systemu plikow

    ? czyzby brakowalo mi jakiegos pakietu ? :|
  • Poziom 12  
    Code:

    drive c: file="/dev/hdd1"
    drive d: file="/dev/hdd3"
    drive e: file="/dev/hdd4"
    drive f: file="/dev/hdd5"


    czasamie nie powino byc tak :?::!:
    jezeli masz na dysku 4 partycje to:
    c: /dev/hda1 jest podstawowa, a /dev/hda2 to roszerzona i na niej powinny byc parycje logiczne
    d: /dev/hda3
    e: /dev/hda4
    f: /dev/hda5

    tak powinnen wygladac prawidlowo podzielony dysk
    ale odpal jeszcze fdisk /dev/hdd i tam sprawdz nr partycji

    a co do tego

    _POCk_ee napisał:

    jak wykonalem polecenie
    mount -t vfat /dev/hdda /mnt/c
    wyskoczyla mi wiadomosc
    /mnt/c nie istnieje


    to

    nie masz katalogu /mnt/C
    wykonaj polecenie
    Code:
    mkdir /mnt/c 

    oczywiscie z roota :]
    pozdrawiam
  • Poziom 14  
    dziki koledze sq8lst :)

    c: /dev/hda1
    d: /dev/hda3
    e: /dev/hda4
    f: /dev/hda5

    ale ja mam na hdd podlaczony drugi dysk

    bo sie mam walniete na plycie glownej i mi na IDE1 nie wykrywa dyskow wiec dyski mam na IDE2 a napedy na IDE1

    pozatym nie zmienia to ze dalej mi wyskakuje ze nie moze rozpoznac systemu plikow :))
  • Poziom 12  
    sory zapedzilem sie z przyzwyczajania :]
    zamiast hda ma byc hdd sory za blad

    utworzyels katalog /mnt/c ?
    sprawdziles typy i nr partycji w jakis programie np fdisk lub na w graficznym QTParted
    i daj znac pokaz jeszcze plik /etc/fstab i powiedz jaka masz dystrybucje
  • Poziom 14  
    Debian GNU/Linux 3.1 aktualizacja (r1)

    teraz zrobielm jakos ze jest c :)) na hdd1

    /etc/fstab
    Code:

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hdc1       /               ext3    defaults,errors=remount-ro 0       1
    /dev/hdc5       none            swap    sw             0       0
    /dev/hda        /media/cdrom0   iso9660 ro,user,noauto  0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0


    /dev/hdd1        /mnt/c          auto    rw,user,noauto  0       0
    /dev/hdd3        /mnt/d          auto    rw,user,noauto  0       0
    /dev/hdd4        /mnt/e          auto    rw,user,noauto  0       0
    /dev/hdd5        /mnt/f          auto    rw,user,noauto  0       0



    juz sie ciesze z c :))
    ale nie wiem jak reszte [/code]
  • VIP Zasłużony dla elektroda
    _POCk_ee napisał:

    /dev/hdd1 /mnt/c auto rw,user,noauto 0 0
    /dev/hdd3 /mnt/d auto rw,user,noauto 0 0
    /dev/hdd4 /mnt/e auto rw,user,noauto 0 0
    /dev/hdd5 /mnt/f auto rw,user,noauto 0 0[/code]


    juz sie ciesze z c :))
    ale nie wiem jak reszte [/code]


    Analogicznie jak "C"
    Wpisy w /etc/fstab są w porządku - teraz tylko załóż odpowiednie katalogi /mnt i powinno wszystko działać.
  • Poziom 14  
    wiec w /mnt mam podobione c d e f

    Code:

    bla-bla:/mnt# dir
    c  d  e  f


    c mi dziala po uzyciu mount

    mount -t vfat /dev/hdd1 /mnt/c

    a w pliku /etc/fstab co kolwiek bym wpisal to c mi dziala nawet jak mam

    /dev/hda2 /mnt/c auto rw,user,noauto 0


    to jest oki a z reszta dyskow probowalem roznie i
    Code:

    /dev/hdd2       /mnt/d          auto    rw,user,noauto  0 
    i
    /dev/hda3        /mnt/d          auto    rw,user,noauto  0 



    jak pisze polecenie

    mount -t vfat /dev/hdd2 /mnt/d
    lub
    mount -t vfat /dev/hdd3 /mnt/d
    wyskakuje mi blad
    Code:

    mount: wrong fs type, bad option, bad superblock on /dev/hdd2,
           missing codepage or other error
           (aren't you trying to mount an extended partition,
           instead of some logical partition inside?)
           In some cases useful info is found in syslog - try
           dmesg | tail  or so
    [/code]