Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Komendy AT w telefonach komórkowych.

Wglik 07 Lut 2006 22:26 6324 13
  • #1 07 Lut 2006 22:26
    Wglik
    Poziom 11  

    Witam.

    Które komórki (z tych starszych/tanich) można sterować za pomocą komend AT? Chodzi mi o wysyłanie SMS oraz połączenie do przesyłania danych.
    Mam Siemensa MT50 ale po podłączeniu go kabelkiem do PC gubi zasięg w momencie nawiązywania połączenia. Podczas normalnej pracy zasięg jest idealny. Czy to normalne w MT50?

    Wglik

    0 13
  • #2 08 Lut 2006 06:02
    i_punkt
    Poziom 12  

    witam...
    Opisywany przez Ciebie objaw jest bardzo dziwny...
    Nigdy nie spotkałem sie z takim przypadkiem powiem szczerze ze odnosze wrazenie ze utraty zasięgu spowodowane są niewłasciwym oprogramowaniem ktorego używasz...
    Spróbuj zmienic oprogramowanie i to powinno pomóc....


    Pozdro....

    0
  • #3 08 Lut 2006 11:15
    Wglik
    Poziom 11  

    Używałem program SiMoCo Siemens Mobile Control 2.2.6 oraz Hypertreminal korzystając z polecenia ATD, ATDT i zawsze w momencie naciśnięcia Entera gubił zasięg. Na dodatek jak dzwoniłem z innego telefonu na MT50 (gdy ten był podłączony pod PC ale nie wysyłałem do niego żadnych komend) to także gubił zasięg i nie dało się dodzwoni. Jedynie udało mi się odebrać SMSa ale wysłać już nie.

    0
  • #5 08 Lut 2006 12:33
    Wglik
    Poziom 11  

    Kiedyś ten telefon był serwisowany i może coś sknocili. Nie wiem bo niezbyt dobrze znam się na komórkach, a dokładniej i wnętrznościach, także z tym MT50 też się poddaję.

    Właściwie głównym tematem jest jakie telefony (te tanie) wykorzystują do komunikacji np. z uC komendy AT. Chodzi mi wyłącznie o możliwość wysyłania SMS oraz ewentualnie transmisję danych. Proszę o podanie modelów. Jakby ktoś miał dokładny opis komend AT wykorzystywanych przez komórki to też mile widziane. Znalazłem w sieci sporo opisów AT ale były one raczej do modemów, a nie do komórek i nie było w nich różnych poleceń wykorzystywanych w telefonach.

    Dzięki za pomoc
    Wglik

    0
  • #6 08 Lut 2006 15:26
    82921
    Użytkownik usunął konto  
  • #7 08 Lut 2006 16:57
    Wglik
    Poziom 11  

    Właśnie zrobiłem kabel na MAX232. Najprostszy jaki może być. Jeżeli wina leży po stronie kabla to dlaczego. Przecież te kabelki, które się kupuje są robione dokładnie tak samo (MAX232) ewentualnie mają jeszcze jakieś zabezpieczenia. Na razie kabelek jest zasilany z osobnego źródła. Spróbuje zasilić go z komórki i zobaczę jak wtedy będzie działać.

    Dodano po 41 [minuty]:

    Problem z MT50 naprawiony. Jak zlikwidowałem zewnętrzny zasilacz i podłączyłem MAX232 pod zasilanie z telefonu wszystko działa prawidłowo.

    0
  • Pomocny post
    #8 08 Lut 2006 18:15
    82921
    Użytkownik usunął konto  
  • #9 08 Lut 2006 22:30
    Wglik
    Poziom 11  

    Znalazłem w końcu informacje na temat komend AT dla w Siemensach i Nokii oraz coś o kodowaniu PDU. Kodowanie dotyczy różnych projektów ale tłumaczy o co tam chodzi. Jak ktoś chce to mogę wrzucić to na forum.

    0
  • #10 05 Sie 2006 18:19
    pieknooki
    Poziom 10  

    fajnie by bylo gdybys wrzucil :)

    0
  • #11 21 Sie 2006 12:33
    Wglik
    Poziom 11  

    Wszystkie pliki z opisami komend AT, które udało mi się skompletować.

    1
  • #13 08 Paź 2006 00:17
    daniej
    Poziom 10  

    Wglik napisał:
    Problem z MT50 naprawiony. Jak zlikwidowałem zewnętrzny zasilacz i podłączyłem MAX232 pod zasilanie z telefonu wszystko działa prawidłowo.


    Problem tkwił w napięciu zasilania MAX232 a konkretniej w napięciu na lini TxD. Gdy jest ono większe od napięcia zasilania telefonu traci on zasięg. Standardowe kabelki działają tylko trzeba ograniczyć napięcie na lini TxD i RxD do napięcia telefonu np po przez wstawienie diody zenera.

    0
  • #14 08 Paź 2006 11:18
    deltasystem
    Poziom 12  

    Objaw ten jest spowodowany niedopasowaniem poziomów napięć pomiędzy max232 a telefonem , najprostszym rozwiązaniem to wstawić w linie pomiedzy układem a telefonem rezystory 10k i po kłopocie , przerabiałem to niedawno i po dodaniu rezystorów działa bezproblemowo.

    0