Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.
itemscope itemtype="https://schema.org/QAPage"

Terminal dla DOSa? Po wysłaniu pliku nie widać zawartości na ekranie.

MCbx 09 Lut 2006 16:12 1374 9
  • Terminal dla DOSa? Po wysłaniu pliku nie widać zawartości na ekranie.

    #1
    Poziom 28  

    Mam taki terminal, Ampex 210+. Po podłączeniu do portu szeregowego komputera PC z DOSem i odpaleniu Terminala Nortona Commandera widać, że komputer go widzi, tzn. można wysłac plik na terminal.
    Po wysłaniu pliku jednakże nie widze jego zawartości na ekranie, tylko jakieś krzaczki. Kiedy w terminalu NC coś napiszę, na ekranie Ampexa nic nie widać. Kiedy nacisnę jakiś klawisz parę razy, na ekranie pojawiają się kolejne krzaczki (różne, z reguły więcej niż naciśnięć klawisza).

    a. Czy mozna go zmusić do prezentowania na ekranie zawartości pliku?
    b. Czy można za pomocą tego terminala wysłać polecenie DOS na komputer?
    c. Jak ten temrinal skonfigurować? Podaję opcje, co do których kompletnie nie wiem, jak ustawić.:

    Menu 1:
    CHAR / BLOCK / LINE / LOCAL
    FDX / HDX
    QT102 / ADM5 / VP-A1 / VP-A2 / R25 / H1500 / H1410 / A210+ / TV925 / T910+ / TV910 / TV920
    USA / FRE / UK / GER / SWD / NOR / DAN
    KBON / KBLK
    MON OFF / MON ON
    AUX OFF / AUX ON
    PROTOFF / PROT ON
    GFXOFF / GFX ON

    Menu 2:
    STATOFF / STAT ON

    Menu 3:
    SAV ENB / SAV OFF
    BELLOFF / BELL ON
    CR=CR / CR=CRLF
    NORMAL / ENHANCE

    Menu 4:
    DTR / DTR-XON / NONE / XON/XOFF
    BIT8=0 / BIT8=1 / 7 BITS
    NO PARCHK / PAR CHECK
    FREQ 65 / FREQ 60

    Menu 5:
    HEOM= ...
    HERE IS= ...

    Menu 6:
    VECTOR= FDX / LOCAL / HDX
    F 1= ...

    Mile widziany byłby jakiś manual.

    Jeszcze jedno: Poniewaz nie miałem kabla, którego jedna stronę podłączył bym do żeńskiego gniazda COM 20pin, a drugą do męskiego portu w terminalu, wybebeszyłem 20-pinoiwe gniazdo COM z komputera, żeby wisiało na taśmie i podłączyłem bezpośrednio do terminala. Jest możliwe, że się jakieś bity poprzestawiały i dlatego nawala?

    0 9
  • #2

    VIP Zasłużony dla elektroda

    Kabel chyba na 25 pin ?
    Jak go podłączyłeś ?
    1:1 ?

    0
  • #3
    Poziom 28  

    Wsadziłem gniazdo COMa w gniazdo terminala. Tak po prostu.

    Po lekkiej zmianie konfiguracji i pobębnieniu na klawiaturze terminala NC terminal wyświetla znaki, ale nie te, co powinien, częśc liter jest wogóle nieaktywne, a np. przy strzałce w górę wyswietla coś w rodzaju "@2Y".

    0
  • #5
    Poziom 16  

    Upewnij sie ze:
    -predkosc transmisji w obu urzadzeniach jest ta sama
    -podlaczenie jest prawidlowe
    -bity stopu, patrzystosc sa tak samo ustawione

    0
  • #6

    VIP Zasłużony dla elektroda

    :arrow: hekto5

    Jak jesteś taki mądry to nie pisz tu zapychaczy tylko wyjaśnij jakie parametry ustawić w tym terminalu.

    Masz przecież podane całe menu !


    Nie pisz o ogólnikach tylko o konkretach.

    0
  • #7
    Poziom 16  

    Napisalem jakie parametry sa najwazniejsze w transmisji zlaczem szeregowym. Mozna je latwo odszukac ale niech bedzie...

    Trzeba w terminalu i na PC ustawic tak samo. A jak dalej nie dziala to probowac troche zmieniac na obu urzadzeniach.

    Menu 4:
    DTR / DTR-XON / NONE / XON/XOFF - sterowanie przeplywem NONE

    BIT8=0 / BIT8=1 / 7 BITS - ilosc bitow transmisji, najlepiej 8

    NO PARCHK / PAR CHECK - sprawdzanie parzystosci - NO PARCHK (bez parzystosci)

    FREQ 65 / FREQ 60 - to byc moze sluzy do ustawienia predkosci transmisji, jednak nie wiem dokladnie jaka predkosc daje 60 czy 65. Byc moze jest to wartosc podzielnika, wtedy Predkosc = CzestotliwoscKwarcu/Podzielnik. Proponuje ustawic na 60, na PC sprawdzac po kolei wszystkie predkosci od najmniejszej, sensowny max = 115200.

    Te krzaczki sugeruja tez problem z kablem, ale nie wiem jak to powinno byc polaczone w tym przypadku.

    0
  • #8
    Poziom 28  

    Dobra, Już to pokonfigurowałem. BIOS strasznie trudno się zmienia, jeszcze te skróty. Bo dopiero po kilkudziesięciu próbach doszedłem, że Ctrl-Shift-Function-S to zapisanie ustawien, a Ctrl-Shift-Home-D to ustawienia fabryczne...
    Te herce od monitora.

    Czy jak się nie da nullmodemu to takie rzeczy sie dzieją?
    Krzaczki - miałem na myśli przypadkowe litery, nie zakłócenia. Zakłóceniami obrywam w momencie, gdy próbuję odebrać plik tekstowy na trybie graficznym, ale wtedy to powinno byc normalne...

    Jak zrobię ten kabel z gniazd z dwóch śledzi (jeden COM do żeńskiego COMa terminala drugi LPT do męskiego COMa w komputerze) to ile mogę max. te przewody prowadzić (długość, lutowanie itd.). Nie chciałbym tam czegoś sfajczyć :)...

    0
  • Pomocny post
    #9

    VIP Zasłużony dla elektroda

    Mój przewód ma dwa metry długości i działa poprawnie.
    Zrobiłem go ze strego kabla od drukarki wymieniając końcówkę.
    Mój ma takie połączenia :

    Code:

            PC male DB25            Terminal DB25
     TxD   Transmit Data     2-->3  RxD   Receive Data
     RxD   Receive Data      3<--2  TxD   Transmit Data
     RTS   Request To Send   4-->5  CTS   Clear To Send
     CTS   Clear To Send     5<--4  RTS   Request To Send
     DSR   Data Set Ready    6
                             |
     DCD   Carrier Detect    8<--20  DTR   Data Terminal Ready
     SG    Signal Ground     7---7   SG    Signal Ground
                                 6   DSR   Data Set Ready
                                 |
     DTR   Data Terminal    20-->8   DCD   Carrier Detect
              Ready


    RS232 w kompie utawiłem tak :

    Code:

    SERIAL TRANSFER  - 9600 BPs
    SERIAL PROTOCOL - READY/BUSY lub NONE
    DATA LENHGT     - 8 bits
    PARITY          - NONE
    STOP BITS       - 1



    Jak był kabel 1:1 to nic się nie pokazywało.
    Jak zrobiłem inny kabel to zaczęły pojawiac sie jakieś krzaczki.
    Dopiero jak dostał poprawny kabel w/g opisu wyżej to zaczęło działać :)

    Powodzenia
    PitD

    1
  • #10
    Poziom 28  

    No udało mi się przez ten Nullmodem, ale nie do końca.
    Jak nacisnę klawisz strzałki na terminalu, to kursor się przesuwa. Tymczasem na komputerze wyskakuje mi jakiś dziwny znaczek. To samo do czyszczenia strony, linii itp. Strzałki w kompie tak samo wpływaną na terminal: nie przesuwanie, ale znaczki.

    0