Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Ploter ROLAND DPX-3300

K2 21 Maj 2003 03:33 3650 8
  • #1 21 Maj 2003 03:33
    K2
    Poziom 12  

    Ploter stołowy A0
    Pracuje tylko oś X -----duży silnik
    w osi Y pracuje sporadycznie lub wcale (mały silnik krokowy lekko wibruje)
    Pytanie ....czy ktoś wie jak usunąć tę usterkę?
    czy przyczyna tkwi w silniku czy w układzię sterowania
    Może ma ktoś namiary na schematy ideowe do tego plotera :arrow: ROLAND DPX-3300 :?: :?:

    0 8
  • #2 21 Maj 2003 12:56
    felu
    Poziom 17  

    Jezeli lekko wibruje to stawialbym na elektronike, ale rowniez moglo pasc ktores z uzwojen w silniku.Napisz ile przweodow dochodzi do silnika.
    Jezeli masz miernik i zasilacz to latwo to sprawdzisz :
    Jezeli masz 5 przewodow (lub 6) do silnika to :
    1 zobacz gdzie podlaczona jest masa (odepnij silnik od plytki!!!! i testerem ciaglosci - zwykly pipczek w mierniku- sprawdz ktory pin na plytce ma zwarcie do masy (ogudowy albo jakiegos ekranu)
    2 Przeczytaj na silniku (albo zmierz ) jakie ma zasilanie silnik
    3 ustaw zasilacz na zadane napiecie podlacz mase do masy silnika i dolaczaj na chwile plus do pozostalych przewodow. Silnik powinien robic "kroczki". Jezeli po dotknieciu plusem do ktoregos przewodu silnik nie zareaguje to jest spalone to uzwojenie. Jezeli bedzie robil "kroczki" (obojetnie w ktora strone) to z silnikiem jest wszystko OK.
    4 Jezeli silnik jest OK to polacz 4 diody (katody masy zlutuj razem) a anody plusy przez odpowiednie rezystorki (oblicz z prawa ohma prad diody to okolo 10 mA) podlacz do kolejnych 4 wyprowadzen na plycie.
    5 Podlacz wszystko i zobacz czy wszystkie diody swieca lub mrugaja (zalezy jak szybko krecil sie ten silnik) jezeli ktoras nie mroga swieci to uszkodzona jest elektronika.

    Jezeli do silnika ida 4 przewody to jest on inaczej sterowany i opis jest zbyt skomplikowany. Mozesz posprawdzac miernikiem czy na wszystkich 4 przewodach pojawia sie napiecie wzgledem masy.

    Najlepiej znajdz cos o sterowaniu silnikami krokowymi na www.google.pl i poczytaj troche teorii a wszystko ci sie rozjasni. (staralm sie napisac dosc jasno :) )

    Powodzenia.

    Pozdrawiam.

    0
  • #3 23 Maj 2003 02:29
    mgim
    Poziom 29  

    Na osi silnika jest osadzone kółko zębate (plastik) które "utraciło kontakt" z osią tegoż silnika.Albo pękło to kółko albo poluzowała się śrubka mocująca.Uwaga do ustawienia musisz użyć szblonu.

    0
  • #4 23 Maj 2003 04:02
    K2
    Poziom 12  

    Bujaj się Fela bo jutro niedziela .... to takie skojarzenie z piosenką

    Ale do rzeczy
    Dziękuję że odpisałeś Felu
    Zawziąłem się na ten ploter z powodu który później wyjaśnię.

    Co do tej pory zrobiłem

    1.__Silnik ma 10 przewodów jest tak nieszczęśliwie przykręcony iż żeby zobaczyć jaki to model
    to należałoby rozkręcić całą mechanikę(wałki, prowadnice,linki,napinacze i wiele innego badziewia ) to byłby krok ostateczny motywowany jedynie przekonaniem że silnik jest w 100 procentach felerny. Nadmienię tylko iż ploter jest w doskonałym stanie.Dostałem go od kolegi grafika za frajer ponieważ nikt z fachowców których wzywał nie potrafił go ruszyć
    to trwało 3 lata.Kolega ma nowy ploter za 25 kawałków a ja jestem szczęśliwym posiadaczem
    zepsutego grata ale jak nadmieniłem .......w doskonałym stanie.
    2.__10 przewodów i pięć niezależnych uzwojeń każde ma 20 omów. To zmierzyłem czyli 5 fazowy silnik krokowy .Jestem przekonany ze podobnie jak ten większy ma 0,45 stopnia
    na krok czyli 1 obrót to 800 kroków. W manualu (500 str)który wygrzebałem w sieci(w ROLAND DG.... kompletna cisza) piszą że pisak ma dokładność ustawiania 0,0125 mm
    czyli 12,5 mikrona imponujące co?.Oczywiście w manualu są tylko opisy jak włożyć pióra
    jak czyścić itp.
    3.__Następnym podejrzanym była plastikowa taśma z wtopionymi drutami .Taśma ta jest w ciągły ruchu w czasie pracy plotera.Po wielu próbach z omomerzem(taśmę skręcałem zginałem itp.) doszedłem do pewności że jest dobra.
    4.__Musiałem więc iść dalej rozkręciłem grata (dolna pokrywa ok. 30 śrub)
    Uchyliłem pokrywę i piękny widok na 2 płytach ok. 120 uładów scalonych w śród nich
    pośrodku królował hybryd z napisem ROLAND DG i wiele numerków na nim .Myślę
    sobie byle nie ON niby ten król ......a jednak .Wykręciłem płyty z plątaniny kabli aby
    coś wydedukować ..z nóżek hybryda ścieżki do gniazda zasilającego kaprawy motor
    4.__Teraz pomiar całego obwodu silnika z pinów hybryda poprzez wszystkie złącza aż do przewodów silnika.....wszystko OK.
    5.__Intuicyjny pomiar napięć na płytach (nie będę się rozpisywał to prawie książka)
    brak dowodów na feler .Stan płyt ich wykonanie OK.
    6__Podejrzane 3 piny hybryda wyraźnie przegrzana cyna ...czyszczenie i poprawa lutów
    .....______ maszyna dalsze płocha rabotajet.
    7__.Walka trwa.
    8.Diody LED z opornikami na każde uzwojenie silnika 2 oscyloskopy 4 multimetry w boju.
    9__małe odkrycie ...w stumieniach oscyloskopów widać regularne przebiegi odpowiadające
    fazom pracy silnika 5 fazowego po ich analizie ..przebiegi są dobre lecz o małej amplitudzie
    diody się żarzą (nie świecą) kiedy przyjdzie na nie kolej ...sterowanie typu tick z pulpitu plotera o odkrycie to, to iż na oscyloskopie widać iż prąd w uzwojeniach jest kluczowany PWM ok. 5 kHz ale skąd się to bierze .Nurkowanie w kable pod blat pomiar i ..
    do jednego z pinów hybryda dochodzi te 5 kilo ale słabe
    10__Wniosek silnik chodzi z czoperem aby zwiększyć moment obrotowy
    11.__Gonię po płycie za tymi 5 kilami znajduję jakieś PWM dotykam sądą miernika pin przy
    scalaczku 16 pin RA xxx silnik rusza i pracuje ok. 4 godz ok.
    Corelę łapię pliki plt Ploter szaleje i .....rysuje ładnego konia ...chyba to Fela ciesząca się na niedzielę
    Kamień z serca Hybryd OK.
    Po wylączeniu ok. 2 godz feler wraca lecz dotkniecie szpilką w czuły punkt reanimuje maszynę do ponownego wyłączenia

    Już.już blisko do końca boju .... do krwi ostatniej

    Acha ploter chcę wykorzystać do automatycznego kładzenia elementów SMD na plytce PCB
    Oczywiście po przeróbce jeśli jesteś zainteresowany to mogę Ci to opisać

    Jeszcze raz dzięki felu miałeś rację silnik dobry
    Pozdrawiam K2 Raczkujący Użytkownik to brzmi dumnie !!!!!

    0
  • #5 23 Maj 2003 10:19
    K2
    Poziom 12  

    Hello :oops: mgim
    :)
    na oś silnika jest wprasowana mosiężna zębatka napędzająca plastikowe kółko zespolone
    z metalowym walcem na który nawija się metalowa linka .Linka ta ciągnie metalową głowicę
    znajdującą się na wałku w osi Y.Tym elementom dokładnie się przyjrzałem są dobrze zamocowane.
    Za pomocą języka wewnętrznego plotera RD-GL Command(opisanego moim zdaniem znakomicie w DPX-3300 Operation Manual) poprzez port szeregowy (prosty program w Delphi) kazałem ploterowi wielokrotnie rysować małe prostokąty, kropeczki znajdujące się
    w różnych miejscach arkusza A1 .Po godzinie takiej gonitwy pisaka po stole uderzał i rysował
    w tych samych zadanych miejscach.
    To utwierdziło mnie w przekonaniu że mechanika plotera sprawuje się świetnie.
    Jednak problemy z elektroniką są dalej do końca nie wyjaśnione o czym pisałem w odpowiedzi do Fela
    Pozdrawiam i mam cichą nadzieję że znajdzie się jakiś spec który to już przechodził(chodzi o DPX 3300) i zechce podzielić się swoją wiedzą.
    Za każdą sugestię jestem niezmiernie wdzięczny ........raczkujący K2 :)

    0
  • #6 25 Maj 2003 00:32
    mgim
    Poziom 29  

    K2 napisał:
    .....z metalowym walcem na który nawija się metalowa linka..

    To masz model "podtypu" KZ-7BA.

    0
  • #7 25 Maj 2003 01:57
    K2
    Poziom 12  

    Życie weszło w ROLANDA

    Jak już wspomniałem po dotknięciu sondą miernika w pewien punkt płyty z elektroniką (dokładnie TP10) ploter zaczynał pracować poprawnie .Ten miernik ma stałą oporność wejściową 10 M om.Dla próby do TB10 i masy przylutowałem opornik 510k itak już zostało.Jest OK.Ploter pracuje od kilku dni.
    Punkt pomiarowy TB10 znajduje sie w pobliżu 2 układów o dziwnych nazwach jest przy nich trochę kondensatorów cer.22p 47p i domniemywam że wymiana ich nowe byłoby postawieniem kropki nad i.
    Jeżeli znów się spieprzy to to zrobię .

    Z mojej strony uważam temat za zamknięty .
    Dziękuję wszystkim za pomoc.

    0
  • #8 17 Lut 2005 13:54
    Anonymous
    Użytkownik usunął konto  
  • #9 29 Sie 2007 12:40
    Kamus
    Poziom 12  

    Witam.Nie moge dać rady przełączyć z obsługi portu szeregowego na port Centronix.Próbuje robić różne kombinacje przełącznikami na boku ale to nic nie daje.Jeżeli wiecie to prosze o wszelkie porady.Będe wdzięczny

    0