Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Problem z synchronizacją procesów.

jahoo 01 Kwi 2006 00:00 744 3
  • #1 01 Kwi 2006 00:00
    jahoo
    Poziom 15  

    Witam, mam mały problem z synchronizacją procesów. Mam takie coś:
    Problem z synchronizacją procesów.
    Nie mam dostępu do sterowników żadnej z pokazanych jako okręgi maszyn, tylko do ich włączników (czerwone strzałki) oraz dostaję informację zwrotną o zakończeniu procesu przez maszynę A (zielona strzałka). Maszyna B wymaga, aby przez cały czas trwania procesu linia sterująca miała stan wysoki. Na dzień dzisiejszy po prostu przez cały czas trwania procesu operator trzyma przycisk start, zamykając obwód.
    Maszyna A potrzebuje tylko jednego przyciśnięcia przycisku start, sama wyłączając się po zakończeniu procesu. Informacja zwrotna którą uzyskujemy z maszyny A to napięcie: wysokie przez czas trwania procesu i niskie po jego skończeniu.
    Problem:
    Mam skonstruować włącznik wspólny do obu procesów wg schematu działania:
    1. Wciskam start( nie przytrzymuję), najpierw uruchamia się proces na maszynie B, po pewnym czasie (około 1,5sek. ) uruchamia się proces na maszynie A.
    2. Gdy maszyna A skończy działanie maszyna B powinna się wyłączyć sama.
    Dodam, że obwód sterowania zasilany jest dla obu maszyn napięciem stałym 24V, informacja zwrotna napięciowa z maszyny A ma około 5V w stanie wysokim. Założeniem jest, aby skonstruować to bez użycia mikroprocesora. Słabo znam się na elementach analogowych, stycznikach itp. i nie wiem nawet, czy da się osiągnąć pożądany efekt bez użycia procesora.
    Proszę o pomoc w rozwiązaniu tego problemu, ew. linki do elementów z których można byłoby próbować coś kombinować ( nie mogę znaleźć przycisku który można byłoby włączyć, potem sygnał "zielony" załączałby np elektromagnes i po jego wyłączeniu przycisk "odskakiwałby") .
    Mam nadzieję, że nie nagmatwałem za bardzo i da się to zrozumieć, jeżeli nie, to przepraszam. Z góry dziękuje za każdą wskazówkę do rozwiązania tego problemu.
    Pozdrawiam
    J.

    0 3
  • #2 02 Kwi 2006 22:27
    WojcikW
    Poziom 38  

    Nieco dziwne wymagania, schemat starałem się zrobić możliwie najprostrzy. Mam nadzieję, że prąd zasilający (lub sterujący) odbiornikami A i B nie jest duży. W zależności od tego prądu należy dobrać elementy tj. przekaźniki P1 i P2, tyrystor Ty oraz diodę D1. Tyrystor BTP10/50 i tranzystor BC211 nie są już produkowane, należy dobrać podobne, przy czym tyrystor należy dobrać do obciążenia odbiornika B. Przekaźniki P1 i P2 mają cewki na napięcie 24V DC.

    0
  • Pomocny post
    #3 02 Kwi 2006 23:03
    WojcikW
    Poziom 38  

    Zmieniłem załącznik, teraz dioda D1 jest prawidłowo.

    0
  • #4 03 Kwi 2006 00:01
    jahoo
    Poziom 15  

    Bardzo wielkie dziękuję.
    Pozdrawiam
    J.

    0