Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

problem z model w simulinku

02 Kwi 2006 09:25 1040 4
  • Poziom 10  
    Witam!
    Mam następujący problem. Wykonuję mały projekt dotyczący regulatora rozmytego w ramach zajęć na uczelni.
    Mam gotowy model obiektu regulacji (właściwie cały układ regulacji) w simulinku. Plik otwiera się bez problemu, symulacja działa też bez zarzutu, ale problem pojawia się jak chcę zapisać plik ze zmianami lub pod inną nazwą. Wywala jakiś komunikat o kodowaniu (zamieszczam go w załączniku). W pliku błędów we wskazanej w komunikacie linii widnieje:
    LastModifiedBy "******* ******ć"
    *** to moje nazwisko zakończone literą 'ć'
    Czy to wystąpienie 'ć' powoduje problem?
    Gdzie muszę wprowadzić te zmiany o których mowa w pkt 1) w komunikacie?
    z góry dziękuję za pomoc
  • VIP Zasłużony dla elektroda
    Tak, to "ć" powoduje problem, możesz ręcznie edytować plik mdl, choćby w notatniku, zamieniając niefortunne "ć" na "c" przykładowo. Oczywiście możesz też zastosować się do rady #1 z okienka :)
  • Poziom 10  
    Chodzi o to że w oryginalnym pliku mdl nie występuje ta linijka i wogóle nie wystepuje litera 'ć'. Odnajduję ja dopiero w pliku błędów err który jest generowany przy próbie zapisu zmian lub pod inna nazwa.

    A czy możesz mi jako matlabowemu laikowi wyjasnić dokładnie jak mam się zastosować do wskazowki #1 z komunikatu? Gdzie mam wprowadzić te zmiany?
  • VIP Zasłużony dla elektroda
    Spróbuj w oknie ze schematem w simulinku kliknąć File>Model Properties>Options i tam możesz spróbuj zmienić nazwe, mam starego Matlaba, ale moge wpisywać dowolne znaki i nie robi mi z tego tytułu żadnych problemów.

    A tekst z okienka wpisujesz w Matlab Command Window
  • Poziom 10  
    próbowałem wszystkiego i nic nie pomagało.
    ostatecznie pomogło wyrzucenie całkiem matlaba 7 i zainstalowanie 6.5.
    dziala wszystko juz!
    dzieki!