Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sterowanie komp. na podczerwień + GRIDER + PILOT

młody-elektronik 08 Maj 2006 21:49 9449 8
  • #1 08 Maj 2006 21:49
    młody-elektronik
    Poziom 11  

    Witam wszystkich

    Ano mam taki mały problemik:

    Zbudowałem sobie urządzenie do sterowania komp. na podczerwień
    Sterowanie odbywa się za pomocą programu GRIDER

    Urządzenie działa piloty również jednakże nie tak jak trzeba:
    - pierwszy pilot wysyła co naciśnięcie guzika inne kody (pokazuje to właśnie grider) problem jest taki że każdy z przycisków wskazuje po jakimś czasie te same kody co cała reszta
    po przypisaniu jakiejś czynności (np włączenie Winampa) do konkretnego przycisku inne też reagują mimo ze nie powinny
    - drugi pilot ku mojemu zdumieniu wysyłał ok 2 razy dłuższe kody zupełnie inne i WSZYSTKO DZIAŁAŁO tak jak trzeba (stop, play itd) lecz nie wiedzieć dlaczego stało się to co z pilotem "pierwszym" dokładnie te same nr pokazują się w griderze

    AAAAAA w programie można przetestować polecenia przypisane konkretnym czynnościom (i tam działa) a za pomocą pilota w kratkę (np. przycisk do włączania "play" również zamyka Winampa)

    Gdzie tkwi problem ... wiecie może ?!

    pozdrawiam

    0 8
  • #2 08 Maj 2006 22:32
    pyton
    Poziom 21  

    Witam. Nie kazdy pilot z tego co wiem sie nadaje... mialem podobny problem... ale wtyczke igorplug zmienilem na nowsza i wszystko dzialalo jak nalezy... albo kupilem pilot uniwersalny za 9zl... nie pamietam;p

    Mam jeszcze pytanie do was czemu pod XP wogule nie chce mi dzialac ten odbiornik pod COM'a ?

    mam jeszcze odbiornik pod usb oryginalny od tunera satelitarnego czy da sie go poprzez jakis program ustawic by np: otwieral winampa? i nim sterował?

    Pozdrawiam

    0
  • #3 09 Maj 2006 23:10
    młody-elektronik
    Poziom 11  

    masz rację nie każdy się nadaje ... lecz mój 1 i 2 zadziałał a ten 2 wręcz idealnie ... niestety coś się poprzestawiało ale nie wiem co :(

    ja również mam XP urządzenie działa (jest na COMIE)

    0
  • #5 10 Maj 2006 15:11
    pyton
    Poziom 21  

    młody-elektronik jesli możesz to prześlij mi ten programik wraz z wtyczkami na maila pyton16(małpa)interia.pl z góry dzięki!!!

    Pozdrawiam

    0
  • #6 13 Kwi 2007 18:55
    zydek89
    Poziom 12  

    to zalezy od czestotliwości na jakiej pracuje pilot i odbiornik
    zapewne twoj odbiornik to tsop1736 czyli pracuje na 36kHz pilot byc może pracuje na innej i stad te blędy

    0
  • #7 22 Kwi 2007 14:40
    młody-elektronik
    Poziom 11  

    Problem został rozwiązany.
    Trzeba było zmienić wartości w ustawieniach (być może to częstotliwość) teraz nie pamietam (mało siedzę przy komp.)

    Wszystko działa jak należy 1 naciśniecie i reakcja, a nie jak wcześniej nawet kilka razy 1 przycisk (rózne kody się pojawiały)

    0
  • #8 23 Kwi 2007 13:39
    UlfgaR
    Poziom 23  

    pyton napisał:

    Mam jeszcze pytanie do was czemu pod XP wogule nie chce mi dzialac ten odbiornik pod COM'a ?
    Pozdrawiam

    Jeśli używasz girdera to musisz włączyć urządzenie wejściowe

    0
  • #9 06 Lis 2008 14:14
    wojtek_vp
    Poziom 2  

    a czy jest możliwe wykonanie odbiornika do pilota na inne gniazdo np. gniazdo do monitora lub inne(mam na myśli jedno z gniazd w laptopie)?

    0