Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornica napięcia na trafie ferrytowym

sq1gpr 11 Maj 2006 16:26 4844 22
  • #1 11 Maj 2006 16:26
    sq1gpr
    Poziom 12  

    Witam, z tego co czytam to temat przetwornic jest tak stary jak całe forum, ale dołoże jeszcze swoje pytanie. Znalazłem na elektrodzie schemat prostej przetwornicy napięcia 12/220V na układzie 4069 i 2x IRFZ44N. Próbowałem zastosować ten układ dla trafa z zasilacza komputerowego oczywiście podnosząc częstotliwość (nie wiem dokładnie w jakich granicach powinna być, z tego co znalazłem to między 50kHz a 100kHz, jaka jest w moim układzie nie sprawdzałem). Skutek jak na razie marny, bez obciążenia układ pobiera dość spory prąd i tranzystory się grzeją. Czy jest możliwe zbudowanie prostej przetwornicy na trafie z rdzeniem ferrytowym żeby przy małych wymiarach osiągnąć większą moc ? Prosty układ - mam na myśli rozwiązanie podobne jak wyżej przedstawiłem, czyli bez specjalnych rozbudowanych układów sterujących przetwornicami impulsowymi.

    0 22
  • Pomocny post
    #2 11 Maj 2006 16:41
    lechoo
    Poziom 39  

    Układ 4069 nie nadaje się do przetwornic pracujących z częstotliwością kilkadziesiąt kHz ze względu na znikomą wydajność prądową wyjść tego układu. Tranzystory mosfet posiadają znaczną pojemność bramek i przy małej wydajności prądowej sterownika nie nadążają się w pełni przeładowywać. Bardzo dobrym sterownikiem do tranzystorów w tego typu przetwornicach jest kostka SG3525 lub TL494 z odpowiednim driverem. Robiłem przetwornice pracujace z częstotliwością 50kHz z wykorzystaniem tych układów oraz transformatorów od zasilaczy PC (bez przeróbek) aby uzyskać z 12V napięcie stałe 300..350V - po wyprostowaniu w podwajaczu. Bez podłączonego obciążenia pobór prądu był rzędu 0,2A.

    0
  • #3 11 Maj 2006 19:22
    sq1gpr
    Poziom 12  

    Dzieki lechoo za podpowiedź. Znalazłem schemat przetwornicy na tl494 w Twoim poście, może wystarczyłoby dobudować do układu z 4069 drivery na bc337 /327 tak jak na schemacie z tl494 ? Wstawiłem potencjometr do tego układu co zrobiłem na 4069, mam teraz możliwość zmiany częstotliwości od ok. 50kHz do 100kHz ale nie zmieniło to za dużo - przy dokładnym dobraniu częstotliwości spada troche prąd jałowy do ok 1A ale to wciąż jest za dużo - tranzystory się grzeją. Pozatym wydajność prądowa tego ustrojstwa jest za mała.

    0
  • Pomocny post
    #4 11 Maj 2006 19:42
    -RoMan-
    Poziom 42  

    TL494 na Alledrogo kosztuje niewiele ponad 1 PLN - czy warto dziadować i upierać się na układ nieprzystosowany do przetwornicy?

    0
  • Pomocny post
    #5 11 Maj 2006 21:20
    irek2
    Poziom 40  

    najwiekszy problem z 4069 to brak czasu martwego czyli czasu miedzy wlaczeniem a wylaczeniem mosfetow. Przez to zanim sie pierwszy mosfet wylaczy to drugi zaczyna przewodzic i powstaja szpilki pradu grzejace tranzystory.

    0
  • #6 13 Cze 2006 14:09
    sq1gpr
    Poziom 12  

    Tak jak radziliście - wykorzystałem układ TL494 wg. schematu jaki lechoo prezentował na forum, do tego trafo z zasilacza ATX. Przetwornica działa ale napięcie na wyjściu jest niskie, po wyprostowaniu mostkiem graetza i podłączeniu żarówki 220V/60W wynosi 70V. Nie próbowałem jeszcze ale pewnie nawet na podwajaczu napięcia nie będzie 220V. Sprawdzałem oscyloskopem co się dzieje po stronie pierwotnej przy obciążeniu przetwornicy - nie widać spadku napięcia. Poniżej przytaczam ten schemat.

    Przetwornica napięcia na trafie ferrytowym

    2
  • #8 13 Cze 2006 18:35
    sq1gpr
    Poziom 12  

    Dzięki za linki, interesowały by mnie jednak bardziej jakieś informacje od kogoś kto zbudował i uruchomił ten układ ze schematu.

    0
  • #9 13 Cze 2006 19:17
    janto
    Poziom 23  

    Rozumiem, że ten mostek, o którym piszesz, jest odpowiedni do przetwornic?
    Sprawdź, czy na bramkach mosfetów jest prostokąt.

    0
  • #10 13 Cze 2006 20:15
    sq1gpr
    Poziom 12  

    Na bramkach jest prostokąt. Co do mostka to nie jestem pewien, dzięki że zwróciłeś na to uwagę - myślałem że nie ma to większego znaczenia poza prądem jakim mozna go obciążyć.

    Dodano po 47 [minuty]:

    Przed chwilą podłączyłem żarówkę bezpośrednio pod uzwojenie trafa - efekt ten sam żarówka ledwo się żarzy także mostek odpada.

    0
  • Pomocny post
    #11 13 Cze 2006 21:03
    lechoo
    Poziom 39  

    Z tego co piszesz (napięcie 70V) wynika, że uzyłeś w transformatorze z zasilacza jako uzwojenia pierwotnego tego, które oryginalnie dostarcza 12V w zasilaczu. Należy użyć tego od 5V, wtedy przy zasilaniu 12V i po wyprostowaniu uzyskasz około 160V lub 2x więcej jeśli uzyjesz podwajacza napięcia. Powodzenia :)

    0
  • #12 14 Cze 2006 09:35
    sq1gpr
    Poziom 12  

    Dzięki lechoo za głos w temacie. Taką próbę jak piszesz też robiłem i jest dokładnie jak mówisz. Mam tylko obawy co do prądu pobieranego - w tym układzie bez obciążenia jest to około 1A, przy podłączeniu pod odczepy na 12V prąd jałowy jest 0,2A.

    0
  • Pomocny post
    #13 14 Cze 2006 11:49
    -RoMan-
    Poziom 42  

    Zwiększ odrobinę częstotliwość - powinno wrócić do normy.

    0
  • #14 17 Cze 2006 22:12
    sq1gpr
    Poziom 12  

    Po zwiększeniu częstotliwości na tyle żeby prąd jałowy był w granicach 0,2 do 0,4 A spada napięcie wyjściowe do poziomu takiego jakie było przy podłączeniu uzwojenia 12V jako pierwotne - czyli około 70V. W miejsce R4 wstawiłem potencjometr, próbowałem płynnie wyregulować częstotliwość i efekty są takie że przy ustwieniu potencjometru w takiej pozycji że napięcie wyjściowe z trafa jest najwyższe (ok. 130V), nie ma syczenia z transformatora, a prąd jałowy jest około 3,5A, po podłączeniu żarówki 220V/60W na wyjście prąd wzrasta do 4,5 A. Czyli wszystko by było ok poza wysokim prądem jałowym, można co prawda dać większe radiatory ale straty takiego układu będą duże. Nie mam pomysłu co dalej.

    0
  • Pomocny post
    #15 18 Cze 2006 21:16
    irek2
    Poziom 40  

    widocznie za malo zwoi jest na uzwojeniu 5V.
    Sprobuj sie podlaczyc pod 12V, przekladnia powinna pozwolic na osiagniecie 160V po wyprostowaniu. Prostownik musisz zrobic na szybkich diodach a nie na scalonym mostku ktory sie do tego nie nadaje.

    0
  • #16 19 Cze 2006 14:43
    sq1gpr
    Poziom 12  

    Po różnych próbach wstawiłem w końcu trafo z innego zasilacza i jest lepiej, wykorzystałem odczepy dla 5V i regulując częstotliwość mogę tak ustawić że jest około 160V przy prądzie jałowym w granicach 0,5A. Czy ktoś może wie na jakie napięcie jest oryginalnie pierwotne uzwojenie w tych trafach ? Analizując schemat wychodzi że jest to mniej niż 220V.

    0
  • #17 19 Cze 2006 14:56
    antrykot
    Poziom 20  

    sq1gpr napisał:
    Po różnych próbach wstawiłem w końcu trafo z innego zasilacza i jest lepiej, wykorzystałem odczepy dla 5V i regulując częstotliwość mogę tak ustawić że jest około 160V przy prądzie jałowym w granicach 0,5A. Czy ktoś może wie na jakie napięcie jest oryginalnie pierwotne uzwojenie w tych trafach ? Analizując schemat wychodzi że jest to mniej niż 220V.

    Offtopikując troche - jest coś takiego jak prąd jałowy ?
    Jest napięcie w stanie jałowym, a ten prąd o którym mówisz, to chyba prąd zwarcia ?

    0
  • #18 19 Cze 2006 15:37
    sq1gpr
    Poziom 12  

    Chodzi o prąd pobierany przez przetwornicę bez jej obciążenia, z takim okresleniem spotkałem się przy innych urządzeniach i maszynach także myślę że tu też można tego użyć.

    0
  • #19 19 Cze 2006 16:06
    antrykot
    Poziom 20  

    sq1gpr napisał:
    Chodzi o prąd pobierany przez przetwornicę bez jej obciążenia, z takim okresleniem spotkałem się przy innych urządzeniach i maszynach także myślę że tu też można tego użyć.


    W sumie myślałem o prądzie na wyjściu. Czyli wszystko jasne :)

    0
  • Pomocny post
    #20 19 Cze 2006 16:12
    Edek45
    Poziom 28  

    Witam,ja bym ci radził to trafo które masz,delikatnie rozebrać żeby nie połamać rdzenia ferrytowego(można całe trafo wrzucić do wrzątku,chwile pogotować i rdzeń powinien dać się rozebrac,chyba że jest sklejony jakimś na bardzo wysoką temperaturę),a nastepnie przewinąć
    Linki do stron jak to zrobić podałem wcześniej
    Ja taka przetwornicę zrobiłem i pobierała na luzie dosłownie mA
    Jeżeli dobrze wykonałeś układ,to pozostaje ci tylko transformator,może wrzuć jeszcze schemat wg którego wykonałeś tę przetworkę

    0
  • #21 19 Cze 2006 20:02
    sq1gpr
    Poziom 12  

    Tak też zrobiłem już. Na szczęście trafo dało się rozebrać bez żadnych problemów. Z przeliczenia ilości zwojów/volt (wg. uzwojenia na 12V) wyszło że oryginalne pierwotne uzowjenie było na 69V także to co mi wychodziło było jak najbardziej prawidłowe. Przewinąłem po swojemu i jest ok. Schemat układu tak jak wyżej podałem, dla tych co budują proponuję na próby zamiast R4 wstawić potencjometr i dobrać częstotliwość.

    0
  • #23 19 Cze 2006 23:16
    irek2
    Poziom 40  

    napiecie uzwojenia pierwotnego w trafie ATX to ok 160V czyli polowa wyprostrowanego napiecia sieci. Amplituda napiecia na wyprowadzeniu 12V to ok 25V a wiec przekladnia ok 1:6.
    Rozebralem wiele traf i liczylem ich zwoje ale gdzies wyniki tych badac mi wsiakly wiec nie pisze dokladnie ile jest zwoi.

    0