Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zegar nixie - nie odlicza czasu

19 Maj 2006 18:30 2238 13
  • Poziom 17  
    Projekt robiony ze strony http://www.electricstuff.co.uk/nixclock.html
    Problem jest z nim, że nie odlicza mi czasu, wyświetla tylko 1 0 0 i to wszystko. Na stronie na zdjęciach pokazane są kontraktony. Ja wstawiłem przełączniki bo tak widać na schemacie.
    Czy one muszą być i jak się reguluje ten zegarek.
  • Moderator
    Cześć .

    "The page cannot be found" - popraw link ...

    Dodano po 35 [minuty]:


    Prawdopodobnie, nie masz impulsów sterujących .
    Zegar jest taktowany częstotliwością sieci energetycznej . Sprawdź, czy na 8 nogę układu U8b /4013/ dochodzi 50 Hz o odpowiedniej amplitudzie .
    Jeżeli masz jakieś bezpieczne źródło 50 Hz /np. miernik z generatorem/, to możesz wymusić te sygnały .
  • Poziom 42  
    Zastosowano kontraktony dla zapewnienie bezpieczeństwa ustawiania zegarka, bo bez transformatora separującego 230V/230V /który powinien w tym zegrku być/ staje się to niebezpieczne.
    Ustawia się go przyciskiem Fast lub Slow. Zegarek liczy od 0:00 do 12:59 naciskając przycisk FAST z prędkością 1/50sek - więc służy do zgrubnego ustawienia czasu. Przyciskiem SLOW ustawia się dokładniej czas - liczy co 1sek.
    Podłącz diodę LED z szeregowym rezystorem 1k do nogi 12 układu U4 /katoda diody do nogi 12/ - ta powinny występować implulsy co 1sek.
    Trzeba też zkontrolować wartość napiecia na diodzie Zenera D1.
  • Poziom 17  
    Aha a pozatym miałem tez problem z podłączeniem lamp. W zastosowanych lampach mam 13 nóżek na płytce tylko 12 rozwiązałem to tak że podłączyłem tylko anode i cyfry pozostałe dwie nózki ic odgiołem
    Sprawa ma sie tak napięcie za diodą zenera wynosi 4 V (powinno być 4,7 V) czyli za mało czy moge zamienić wartość rezytora 100K na mniejszą żeby podwyższyc napięcie zasilania tej diody. Dwukropek oddzielający godziny od minut miga z częstotliwośćią 1 Hz .. Przy próbie regulacji godziny tylko zatrzymuje się ten dwukropek i czasami ostatnie zero minut chce przejśc na 1 ale mu sie nieudaje.

    Jesli robił go ktoś niech mi powie co gdzie jak bo przetłumaczenie z angielskiego na polski sprawia mi lekki kłopot np: co to znaczy>> C10 (100-220pF) may be required for some makes of U1,8 if hours don't reset correctly
    C2 may not be required - fit only if hours don't roll over correctly


    Pisanie postu pod postem.
    Należy używać przycisku ZMIEŃ.
    Scaliłem dwa posty. [h]
  • Poziom 42  
    Jeżeli się zatrzymuje dwukropek to sprawdź wartości elementów R9, R13 i C6. Diode Zenera wymień na 5,1V lub 5,6V, nie ruszając rezystorów R1 i R2.
    Zegar poprawnie działa przy napięciu zasilania 4,3V. Napiecie zasilania (obciążenie zasilacza) jest zależne od producenta układów CD4017/CD4013.
    C10 powinien mieć wartość dużo większą niż podano, ok 47nF - a służy do resetowania układów U1/U8A i prawidłowego ustawienia liczników (godz. 1:00AM po włączeniu nap. zasilania). Wartość kondensatora zależy od firmy produkującej CD4017/CD4013.
    C2 powinien mieć wartość ok 1,5nF (jak wyżej od firmy) - a służy do prawidłowego ustawienia cyfr przy przejściu z godz. 12:00AM na 1:00PM.
  • Poziom 17  
    jak podmieniam C10 na 47nF i wyżej to zatrzymuje mi sie kropek i nic wyświetla 1:10 zmiana C2 nic niepomaga. Musze jeszcze podmienić tą zenerke ale myśle że to i tak nic nieda bez ruszenia R1 i R2
  • Poziom 42  
    Coś masz nie tak z tym zegarem (PCB) lub tak jak pisałem nie wszystke układy pracują poprawnie z tak niskim napięciem zasilania.
    C10 i C2 nie mają wpływu czy dwukropek miga czy nie, chyba że są jakieś zmiany między schematem a PCB. Schemat jest poprawny.
    Zasil zegarek z zewnętrznego transformatorowego zasilacza 5V, wylutuj diodę zenara 4v7 oraz jeden z rezystorów R1 lub R2; napięcie podłącz w miejsce diody Zenara D1.
  • Poziom 17  
    Podłączyłem pod zasilacz na którym mam 4,7V i nic, pokazała się godz 11:00 i to wszystko i stoi zegrek, brak sterowania.
    Co robić dalej? może układy coś nie tak mam HEF4017BP i CD4013BCN ?A moze coś z lampami(Z5740M) może niechcą załapywać jak pisałem wcześniej podłączyłem Anode i cyfry a pozostałe dwie nużki H i IC odłączyłem..... Jak zmieniłem kondensator C10 z 100nF na 1 nF to pokazała mi sie godzina 11:20 i tak stoi.
  • Poziom 42  
    Nóżki IC, oraz dp są niepotrzebne.

    Problem leży dalej w pozyskaniu częstotliwości 50Hz, kondensator C2 nie ma wpływu na to.

    Najpierw trzeba znaleść przyczyne nie migania dwukropków. Sprawdzić C5


    Proponuje zamiast 230V podłaczyc transformator 12-24V AC i przetestować układ. Tak jaki pisałem wcześniej podłączyć diodę LED aby uzyskać jej miganie z częstotliwością 1Hz.
  • Moderator
    Cześć .

    Wydaje mi się, że trochę dziwnie rozwiązano sprawę wzorca 50 Hz.
    Jeżeli dobrze widzę, to by zegar miał taktowanie, wtyczka zasilająca musi być odpowiednio włączona ( faza i zero :) ) .
  • Poziom 42  
    Włączenie wtyczki akurat nie ma znaczenia.

    Oznaczenie na schemacie L i N było podyktowane bardziej do wersji 115V gdy masa zegara jest połaczona galwanicznie z siecią. I wtedy najlepiej aby na masie było N.

    Dlatego najlepiej zastosować transformator 230V/230V lub dwa transformatory o mocy 2-4W połaczone uzwojeniami wtórnymi
  • Poziom 17  
    Pisałeś >>> 1k do nogi 12 układu U4 /katoda diody do nogi 12/ a anoda gdzie? do plusa zasilania ? Widze że wprowadziłem was w błąd zamiast C10 podmieniałem C5
  • Poziom 42  
    Do nogi 12 (U4) podłaczasz LED / katoda do nogi 12/ przez rezystor 1k do zasilania 4,7V
  • Poziom 17  
    Są impulsy na tej nodze co 1 sekunda Aha na układzie CD4013 na 8 nodze jest napięcie względem masy 4,75V AC Wszystkie układy scalone zostały powymieniane i to samo stoi zegarek ... może coś z płytką czy ktoś robił tego zegarka z tej strony