Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Niestabilne zasilanie urządzeń w sieci komputerowej

mroszkow 26 May 2006 17:31 2559 8
  • #1
    mroszkow
    Level 11  
    Witam szanowych forumowiczow,

    Wiem, ze podobny temat, o ile nie taki sam byl poruszany na forum, ale jakos nie moge sie do niego dogrzebac.



    Opiekuje sie sieca komputerowa zbudowana w oparciu o przelaczniki (SOHO) Switch Planet, Dlink, OvisLink itp. W calej sieci jest ich okolo 80 szt. jednak liczba polaczen od koncowego urzadzenia do routera nie przekracza 7 szt. Urzadzenia montowane sa w roznych miejscach w roznych budynkach/pawilonach i zasilane ze standardowych, dolaczonych do nich zasilaczy 7,5-12v (500mA-1000mA).
    Niestety coraz czesciej obserwuje niestabilne dzialanie zasilania 230V. Co widac po delikatnie mrugjacym oswietleniu, resetowaniu sie komputerow nie podpietych pod UPS. Takie "wahniecia" pradu trwaja zazwyczaj niedluzej niz 1sek. Urzadzenia typu telewizor, wieza czy pralka :) nawet nie zdaza zareagowac. Inaczej jest jednak w przypadku urzadzen przelaczajacych w sieci. Niezaleznie od miejsca - zupelnie losowo - po takim "wahnieciu" napiecia zawieszaja sie one i pomaga im wtedy reset poprzez odlaczenie i podlaczenie ponowne zasilania. Nie byloby w tym nic strasznego gdyby liczba urzadzen siegala 3 - 4. Ale przy 80 sztuk. spacer "resetmana" jest konieczny. Jak juz wspomnialem sytuacja zaczyna sie dziac coraz czesciej. Zaklad eneregtyczny twierdzi, ze wszystko jest w poarzadku. Chcialbym zatem zwrocic sie o pomoc (porade) do tych co poradzili sobie z podobnym problemem lub znaja jakies sensowne rozwiazanie. Slyszalem i czytalem o stosowaniu jakis ukladow, ktore potrafia wykryc niewielkie skoki napieci i automatycznie odciac na kilka sekund zasilanie. Byc moze istnieje jeszcze jakis inny sposob.
    Warunki techniczne i finansowe nie pozwalaja na to aby wstawic tam UPS'y ktore rozwiazalby sprawe. Budowanie wlasnej linii zasilajacej tez raczej nie wchodzi w gre. Z gory dziekuje za wszystkie pomocne odpowiedzi.

    Pozdrawiam,

    --
    Marek R.
  • #2
    adamjur1
    Level 41  
    Napisz jakim medium są połączone ze sobą urządzenia aktywne pomiędzy budynkami- światłowody czy miedź ( a może WIFI ?).
    a przy okazji - co to za kuriozalna sieć - 80 urządzeń aktywnych i 7 użytkowników średnio .......

    Pozdr.J.
  • #3
    mroszkow
    Level 11  
    adamjur1 wrote:
    Napisz jakim medium są połączone ze sobą urządzenia aktywne pomiędzy budynkami

    Polaczone sa skretka FTP kat. 5e. Odleglosci nie przekraczaja norm. Sa puszczone w ziemi w kanalach teletechnicznych. Nie ma urzadzen WIFI. Chyba ze u koncowych odbiorcow.

    adamjur1 wrote:

    a przy okazji - co to za kuriozalna sieć - 80 urządzeń aktywnych i 7 użytkowników średnio .......
    Pozdr.J.

    Zle mnie zrozumiales. Odbiorcow (uzytkownikow) jest ok. 300 - 350.
    Siec strukturalna (wlasnie ta w ktorej nastepuja najczestrze zawieszki urzadzen) zbudowana jest tak, aby droga od pierwszego do ostatniego switcha nie przekraczala 7 urzadzen. Switche nie sa polaczone ze soba rownolegle.

    Dodam jeszcze, ze w sieci sa urzadzenia tj. jak swtich zarzadzalny z wew. zasilaniem. Jednak o nich nie pisalem, bo z nimi nie ma najmniejszych problemow. Tez sa nie czule na tego rodzaju "wahania".

    Pozdrawiam,
  • #4
    adamjur1
    Level 41  
    No to masz problem wynikający ze złej organizacji sieci prawie rozległej.
    W takiej sieci , jeżeli nie masz wydzielonego zasilania systemu konputerowego ( spotkałem się nawet z wydzieloną sekcją stacji energetycznej) przy jakichkolwiek niestabilnościach napięcia zasilania, powstajace przy tym anomalie napięciowe rozpływają się po sieci logicznej.
    Jest to trochę awangardowe podejście, ale oparte na doświadaczeniach budowy dużych sieci strukturalnych. Poszczególne budynki są zasilane z różnych ( różnie uziemionych ) przyłaczy,skoki napięcia powodują powstanie przepięć, które na podobieństwo fali rozpływają sie po sieci. A już nie wyobrażam sobie sytuacji wyładowania atmosferycznego.
    A jak temu zaradzić.
    Po pierwsze prawo budowlane i energetyczne mówi o zabezpieczeniach przeciwprzepięciowych wszystkich mediów wchodzących do budynku.

    Innym rozwiązaniem były by łaczniki światłowodowe między budynkami ( ale jak sądze na to nie mozesz liczyć)
    W tym konkretnym przypadku trzeba odseparowac galwanicznie segmenty sieci, ( z zachowaniem szybkosci transmisji)
    Możesz to zrobić stosując konwertery swiatłowodowe na wejściach switchy łączących segnmenty miedzy budynkami. Jednak pozostaje problem ich zasilania. Ponieważ do budynku wchodzi medium miedziane krótka wstawka fibre musi mieć zasialne konwertery, a zasilanie to znowu ich słaby punkt. Należałoby zastosować transformatorowe zasilacze z galwanicznym oddzieleniem strony pierwotnej od wtórnej.

    Podobnie możesz postąpić z zasilaczami tych switchy, które sie wieszają, ale przyczyna wieszania może nie powstawać w tym switchu tylko w innym połączonym z nim galwanicznie.

    Możesz spróbować zastosowac też netprotectory 100 BT na wejściach łącznikow, ale ich skuteczność nie jest 100% ( nie dają oddzielenia galwanicznego a tylko ograniczają napięcie jakie moze się pojawiać na pinach gniazdka RJ45)

    Miałem podobny problem w jednym z banków który mieścił się w kilku kamienicach stojących w jednym ciągu ulicy. Zasilania były nawet z Upsów centralnych ale w kazdej czesci banku ze swojego.
    Najpierw zastosowałem net protector APC, ograniczył kłopoty
    ( występowały z mniejszą cestotliwością. ale dopiero światłowód wielomodowy załatwiła sprawę).

    Jeszcze jeden pomysł jaki mi przychodzi do głowy to wykorzystanie czegoś na wzór PowerOnLan, to zn po wolnych żyłach łączników rozprowadzać sygnał resetujący urządzenia, musiałbyś zastosować jakieś moduły przekażnikowe odcinające na chwile zasilanie switchy ( tych do których zarządzania nie masz dostępu przez SMTP) ale to likwiduje tylko skutki a nie przyczyny zkłóceń sieci. Kiedyś możesz się obudzić z ręką w nocniku i bez urządzeń aktywnych w sieci.......

    No to trochę potrułem
    Pozdr.J.
  • #5
    robball
    Level 21  
    Miałem podobne problemy, aczkolwiek w dużo mniejszej sieci. Rozwiązanie było proste, aczkolwiek niezbyt tanie: wymiana switchy na 3com'y. Problem zawieszonego sprzętu po prostu zniknął.

    Jeśli lubisz eksperymenty to można pokombinować z jakimiś innymi zasilaczami, o większej pojemności filtrującej, może nawet jakiś mały akumulatorek w trybie buforowania. Ale to wszystko to tylko półśrodki.
  • #6
    mroszkow
    Level 11  
    Problemy o ktorych pisze wynikaja tylko w momencie krotkotrwalych i nieplenych zanikow napiecia w sieci 230V. Statystycznie czesciej pojawiajacych sie w porze letniej niz w zimowej. W letniej zas albo przy duzych opadach deszczu albo przy gwaltownych burzach. W zimie bardzo rzadko. Niemniej jednak kazde takie zdarzenie zawieszonego swticha poprzedzone jest "mrugajacym swiatlem" czyli ewidetnym spadkiem napiecia. Rowniez statystycznie, najczesciej "wiszacym" swtichem jest ten, ktorego zasilacz daje na wyjsciu napiecie mniejsze niz 12V. Jednak i te 12V potrafia sie zawiesic.
    Ta siec pracuje w tej samej konfiguracji ponad 3 lata. Nigdy nic sie podobnego w niej nie dzialo. Dopiero od zimy, kiedy zauwazone zostaly problemy z zasilaniem 230V zaczely sie takze problemy w sieci LAN.
    Szukajac rozwiazan problemu w sieci natrafilem na roznego rodzaju "autoresety" ktore albo odlaczaja napiecie co 1h na 1 sek. albo wykrywaja niewielki spadek napiecia w sieci 230V i odlaczaja zasilanie na kilka sekund powodujac efekt taki, jak czlowiek ktory musi wykonac kilku kilometrowy spacer "resetujac" swtiche. Niestety nie wiem skad i jak cos takiego zbudowac ;/
    Wczesniej, kiedy probowalem sie upewnic, ze to jednak wina pradu, a nie jakiegos bledu w sieci LAN wykonalem test. Podlaczylem swticha do listwy przepieciowej z wylacznikiem. Do niego podpialem dwa komputery, ktore pingowaly sie wzajemnie. Przyciskiem na wla/wyl na listwie manewrowalem na pograniczu 0/1 i udalo mi sie wywolac taki wlasnie niewielki spadek napiecia, ktory to w owym switchu spowdowal zawieszenie sie i komputery nagle przestaly odpowiadac na ping.
    Dodam jeszcze, ze podobny test nie wyszedl mi na zasilaczu 12v 1000mA i innym modelu swticha. Wydawaloby sie najprostrzym powymieniac wszystkie urzadzenia i zasilacze, ale niestety to nie wchodzi w gre. Szukam tanszego rozwiazania.
    W innej lokalizacji, gdzie problemy z pradem takze wystepuja, warunki techniczne pozwolily mi podlaczyc 30 takich samych urzadzen jak w sieci o ktorej pisalem wyzej ale na na trzech zasilaczach przemyslowych 15V 20A po 10 urzadzen na kazdy podlaczonych szeregowo. Na cale szczescie tam takie problemy nie wystepuja w ogole. Uzytkownikom zawieszaja sie urzadzenia w lokalach i nalezy wtedy wykonac reset, ale moje - nalezace do sieci strukturalnej - pracuja jak trzeba.

    Reasumujac, szukam rozwiazania ktore albo wyprostuje krotkotrwaly zanik pradu, albo wykryje go i automatycznie zresetuje urzadzenie.

    Pozdrawiam,
  • #7
    prez8s
    Level 33  
    Witam, jakims super specem od sieci nie jestem, ale skoro piszesz, ze winą są chwilowe spadki napięcia, to ja bym pokombinował przy tych zasilaczach sieciowych. Zapewne są to małe zasilacze wtyczkowe. One mają tam z reguły małe kondensatory (ok 470uF), spróbuj zwiększyć pojemność dwukrotnie, dolutowując drugi taki, ewentualni zmien na taki co ma co namniej dwa razy większa pojemność. Przeprowadz z nowu ten eksperyment. Jezeli jeszcze będzie to sie działo to jeszcze zwiększ pojemnosc kondensatorów. Jesli sie powiedzie to będziesz miał tanie rozwiązanie problemu. Ewentualnie mozesz sie przejsc na gielde komp, lub z allegro kupic tanie zasilacze komputerowe AT (od 5zl/szt!), wystarczy tylko podorabiac wtyczki, lub obciąc kable od tych zasilaczy wtyczkowych i przylutowac do zasilaczy AT, ale za to bedziesz mial bardzo stabilne zasilanie 12V, tyle że pozostanie jeszcze kwestia niezbyt ładnej obudowy zasilacza i szwędających się kolorowych kabli, ale calosc mozna zawsze wrzucic do jakiejs szafki, ewentualnie poobcinac te zbedne kable i obudowe pomalowac czarnym sprayem :).
  • #8
    mroszkow
    Level 11  
    prez8s wrote:
    Witam, jakims super specem od sieci nie jestem, ale skoro piszesz, ze winą są chwilowe spadki napięcia, to ja bym pokombinował przy tych zasilaczach sieciowych. Zapewne są to małe zasilacze wtyczkowe. One mają tam z reguły małe kondensatory (ok 470uF), spróbuj zwiększyć pojemność dwukrotnie, dolutowując drugi taki, ewentualni zmien na taki co ma co namniej dwa razy większa pojemność.

    Nie bylbym soba, gdybym czegos takiego nie wyprobowal. Nie wiem tylko czy dobrze podlaczalem ten kondensator. Oczywiscie nie grzebalem wewnatrz zasilacza, bo to wszystko zalane wsrodku i nierozbieralne. Ale na przewodzie wyjsciowym podlaczalem kondensator nawet do 10000uF/16V i niewiele to pomagalo ;/

    prez8s wrote:
    Ewentualnie mozesz sie przejsc na gielde komputer, lub z allegro kupic tanie zasilacze komputerowe AT (od 5zl/szt!), wystarczy tylko podorabiac wtyczki, lub obciąc kable od tych zasilaczy wtyczkowych i przylutowac do zasilaczy AT, ale za to bedziesz mial bardzo stabilne zasilanie 12V, tyle że pozostanie jeszcze kwestia niezbyt ładnej obudowy zasilacza i szwędających się kolorowych kabli, ale calosc mozna zawsze wrzucic do jakiejs szafki, ewentualnie poobcinac te zbedne kable i obudowe pomalowac czarnym sprayem :).

    Niestety. Do dyspozycji mam cieniutki szacht teletechniczny gdzie z trudem upycham switcha i zasilacz. Ale rozwaze te opcje i ew. montaz skrzynek.

    Dzieki i pozdraiwam,

    Marek R.
  • #9
    jabbson
    Level 13  
    wydaje mi sie że właściwym rozwiązaniem tego problemu byłoby dodanie do zasilaczy układów elektronicznych włączonych w linie zasilania prądu stałego, które samoczynie resetowałyby switcha, tak żebyś nie musiał robić tego osobiście.