Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Problem. Sterownik halogenów

07 Cze 2006 10:28 1377 9
  • Poziom 11  
    Zaprojektowałem sterownik z płynną regulacją jasności do 4 halogenów po 35W 12V.
    Problem jest taki że co jakiś czas uszkadza mi końcowy tranzystor irf540
    po wylutowaniu ten tranzystor ma miedzy źródłem a bazą 40 omów a miedzy
    źródłem a drenem 9 omów może ta informacja będzie pomocna przy ocenianiu co go mogło uszkodzić. Myśle że nie uszkodził go wzrost prądu i uszkodzenie termiczne bo zazwyczaj wtedy miedzy wszystkimi końcówkami jest zwarcie i tranzystor "przewodzi". Przy tym uszkodzeniu ma 9 omów halogeny sie świecą lecz nie całkowitą mocą bo część odkłada sie na tych 9 omach i uszkodzony tranzystor szybko sie nagrzewa. Gdy dam na bramkę napięcie ok (12v) otwierające tranzystor to halogeny z ok 95% jasności zaczynają świecić 100%.

    Dodam jeszcze że dzieje sie tak gdy tranzystor jest na wspólnym radiatorze z 3 takimi sterownikami lecz każdy jest odizolowany od radiatora.

    Do tego zasilanie jest z trafo 150W 24V kabel zasilający układ ma 30cm.
    Kable do halogenów mają długość 1m.

    Dodatkowo od czasu do czasu uszkadza mi port na mikrokontrolerze Atmela który daje pwm 160Hz.

    Podsumowując przy zasilaniu z akumulatorów 24V uszkodzeniom ulega tylko port mikrokontrolera.
    Przy zasilaniu z trafa 150W 24V uszkodzeniu ulega port mikrokontrolera i dodatkowo mosfet IRF540 jesli jest on na radiatorze gdy zdjąłem go z radiatora do tej pory nie odnotowałem uszkodzenia ale niestety port mikrokontrolera uszkadza sie niezależnie od źródła zasilania i zamontowanych radiatorów i czasu pracy urządzenia.

    Rozwiązaniem byłoby zastosowanie optoizolatora na port mikrokontrolera
    ale chciałbym jednak wiedzieć co jest przyczyną i uporać sie z tym bez optoizolatora.
  • Poziom 35  
    Witam .
    Najprawdopodobniej będzie to przeciążenie portu . Sprawdź ile prądu płynie z portu procesora do układu sterowania .
  • Poziom 11  
    Port na pewno nie jest przeciążony tam jest rezystor 3k
  • Poziom 31  
    Witam

    Po pierwsze zrezygnowałbym z pierwszego tranzystora od lewej strony jest on nie potrzebny. W zasadzie niczego nie wnosi do tegu układu. Po drugie rezystancję na bramce tranzystora nie zwiększyłbym np. do kilkudziesięciu omów. Po trzecie między bramkę a masę dałbym diodę zenera 10V. Co prawda jej brak w tym wypadku nie powinien mieć znaczenia jednak sprawdzić nie zaszkodzi. Po czwarte zmieniłbym tranzystor na IRFZ44N. Jak dobrze pamiętam ma chyba nieco mniejszą rezystancję kanału a więc moc start będzię mniejsza.

    Robiłem podobny układw oparciu o cztery tranzystory (bez pierwszego od lewej) jednak obciążeniem był silnik z motoreduktorem o mocy 103W zasilany napięciem ponad 50V. Żadnych takich ani innych problemów nie miałem !!!. Jeśli do zasilania uC i żarówek używasz jednego napięcia to na początek spróbuj je jednak odizolować. Sprawdź układ ścieżek.

    --
    pozdrawiam
  • Poziom 11  
    Wstawiłem diodę równolegle z halogenami zabezpieczającą przed indukującym sie prądem wstecznym który pojawia sie tuż po zaniku impulsu i od tej pory nic mi nie padło.
    Doszedł drugi problem który teraz zauważyłem. Bardzo mocno grzeje sie kondensator 6800uF jest on na 50V i filtruje zasilanie idące z mostka prostowniczego. To chyba nie jest normalna praca jeśli kondensator jest tak gorący że prawie parzy w palce?
  • Poziom 11  
    Dokładnie tak. Ten kondensator jest rozładowywany pmw'em. Gdy zamiast tego jednego dałem dwa to już mniej sie grzeją, więc dam może 4 równolegle po 2200uF.
    Ten zasilacz będzie w odległości ok 7m od sterownika. Tym kablem 0,75 "popłynie" 140W przy 24V czyli ok 6A. Trafo ma 2x 125W więc połączyłem dwa wyjścia z trafa w zgodnej fazie czyli powinienem mieć 250W, chyba może tak pracować bo to jest z jednego trafa więc raczej wykonanie jest bardzo zbliżone obu uzwojeń wtórnych i nie będą płynęły duże prądy wyrównawcze które nagrzewałyby trafo.

    Dodatkowo będą 4 takie zasilacze w jednej obudowie to są transformatory toroidalne będą blisko siebie do tego 4 mostki na dużym radiatorze. Obudowa ma perforacje więc będzie cyrkulacja powietrza.

    Czy na samym sterowniku też dawać kondensatory na zasilaniu halogenów?
    Czy wystarczą te co są na zasilaczu?
    Na pewno pojemność kondensatorów które miałyby być na sterowniku w zasilaniu zależy od częstotliwości pwm. Ta częstotliwość pwm może być ustawiana od 50hz do 2KHz. W sumie to chyba te kondensatory niewiele tam dadzą jedynie może mniejsze grzanie sie kabla zasilającego i zmniejszy może przydźwięk. Na razie to przydźwięk o częstotliwości pwm jest największy na kondensatorach w zasilaczu ale i tak da sie wytrzymać.
    Wszelkie uwagi mile widziane:)
  • Poziom 31  
    Witam

    Kabelek łączący minimum 1.5mm2 a najlepiej 2.5mm2. Jeśli kondensatorki będą się grzały można bezpośrednio do ich wyprowadzeń dolutować kondensatory 100 do 470nF. Transformatorów nie łączy się równolegle po stronie wtórnej. Przed chwilą czytałem posta, w którym jego autor połączył dwa identyczne transformatory i po dłuższej chwili były gorące i był tym faktem zdziwiony.
    W sumie można sprawdzić jak się zachowają. Jedne bieguny zmostkować bezpośrednio a drugie przez amperomierz i zobaczyć co pokaże.

    --
    pozdrawiam
  • Użytkownik usunął konto