Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

willem + firmware HUB/LPC

polls 15 Cze 2006 17:39 3122 9
  • #1 15 Cze 2006 17:39
    polls
    Poziom 17  

    Witam.
    Czy komuś udało się zaprogramować na willem PCB3b kości wymagające hub (3.3V). Męcze się z tym od dwóch dni próbowałem wszelkich ustawień r/c zmiana napięcia 12v tak że pominąłem to z przetwornicy, modyfikacja samej przystawki i kompletnie nic.
    Programów używalem od wersji g do ja.

    0 9
  • #2 15 Cze 2006 23:17
    WojtasJD
    VIP Zasłużony dla elektroda

    Udało się, ostatnio FWH/LPC PMC Flash - PM49FL004T-33JC z płyty Abit NF7S v.2.0
    Jak dobrze pamiętam to na wersji programu 0.97ja.

    0
  • #3 16 Cze 2006 10:25
    polls
    Poziom 17  

    W takim razie prosze o dokładne ustawienia willema, jakie napiecia, jakie r/c. Moja walka nadal trwa, próbuje zaprogramować w39v040ap, niestety bez powodzenia.

    0
  • #4 16 Cze 2006 20:13
    WojtasJD
    VIP Zasłużony dla elektroda

    Najpierw trzeba wiedzieć czy Willem przechodzi "Test Hardware", bezproblemowo radzi sobie z układami równoległymi (np. 27C512 , 28F010 , ...) oraz ewentualnie z układami szeregowymi (np. 24C16 , PIC16F84A , 93C46 , ...), dopiero potem można zabierać się za adaptery jak FWH/LPC<->DIP32.
    Co do ustawień to powinny się sprawdzać te proponowane przez program.

    0
  • #5 17 Cze 2006 01:34
    polls
    Poziom 17  

    Nie no teraz to mi rece opadły jak to przeczytałem, skoro pisze o tym adapterze to chyba wiem o co chodzi i nie jeden bios zaprogramowałem bez problemów. Wymienione przez ciebie kości jest w stanie zaprogramowac ta niedopracowana kupa złomu, ale nie w39v040. Prosiłem o rade i wartości do ustawienia a nie wymądrzanie się na temat hardware test czy też programowania , poza tym to w co drugim poście jest napisane o tym.
    Dzięki za rzetelną odpowiedź

    0
  • #6 17 Cze 2006 09:21
    oldboy
    VIP Zasłużony dla elektroda

    Proszę o zachowanie umiaru podczas wymiany zdań. Najczęściej jest tak, że odpowiadający nie do końca czytają posty autora i o kontrowersję nie trudno.
    Nikogo tu nie rozgrzeszam ale nie życzę sobie sytuacji konfliktowych w tym dziale.

    0
  • #7 17 Cze 2006 12:53
    WojtasJD
    VIP Zasłużony dla elektroda

    :arrow: polls

    Przepraszam że Cię zawiodłem, że przy tej odrobinie Twoich informacji nie wywróżyłem 100% skutecznej odpowiedzi; jakbyś przejrzał _dokładnie_ posty o Willemie to byś wiedział że w sporej części przypadków ludzie zgłaszają problemy z danym układem nie przeprowadzając uprzedniego uruchomienia/sprawdzenia programatora. Mimo że takie - bolesne dla Ciebie - pytanie o poprawność obsługi innych 'podstawowych' układów oraz dodatkowo wspomnienie wersji laminatu, zasilaniu itp. czy nawet podanie odpowiedzi na 'Electronic ID' - może być denerwujące to jednak sporo pomaga odpowiadającemu.

    Akurat w pierwszym poście tego wątku padło konkretne pytanie -> odpowiedziałem.
    Twoja druga prośba o 'dokładne ustawienia willema' -> ponieważ dalej nie padły te dodatkowe informacje to automatycznie nasuneły się dodatkowe pytania, które zadałem.

    Cytat:
    skoro pisze o tym adapterze to chyba wiem o co chodzi i nie jeden bios zaprogramowałem bez problemów

    Przeczytałem dokładnie posty w tym wątku to wcześniej o tym nie było wspomniane więc skąd mogłem wiedzieć.

    Cytat:
    Wymienione przez ciebie kości jest w stanie zaprogramowac ta niedopracowana kupa złomu

    O 'Willemie' już trochę napisałem, nie jednej osobie z nim pomogłem; jesteś niecierpliwy, nie masz czasu na diagnoze, brak Ci obsługi nowszych/mniej typowych układów -> kup sobie porządny fabryczny programator ze wsparciem technicznym.
    Jak nie - wkładasz pusty adapter do podłączonego Willema, przechodzisz na zakładkę 'Test H/W' i sprawdzasz napięcia na podstawce mając w tle otwarty:
    http://www.winbond.com.tw/c-winbondhtm/partner/PDFresult.asp?Pname=883
    oraz schemat adaptera.

    0
  • #8 17 Cze 2006 15:30
    polls
    Poziom 17  

    Ok może i za ostro podszedłem do sprawy sorki. Informacji co do przechodzenia testu hw nie umieszczalem bo to naturalna sprawa, nie jestem początkującym w tych sprawach , co do wersji pcb to była opisana od samego początku. Napięcia na podstawce są wporządku zgodnie z pdf'em więc sam juz nie wiem w czym problem być może willem nie trawi tego układu.

    Cytat:
    kup sobie porządny fabryczny programator ze wsparciem technicznym
    zabawne :)

    pozdrawiam

    0
  • #9 18 Cze 2006 21:11
    fachman
    VIP Zasłużony dla elektroda

    Ustaw R/C na 50, najpierw uzyskaj poprawny odczyt ID.
    Nie rozumiem po co czepiasz się napięć z przetwornicy dla kości LPC ?

    0
  • #10 18 Cze 2006 21:43
    polls
    Poziom 17  

    Czepiam sie napiec z przetwornicy bo adapter fimware hub wkorzystuje napiecie vpp=12v patrz schemat

    0