Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornik 24bit (AD7730).

markosik20 23 Cze 2006 10:09 4395 10
  • #1 23 Cze 2006 10:09
    markosik20
    Poziom 33  

    Witam.

    Zaprojektowałem i wykonałem układ pomiarowy (20mV) na '51 i w/w przetworniku AC. Wszystko chodzi pięknie tylko......
    Od czasu do czasu w sterowni, w szafie elektrycznej nastąpi zakłócenie (kilka zakłóceń naraz) i AC się wysypuje. Wtedy procek odczytuje z niego bardzo dziwne wartości (AC szaleje w górę i w dół), że trzeba przetwornik AC resetować i inicjalizować jeszcze raz. Da się to jakoś ominąć ? Czy najlepszym sposobem będzie profilaktyczny reset AC co np: 1s.

    A dodam, że układ się wykrzacza nieregularnie. Potrafi pracować nawet 24godziny bez zawieszenia i nagle bach.

    0 10
  • #2 23 Cze 2006 10:50
    diag
    Spec od samochodów

    Szczerze mówiąc to prawdopodobnie masz skopane zasilanie i dlatego masz problemy.

    0
  • #3 23 Cze 2006 11:12
    markosik20
    Poziom 33  

    Raczej nie bardzo bo AC jest zasilany trzema napięciami (-2,5V + 2,5V i 3V na cyfrówkę i wszystko na osobnych stabilizatorach) aplikacja jest żywcem wzięta z fabrycznego układu pomiarowego.
    I dlaczego jak resetuję sam AC to powraca on do poprawnej pracy?

    0
  • #4 23 Cze 2006 14:15
    marek_Łódź
    Poziom 36  

    Cykliczny reset z pewnością zwiększy pewność odczytów, chociaż niekoniecznie do 100%. Faktycznie układ jest skopany, chociaż niekoniecznie po Twojej stronie. Cóś nie spełnia norm kompatybilności EM. Ja bym popatrzył jeszcze w obwody zasilania i pomiarowe przetwornika oraz do samej szafy (jeśli jest taka możliwość). Może wystarczy proste odkłócenie czy zblokowanie w części silnoprądowej. Wewnętrzne sterowanie przetwornika jest układem sekwencyjnym i jako takie przy chwilowym zafałszowaniu stanu może już nie wrócić do rozumu bez reseta.

    0
  • #5 24 Cze 2006 02:25
    markosik20
    Poziom 33  

    Zapomniałem dodać, że w szafie pracuje pięć takich samych urządzeń i wykrzaczają się tylko dwa (co najlepiej po jednej stronie szafy :|)i nigdy razem :cry:
    Zasilane wszystko z UPS, przekaźniki z układami gasikowymi, osobne uziemienie itd. itd.
    Wytłumienie całej szafy za dużo by kosztowało więc będę resetował AC jak wskazania odbiegną od normy :D

    0
  • #6 24 Cze 2006 09:23
    Skubik
    Poziom 15  

    Jesli pracuje 5 takich samych urzadzen. to zamien miejscami te które sie zawieszają z tymi które pracują ok, ale zasilanie do nich zostaw takie samo. bedziesz wiedział czy cos w układzie jest nie tak. jak nadal bedie sie to samo urzadzenie zawieszac to zamien midzy urzadzeniem sprawnym i nie sprawnym zasilanie i wtedy zobacz. Bedziesz przynajmniej wiedział w czym tkwi problem.

    0
  • #7 26 Cze 2006 08:55
    markosik20
    Poziom 33  

    Już wiem co bolało :D. Wejscia sterujące. Niestety układ transoptorowy jest za bilisko układu pomiarowego i po kabelkach z pulpitu sterującego wchodziło do środka wszystko co styczniki są w stanie wygenerować. Pomogło założenie ferrytów na kabelkach i zrobienie połączenia kablem ekranowanym. Szkoda, że AD7730 po zakłóceniu na wejściu pomiarowym poprostu wariuje(a można podać max 7V co w porównaniu z 20mV jest bardzo dużo) Za wszelkie sugestie z dziękuję.

    0
  • #8 06 Mar 2007 21:25
    markosik20
    Poziom 33  

    Odkopuje temat bo po wielu próbach mam nastepujący problem.
    Z AD7730 uzyskuje prawie 0,2uV stabilności pomiaru (nie mylić z dokładnością)co jest bardzo dobrym wynikiem. Po testach w "domowym" laboratirium EMC :) okazuje sie że od czasu do czasu na wejście pomiarowe jednak dostają się zakłócenia. Skutkuje to tym , że AD7730 poprostu "się zawiesza". Najgorsze jest to, że nie ma sposobu sprzętowego wykrycia błędu AD7730, pozostaje liczenie czasu między kolejnymi odczytami danych i reagowanie jak dane nie przyjdą. Wszystko jest ok bo AD7730 inicjalizuje się bardzo szybko tylko jak się zawiesi to trzeba odczekać od 500 do 800ms żeby móc go ponownie zresetować i zainicjalizować. Z racji ,że nie mam "danych" w tym okresie i dodatkowo ostatnie dane są bzdurami (bo odebrane po zawieszeniu) cały proces dozowania jest do zatrzymania :(.
    No i AD7730 niestety już sie nie nadaje do tego typu zastosowań (szybkich pomiarów) :(. I tu moje pytanie. Istnieje jakaś alternatywa dla AD7730 (24bity, pomiar bezposredni do +-80mV) innego producenta? Dla porównania podobny przetwornik 24 bity w ADuC845 jest nie "do zajechania" tzn. jak sie go uruchomi to co by na wejscie nie dostał to działa dalej tylko że jest 10x wolniejszy i 10x ma większe własne szumy wew. :(

    0
  • #9 06 Mar 2007 23:57
    ktrot
    Poziom 19  

    Zwróć może uwagę na przetworniki Burr-Brown serii ADS12xx. Osobiście pracowałem z ADS1241 (pomiar na mostku) i byłem z niego zadowolony, chociaż do twoich celów chyba za wolny, ale są z tej rodziny i szybsze i z zakresem 100mV (ewentualnie z PGA). Ciekawe mogłyby być A/C z serii PCM18xx oraz PCM42xx mimo ,ze na wyjściu dają PCM jednak chyba nie ma wśród tej serii wejścia na poziomie 100mV.

    0
  • #10 31 Paź 2008 09:15
    romantv
    Poziom 17  

    Witam serdecznie.
    potrzebuję wykonać układ który będzie precyzyjnie mierzył spadek napięcia na R.
    R = górna granica to 110 om a dolna to 25 om, prąd płynący przez R to dokładnie 10uA.
    Czyli spadek napięcia to od 0.00025V do 0.0011V
    i to napięcie muszę mierzyć.
    Układ z uC już mam zrobiony teraz tylko przetwornik (karta), która jest dołączona za pomocą złącza do uC.
    Czy przetworniki AD.. które Pan proponuje mogą być?
    j jak powinienem je podłączyć do uC?

    Roman

    Bardzo proszę o pomoc.

    Pozdrawiam

    0
  • #11 31 Paź 2008 12:00
    5451
    Użytkownik usunął konto