Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Combo QSI SBW-241 w Toshiba Satellite Pro 4600

04 Lip 2006 23:42 3602 5
  • Poziom 13  
    Witam
    Wiem że temat już był poruszany, jednak pomimo tego prosiłbym o jakąś poradę, która przyniosłaby pożądany efekt (czyli żeby to cholerne combo wreszcie zaczęło działać)
    Fakty są następujące:
    1) oryginalny napęd w tym laptopie to cd-rom Teac cd-224e - oczywiście bios go widzi, system również (XP pro), w meneżerze urządzeń w gałązce kontrolery IDE ATA / ATAPI widoczne są trzy urządzenia:
    - kontroler Intel 82801BA Bus Master IDE
    - podstawowy kanał IDE
    - pomocniczy kanał IDE
    w ustawieniach zaawansowanych dla podstawowego kanału IDE widać urządzenie główne w trybie UDMA 4, dla pomocniczego kanału IDE - urządzenie główne w trybie PIO - stąd wniosek, że na kanale primary jest podłączony dysk twardy jako master, natomist cd-rom działa również jako master na kanale secondary

    2) zamiana cd Teac na combo QSI oczywiście nie przyniosła żadnego efektu, napędu nie widać ani w biosie ani w systemie
    oczywiście pokusiłem się o powalczenie z tym combo poprzez zwieranie pinu 47 do masy, do +5V, odizolowanie pinu 47, czyli wypróbowałem wszystkie metody znalezione na forum, niestety efekt za każdym razem zerowy :cry:
    przy okazji - kiedy podłączone było to combo, w menedżerze urządzeń widoczny był tylko podstawowy kanał IDE, pomocniczy gdzieś wcięło

    3) dla próby podłączyłem zamiast cd Teac cd Samsung SN-124 - i tutaj zdziwienie - napęd jest widoczny w biosie, aczkolwiek nie da się z niego wybootować komputera, po starcie systemu w menedżerze urządzeń pojawił się znowu pomocniczy kanał IDE, natomist cd-rom w systemie pozostawał niewidoczny
    zrobiłem jednak następujący manewr - odłączyłym od płyty taśmę sygnałową fdd, odpaliłem system - nadal nic - jednak po wprowadzeniu kompa w stan uśpienia i wybudzeniu system wykrył tego Samsunga
    po restarcie jednak cd-ka znowu nie było (pomagał tylko ten manewr z uśpieniem)

    4) każdy z tych trzech napędów podłączałem kontrolnie do zwykłego pc-ta przez odpowiednią przejściówkę - każdy zawsze wykrywał się jako master (również to combo, które dzięki operacjom z pinem 47 powinno przełączyć się w tryb slave)

    z tego wszystkiego wyciągnąłem sobie wniosek, że zarówno dysk jak i napęd optyczny pracują jako "master", każde na osobnym kanale, dlaczego jednak w takim razie nie są widoczne inne napędy i co wspólnego z drugim kanałem ma wbudowana sacja fdd ?

    no i wreszcie - czy jest na to jakaś rada, czy po prostu w tym modelu musi zostać ten oryginalny cd-rom i już ??

    bios mam w wersji 2.60, czyli teoretycznie najnowszy

    proszę o pomoc, męczę się z tym już 3 dzień i zaczynam opadać z sił witalnych .........
  • Pomocny dla użytkowników
    Jaki piękny problem :D :!:

    Ja miałem podobny z Compaq Armada 1750, ale w końcu zmusiłem tego lapka do pracy nawet z nagrywarką DVD (obecnie siedzi w nim combo).
    Problemem okazała się przejściówka, przez którą napęd był podłączany do płyty. Na niej musiałem ODCIĄĆ ZUPEŁNIE PIN 47 i dopiero wtedy napęd ruszył jako SLAVE (siedzi na jednym kanale z dyskiem).
    Jednak Twój poblem jest trochę dziwny.
    1. Nie wiem dokałdnie jak się podłącza napędy w tym laptopie, ale jeśli jest specjalna przejściówka to możesz spróbować na niej ODIZOLOWAĆ PIN47, a nie na napędzie.
    2. Niektóre laptopy wymagają by napęd miał wgrany odpowiedni BIOS (z zapisanym ustawieniem MASTER lub SLAVE). Producenci udostępniają też takie BIOSy.
    3. Na stronie Toshiby znalazłem to:
    Cytat:

    My new combo drive does not work in a Toshiba Satellite Pro 4600 notebook
    Because of a BIOS timing issue, our combo drives SD-R2612 and SD-R2612C will not work in Toshiba Satellite Pro 4600 notebooks. Please use one of our other drive models instead.

    Dotyczy to napędów Toshiby, ale myślę, że może się też odnosić do innych.
    4. Ciekawe jest też to:
    Cytat:
    My new slimline drive is not detected by my notebook or: I get an IDE #1 (or other numbers) error
    Background information: All Toshiba slim line drives work in cable select mode (CSEL) by default. This means, the drive gets a signal from the laptop telling it if it has to act as master or as slave device on the IDE channel.

    Some laptop computers in the market do not work according to this specification, but use the CSEL signal in an inverted manner to save a little bit of electric current. If you install a drive running in standard CSEL mode in such a laptop, the inverted signal will force it to work in the wrong master/slave mode giving the drive the same logical address as the hard disk drive installed on the same IDE channel. As a result, either the HDD or the optical drive, or both may not be detected by the BIOS and will not be usable. Some notebooks might show an error message on start-up, e.g. "IDE #1 error" or similar.

    Solution: The drive needs a special firmware version that can deal with the inverted CSEL signal. To avoid this special firmware being installed by mistake, we do not offer it as download from our website, but send it to customers on a case by case basis. To receive the special firmware version for your drive, please fill in the contact form on this website, or send an email to our hotline team with the following information: Exact model number, current firmware, problem description, your email address (for sending the necessary files).

    I chociaż wygląda podobnie do tego co napisałem w pkt. 2, to tylko pozór. Chodzi o odwróconą logikę sygnału CSEL.

    Z tym FDD to myślę, że to może mieć związek z problemem w BIOSie wspomnianym w pkt. 3.

    Dużo po angielsku, mam nadzieję, że to nie problem :D

    Właśnie znalazłem info, że ta Toshiba wymaga napędu, z BIOSem SLAVE :!:
    Możesz w sumie to chyba sprawdzić... przynajmniej tak twierdzili na tym forum. Odłącz dysk i spróbuj zbootować laptopa z tego nowego napędu.
  • Poziom 13  
    hehe, fajna ta toshiba, fajna

    w tym modelu nie stosuje się żadnej przejściówki do podłączenia napędu, na płycie jest wlutowane odpowiednie gniazdo i już

    pytałem w autoryzowanym serwisie toshiby, panowie byli mili i uprzejmi i wycisnęli z siebie tylko tyle, że nie wystarczy przeróbka napędu, wymagana jest również drobna zmiana na płycie głównej - być może faktycznie jest to problem wiązany - przeróbka napędu, odizolowanie pinu 47 bezpośrednio na płycie głownej i modyfikacja biosu notebooka i napędu

    niestety chwilowo już tego nie sprawdzę, zdobyłem w przyzwoitej cenie combo toshiby dedykowane tylko do satellitek i ruszyło bozboleśnie

    jak się nadarzy okazja to postaram się wypróbować metodę

    oczywiście czekam też na inne podpowiedzi :)
  • Poziom 2  
    Witam Wszystkich!
    Zdecydowałem się umieścić swój skromny post ponieważ miałem podobny problem ze zmianą napędu dvd w laptopie. Rozwiązanie jest prostsze niż można to sobie wyobrazić; nie trzeba zwierać (izolować) żadnych pinów ani zmieniać biosu w napędzie (wszystko to przerabiałem - niepotrzebnie) wystarczy skorzystać z oprogramowania, które z poziomu windy lub dosa zmienia domyślne ustawienia w napędzie optycznym master/sleave w obie strony.
    oto link na stronkę: http://codeguys.rpc1.org/utilities.html
    strona zawiera również inne ciekawe programiki oraz biosy. Myślę, że warto też wspomnieć o innym problemie, który się przy okazji uwidocznił: w moim laptopie nie zainstalowały się prawidłowo sterowniki ASPI (dłuuugo nagrywa się płyta), właśnie walczę z tym problemem i jeśli dojdę do jakichkolwiek wniosków, które mogą być przydatne - napiszę.
    Pozdrawiam!
  • Poziom 13  
    witam ponownie

    jak wspomniałem, problemu z toshibą nie udało mi się dociągnąć do końca, natomiast przy okazji walki z uruchomieniem combo QSI w Armadzie M700 udało mi się odkryć, że w tych napedach (dotyczy to SBW-241 i SBW-242) nie powalczymy ze zmianą trybów master/slave przy pomocy kombinacji z pinem 47, one po prostu na to nie reagują

    wystarczył natomiast jeden mały programik QFSBW081 uruchamiany w trybie DOS, aby to ustawienie zmienić w firmware napędu

    Cytat:
    nie trzeba zwierać (izolować) żadnych pinów ani zmieniać biosu w napędzie (wszystko to przerabiałem - niepotrzebnie) wystarczy skorzystać z oprogramowania, które z poziomu windy lub dosa zmienia domyślne ustawienia w napędzie optycznym master/sleave w obie strony


    masz rację Margo, takie zmiany robi się dużo łatwiej i przyjemniej, jednak w przypadku tej toshiby problemu to w żaden sposób nie rozwiązuje (niestety) - napęd był ustawiony na master i miał działać jako master, cała boleść w tym, że laptop go nie widział

    nadal więc czekam na fachowe podpowiedzi w tym temacie, co prawda chwilowo tego nie wypraktykuję, ale mimo wszystko ciekawość mnie zżera, co też takiego tkwi w tych cholrnych toshibach...
  • Poziom 2  
    myślę, że warto podzielić się z wszystkimi, którzy walczą z napędami optycznymi w swoich laptopach następną ciekawostką: otóż niektóre laptopy Acera mają kłopoty z poprawnym nagrywaniem płyt dvd - płyta się nagrywa (lub czasami uszkadza) baaaaardzo długo - np 1do 2 godzin - takie dziwne rzeczy dzieją się z nagrywarkami Liteon/Sony i niewiele daje tu zmiana biosu - najnormalniej w świecie nagrywarka "gryzie się" z chipsetem płyty głównej. Na stronie http://forum.cdrinfo.pl/ogolnie-o-dvd/60568-wolne-nagrywanie-plyt.html?highlight=SOSW-833S jest post osoby, która miała już taki problem i zawiera bardzo ciekawy programik, który go likwiduje :D
    Pozdrówka dla użytkowników elektrody