Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

włącznik (na przekaźniku) z opóźniaczem - poszukuję schematu

obe 20 Lip 2006 00:18 4553 22
  • #1 20 Lip 2006 00:18
    obe
    Poziom 10  

    Witam

    jestem sredniozaawansowanym elektoronikiem i nie moge przebrnac przez pewien problem, oto on.
    chce zbudowac wlacznik w ukladzie elektrycznym pojazdu 12 V taki, ze po nacisnieciu przycisku uklad na stale (czyli do nastepnego nacisniecia) załaczy przekaznik... ale problem w tym, zeby ten przycisk byl obojetny na przypadkowe wcisniecia, pomyslalem ze dobrze gdyby zmiana poziomow napiec na wyjsciu ukladu sterujacego przekaznikiem dokonywala sie np. po 2 sek. ciaglego trzymania przycisku.
    i nawet wymyslilem taki ukladzik, ze przycisk bedzie wlaczal generator na NE555, ktory bedzie zasilal CLK ukladu liczacego i na ktorejstam koncowce po okreslonym czasie pojawi sie napiecie dodatnie, problem w tym, zeby uklad sie RESETOWAL i liczyl od nowa gdy przycisk bedzie trzymany za krotko! bo inaczej kilka razy zostanie przypadkowo nacisniety i bedzie niekontrolowane przelaczenie, i tutaj sie troche zawisilem, zalezy zeby ukladzik byl mozliwie prosty (zadne procesory) i z jak najmniejsza liczba elementow, no i odporny na zaklocenia z instalacji pojazdu :(
    tylko nie piszcie, ze takie zeczy to tylko w Erze ;)

    pomocy, moze ma ktos jakis pomysl, sprawa palaca :(

    pozdrawiam
    robert

    0 22
  • #2 20 Lip 2006 00:33
    Figi
    Poziom 37  

    obe napisał:
    [...]problem w tym, zeby uklad sie RESETOWAL i liczyl od nowa [...]
    Szczerze mówiąc nie widzę problemu... Przycisk powinien być w układzie zasilania 555 (tak, żeby włączenie przycisku powodowało zasilenie 555, a jego zwolnienie odłączenie od zasilania) - to będzie Twój "reset", a dalej za układem włącznik bistabilny do realizacji funkci "włącz, aż następny impuls Cię nie wyłączy".
    W takim wypadku bez układu liczącego, a jedynie z 555 jako generatorem pojedynczego impulsu o zadanym opóźnieniu.

    0
  • #3 20 Lip 2006 01:19
    obe
    Poziom 10  

    no tak to jest jakis pomysl, chociazwidze pewna niescislosc, mianowicie:
    gdybysmy w momencie przycisniecia zalaczali na piecie zasilajace dla generatora Ne555 to uklad liczacy i tak zapamietywalby te impulsy wczesniej juz zliczone przy poprzednim zalaczeniu generatora :( natomiast gdybysmy przysickajac przycisk zalaczali napiecie zasilajace na 2 uklady (generator i licznik) to owszem przed momentem zliczenia odpowiednij liczby impulsow (i przelaczeniu przekaznika) puszczenie przycisku powodowaloby reset ukladu licznika, ale gdybysmy puscili ten przycisk po zliczeniu odpowiednij liczby impulsow i przelaczeniu przekaznika to ten i tak wyb powrocil do poprzedniego stanu gdyz niebyloby napiecia podtrzymania od licznika! :(
    dobrze mysle?

    0
  • #4 20 Lip 2006 11:44
    rasty
    Poziom 27  

    Nie ma potrzeby sięgania po tak "poważny" układ jak 555. :D
    Tu starczy zwykły opóźniacz na inverterach Schmitta.
    Układ ma dwa różne wyjścia, do wyboru, zależy, czym będzie dalej sterował.
    W stanie spoczynkowym na OUT1 jest "0".
    Po włączeniu switcha kondensator zaczyna się ładować i po czasie ustalonym (1M - 2,2uF) przełacza inverter.
    Puszczenie switcha powoduje b. szybkie (ok. 10 msec) rozładowanie kondensatora.
    Puszczenie switcha przed czasem nie spowoduje na wyjściu nic.
    Możesz tym posterować np. dwójkę liczącą (na 4013 albo dowolnym przerzutniku J-K).

    pozdr.

    0
  • #5 21 Lip 2006 18:16
    WojcikW
    Poziom 38  

    Jeżeli układ ma sterować przekaźnikiem to może lepiej zrobić układ na dwóch przekaźnikach z cewką 12V. Jak widać na schemacie układ jest prosty, 1 tranzystor Darlingtona, kondensator, kilka rezystorów, 3 diody o prądzie 1A. Oczywiście conajmniej jeden z przekaźników powinien mieć dodatkowy zestyk (nie ma go na schemacie) by załączał ten Twój obwód.
    Zmieniłem załącznik, zamiast rezystancji R4 = 1k należy zastosować 4,7k.
    Stara wersja załącznika nie chce się skasować.

    0
  • #6 21 Lip 2006 21:43
    obe
    Poziom 10  

    hmmm
    uklad z inwerterami zamierzam zrobic i sprawdzic jak dziala (mam juz scalaki), ale przyznam ze ten pomysl z przekaznikami tez nie jest glupi, tylko nie bardzo go rozumie :(
    jakie opoznienie osiaga sie przy tych wartosciach elementow?
    czy ukladzil zostaj juz sprawdzony w rzeczywistosci?
    a jak by Ci sie chcialo to czy mozesz go opisac/wyjasnic?

    pozdrawiam
    i dziekuje za podjecie tematu :)

    0
  • #7 21 Lip 2006 23:06
    WojcikW
    Poziom 38  

    Układ nie został sprawdzony, wg. mnie powinien działać. Czas opóźnienia zależy od stałej czasowej R2 C1. Przyznam się, że nie liczyłem tego czasu. Chyba powinien wynieść 2 ÷ 3 sekundy dla elementów jak na schemacie. Rasty pamięta takie wzory, ja mam sklerozę. W razie potrzeby można ten czas zwiększyć lub zmniejszyć zmieniając pojemność C1. Kondensator C1 może być na niskie napięcie np. 6V. Acha, zmieniłem załącznik, lepiej by R4 = 4,7kΩ.
    Opiszę działanie układu.
    Na schemacie jest stan gdy nie jest podane napięcie.
    Po włączeniu zasilania załączy przekaźnik S1. Gdy przyciśniemy przycisk K (odpowiednio długo - 2 ÷ 3 sekundy), zostanie wysterowany tranzystor T1 i załączy również przekaźnik S2 bo prąd cewki zamknie się przez diodę D2. Gdy przycisk K puścimy to wyłączy przekaźnik S1, a S2 pozostanie załączony. Jeżeli teraz przyciśniemy przycisk K to przekaźnik S2 wyłączy się. Gdy K puścimy to załączy S1 i będzie taki stan jaki był po włączeniu zasilania.

    0
  • #8 27 Lip 2006 15:50
    obe
    Poziom 10  

    a wiec przetestowalem uklad z przekaznikami...
    i powiem tak: nie zawsze teoria idzie w parze z praktyka :(
    wzialem dwa przekazniki na 12 V, jeden musialem kupic i o zgrozo kosztowal mnie 22 PLN (zlodziejstwo), wykonalem najpierw w pajeczynke logike - czyli polaczenia samych przekaznikow i ku mojemu zdziwieniu faktycznie po podaniu napiecia najpierw jeden (na schemacie lewy) sie przelaczyl, podanie masy w punkt gdzie sbiegaja sie diody prostownicze spowodowalo przelaczenie przekaznika drugiego (na schemacie prawy), kolejne podawanie masy na krotko powodowalo kolejne przelaczenia przekaznika prawego (taki przezutnik), w tym czasie pierwszy przekaznik pewnie tez tak sobie jakos przeskakiwal ale ten byl obudowany i nie widzialem ani nie slyszalem czy na pewno, tak wiec ta czesc ukladu nawet dzialala, niestety problem pojawial sie przy napieciach 10 czy 15 V, tu juz albo sie nie zalaczalo albo nie rozlaczalo :(
    potem dorobilem dalsza elektronike z tranzystorem, i tu wlasnie sie posypalo, przy zasilaniu 12 uklad sie nie zalaczal, a przy napieciu 15 przekaznik glowny (ten zalaczjacy costam - prawy) wracal do pierwotnego polozenia tylko na czas przycisniecia przycisku, a po puszczeniu wracal do ztanu zalaczenia :(

    uklad musi byc dla tego projektu pewny i odpowrny na wszelkie zaklocenia czy wachania napiec zasilania
    tak wiec chyba nic z tego nie wyjdzie, ale przyznam ze "logika" na przekaznikach sama w sobie jest bardzo ciekawa i moze kiedys ja gdzies wykorzystam

    ps. trzeba zaznaczyc, ze na schemacie wszystkie narysowane polozenia stycznikow przekaznikow sa w stanie NZ (normalnie zwarte)

    teraz w wolnej chwili przetestuje uklad kolegi, ktory zaproponowal rozwiazanie na inwerterach :D

    pozdrawiam i czekam na jeszcze inne/lepsze pomysly (najlepiej sprawdzone)

    0
  • #9 27 Lip 2006 22:17
    WojcikW
    Poziom 38  

    obe napisał:
    a wiec przetestowalem uklad z przekaznikami...
    i powiem tak: nie zawsze teoria idzie w parze z praktyka :(
    Ja akurat tu nie widzę sprzeczności teorii z praktyką, zresztą nigdy takiej sprzeczności nie zauważyłem. Układ nie był sprawdzony a elementy dobierane bardziej intuicyjnie niż obliczone. Przede wszystkim przekaźnik przekaźnikowi nie równy. Rezystor R1 należy dobrać doświadczalnie (bo przekaźniki nawet na to samo napięcie mają różną rezystancję cewki, siłę sprężyn itd.) do danego typu przekaźnika. Dlatego też oba przekaźniki muszą być identyczne. Następnym problemem jest duży (w porównaniu z napięciem 12V) spadek napięcia na półprzewodnikach. Moje zalecenia:
    Kupić drugi przekaźnik za 22 zł (chyba ma złote styki), wymienić tranzystor na BD135, diody dać 2A÷3A Schottkiego, zmniejszyć rezystancję R1 (np. dołożyć równolegle do R1 drugi rezystor 82Ω/2W).

    0
  • #10 28 Lip 2006 16:26
    obe
    Poziom 10  

    tak czy siak, pomysl z przekaznikami jakos mnie troche zniechecil i wydaje mi sie zbyt niepewny jak do pracy w srodowisku instalacji elektrycznej motocykla

    ale za to zabralem sie dzisiaj za montowanie ukladu z pomyslu kolegi, ktory proponowal inwertery, udalo mi sie jak dotad zrobic tylko tyle co widac na powyzszym schemacie z dokladnie takimi elementami (nie mialem 1Gohm dalem 1,2 Gohm) i faktycznie napiecie miezone na koncowce nr 8 gwaltownie narasta po czasie ok 2 sek od przycisniecia przycisku, teraz dorobie do tego jakis licznik i powinno smigac :)
    tylko zobaczymy czy w tym przypadku teoria bedzie tak samo optymistyczna co teoria ;)

    jak bedzie dzialalo to opisze i zostawie dla potomnych :D
    pozdrawiam
    obe

    0
  • #11 28 Lip 2006 22:46
    rasty
    Poziom 27  

    W najprostszym przypadku może to tak wyglądać.
    Kondensator 220 n i rezystor 47 k tworzą prosty układ zerowania po właczeniu. Jest to opcjonalne.
    Parę uwag praktycznych. W pojeździe masz mnóstwo zakłóceń zwłaszcza od zapłonu. Postaraj się dobrze odfiltrować zasilanie.
    Dodatkowo wszystkie nieużywane wejścia scalaków podłącz do masy. Nie mogą wisieć w powietrzu.

    pozdr.

    1
  • #12 30 Lip 2006 03:34
    obe
    Poziom 10  

    powiem tak: jest juz niezle :)
    zrobilem uklad w oparciu na dwoch scalakach 40106 i 4013 tak jak pokazuja powyzsze pomysly i przyznam, ze czesc analogowo-cyfrowa fajnie dziala, opoznienie jakie uzysklaem to ok 3 sek czyli dokladnie tyle ile chcialem
    ale mam kolejne schody: do wyjscia nr 8 kosci 4013 podlaczylem przez rezystor 5k6 baze tranzystora BC548, emiter tranzystora podlaczylem do masy a z pomiedzy kolektorem i napieciem zasilania wstawilem przekaznik, po przytrzymaniu przycisku 3 sek przekaznik sie zalacza ale po ponownym przytrzymaniu przekaznik nie wraca do pierwotnego polozenia, wybadalem, ze przerzutnik sie "przytyka", bo bez obciazenia przekaznikiem prad bazy przwdopodobnie jest bliski zero i przerzutnik zmienia swoj stan co kazdy impuls zegarowy, wiec teraz pojawia sie moje pytanko:

    czy zna ktos pewne rozwiazanie tego problemiku?

    dodam, ze probowalem zmieniac rezystancje opornika ktory "siedzi" pomiedzy baza tranzystora a wyjsciem przerzutnika, ale to nie zdaje zadania poniewaz kiedy juz przekaznik zaczyna wracac do polozenia poczatkowego to ma wtedy problemy z zalaczeniem bo napiecie jego zasilania wynosi ok 8V - wiec zmiana rezystancji nie jest rozwiazaniem

    wpadlem na pomysl zeby na wyjscie przerzutnika dolozyc dwa inwerteru ktore (jak sadze) sa jeszcze do wykozystania z kosci 40106 - czy to moze pomodz?

    0
  • #13 30 Lip 2006 11:17
    rasty
    Poziom 27  

    Zmontowałem ten układzik z ciekawości. Podłączyłem przekaźnik jak na rys. poniżej. Dałem przekażnik samochodowy z cewką 200
    Ω. Dla utrudnienia, nie blokowałem zasilania żadnym kondensatorem. :D
    Wszystko działa bez problemu. Przekaźnik włacza się i wyłącza.
    Możliwe przyczyny :
    1. brak diody równolegle do cewki. Przy wyłaczaniu tranzystora następuje przepięcie na cewce. Tranzystor mógł sie przebić i przewodzi.
    2. jakiś systematyczny bład montażu.

    Co do tranzystora BC548, kiepski wybór, jest słaby do tych celów. Ma dość mały dopuszczalny prąd kolektora. Cewka przekaźnika o małej oporności może go zepsuć przy pierwszym właczeniu.
    Zmierz jeszcze napięcie na bazie tranzystora przy wyłączeniu przekaźnika, powinno być bliskie zeru.
    Invertery oczywiście możesz wykorzystać, odseparujesz obwód właczania przekaźnika od przerzutnika.

    0
  • #14 31 Lip 2006 01:27
    rasty
    Poziom 27  

    Cytat:
    ale mam kolejne schody: do wyjscia nr 8 kosci 4013 podlaczylem przez rezystor 5k6 baze tranzystora BC548


    pin 8 to wejście ustawiające przerzutnika a nie wyjście Q.
    Nie zaglądałem do rozstawu nóżek, myslałem, że wykorzystałeś drugi przerzutnik i się nie pomyliłeś.

    0
  • #15 31 Lip 2006 11:49
    obe
    Poziom 10  

    nie nie
    sorki pomylilem sie w opisie, oczywiscie chodzilo mi o wyjscie z przerzutnika czyli nozke nr 1
    sprawdzilem parametry tranzystora ktorego Ty uzyles i faktycnie ma 5ciokrotnie wiekszy dopuszczalny prad kolektora i to moze byc ten problem

    i jak na zlosc nie mam na stanie podobnego tranzystora :( i bede znow musial bybrac sie do sklepou ale jest juz naprawde dobrze, w tech chwili kombinowalem z jakims NPN KT940A i ten juz wlacza i wylacza przekaznik ale bywa ze czasem nie che czegos wykonac, mysle ze ten tranzystor potrzebuje wiekszego pradu bazy (to to taki przystosowany do radiatora) wiec kupie BC337 i dam znac czy juz "gra muzyka" ;)

    0
  • #16 31 Lip 2006 18:59
    allsiolek
    Poziom 13  

    Witam!
    Zobacz sobie tutaj..
    https://www.elektroda.pl/rtvforum/viewtopic.php?t=537644&highlight=
    https://www.elektroda.pl/rtvforum/viewtopic.ph...days=0&postorder=asc&highlight=cd4017&start=0
    I schemat
    Mialem podobny problem i po zlozeniu ukladu okazalo sie ze uklad nie przelacza sie po 2 wcisnieciach switcha tylko po jednym trwajacym ok 4 sekundy. Uklad sprawdzalem w samochodzie i dzialal idealnie (napiecie zasilania 5-18V. dla otrzymania czasu ok 3 sek trzeba dac R1 ok. 1M ohm i C1 220nF do 1uF juz nie pamietam... Na pierwszym schemacie w 2 poscie nie ma rezystora R3 o wartosci 3,3k ale dalej jest napisane gdzie powinien sie on znajdowac... Jakbys mial jeszcze jakies pytania pisz!
    A tak na marginesie (co do mojego prblemu) zeby uklad wylaczal sie po nacisnieciach switcha wystrczylo podlaczyc wejscie reset zmiasta do wyjscia Q2 do Q3 bez zadnych kombinacji...

    0
  • #17 07 Sie 2006 10:24
    obe
    Poziom 10  

    zrobilem ukladzik wedlug wskazan i pomyslow,
    uklad w warunkach domowych dziala i to dziala bardzo dobrze,
    niestety w ukladzie motocyklowym pracuje zle i wogole sie do takiej instalacji nie nadaje, gdy silnik pracuje uklad jest nieobliczalny... :(
    wiec chyba pozostanie mi kupic zwykly mechaniczny wlacznik i wmontowac w jakies miejsce

    tak czy inaczej zamieszczam pelny schemat, gdyz do zastosowan innych niz instalacja elektryczna motocykla, zadaje sie bardzo dobrze

    0
  • #18 07 Sie 2006 13:01
    rasty
    Poziom 27  

    Parę postów powyżej napisałem:

    Cytat:
    Parę uwag praktycznych. W pojeździe masz mnóstwo zakłóceń zwłaszcza od zapłonu. Postaraj się dobrze odfiltrować zasilanie.


    Moze tu tkwi przyczyna ?
    Między +12 V z instalacji a zasilaniem scalaka i switcha jakiś niewielki rezystor (220 omów) i za nim elektrolit 100 uF i kondensator ceramiczny 100nF.
    Cewka noże byś podpieta do +12 V instalacji.

    pozdr.

    0
  • #19 07 Sie 2006 13:08
    obe
    Poziom 10  

    odpowiem w ten sposob:
    gdyby ukladzik troche wariowal, albo czasem sam przelaczal przekaznik to moze szukalbym dalej jakiegos wyjscia, ale w moim konkretnym przypadku uklad kompletnie zwariowal i nie moglem nad nim nawet na chwile zapanowac, wiec doszedlem do wniosku gra nie jest warta swieczki wiec zainwestuje w manualny perzelacznik - moze bedzie to troche mniej wrafinowane rozwiazanie ale za to pewne! i zaczalem upewniac sie w stwierdzeniu, ze najlepsze sa najprostrze rozwiazania ;)

    0
  • #20 07 Sie 2006 15:23
    jony
    Specjalista elektronik

    A co zrobiłeś z pozostałymi bramkami i jednym przerzutnikiem.
    Jak wiadomo niewykorzystane wejścia trzeba podłączyć do masy.
    No i na schemacie nie ma ani jednego kondensatora filtrującego zasilanie i jednegomałego ceramicznego 100nF zamontowanego jak najbliżej układów scalonych.
    Zresztą sam sposób montażu też ma znaczenie.

    0
  • #21 07 Sie 2006 15:31
    obe
    Poziom 10  

    kondensatorki nie nam,alowane ale sa bliziutko scalaczkow ;)
    a co do bramek... inwertery wykorzystalem wszystkie (chociaz tego nie widac) ale po wyjsciu z przerzutnika dolozylem dwa inwertery co nie zmienia nic logicznie a jedynie odciaza pradowo przerzutnik; drugi przerzutnik w scalaku ma zlaczone koncowki i jak pamietam lezy na masie

    0
  • #23 08 Sie 2006 08:15
    obe
    Poziom 10  

    hmmmm
    obawiam sie, ze nie pomoze ale sprawdzac juz mi sie tego nie chce
    a dla czego nie pomoze? ano dla tego, ze zaklocenia ktore rozwalaja cala elektronike w glownej mierze pochodza od cewki i sa indukowane w urzadzeniach elektronicznmych, oczywiscie moge sie mylic, ale inne urzadzenie, ktore podobnie reagowalo (resetowalo sie) jak osunalem doslownie o 10-15 cm od pierwotnego miejsca "pobutu" ;) zaczelo zachowywac sie calkiem dobrze i chociaz testow jeszcze nie zrobilem to podejrzewam, ze skrocenie przewodow i znalezienie odpowiedniego miejsca gdzie cewka najmniej "sieje" rozwiaze problem, niestety w bezpiecznej strefie nie ma wiecej miejsca na kolejne pudeleczko ;)

    takze temat uwazam za zamkniety... no chyba, ze znajdzie sie ktos kto mial identyczne problemy i zrobil taki ukladzik, ktory jest nieczuly na uklad zaplonowy i wybuch atomowy takze :D

    pozdrawiam

    0
TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo