Elektroda.pl
Elektroda.pl
X
Computer ControlsComputer Controls
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

automatyczny przełacznik wejsc... CD4052 ... problem

22 Lip 2006 10:59 2442 15
  • Poziom 12  
    Hey pisze bo mam kilka pytan. Mam sprzet dekoder dolby digial. ma on 3 wejscia w tym jedno podwoje coaxial i swiatłowod. robione jest to w ten sposób ze sprzet rozpoznaje coaxial i wgry jest podłaczony automatycznie przłęnacza na to zrodło natomiast gdy nie ma sygnału przełancza sie na swiatłowod. Wszystko niby działa ale...

    Jak to zawsze z sygnałem coaxialnym bywa zdarzaja sie sporadyczne przerwy w graniu muzyki - ok to jestem w stanie zrozumiec, ale dlaczego tych przerw jest blisko 40 razy wiecej gdy kabel coaxialny podłaczony jest do tego automatycznego przełacznika. Co gorsze wyłaczenie i właczenie kabla coaxialnego powoduje ZAWSZE spalenie układu CD 4052. Macie moze propozycje co z tym zrobic...

    Podłanczam uziemiony komputer. Masa jest na bank dobra bo pomiedzy obudowa kompa a rurka kaloryfera mam idealne przejscie. roznica pomiedzy obudowa sprzetu a obudowa kopa okolo 1,5v nie moge sprzętu uziemic a nawet jesli to zrobiłe nie poprawiło to sytuacji i sprzet nadal przerywa...

    Co moge zrobic by
    1. Zabezpieczyc układ przed ciagłym spalaniem (na szczescie nie jest drogi i kosztuje 2zł ale juz spaliłem 4 ) czy mozna go zstapic 4053 i jaka jaest roznica pomiedzy 4052 a 4053?
    2. Co zrobic by zlikwidowac ciągłe przerywanie sygnalu gdy idzie przez ten układ... PLIS help..

    Układ był wymieniany kilkukrotnie i nic to nie pomogło zawsze wstawiałem CD 5052
  • Computer ControlsComputer Controls
  • Poziom 12  
    Jeszcze jedno pytanie.
    Oryginalny uklad to tc4052BP - co oznacza BP ???
  • VIP Zasłużony dla elektroda
    Witam.

    Wejście JK302 nie ma separacji składowej stałej. Spróbuj wstawić kondensator elektrolityczny 2µ2 do 10µF, tuż przy pin 12. Plusem do wyprowadzenia :!:.
    4052 -> podwójny, czterokanałowy multi/demultiplekser analogowy
    4053 -> poczwórny, dwukanałowy

    B -> wersja, związane z wbudowanymi zabezpieczeniami

    P -> obudowa dwurzędowa DIP-16


    Pzdr.
  • Computer ControlsComputer Controls
  • Poziom 12  
    Dziekuje jak nie wiem co .. naprawde mam dosc kupowania ciagle tego ukałdu (dzisja kupiłem 3 kolejne scalaki) ...

    Wracajac do sprawy mam zewrzec kondensatorem 2mikro noge 12 układu do masy? czy tez rozpruc sciezke i wstawic tam kondensator?

    Masz pomysłskad pojawiaja sie te zaniki sygnału na tym 1 wejsciu? bo na wejsciu nr 3 jest wszystko ok. Wymieniałem scalaka, i tranzystorki .. nic to nie dawało....

    Mogłbys zaznaczyc na schemacie jak mam wstawic tego kundziora :)

    Dodano po chwili __________________
    Jk by na to nie patrzec wejscie nr 3 tez nie ma. Moze skoro pojawiaja sie składowe stałe bo tak wywnioskowałem warto zabezpieczyc oby 2 wejscia... Jeszcze raz prosze o scemat jak i gdzie domontowac te kundziory :)
  • VIP Zasłużony dla elektroda
    Witam.

    Trzeba przeciąć ścieżkę i wstawić kondensator. Wejście IN3 jest separowane C325 (10n ?) . Możesz wstawić identyczny. Zaniki sygnału mogą być wynikiem zasilania multipleksera pojedynczym napięciem (+5V) wzgledem masy i braku separacji składowej stałej sygnału wejściowego. Źródło sygnału może być zasilane symetrycznie względem masy . ?


    Pzdr.
  • Poziom 12  
    Ok.
    Widac to wszystko nie jest takie proste. Zabrałem sie za ten sprzęt. Wymieniłem ponownie scalaka. I o zgrozo wejscie nr 1 na coaxialu nie dziala. Zamieniłem wiec wejscia z płyty głownej by wykluczyc przetwornik. wejscie nr 1 pod wejscie nr 3 - dziala. Ok. wymieniłem wiec dla proformy jeszcze te 2 tranzystory (sam sie zastanwiam po co skoro steruja one tylko układem przełanczajacym. LIPA. Zasiegłem wiec bardziej radykalnego sposobu. Wyjąlem uklad, wylutowałem z 1 strony C306 i zwarłem na sztywno nogi układu 12 z 13. Co sie okazało nadal lipa. Idac dalej tym tematem sprawdzałem wszystko po kolei dotyczace tego wejscia. Okazało sie ze lezy rezystor R304 - wymieniłem go...

    Podłaczyłem i dziala juz wejscie nr1, ale nie tak do konca. Wystarczy ze wepne swiatlowod w dowolne wejscie swiatlowodowe to sprzęt zaczyna strasznie przerywac. Skoro przerywanie ma miejsce gdy do wejscia 1 podłaczony jest sygnał coaxialny a nic takiego sie nie dzieje gdy to jest wejscie nr3 podejrzewam usterke kondensatorów c304 i/lub c303...


    Problem w tym ze gubie sie w tym nazewnictwie ...
    tam jest napisane ze to kondensator 0,01
    dla mie to jest o,o1 mikro czyli 10nF
    Czlyli musze wstawic tam kondensator który ma napisane na obudowie 103...

    Dobrze mysle?
    ----------------------------------------
    Przez to wszystko dotarłem do wiedzy tego typu ze przerywanie na wejsciu nr1 na coaxialu odbywaja sie tylko wtedy gdy podłaczony jest w dowolne wejscie kabel swiatłowodowy... gdy go nie ma przerywania tez nie słychac...
    ----------------------------------------

    Ps. Fitrem sie zajme jak go wreszcie uruchomie. Czekam na dalsza pomoc
  • VIP Zasłużony dla elektroda
    Witam.

    Rezystor R304 mógł ulec uszkodzeniu w dwóch przypadkach: 1) duża składowa stała sygnału wejściowego
    2) przebicie kluczy i pojawienie się napięcia 5V na pin 12
    Uszkodzenie C303 i 304 jest mało prawdopodobne.
    Zauważ, że sygnał wejściowy jest podawany na płytę główną trzema torami. IN2 i IN3 idą bezpośrednio, natomiast IN1 i JK302 są przełączane przez IC301. Jeśli masz , to załącz dalszą część schematu (fragment płyty głównej) lub link do tego. Dodatkowo podaj, z czego podajesz sygnał na coaxial.

    .01 to 10nF


    Pzdr.
  • Poziom 12  
    Teraz to ja juz niczego nie rozumiem....

    Na ta chwile sytuacja jest taka - po wymianie rezystora r304 wszystke wejscia działaja poprawnie. Jedyne co jest nie tak to to, ze gdy puszcze sygnał coaxialny przez wejscie nr1 i wepne swiatłowod z sygnałem sprzęt caczyna przerywc. Gdy przewód ze swiadłowodem wyłacze sprzęt gra poprawnie!!!! gdy zas podłacze sygnał coaxialny do we 3. to nie wazne gdzie mam swiatłowod to jest wszystko w porzadku. Czyli problem jest nadal na wejsciu nr1.

    po podmanie kabli 1 na 3 a 3 na 1. wejscie nr 1 - wyswietla mi sie na sprzecie jako 3 ale teraz 3 przerywa a wejscie nr 3 jako 1 idzie ok. Daltego wiem ze nadal problem jest na tej płytce.... gdzies naspepuje przebicie pomiedzy sygnałem swiatłowodowym a coaxialnym na wejsciu nr1 ..... :( a tam poza c303 i c304 (filtry) chyba juz nigdzie indziej nie moze byc przebicia.. chyba ze na układzie CD4052... moge spróbowac go podmienic... Pytanie. Dlaczego Twoim zdanie usterka c303 i c 304 jest mało prawdopodobna skoro padł r304 to calkiem mozliwe ze pdało cos jeszcze... tylko cooo. układ bym podejrzewał w wypadku gdy przerywanie odbywało by sie gdy sygnal swiatlowodowy byłby podłaczony do wejscia nr1 ale to samo sie dzieje gdy jest podłaczony do wejscia nr2 !!!! a na schemiasie we2 poza zasilaniem w rzaden sposób nie jest powiazane z coaxialem 1 !!!! Jeszcze jedno.

    Wiem ze musze sprawdzic co nastepuje
    1. Czy na pewno układ cd jest dobry .. mam kilka jego egzemplarzy wiec moge to sprawdzic
    2. Zaobserwowac czy przerywania sygnal coaxialnego sa takie same na wejsciu swiatła 1 i 2.... jezeli bedzie rozbierznosc to skieruje mnie to do punktu 1... lub do przełacznika na tranzystorach ale cholera wymieniałe mje ...
    3. Sprawdzic wejscie 1 gdy podłaczone jest samo swiatło... bez coaxiala
    4 Zrobic jeszcze raz to samo czyli zewrzec noge 12 z 13 csalaka i sprawdzic czy nadal przerywa...

    Zobaczymy

    Sygnały z płytki 1 - 5V - stabilne i sprawdzone 2 - GDM - 3,4,5 - wyjscia cyfrowe ida do układu scalonego cs4226KQ. Sygnał coaxialnu podawany ze stacjonarnego DVD lub z umasionego Kompa... dowolnie. Jak powsała usterka? wszystko dzilalao poprawnie az z biegiem czasu zaczelo coraz bardziej i bardziej przerywac by wrescie przestac totalnie grac...
  • VIP Zasłużony dla elektroda
    Witam.

    Na samym początku wstaw dodatkowy kondensator tak, jak zaznaczyłem.

    Rezystor mógł się uszkodzić z powodu zbyt dużego pąrdu. Jeśli uszkodzony 4052 podał (na pin 12) 5V . Kondensatorów tak niskie napięcie nie uszkodzi.

    Co do zaników sygnału, to wina może leżeć po stronie automatyki. Sygnał wejściowy ma przesunięty poziom masy na rezystorach R303 i 304.
    Sprawdź, czy w czasie zaniku nie następuje zmiana stanu H/L (5V/0V na pin 10).

    Pzdr.
  • Poziom 12  
    jadac dalej mam odpowiedz na kilka pytań.

    gdy zamienilem przeody wejsciowe z płyty głownej z 1 na 3 i wpiąłem coaxial to nie ma przerywania na 1 a na 3 nadal jest, czyli nadal cos musi siedziec na wejsciu coaxialnym nr1.

    PRzełacznik działa prawidłowo TZN przełancza wejscie nr1 w zaleznosci od tego czy mam właczone swiatło czy coaxial na wejsciu 1. Problem jest na bank w tym ze sieje mi coaxial nr1 na swiatło nr2.

    Wykluczyłem rezystory r304 i r303 sa w pełni sprawne układ TC wymieniłem na nowy, tak samo jak tranzystory. Po raz 3 i nadal jest ten sam problem.. coraz bardziej jestem prekonany o wymianie tych kondensatorów c304 i c 303 daltego ze (zobacz sam) wejscie nr 1 nie ma nic wspolnego z wejsciem nr 2 Tam praktycznie dociagniete jest tylko zasilanie ...

    1. Czy na pewno układ cd jest dobry .. mam kilka jego egzemplarzy wiec moge to sprawdzic .. TAK UKLAD JEST DOBY !!!
    2. Zaobserwowac czy przerywania sygnal coaxialnego sa takie same na wejsciu swiatła 1 i 2.... jezeli bedzie rozbierznosc to skieruje mnie to do punktu 1... lub do przełacznika na tranzystorach ale cholera wymieniałe mje ... NIE NIE SA TAKIE SAME. WEJSCIE 1 SWIATLO DZIALA PRAWIDLOWO!!
    3. Sprawdzic wejscie 1 gdy podłaczone jest samo swiatło... bez coaxiala .. DZILAA I NIE PRZERYWA
    4 Zrobic jeszcze raz to samo czyli zewrzec noge 12 z 13 csalaka i sprawdzic czy nadal przerywa... NADAL PRZERYWA !!!


    Wymienie teraz je i zobaczymy.
  • Poziom 39  
    Mariusz Ch. napisał:
    Witam.

    Trzeba przeciąć ścieżkę i wstawić kondensator. Wejście IN3 jest separowane C325 (10n ?) . Możesz wstawić identyczny. Zaniki sygnału mogą być wynikiem zasilania multipleksera pojedynczym napięciem (+5V) wzgledem masy i braku separacji składowej stałej sygnału wejściowego. Źródło sygnału może być zasilane symetrycznie względem masy . ?


    Pzdr.


    Proponowałbym dodać kondensator na wejściu Optical IN1 w ten sam sposób jak kolega Mariusz Ch proponuje na wejściu Coaxial.
  • VIP Zasłużony dla elektroda
    Witam.

    Układ scalony nie zapewnia separacji dla sygnałów cyfrowych na wejściu IN1 i JK302. Multiplekser to jedna płytka krzemu.

    Sprawdź, czy nie występuje różnica potencjału mas pomiędzy komputerem i dekoderem. W przypadku dużej różnicy, prąd wyrównawczy dobije 4052. Najlepiej wyjście z komputera podłączyć światłowodem. Wtedy masz pełną izolację galwaniczną.

    Pzdr.
  • Poziom 12  
    Tosmy sie nie do konca zgadali...

    Swiatłowod mam podłaczony do wejscia In2. A przewód coaxialny do jk302 wtedy przerywa gdy zamienie jk302 na jk304 przerywania nie słychac.

    Zrobiłem wiec machloje zamieniłem wyjscia z płytki drukowanej 3 z 5 i z 5 na 3. Podłaczyłem to i znowu przerywanie słychac gdy Swiatłowod mam podłaczony do wejscia In2. A przewód coaxialny do jk302. Przerywa nawet gdy mam wylutowany c306 i wyjety układ scalony (zwarte zworka nogi układu 13 z 12.... zobacz co w takiej sytuacji. Nie ma układu tranzystory sa odseparowane i nadal przerywa !!!! wtedy elementów do samego wyjscia jest tylko kilka prad płynie przez R303, c303, r304, c304, i c305.... wieceje elemenow nie ma i wsrod nich musze szukac usterki... tak mi sie wydaje :) jutro napisze jak wymienie te kondensatory .. zobaczymy wtedy co dalej...
  • Poziom 39  
    Po pierwsze instalacja CO nie jest uziemieniem, jest izolowana od ziemi ( otulina ) więc to żadne uziemienie - gorzej grozi to porażeniem kogoś z domowników. Po drugie czy sygnał coaxial i światłowód to ten sam sygnał? z tego samego urządzenia? Ponadto występuje dziwna różnica potencjałów między urządzeniami której nie powinno być. Doraźnie można spiąć masy urządzeń grubym przewodem. Byc może przyczyna leży po stronie urządzenia podającego sygnał, jest zbyt duża składowa stała. Separacja kondensatorem powinna pomóc. Kondensator włączony szeregowo między wejściem a nóżką układu scalonego, czyli należy przeciąć ścieżkę. Prawdopodobnie jedno wejście jest uprzywilejowane i taki stan jest wymuszany na układzie scalonym, gdy spada poziom sygnału na coaxial następuje automatyczne przełączenie.
  • Poziom 12  
    na ta chwile:

    wymieniłem z 6 kondensatorów 10nf :)... dodatkowo tak jak radziłes zacząłem sie zastanwiac jak z tą masa. okazuje sie ze to był strzał w 10. :) z ta roznica ze masa na rurce od kaloryfer jest ok. Wnioskuje to z tego ze gdy komputer nie był zwarty do kaloryfer to kopał gdy go dotykałem. Teraz problem przestał istnieć. Zreszta poprzednio zjarałem tak cd4052 i cs4226kq (kosztował mne 120zł) bo podłaczyłem nieuziemionego kompa do tego sprzęta...

    To co napisałes dało mi do myslenia bo wymierzyłem obudowe dekodera z obudowa kompa i jest tam o zgrozo napiecie stałe o wysokosci 1,5v i sie waha. Prawdopodobnie gdy osiagało wartosc krytyczna palił sie układ a co najciekawsze !!! UWAGA minus w kontakcie gdy go mierze miernikiem z rurka od kaloryfera to roznica siega 60V wiec nie moge masy wyciagnac z minusa kontaktu.

    Probowałem zewrzec na kompie kontaktowy - z obudowa kompa !!! i albo jak nie szły korki to szłą płyta głowna (na szczescie na gwarancji). Teraz poprowadziłem kabelek z kaloryfera do obudowy kompa i dekodera... juz nic nie strzela wszystke wejscia dzialaja prawidłowo...

    mam jeszcze jeden problem ale to juz z innej beczki. Zaobserwowałem pewna prawidłowowsc zwiazana o zgroo.... z lodówka... wystarczy ze ja otworze lub zamkne to zawsze przerywa mi akurat w tm momencie prawdopodbnie cos sieje i nie bardzo wiem co... moe daltego ze sygnał coaxialny dociagnałem kablem audio a wiem ze taki tez byc nie moze .... mam kupic 75ohm czy 50? który bedzie dobry do sygnału coaxialnego? moe zamontuje jakis filtr na zasilaniu tegi urzadzenia?
  • VIP Zasłużony dla elektroda
    Witam.

    Do połączenia zastosuj kabel "cyfrowy". Dostaniesz taki w większości sklepów.

    Dodatkowo trzeba pomyśleć nad remontem instalacji elektrycznej.

    Pzdr.