Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Programator Progat wielki problem proszę o pomoc.

bloktech 26 Sie 2006 22:00 1343 22
  • #1 26 Sie 2006 22:00
    bloktech
    Poziom 9  

    Zlutowałem progat i nic. Ani nie czyta sygnatury ani nie programuje. Chc zaprogramować atmelka 89c52. Wszystko sprawdziłem 3razy i wszystko dobrze. Próbowałem na dwóch kompach z wiindowsem 98. Widziałem już dużo postów na temat progata ale nie znalazłem ni dla mnie pomocnego. Licze na waszą pomoc i rady. Bardzo proszę o pomoc i pozdrawiam

  • #2 26 Sie 2006 22:28
    sp4msu
    Poziom 20  

    Jak zasilasz tego progata , chodzi mi o +5 i +12 V ??

  • #3 26 Sie 2006 23:12
    bloktech
    Poziom 9  

    Zgadza się zasilam dwoma napięciami +5V i +12V.
    Pozdrawiam

  • #4 26 Sie 2006 23:25
    sp4msu
    Poziom 20  

    bloktech napisał:
    Zgadza się zasilam dwoma napięciami +5V i +12V.
    Pozdrawiam

    Spróbuj zasilić z komputera którym programujesz , w moim progacie za boga nie chciało i nie chce z zewnętrznego i dlatego pytałem jak zasilasz .

  • #5 26 Sie 2006 23:32
    bloktech
    Poziom 9  

    Spróbuje a jeśli nie pomoże to jeszcze jakieś pomysły? Mi nawet nie chce zczytać sygnaturki z procka, zaprogramowac i odczytać też nie. Próbowałem z pod windowsa i pod DOSa. Z pod DOSa niby sie zaprogramuje ale nie działa:(
    Dzięki za rade spróbuje

  • #6 26 Sie 2006 23:58
    sp4msu
    Poziom 20  

    Nie piszesz tez jakiego programu używasz do programowania , spróbuj MikrolLuk to pod WIN .
    Programowałem tez Programatel .
    Pozdrawiam .

  • #7 27 Sie 2006 11:33
    bloktech
    Poziom 9  

    Programuje progatmelem i flashprogramatorem i też orginalnym programem z pod DOSa. Dzisiaj spróbuje z tymi napięciami i innymi programami jk piszesz. Pozdrawiam

  • #8 27 Sie 2006 12:55
    sp4msu
    Poziom 20  

    A co się tyczy czytania Sygatury , to jakoś tak jest ze nie zawsze czyta i typ procka też trzeba podawać .
    Pozdrawiam i życzę powodzenia w programowaniu .

  • #9 27 Sie 2006 14:36
    bloktech
    Poziom 9  

    Próbowałem już ładowa zaprogramowany at89c2051 bo kiedys kupiłem zamek szyfrowy chyba nor elektronik i z tym na 100% sprawnym prockiem to samo. Nie czyta sygnatury, nie programuje, nie czyta programu z procka. Czy to może by normalne? Pozdrawiam i dziękuje za zainteresowanie

  • #10 27 Sie 2006 15:45
    sp4msu
    Poziom 20  

    To ze nie czyta tego zaprogramowanego to raczej tak ma być (zabezpieczony przed odczytem ) , a co do reszty to nic mi nie przychodzi do głowy . No i nie napisałeś czy zasilasz z komputera czy nie .

  • #11 27 Sie 2006 17:55
    McRancor
    VIP Zasłużony dla elektroda

    Nawet zablokowany procek daje się odczytać - tylko odczytany kod to bzdury

  • #12 27 Sie 2006 22:06
    bloktech
    Poziom 9  

    Na zasilaniu z kompa nie działa. Co mam zrobic dalej? pozdrawiam

    Dodano po 4 [minuty]:

    Chciałem se zaprogramowac 89c52 bo mam ochote zribic przedwzmacniacz z tda7318 z kitu ne 135-k pewnie go znacie. Pomóżcie prosze:(

  • #13 27 Sie 2006 22:17
    McRancor
    VIP Zasłużony dla elektroda

    Wymień po kolei tranzystory, a potem scalaki, może któryś jest padnięty

  • #14 27 Sie 2006 22:33
    bloktech
    Poziom 9  

    Chyba masz racje będę wymieniał pokolei. Wiem, że tranzystorki są na 100% pewne sprawdzałem. Ale według ciebie który scalak padł. Wszystkie kupiłem w sklepie nowe, nieużywane i jeszcze do tego przy programowaniu (jeśli oczywiście wyłączę korekcję błędów) to na każdej nodze procka jest jakiś przebieg na oscyloskopie więc nie wiem już czy może by jakiś scalak uwalony:( Co wy na to? Jak myślicie może ja się mylę

  • #15 28 Sie 2006 10:28
    McRancor
    VIP Zasłużony dla elektroda

    Możesz jeszcze pokombinować z ustawieniami LPT w biosie, jeśli tego nie zrobiłeś, ale podejrzewam że masz gdzieś po prostu zwarcie na płytce. Jakim kablem łączysz to ustrojstwo z kompem? Może masz wlutowaną wtyczkę nieodpowiedniej płci

  • #16 28 Sie 2006 10:38
    bloktech
    Poziom 9  

    Łącze zwykłym kablem z drukarki, wtyczka chyba dobra bo do komputera wchodzi:] Narpiew mialem 1,5m ale wyczytałem, że może by on za długi i skróciłem na 15cm:) i to samo. Na płytce nie ma na 100% błedu ani jakiegoś zwarcia sprawdzałem 100 razy i nic nie znalazłem niestety. A co do ustawień portu LPT to robiłem to na laptopie 150MHz IBM i tam nie widzę jakiegoś zaawansowanego BIOSu tak jak w normalnych kopach. BIOS w nim jest bardzo prościutki - podstawowe funkcje żadnych ustawień portu. A co wy na te przebiegi powiecie mogą tam by jakieś scalaki uwealone? Pozdrawiam

  • #17 28 Sie 2006 11:03
    McRancor
    VIP Zasłużony dla elektroda

    Na laptopie może progat nie działać wcale, bo bywa że jest tam port 3Voltowy, na moim laptoku nie chodziło kilka programatorów, sprawdzaj na stacjonarnym PC

  • #18 28 Sie 2006 11:07
    sp4msu
    Poziom 20  

    Z tą wymianą to pomysł nie do końca dobry , bo może sie okazać że podstawisz wszystko na nowo i nic się nie zmieni .Nic nie piszesz czy i jaka to płytka , czy robiłeś sam , czy Kit , Scalaki jeśli juz będziesz podstawiał a nie ma podstawek to je zamontuj . Nie wiadomo tez czy
    Port LPT jest dobrze ustawiony ( u mnie standardowo ) . Albo zmień 89C na 89S i programowanie ISP , dużo mniej kłopotliwe . Pozdrawiam .

  • #19 29 Sie 2006 10:46
    bloktech
    Poziom 9  

    Próbowałem też na stacjonarnym i to samo. Port ustawiony standardowo (normal) schemat mam z elektrody, płytka uniwersalna ale gwarantuje, że nie ma ani jednego małego błędu. Płytkę sprawdzało kilka osób ze schematem i nic nikt nie znalazł. A z tym 89s52 to jak to jest jak się je programuje?

  • #20 29 Sie 2006 11:37
    john_t
    Poziom 29  

    Zrobiłem ten programator. Płytkę zrobiłem sam (ręczny lapitograf bo miało być to szybko i prosto). Programator działa bez zarzutu. Zasilam go zewnętrznym napięciem. Długość kabla do kompa to 2 metry. Programuję z laptopa z systemem XP. To bardzo proste urządzenie. Wg. mnie musisz mieć jakiś błąd na płytce lub w połączeniu kabelków do LPT.

  • #22 31 Sie 2006 10:08
    bloktech
    Poziom 9  

    Dziękuję za bardzo fajny i prosty schemacik. A jeszcze jedno pytanko mogę w tym programatorze 89s52 użyc zamiast układu 74lvc244 układu 74hct244?

  • #23 31 Sie 2006 10:25
    sp4msu
    Poziom 20  

    bloktech napisał:
    Dziękuję za bardzo fajny i prosty schemacik. A jeszcze jedno pytanko mogę w tym programatorze 89s52 użyc zamiast układu 74lvc244 układu 74hct244?

    Tak możesz , powodzenie w programowaniu .
    Pozdrawiam .

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME