Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Długi czas uruchamiania komputera...

mdst 06 Wrz 2006 18:53 5510 17
  • #1 06 Wrz 2006 18:53
    mdst
    Poziom 10  

    Witam
    od pewnego czasu mam spory problem z uruchamianiem xp'ka. najpierw jakieś pół minuty leci ekran z przelatującym paskiem, a potem jeszcze jakąś minute mam czarny ekran - dopiero po tym czasie pojawia sie ekran logowania. Mam pentium d 2,8 ghz i 1mb ramu. Wczesniej tego problemu w ogóle nie było - komp ładował sie może z 10 sekund. Aha - to samo było po formacie dysku więc to prawdopodobnie nie jest spowodowane software'em. niedawno wyłączyłem prefetch ale dużo to nie dało. Może ktoś wie czym to może być spowodowane?

    0 17
  • #2 06 Wrz 2006 18:58
    Poliken
    Poziom 14  

    A zmieniales ostatnio jakies sterowniki - na nowsze?
    Uzywasz progamu antwirusiwego?
    Czy formatowales jedyna partycje na komputerz, czy masz jeszcze inne?

    0
  • #3 06 Wrz 2006 19:08
    mdst
    Poziom 10  

    hmm...od karty graficznej, ale problem występował już wcześniej wieć nie sądze by chodziło o to. Co do antivira tak samo teraz mam avast'a, ale wcześnej miałem avira antivir i było to samo.
    jeszcze co do partycji. komp od nowości miał jedną i nic nie zmieniałem.

    0
  • #4 06 Wrz 2006 19:54
    313846
    Użytkownik usunął konto  
  • #5 06 Wrz 2006 19:57
    paweliw
    Spec od komputerów

    Przyczyn może być wiele, np. problemy hardwaru (zła współpraca podzespołów, złe chłodzenie, niewłaściwe ustawienia w BIOS-ie, itp.), problemy oprogramowania i sterowników (duża ilość programów w autostarcie, błędy w rejestrze, złe bądź nieaktualne sterowniki, niewłaściwy typ transferu dysku itp.), problemy z robactwem ...

    Podstawowy problem to tylko 1 partycja na dysku. Zmieniłbym to jak najszybciej, tworząc małą partycję systemową (8-10 GB) a pozostałą część dysku podzieliłbym wg potrzeb. Znacznie ułatwi to zarządzanie dyskiem i ewentualne reinstalacje systemu (dane mogą być na partycjach niesystemowych)

    Zacząłbym od sprawdzenia komputera zgodnie z tym opisem https://www.elektroda.pl/rtvforum/viewtopic.php?p=2797042#2797042
    i zapoznania nas z wynikami.

    Przydałby się też log z hijackthis, zobaczymy czy Ci się jakieś robactwo nie zalęgło a przy okazji jakie programy są uruchamiane w autostarcie. Hijackthis ściągnij stąd http://www.spywarewarrior.com/uiuc/merijn/HijackThis.exe, potem uruchom program i wykonaj: "Do a system scan and save a logfile". Log wklej w treść wiadomości, nie jako załącznik.

    Wiele można przyspieszyć system poprzez zastosowanie porad np. z artykułów
    Optymalizacja i odchudzanie XP, Oraz tips'n'tricks'n'fix http://www.searchengines.pl/phpbb203/index.php?showtopic=5989
    Services - Usługi w XP, Które wyłączyć ?http://www.searchengines.pl/phpbb203/index.php?showtopic=7723

    0
  • #6 06 Wrz 2006 20:08
    mdst
    Poziom 10  

    michna3 napisał:
    Niestety, ale 1 mb (megabit) RAMU to za malo na xp i dziwne ze wogole ci sie uruchamia komputer.

    A tak na serio
    Defragmentowales dysk???
    Ile masz zajetego ramu po pelnym uruchomieniu komputera???


    tak, robiłem niedawno defragmenta, a po pełnym uruchomieniu mam zajęte jakieś 400 mb

    Dodano po 1 [minuty]:

    Logfile of HijackThis v1.99.1
    Scan saved at 20:00:48, on 2006-09-06
    Platform: Windows XP SP2 (WinNT 5.01.2600)
    MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

    Running processes:
    C:\WINDOWS\System32\smss.exe
    C:\WINDOWS\system32\winlogon.exe
    C:\WINDOWS\system32\services.exe
    C:\WINDOWS\system32\lsass.exe
    C:\WINDOWS\system32\svchost.exe
    C:\WINDOWS\System32\svchost.exe
    C:\WINDOWS\system32\ZoneLabs\vsmon.exe
    C:\WINDOWS\explorer.exe
    C:\WINDOWS\system32\spoolsv.exe
    C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe
    C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
    C:\WINDOWS\system32\RunDLL32.exe
    C:\Program Files\QuickTime\qttask.exe
    C:\WINDOWS\RTHDCPL.EXE
    C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe
    C:\Program Files\Alwil Software\Avast4\ashServ.exe
    C:\Program Files\Gadu-Gadu\gg.exe
    C:\WINDOWS\system32\ctfmon.exe
    C:\WINDOWS\Resources\Themes\DameK UltraBlue\Desktop Sidebar\sidebar.exe
    C:\Program Files\Skype\Phone\Skype.exe
    C:\Program Files\Messenger\msmsgs.exe
    C:\WINDOWS\Resources\Themes\DameK UltraBlue\Desktop Sidebar\sidebar.exe
    C:\Program Files\Kalendarz XP\Kalendarz.exe
    C:\WINDOWS\eHome\ehSched.exe
    C:\Program Files\Pinnacle\MediaServer\Microsoft SQL Server\MSSQL$PINNACLESYS\Binn\sqlservr.exe
    C:\WINDOWS\system32\nvsvc32.exe
    C:\Program Files\Alcohol Soft\Alcohol 120\StarWind\StarWindService.exe
    C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe
    C:\Program Files\Alwil Software\Avast4\ashWebSv.exe
    C:\Program Files\Windows Media Player\wmplayer.exe
    C:\Program Files\Mozilla Firefox\firefox.exe
    C:\WINDOWS\system32\svchost.exe
    C:\Program Files\Alcohol Soft\Alcohol 120\Alcohol.exe
    C:\Documents and Settings\Kasper the Master\Desktop\HijackThis.exe

    F2 - REG:system.ini: Shell=explorer.exe
    O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 7.0\ActiveX\AcroIEHelper.dll
    O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
    O4 - HKLM\..\Run: [Alcmtr] ALCMTR.EXE
    O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
    O4 - HKLM\..\Run: [NvMediaCenter] RunDLL32.exe NvMCTray.dll,NvTaskbarInit
    O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime
    O4 - HKLM\..\Run: [RTHDCPL] RTHDCPL.EXE




    O4 - HKLM\..\Run: [Zone Labs Client] "C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe"
    O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup
    O4 - HKLM\..\Run: [MSConfig] C:\WINDOWS\PCHealth\HelpCtr\Binaries\MSConfig.exe /auto
    O4 - HKCU\..\Run: [Gadu-Gadu] "C:\Program Files\Gadu-Gadu\gg.exe" /tray
    O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
    O4 - HKCU\..\Run: [SIDEBAR] "C:\WINDOWS\Resources\Themes\DameK UltraBlue\Desktop Sidebar\sidebar.exe"
    O4 - HKCU\..\Run: [Skype] "C:\Program Files\Skype\Phone\Skype.exe" /nosplash /minimized
    O4 - HKCU\..\Run: [MSMSGS] "C:\Program Files\Messenger\msmsgs.exe" /background
    O4 - Startup: Desktop Sidebar (2).lnk = C:\WINDOWS\Resources\Themes\DameK UltraBlue\Desktop Sidebar\sidebar.exe
    O4 - Startup: Skrót do Kalendarz.lnk = C:\Program Files\Kalendarz XP\Kalendarz.exe
    O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
    O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
    O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O16 - DPF: {1D6711C8-7154-40BB-8380-3DEA45B69CBF} (Web P2P Installer) -
    O23 - Service: Adobe LM Service - Unknown owner - C:\Program Files\Common Files\Adobe Systems Shared\Service\Adobelmsvc.exe
    O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - Unknown owner - C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe
    O23 - Service: avast! Antivirus - Unknown owner - C:\Program Files\Alwil Software\Avast4\ashServ.exe
    O23 - Service: avast! Web Scanner - Unknown owner - C:\Program Files\Alwil Software\Avast4\ashWebSv.exe" /service (file missing)
    O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriverT.exe
    O23 - Service: Pinnacle Systems Media Service (PinnacleSys.MediaServer) - Pinnacle Systems - c:\program files\pinnacle\shared files\programs\mediaserver\pmshost.exe
    O23 - Service: Pml Driver HPZ12 - HP - C:\WINDOWS\system32\HPZipm12.exe
    O23 - Service: TrueVector Internet Monitor (vsmon) - Zone Labs, LLC - C:\WINDOWS\system32\ZoneLabs\vsmon.exe

    Dodano po 3 [minuty]:

    robiłem już sporo tego typu rzeczy - praktycznie codziennie skanuje rejestr registry mechanic'iem, zbędne usługi tez wyłączałem. co do partycji to może i powinienem sobie ustawić, ale nie sądze żeby to była przyczyna - nic nie zmieniałem a przecież wcześniej nie było problemów.

    0
  • #7 06 Wrz 2006 20:21
    timo66
    Poziom 23  

    witam
    Dlaczego tylko stan wstrzymania ,jak mozna by bylo w stan hibernacji(komp sie wylancza duzo szybciej,w moim przypadku z ponad 40s na 13s)a zasilanie mozna odlaczyc poniewarz jest robiony skan pamieci ram i ustawienia otwartych programo pozostaja tak samo jak przy stanie wstrzymania,wada tej poeracji jest potrzebna pamiec na dysku ok 500MB (ale to niejest znowu chyba nie jest az tak duzo)
    1 mb ramu to stanowczo za malo (do normalnej pracy xp zalecane jest 256MB ,chociaz sam mialem przez ponad 2 lata tylko 128MB i tez chodzilo)
    mozna jeszcze uruchomic "program" narzedzia konfiguracji systemu za pomoca komendy "msconfig.exe" i w zakladce URUCHAMIAIE odznaczyc niepotrzebne programy (niektore programy sa uruchmiane przy starcie komputera sa "niewidoczne" z spowalniaja system ,i tam skutecznie mozna je wylaczyc)

    0
  • #8 06 Wrz 2006 20:27
    mdst
    Poziom 10  

    timo66 napisał:
    witam
    Dlaczego tylko stan wstrzymania ,jak mozna by bylo w stan
    1 mb ramu to stanowczo za malo

    kurcze, darujecie sobie z tym ramem??:P wiadomo że chodzi o 1 gb. hibernacja nic nie rozwiązuje- wiadomo że sie szybciej wyłącza ale ja chce mieć normalnie uruchamiający sie komp;/

    Dodano po 1 [minuty]:

    w msconfigu też już ustawiałem

    0
  • #9 06 Wrz 2006 20:34
    paweliw
    Spec od komputerów

    Fix w hijackthis:
    O16 - DPF: {1D6711C8-7154-40BB-8380-3DEA45B69CBF} (Web P2P Installer) -

    Usunąłbym też (przynajmniej na czas sprawdzenia, najpierw wyłączając oba procesy sidebar.exe):
    O4 - HKCU\..\Run: [SIDEBAR] "C:\WINDOWS\Resources\Themes\DameK UltraBlue\Desktop Sidebar\sidebar.exe"
    O4 - Startup: Desktop Sidebar (2).lnk = C:\WINDOWS\Resources\Themes\DameK UltraBlue\Desktop Sidebar\sidebar.exe

    Masz ponado wiele programów uruchamianych przy starcie systemu, zupełnie zbędnych w tym momencie i obciążających dodatkowo system (O4 w logu), zastanów się czy Ci wszystkie potrzebne (zawsze można je włączyć) np:.
    O4 - HKLM\..\Run: [Alcmtr] ALCMTR.EXE
    O4 - HKLM\..\Run: [NvMediaCenter] RunDLL32.exe NvMCTray.dll,NvTaskbarInit
    O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime
    O4 - HKLM\..\Run: [RTHDCPL] RTHDCPL.EXE
    O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup
    O4 - HKLM\..\Run: [MSConfig] C:\WINDOWS\PCHealth\HelpCtr\Binaries\MSConfig.exe /auto
    O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
    O4 - HKCU\..\Run: [MSMSGS] "C:\Program Files\Messenger\msmsgs.exe" /background

    0
  • #10 06 Wrz 2006 22:04
    mdst
    Poziom 10  

    hmm, sidebar jest w porządku, a większośc tych programów jest mi potrzebnych;/. poza tym już wcześniej wspominałem, że problem występował też świeżo po formacie więć raczej nie chodzi o programy.

    Dodano po 1 [godziny] 24 [minuty]:

    zresetowałem przed chwilą kompa i jest troche szybciej (dużo nie zmieniałem - wyłączyłem wyszukiwanie slave'ów, których nie mam- teraz przynajmniej czarny ekran trwał jakies 10 sekund)

    0
  • #11 06 Wrz 2006 22:18
    jannaszek
    Poziom 39  

    przecierz nikt ci nie mówi że masz zrezygnować z podanych programów czy usług-ale nie muszą startować wszystkie z startem systemu?-przecież to zamula uruchamianie,tak samo zapchany pulpit skrutami tapetami itp -włącz w panelu /system/zaawansowane>wydajność /zaawansowane >ustawiienia zaznacz:dopasuj do uzyskania najlepszej wydajności

    0
  • #12 06 Wrz 2006 23:10
    paweliw
    Spec od komputerów

    mdst napisał:
    hmm, sidebar jest w porządku, a większośc tych programów jest mi potrzebnych

    Jasne, jest Ci potrzebnych (szczególnie przy starcie):
    O4 - HKLM\..\Run: [Alcmtr] ALCMTR.EXE <- moduł Zdarzeń Realteka notabene uważany za Spyware http://www.bleepingcomputer.com/startups/ALCMTR.EXE-240.html - zupełnie zbędny, wręcz szkodliwy !

    O4 - HKLM\..\Run: [NvMediaCenter] RunDLL32.exe NvMCTray.dll,NvTaskbarInit <- "odpalenie" menadżera ustawień karty graficznej NVidii, w 99% zbędne http://www.bleepingcomputer.com/startups/RunDLL32.exe_NvMCTray.dll_NvTaskbarInit-4644.html

    O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime <- uruchomienie "agenta" Quick Time - cały czas odpalasz aplikacje w tym programie - 100% zbędne http://www.bleepingcomputer.com/startups/QuickTime_Task-4341.html

    O4 - HKLM\..\Run: [RTHDCPL] RTHDCPL.EXE <- Realtek HD Audio Sound Effect Manager - cały czas zmieniasz ustawienia dźwięku - 100 % zbędne http://www.bleepingcomputer.com/startups/RTHDCPL.EXE-13554.html

    O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup <- inicjalizacja ustawień zegara i pamięci dla przetaktowywanych kart graficznych NVidii - 99 % zbędne http://www.bleepingcomputer.com/startups/NvCplDaemon-3809.html

    O4 - HKLM\..\Run: [MSConfig] C:\WINDOWS\PCHealth\HelpCtr\Binaries\MSConfig.exe /auto <- zbędne uruchamianie msconfig przy każdym starcie systemu http://www.bleepingcomputer.com/startups/msconfig.exe-3313.html

    O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe <- uruchamianie dodatkowych opcji językowych dla Office XP - 99 % zbędne http://www.bleepingcomputer.com/startups/ctfmon.exe-1121.html

    O4 - HKCU\..\Run: [MSMSGS] "C:\Program Files\Messenger\msmsgs.exe" /background <- uruchamianie MS messenger, rzadko kto tego używa http://www.bleepingcomputer.com/startups/msmsgs.exe-3386.html

    Rozbrajają mnie ludzie, którzy nie wiedząc do czego jest dany wpis w autostarcie (z lenistwa nie chce się im tego sprawdzić) twierdzą, że jest on im potrzebny.
    Większość "spraw" załatwia sterownik urządzenia, programy dodatkowe to tylko zbędne obciążenie systemu, jak są używane raz na kilkadziesiąt uruchomień to dużo ...
    Każdy program uruchamiany w autostarcie to dłuższy start komputera, to chyba logiczne ...

    0
  • #13 06 Wrz 2006 23:50
    mskalski
    Poziom 13  

    Kilka lat (ze 2) temu miałem podobny objaw na Win98 jeszcze, nie wiem, czy ten problem występuje na XP czy też 2000. Przyczyną długiego czasu "nic nie robienia" podczas startu (widać już było klepsydrę) był nieustawiony adres IP karty sieciowej, a jak wiadomo jeśli nie jest ustawiony na sztywno, to Windows próbuje go uzyskać przy pomocy DHCP. Jeśli nie ma żadnego serwera DHCP w sieci lub co gorsza nie jest podpięty w ogóle kabel, to czas oczekiwania na odpowiedź od nieistniejącego serwera jest rzędu 30 sekund (domyślny timeout dla operacji sieciowych).

    Wiem, że XP startuje większość sterowników równocześnie, więc to może go nie dotyczyć, ale na wszelki wypadek dobrze ten numer ustawić na stałe (jeśli nie ma serwera DHCP w sieci), albo jeszcze lepiej wyłączyć kartę sieciową (jeśli sieć w ogóle nie jest używana). Oczywiście zmiana nie ma sensu, jeśli CHCESZ wykorzystać serwer DHCP do konfiguracji karty sieciowej.

    0
  • #14 07 Wrz 2006 09:53
    Anonymous
    Użytkownik usunął konto  
  • #15 07 Wrz 2006 11:04
    paweliw
    Spec od komputerów

    tjanusz :arrow:

    Widzę, że nie czytasz co piszą poprzednicy (link w poście też do tego należy !).
    W pierwszym swoim poście w tym temacie dokładnie o to samo prosiłem mdst.
    Niestety, wyników nie podał do chwili obecnej.

    I jak tu komuś pomóc jak sam tego nie chce ...

    0
  • #16 07 Wrz 2006 11:30
    Anonymous
    Użytkownik usunął konto  
  • #17 07 Wrz 2006 12:56
    paweliw
    Spec od komputerów

    tjanusz napisał:
    (przeczytaj w slowniku co po polsku oznacza "post")

    Termin post stosowany głównie na forach internetowych pochodzi z języka angielskiego - co oznacza poszukaj sobie w słowniku.
    Słowo to jest już tak zakorzenione w internecie, że chyba nie ma najmniejszego sensu wymyślać do tego polskiego odpowiednika, typu "list". Chociaż może i jest, ale nie mnie to oceniać ...

    tjanusz napisał:
    Ja natomiast podalem przyczyny które moga spowodować problem opisany przez założyciela tego tematu. Sam przez to przeszedłem i nie widzę powodów by nie podzielic się swoimi spostrzeżeniami.

    Bardzo dobrze, że podałeś, tylko że wcześniej podałem link wskazujący co i jak ma sprawdzić w komputerze. Po to są tworzone tematy przyklejone aby aby z nich korzystać a nie za każdym razem pisać to samo.
    Twoje porady aby sprawdzić RAM i zasilacz są więc powtórzone.
    Zostaje, więc tylko sprawdzenie dysku programem diagnostycznym producenta.

    0
  • #18 07 Wrz 2006 19:05
    mdst
    Poziom 10  

    nie miałem wczoraj za bardzo czasu żeby to wszystko sprawdzać, zrobie to teraz i poinformuje o wynikach

    Dodano po 2 [godziny] 34 [minuty]:

    hmm...zdaje sie że jest ok, z resztą po pewnych zmianach komputer uruchamia sie w tempie, które mnie zadowala:). Dzieki wszystkim za pomoc

    0