Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Problem z HDD Samsung SP0411N prawdopodobnie układu HA13627

RADKON 28 Feb 2007 17:53 4167 5
  • #1
    RADKON
    Level 12  
    Witam



    Problem polega na tym , że kiedy dysk zbyt długo coś ładuje , a dzieje się tak czasami przy sprawdzaniu dysku lub kiedy w danym czasie jakiś program wykonuje zadanie.
    Bądź też mam uruchomioną jakąś grę czyli dokładnie wtedy kiedy pozycjoner jest w ciągłym ruchu to w danym momencie dysk się sam wyłancza, ale na krótką chwilę.
    Czyli silnik dynamicznie zwalnia, ale nie do końca , a pozycjoner przechodzi na strefę lądowania.
    Następnie znów wraca do poprzedniego stanu i cały ten proces trwa zaledwie chwilkę i powtarza się kilkakrotnie aż do momentu kiedy pozycjoner skończy czytać dany obszar nośnika.
    Zatrzyma się jednak czasami zdarza się, że uruchamianie systemu przebiega bez żadnych zakłuceń.
    Podobnie tak jak uruchamianie programów lub gier dlatego trudno stwierdzić co naprawdę ma wpływ na wyłanczanie się dysku.
    Czy jest to zbyt wysoka temperatura układu sterującego napędem i pozycjonerem dysku powodująca przemęczenie się układu podczas gdy pozycjoner oscyluje nad czytanym obszarem nośnika.
    Wiadomo zato , że układ HA13627 musi sprostać obciążeniom jakie wymuszają na nim silnik i pozycjoner ale nie powinno to zachwiać stabilnej pracy układu bo przecież takie układy produkowane są z myślą o ciągłej nieprzerwanej pracy, której nic nie ma prawa zakłucić no, ale mogę się mylić co do tego.
    W moim przypadku to ja zarządzam kiedy dysk ma przejść w stan st-by lub kiedy należy go wyłączyć bo tak jest skonfigurowany mój komputer. Natomiast na to , że dysk wyłancza się bez powodu to na to nie mam wpływu. Przyczyna musi leżeć po stronie firmwara lub innej rzeczy.
    Więc kiedy dochodzi do tych rozruchów w dysku to nie pomaga nawet restart kompa z pozycji softu bo jest to raczej niemożliwe kiedy każdy mocny ruch pozycjonera powoduje dalsze wyłanczanie się dysku i uszkodzenia systemu.
    Właśnie przez to już 3 razy robiłem repair systemu i 2 razy instalowałem go na nowo w ciągu miesiąca i nic nie pomaga nawet format.
    Sprawdziłem go nawet programikiem HD Tune i jest czysty nie ma żadnych badów na nośniku dlatego podejrzewam firmware, a najbardziej ten układ HA13627.
    Jedyne co pomaga , że dysk mi jeszcze działa to ostry restart kompa czyli z listwy w momencie kiedy dostaje tych rozruchów następnie odłączenie zasilania od dysku i uruchomienie komputera bez podłączania zasilania dla dysku, a później ponowny restart, ale tym razem przy podpiętym zasilaniu i komp działa bez problemu.
    Robi scandiska i ładuje programy nawet przy dużym obciążeniu kiedy dysk ma do wykonania wiele zadań ale po jakimś czasie sytuacja się powtarza.
    Dysk znów dostaje rozruchów i trzeba powtarzać procedurę od nowa bo przy samym restarcie sytuacja pogarsza się zaraz przy bootowaniu.
    Dysk dostaje takiego napadu , że nawet drobne mrugnięcie diody rejestrującej każdy ruch pozycjonera powoduje dalsze rozruchy, ale tym razem występują one regularnie i przez to system nie chce odpalić.
    Więc jeśli ktoś z forumowiczów wie gdzie w necie można znaleźć firmwara do tego dysku lub pdf-a do układu HA13627 niech wrzuci tutaj linki do stronek lub podeśle mi na maila : radcon(malpa)wp.pl będe bardzo wdzięczny. Być może jest to jedyny najtańszy sposób ażeby naprawić ten dysk bo jak narazie wstrzymuję się z kupnem nowej elektroniki.
    Poniżej dołączam jeszcze log ze smarta :

    [ SAMSUNG SP0411N (S01JJ20WA56944) ]

    01 Raw Read Error Rate 51 100 100 0 OK: wartość w normie
    03 Spin Up Time 0 72 36 4992 OK: zawsze pozytywnie
    04 Start/Stop Count 0 92 92 8798 OK: zawsze pozytywnie
    05 Reallocated Sector Count 10 253 253 0 OK: wartość w normie
    07 Seek Error Rate 51 253 253 0 OK: wartość w normie
    08 Seek Time Performance 0 253 253 0 OK: zawsze pozytywnie
    09 Power-On Time Count 0 98 98 1750631 OK: zawsze pozytywnie
    0A Spin Retry Count 49 253 253 0 OK: wartość w normie
    0C Power Cycle Count 0 95 95 5940 OK: zawsze pozytywnie
    C2 Temperature 0 172 73 22 OK: zawsze pozytywnie
    C3 Hardware ECC Recovered 0 100 100 126762061 OK: zawsze pozytywnie
    C4 Reallocation Event Count 0 100 100 1 OK: zawsze pozytywnie
    C5 Current Pending Sector Count 10 253 253 0 OK: wartość w normie
    C6 Off-Line Uncorrectable Sector Count 10 100 100 1 OK: wartość w normie
    C7 Ultra ATA CRC Error Rate 51 100 100 2 OK: wartość w normie
    C8 Write Error Rate 51 100 100 0 OK: wartość w normie
    C9 <specyficzne dla dostawcy> 51 100 100 0 OK: wartość w normie
    [28-30.06.2022, targi] PowerUP EXPO 2022 - zasilanie w elektronice. Zarejestruj się za darmo
  • #3
    RADKON
    Level 12  
    Heh to , że datasheetarchive jest największą bazą aplikacji podzespołów elektronicznych to i ja to wiem i też tam szukałem , a co do pozostałych stronek to niestety ale się nie doczytam tego co tam pisze po rusku ale i tak dzięki za pomoc. A i co do temperatury układu to trudno powiedzieć jaka jest przy normalnej pracy dysku , a jaka kiedy jest zajęty ale z EVERESTA wyczytałem , że przy normalnej pracy ma zazwyczaj od 22 do 24°C , a kiedy jest zajęty i pozycjoner pracuje naprawdę długo to dochodzi do 30°C lub czasami przekracza o 1° ale nie wiem czy on rejestruje temperaturę tego układu czy całego dysku. Tak czy inaczej dysk dostaje napadów nawet jak go uruchomię po długiej przerwie i nie ze wzgledu na temperaturę , która wynosi wtedy zaledwie 17°C tylko na rozruchy , które pojawiły się nagle dzień wcześniej po uruchomieniu jakiegoś programu lub gry czegokolwiek i zmusiły mnie do ostrego zrestartowania kompa. Ja nie wiem ale podejrzewam , że dysk poprostu zapisuje , że jeśli rozruchy wystąpiły przy wyłączeniu to pojawią się przy włączeniu komputera i wtedy pomaga tylko to co pisałem w powyższym poście czyli w skrócie krótkie spięcie :D
    Może ma ktoś jeszcze jakieś pomysły co z tym dalej robić bo liczyłem bardziej na pdfa do tego układu lub firmwara ale widzę , że ciężko to znaleźć w sieci.
  • #4
    zorg666
    Level 22  
    Jak mogłeś liczyć na firmware jeśli nie podałeś typu, modelu dysku i wszystkiego co na naklejce napisane.
    Parametry SMART to na C6 posiada jeden sektor do realokacji, tylko gdzie on jest ?
    Jak ten sektor jest na początku to i masz takie siupy z tym dyskiem.
    Zastosuj program Victoria w wersji 4.2 API i zrób testy czasu dostępu do sektorów.
  • #5
    RADKON
    Level 12  
    Podałem przecież model dysku w temacie ale dobra podam jeszcze dane z tego programiku więc :

    Model : SAMSUNG SP0411N
    Firmware : TW100-08
    Serial : S01JJ20WA56944
    Disk size : 78242976 LBAs 38204 Mb
    **Real : 186799388560289 LBAs 91210638945 Mb
    CHS : 16383/16/63 8063 Mb
    SMART : Enabled, Errlog, Selftest
    CACHE : 2048k; L/A=ON; WR=ON; ok
    Support : LBA, HPA, AAM, DLM, DMA UDMA-5
    AAM val : 0 Disabled
    Erase : ~24 minutes
    Status : Passed
    Spindle : Active
    Security : OFF

    Mam nadzieję , że to wystarczy bo dokładniej już nie można było tego ująć zresztą tu jest więcej danych niż na samej nalepce :D
    Co do testów to wypadły tak czas dostępu do sektorów wachał się pomiędzy 13,0ms , a 15,0ms minimalna odnotowana szybkość to 12,8ms , a maxymalna 16,0ms temperatura podczas testu wynosiła od 26°C do nawet 40°C i pewnie by dalej rosła gdybym nie przerwał. Przy sprawdzaniu sektorów wykrył 1 uszkodzony blok 1616896 Error : IDNF czyli mam rozumieć , że to to powoduje te rozruchy ?
  • #6
    RADKON
    Level 12  
    Witam problem rozwiązany :D
    Przycznyą takiego zachowania się dysku był padający zasilacz i z czasem zaczęło to też dotykać płyty głównej oraz reszty sprzętu ale na szczęście w pore wymieniłem na nowy bo pewnie poszedłby cały sprzęt :twisted:
    Teraz mam ATX 420W Akyga , poprzedni to był Megabajt 350W straszne badziewie :evil: a to dlatego bo gdzieś w necie przeczytałem wypowiedzi forumowiczów na temat tych zasilaczy i podobno palą one kompy 8-O
    Objawy jakie występowały u mnie podczas używania Megabajta to : blue screeny , restarty kompa , zwisy , chwilowe przerwy w zasilaniu dysku podczas jego pracy , stacja dyskietek miała czasami problemy z odczytem danych podobnie z pozostałymi napędami.
    Błędy i uszkodzenia to : bad sektory , błędy w modułach ram , zwalona partycja systemowa , częste przerwy w zasilaniu dysku podczas jego pracy doprowadzały do tego , że uszkadzał się plik system na począdku tak , że powodowało to przycinanie się myszy , a z czasem też dźwięku i grafiki.
    Im więcej takich przerw tym coraz to wolniej szło uruchamianie systemu i programów gdzie w ostateczności doprowadzało to do całkowitego uszkodzenia tego pliku dlatego zawsze robiłem kopię zapasową :)
    Nie wiem dlaczego nie wziąłem sobie tego na poważnie ale teraz żałuję , że nie wymieniłem wcześniej tego zasilacza uniknął bym tych błędów , a tak mam teraz bady na dysku :|
    Temat uważam za zamknięty.