Elektroda.pl
Elektroda.pl
X
Elektroda.pl
PCIM Europe 2019
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zwiększanie się napięcia na zasilaczu stabilizowanym

mpn103 30 Mar 2007 03:18 4824 31
  • #1 30 Mar 2007 03:18
    mpn103
    Poziom 34  

    Witam.
    Posiadam od pewnego czasu zasilacz własnej roboty.
    Wcześniej jako końcówka mocy był 6xBD911 i było wszystko ok.
    Ale pewnego czasu postanowiłem zmienić je na 6 sztuk KD502 ale zauważyłem dosyć nietypowy efekt.
    Podbijanie się napięcia. Z 13,8 volt pod obciążeniem 5A potrafi się zrobić 14,5V.
    Wiem że nie jest to dobry objaw bo urządzenia podłaczone pod stałe napięcie nie lubią za bardzo zmian i to takich skokowych.
    Co może być przyczyną?
    Napięcie wychodzące z transformatora to 16,5V~ po wystabilizowaniu ok 22V. Driver układu daje 13,8V i nie zmienia się pod obciązeniem. Zmienia się natomiat jedynie wyjściowe napięcie na stopniu końcowym.
    Czyżby stopień końcowy się wzbudzał?

    0 29
  • #2 30 Mar 2007 08:04
    irekr
    Moderator

    Może się wzbudzać albo za mała jest wydolnośc prądowa tego co steruje bazami tych KD502.
    Oddzielna sprawa to jakiego typu jest to obciążenie. Jeżeli jest to jakies urządzenie CB to po prostu pole w.cz indukuje się w zasilaniu.

    0
  • #3 30 Mar 2007 11:09
    sq6ade
    Poziom 40  

    Pytanie jak wygląda układ stabilizacji? Jak zachowuje się napięcie referencyjne i wzmacniacz błędu - to bym sprawdził.

    0
  • #4 30 Mar 2007 13:15
    mpn103
    Poziom 34  

    Witam i dziękuje za odpowiedź.
    Układ zbudowałem na podstawie układu z Nord Elektronika NE100
    Zwiększanie się napięcia na zasilaczu stabilizowanym
    Tylko wyrzuciłem z niego układ LM324 bo zabezpieczenie prądowe nie działało tak jak potrzeba ale nie ważne.
    Jako driver jest BD911 a końcówki KD502.
    Pryz identycznym schemacie ale z końcówkami BD911 było ok.

    0
  • #5 30 Mar 2007 13:26
    sq6ade
    Poziom 40  

    Jeśli te skoki napięcia spowodowane są przez w.cz. - podłącz od wejść + i - US1A kondensatory ceramiczne ok 1n do masy. Sprawdź jak zachowuja się napięcia na tych wejściach przy wzrostach napięć zasilacza. Na tym schemacie nie ma żadnych odsprzęgnięć dla w.cz. !!

    0
  • #6 30 Mar 2007 14:42
    mpn103
    Poziom 34  

    Tylko w tym problem żę te skoki napięcia są na emiterach T4-T9. Napięcie na driverze ani na US1 nie "skacze"

    0
  • #7 30 Mar 2007 14:51
    sq6ade
    Poziom 40  

    Wepnij miliamperomierz pomiędzy emiter drajwera i bazy regulatorów - zobacz czy prąd skacze.

    0
  • #8 30 Mar 2007 16:58
    Driver-
    Poziom 38  

    Sprawdź pod obciążeniem powiedzmy 6A (obciążyć możesz samochodową żarówką 12V 65W) czy regulacja PR1 działa i czy da się ściągnąć napięcie do znamionowego 13,8 V. Jeśli się nie daje to znaczy ze któryś z KD502 jest przeciążony i puszcza prąd. Pozatym po co aż tyle tych KD502, każdy ma Ic max 20A razem to 120A moc jaką można odłożyć na jednym Ptot max 150W, ale żeby ich nie przegrzać to max moc 70-80W na dwóch 140-160W, więc zakładając że zasilacz jest bardzo twardy i napięcie po prostowniku na kondensatorach filtrujących nie spada poniżej 22V możesz pobierać z dwóch tranzystorów 17A przy obciążeniu ciągłym, oczywiście przy takim radiatorze, który odprowadzi ciepło wydzielone przy mocy strat 140W. W impulsie można w porywach szarpnąć spokojnie do 25-30A jeśli mostek prostowniczy wytrzyma. Ja już nie robie zasilaczy na tranzystorach bipolarnych, dają za duże straty w zasilaczu i jego sprawność jest rzędu 60-70%. Przeszedłem na MOSFETy sprawność jaką osiągam to 80-90% przy prądzie do 30-50A.

    0
  • #9 30 Mar 2007 18:32
    tatronic
    Poziom 24  

    Driver- napisał:
    Pozatym po co aż tyle tych KD502, każdy ma Ic max 20A razem to 120A moc jaką można odłożyć na jednym Ptot max 150W, ale żeby ich nie przegrzać to max moc 70-80W na dwóch 140-160W, więc zakładając że zasilacz jest bardzo twardy i napięcie po prostowniku na kondensatorach filtrujących nie spada poniżej 22V możesz pobierać z dwóch tranzystorów 17A przy obciążeniu ciągłym, oczywiście przy takim radiatorze, który odprowadzi ciepło wydzielone przy mocy strat 140W. W impulsie można w porywach szarpnąć spokojnie do 25-30A .


    Mozesz mi wytlumaczyc skad sie wzielo te 17A? ( przy mocy wydzielanej na dwoch tranzystorach 140-160W).Owszem zgodze sie ze wyciagniesz 17A ale to przy mocy wydzielanej na pojedynczym tranzystorze w granicach 130W czyli na dwoch 260W.Pozdrawiam Arek

    0
  • #10 30 Mar 2007 22:09
    mpn103
    Poziom 34  

    Wracając do tematu.
    Wkurzyłem się i wywaliłem cały ten układ stabilizatora na lm358 i driverze.
    Wsadziłem zamiast tego stabilizator KA7812 i dołożyłem pomiędzy masę napięcia a masę stabilizatora rezystor 470Ω i uzyskałem na wyjściu 13,5V.
    Narazie starczy, napięcie się już nie podbija ale są nieznaczne spadki przy większej mocy nadawania których nie było na poprzednim układzie.
    Znacie może jakiś dobry schemat stabilizatora na którym nie było by tych spadków?
    Trafo mam 500W/~16,5V,
    Mostek 50A,
    6xKD502

    0
  • #11 30 Mar 2007 22:30
    SP5IT
    VIP Zasłużony dla elektroda

    Napięcie na stabilizatorze lepiej jest obniżać niż podnosić.
    Najprostszy: http://www.pcs-electronics.com/schematics/usm3.jpg

    Ja robiłem na LM317 i BD250C.
    20A jak drut, tranzystor na radiatorze z wiatrakiem.
    Możesz użyć KD, nie zapomnij o wyrównawczych rezystorach.

    Tu masz ciekawe rozwiązanie z ograniczeniem prądu: http://www.electronics-lab.com/projects/power/028/index.html
    Tu na 741: http://ludens.cl/Electron/Ps20/Ps20.html

    Michał

    0
  • #12 30 Mar 2007 23:04
    mpn103
    Poziom 34  

    A jak można obniżyć napięcie na stabilizatorze?

    0
  • #13 30 Mar 2007 23:32
    SP5IT
    VIP Zasłużony dla elektroda

    Heh na 78** nie obniżysz :)
    M.

    0
  • #14 31 Mar 2007 00:07
    mpn103
    Poziom 34  

    Już sobie poradziłem :)
    Dałem jeszcze kondensatorki po 100n na stabilizator i się uspokoiło spadanie napięcia :)

    0
  • #15 31 Mar 2007 01:34
    Driver-
    Poziom 38  

    tatronic napisał:
    Driver- napisał:
    Pozatym po co aż tyle tych KD502, każdy ma Ic max 20A razem to 120A moc jaką można odłożyć na jednym Ptot max 150W, ale żeby ich nie przegrzać to max moc 70-80W na dwóch 140-160W, więc zakładając że zasilacz jest bardzo twardy i napięcie po prostowniku na kondensatorach filtrujących nie spada poniżej 22V możesz pobierać z dwóch tranzystorów 17A przy obciążeniu ciągłym, oczywiście przy takim radiatorze, który odprowadzi ciepło wydzielone przy mocy strat 140W. W impulsie można w porywach szarpnąć spokojnie do 25-30A .


    Mozesz mi wytlumaczyc skad sie wzielo te 17A? ( przy mocy wydzielanej na dwoch tranzystorach 140-160W).Owszem zgodze sie ze wyciagniesz 17A ale to przy mocy wydzielanej na pojedynczym tranzystorze w granicach 130W czyli na dwoch 260W.Pozdrawiam Arek

    Już ci odpowiadam na kondensatorach wygładzających masz 22 V na wyjściu zasilacza 13,8 spadek napięcia na tranzystorach wykonawczych wynosi 8,2 V zakładając że aby nie przegrzać tranzystorów na każdym jest po 70W razem 140 W więc 140/8,2=17.0732 A. Na obcieżeniu możesz odebrać 235,61 W mocy ciągłej, przy mocy doprowadzonej 375,61 W sprawność zasilacza 62,8%.

    0
  • #16 31 Mar 2007 10:37
    Driver-
    Poziom 38  

    mpn103 napisał:

    Znacie może jakiś dobry schemat stabilizatora na którym nie było by tych spadków?
    Trafo mam 500W/~16,5V,
    Mostek 50A,
    6xKD502
    Znacie i macie. W załączniku jest schemat zasilacza do 50A 12-13,8V a zabezbieczeniami napieciowym, przekroczenia prądu szczytowego i łagodnym startem. Tętnienia na wyjściu są na poziomie szumów własnych zasilacza sprawność 87%. Odradzam stosowania mostka 50A po jakimś czasie, przy poborze dużego prądu mostek pada ponieważ nie jest zdolny odprowadzić ciepła ze strukrury diod, odpalają się też końcówki. Jeśli będziesz miał pytania odnośnie szczegółów wyślij na PW.

    0
  • #17 31 Mar 2007 11:08
    sq6ade
    Poziom 40  

    Przy takiej sprawności to chyba jakaś impulsówka - nie możesz zdjąć haraczu za schemat?

    0
  • #18 31 Mar 2007 11:20
    Driver-
    Poziom 38  

    To nie impulsówka tylko mosfety i odpowiednie ustawienie napięcia na kodensatorach wygładzajacych daje taką sprawność. Straty na tranzystorach wykonawczych przy 50A wynoszą 100W. Zasilacz jest mojego projektu. Wykonałem parę sztuk dla kolegów w różnych wersjach prądowych chodzą do dzisiaj. Jeszcze jedna uwaga, zasilacz przy włączaniu pod obciażeniem, lub gdy na wyjściu w momencie włączenia jest zawarcie, oddaje prąd około 1-2,5 A. Włączyć go można tylko przy braku obciążenia.

    0
  • #19 09 Kwi 2007 14:47
    Driver-
    Poziom 38  

    W związku z pytaniami dotyczącymi szczegółów konstrukcyjnych Tr2, zamieszczam jego rysunek poglądowy. Rdzeń Tr2 to zwinięty lub składany z odpowiednio giętych, blach transformatrotowych, można go wyciąć z jakiegoś starego rdzenia i odpowiednio ukształtować. Zasilacz można również wykonać bez zabezpieczeń.

    0
  • #20 12 Kwi 2007 08:19
    birband
    Poziom 23  

    Czasami najprostsze rozwiązania są najlepsze. I tak jak kolega ci podpowiada układ ze stabilizatorem i potencjometrem na jego masie wydaje się być najlepszym rozwiązaniem. Do tego bym dołożył przed każdym z tranzystorów opornik paro omowy do wyrównania warunków prądowych tranz. końcowych i po sprawie. Oczywiście dla poprawy warunków pracy radia należy poorządnie wyfiltrować napięcie. a i jeszcze jedno LM 324 doskonale nadają się do torów mcz (audio) ale nie widzę ich za bardzo w takich układach jak twój. W zależnmości od mocy za stabilizatorem warto wstawić tranzystor sterujący tranzystory wykonawcze. Polecam mosfety lub co się sprawdza tranzystory typu KD lub 2N3055.

    0
  • #21 13 Kwi 2007 02:18
    mpn103
    Poziom 34  

    Witam.
    Nie mam LM324 a LM358 w stabilizatorze napięcia. LM324 kiedyś wyrzuciłem bo był dla mnie zbędny. I tak teraz nie mam tego układu.
    Ale już za późno, wstawiłem stabilizator 7812 i dałem PR 1k do masy, ale teraz mi napięcie spada nie powinno, widocznie te stablizatory tak mają.
    Spróbuje z tym tranzystorem jeszcze i powiem jakie są efekty.
    Pozdrawiam.

    0
  • #22 13 Kwi 2007 12:02
    trol.six
    Poziom 31  

    Driver- napisał:
    zasilacza sprawność 87%. Odradzam stosowania mostka 50A po jakimś czasie, przy poborze dużego prądu mostek pada ponieważ nie jest zdolny odprowadzić ciepła ze strukrury diod,

    Na pewno jest to sprawność zasilacza? Czy stabilizatora przy określonych warunkach?

    50A na zwykłym mostku to coś >100W, ale i tak nieżle.

    No i ciekawe jak pracuje trafo w takich warunkach.

    Gorzej jak ktos będzie miał za duze spadki w sieci u siebie.

    0
  • #23 13 Kwi 2007 18:40
    emka371
    Poziom 19  

    Witam!
    W pierwszym poście napisałeś:

    Cytat:
    Driver układu daje 13,8V i nie zmienia się pod obciązeniem. Zmienia się natomiat jedynie wyjściowe napięcie na stopniu końcowym

    Przy założeniu napięcia 13,8 V na wyjściu zasilacza napięcie na emiterze tranzystora T3 powinno być ok. 14,5 V a na jego bazie ok. 15,2 V. Brak różnicy napięć między wyjściem zasilacza a bazami tranzystorów wykonawczych sugeruje uszkodzenie (przebicie) złączaB-E któregoś z tranzystorów. Może jest to coś ruchomego objawiającego się dopiero pod obciążeniem po zwiększeniu temperatury?
    W kolejnym poście:
    Cytat:
    Ale już za późno, wstawiłem stabilizator 7812 i dałem PR 1k do masy, ale teraz mi napięcie spada nie powinno, widocznie te stablizatory tak mają.

    Domyślam się, że wyjście stabilizatora 7812 steruje bazy tranzystorów wykonawczych (ewentualnie przez driver). Jeśli tak, to z układu zrobił się zwykły zasilacz parametryczny (taka dioda Zenera o b. dużej mocy). 7812 stabilizuje napięcie na swoim wyjściu a nie na wyjściu zasilacza. Przy zwiekszonym obciązeniu wzrasta spadek napięcia na rezystorach wyrównawczych (w emiterach tranzystorów), przy niezmienionym napięciu sterującym (na bazach tranzystorów) maleje napięcie baza-emiter, tranzystory zostaną przytkane i w konsekwencji maleje napięcie wyjściowe. Brak jest sprzężenia zwrotnego - w pierwotnym układzie napięcie proporcjonalne do wyjściowego było z dzielnika R19, PR1, R20 podawane na wejście odwracające wzmacniacza operacyjnego.
    Kolega SP5IT napisał:
    Cytat:
    Heh na 78** nie obniżysz

    Oczywiście, że można obniżyć napięcie stabilizowane. Na masę 78** należy podać napięcie ujemne względem masy układu zasilacza (z dodatkowego źródła). Ograniczeniem jest tu przede wszystkim maksymalne napięcie wejściowe 78** (mierzone względem masy 78** a nie względem masy zasilacza).
    Pozdrawiam!

    0
  • #24 14 Kwi 2007 00:33
    mpn103
    Poziom 34  

    Do kolegi emka371.
    Czy da się spowrotem wykorzystać stary układ ale tak żeby nie wzrastało napięcie?

    A w pierwszym poście bardziej mi chodziło o to że napięcie jest stałe i nie spada pod obciążeniem ani nie wzrasta.

    0
  • #25 14 Kwi 2007 06:34
    mkos1
    Poziom 29  

    Małe pytanko do kol. Driver-
    Zamieściłeś swój "superschemat" wiec teraz proszę o wytłumaczenie mi w czym on jest lepszy od zasilaczy korzystających ze standartowych tranzystorów (nie MOS) ?
    Przecież straty na nich i tak będa takie same więc grzanie się ich tez się nie zmieni ?

    0
  • #26 14 Kwi 2007 12:24
    trol.six
    Poziom 31  

    Schemat nie jest jakis super, po prostu tranzystory mos są w stanie pracowac przy małych spadkach napiecia żródło dren. Tranzystory zwykłe wchodza w stan nasycenia. I potrzebują troche wiecej tej róznicy napiecia.

    Przy mos, trzeba uważać na sterowanie, bo łatwo sie wzbudzają przez swoje pojemności.

    Jednak dorzucanie takich ilosci pojemności filtrujacych, skutkuje dużymi pradami Irms. Co zarówno przekłada sie na trafo, sieć jak i na diody prostownicze

    0
  • #27 16 Kwi 2007 16:59
    emka371
    Poziom 19  

    Do kolegi mpn103:
    Przepraszam za długie milczenie - nie zagądałem tutaj. Układ wygląda na poprawny, zresztą piszesz o poprawnym działaniu przy BD911.
    Proponuję wykonać pomiary tranzystorów - aby wykluczyć upływności któregoś, sprawdzić połączenia i ścieżki na druku i podłączyć. Bez obciążenia sprawdź możliwość regulacji napięcia wyjściowego (PR1). To samo powtórz dla kilkuamperowego obciążenia (np. żąrówka samochodowa). Pomierz (i zanotuj) napięcia na tranzystorach i wyjściu układu. Jeśli uważasz, że piszę o rzeczach oczywistych to trudno ale należy podejść do tematu w sposób uporządkowany i wykluczyć pewne rzeczy. Uszkodzenie jest raczej nietypowe.

    Przejrzałem jeszcze raz twoje posty. Mam pytanie: Jakiej wartości są rezystory wyrównawcze (R4 - R9)? Czy pomiar napięcia był wykonywany tak jak piszesz na emiterach tranzystorów wykonawczych?

    0
  • #28 16 Kwi 2007 17:52
    mpn103
    Poziom 34  

    To odrazu odpisze :)
    PR1 można regulować napięcie zarówno podczas obciążenia jak i bez. Zauważyłem także że na obciążeniu poprzez dwie żarówki 50W/12V napięcie nie wzrasta (z prawa ohma wychodzi ~7,3A), a wystarczy że podłącze radio do niego które bierze minimum 3A to się napięcie podnosi. Podnosi się wraz ze wzrostem prądu pobieranego w zasilacza.
    Nie podnosi się tylko napięcie na emiterze drivera czyli BD911 (bo taki zastosowałem do sterowania KD502.

    0
  • #29 16 Kwi 2007 19:03
    emka371
    Poziom 19  

    Ponowię pytanie. Czy napięcie było mierzone na emiterach T4 - T9, czy na wyjściu zasilacza? Jaka wartość R4 - R9?

    0
  • #30 17 Kwi 2007 02:35
    mpn103
    Poziom 34  

    Przecież wyjście zasilacza jest brane z emiterów T4 - T9... Wartość rezystorów to: 0,2Ω / 5W

    0