Elektroda.pl
Elektroda.pl
X
PCBwayPCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

K500i-Problem z komunikacją

DJF1 07 Kwi 2007 12:05 3473 46
  • #31
    MES Mariusz
    Poziom 36  
    Wylutowałeś, wyczyściłeś, przylutowałeś. Jeśli ci się udało. A skąd wiesz, że sam układ był dobry?

    Pracowałem w centrum, coś o wprawie mogę powiedzieć. Ale nie podjąłbym się wlutowywania raz już wylutowanego układu BGA.
  • PCBwayPCBway
  • #32
    DJF1
    Poziom 22  
    Dokładnie kolega ma rację,ale powróćmy do tematu w którym chyba powinienem zmienić tytuł,z problem z komunikacją na brak dzwięków i mic not working.Nie sprawdziłem na samym początku bo nawet mi to do głowy nie przyszło żeby sprawdzić czy ma on dzwięki,chciałem zdjąć simloka bo był w plusie a nie spodziewałem się że po naprawie usterki brak karty sim wyjdą takie cyrki.Okazało się że dodatkowo brak w nim dzwięku i nie działa mikrofon ale z mikrofonem to wiadomo że układ był skruszony.Dla pewności wrzuciłem mu soft ale to nie naprawiło usterki,czekam na dalszą pomoc z waszej strony bo tyle czasu się nasiedziałem że szkoda by było żeby rzucić go w kąt na części
  • #33
    ftb
    Spec od GSM
    centra..tak tam przeważnie naprawiają gwarancyjne .tu jest fon po zalaniu a jak tam znajdą choć jedną kropelkę wody to wiadomo ..
    Układy BGA wlutowuję w ponad 90% z dawców ale ok ..powinno wstawiać sie nowe tylko ...i.t.d.
    Do meritum..po co umieściłem schemat..miernik i sprawdz czy masz napięcia.Jak nie będzie zasilania to nawet nowiutki chip nic nie da.Dalej masz też te dwa układziki -N2300 i N2400 zwłaszcza jak są wyprowadzone piny.Układ najpewniej nie ma połaczenia wewnątrz i przelutowywanie też nic tu nie da.Po wylutowaniu możesz pomierzyć oporności między poszczególnymi wyprowadzeniami i stwierdzić na 100% czy jest dobry.Z doświadczenia wiem że najczęściej nawalają te ,które podają zasilanie 1k (A2-C1,A1-B2) i dwa 100R (A2-D2,A1-D1).
    Patrząc na schemat nie trzeba żadnych solucji bo tą można szybko stworzyć samemu, w zależności od potrzeby..
  • PCBwayPCBway
  • #34
    MES Mariusz
    Poziom 36  
    ftb napisał:
    centra..tak tam przeważnie naprawiają gwarancyjne

    I pogwarancyjne, tzw. kosztorysowe, o ile nie wystąpiła w nim woda.

    ftb napisał:
    .tu jest fon po zalaniu a jak tam znajdą choć jedną kropelkę wody to wiadomo ..

    Wbrew pozorom, nie robią tego ze złośliwości, a zapis o anulowaniu gwarancji w przypadku wykrycia wody, wynika z rozsądku / opłacalności (czas przeznaczony na naprawę jednego telefonu).

    ftb napisał:
    Układy BGA wlutowuję w ponad 90% z dawców ale ok ..powinno wstawiać sie nowe tylko ...i.t.d.

    Podziwiam, ale nie popieram. Rezystor owszem, kondensator ok, ale BGA bym się nie podjął (szkoda PCB, cierpliwości, nerwów), jeśli dostępne są nowe.

    ftb napisał:
    Do meritum..po co umieściłem schemat..miernik i sprawdz czy masz napięcia.Jak nie będzie zasilania to nawet nowiutki chip nic nie da.Dalej masz też te dwa układziki -N2300 i N2400 zwłaszcza jak są wyprowadzone piny.

    Ale montując nowy układ, przynajmniej możesz być spokojny o to, że to nie wada elektroniczna, elektryczna czy też mechaniczna układu scalonego. A tak możesz pięć godzin ślęczeć nad fonem, i przyczyny nie dojdziesz, która, być może zaszyła się wewnątrz struktury układu. W centrum idziesz drogą eliminacji możliwych usterek. Tam się nie zakłada, że "a może ten układ jest dobry", tylko się go wymienia. W ten sposób zyskujesz na czasie, a jeśli telefon wciąż nie działa, możesz przyjąć, że zrobiłeś już wszystko, i więcej nie zrobisz. Możesz złomować fon z czystym sumieniem i bez nerwów, bo wiesz, że jego naprawa (jeśli możliwa) wiąże się z wyższym lewelem, któremu nie jesteś w stanie podołać (np. naprawa laserowa na poziomie platyny PCB, z tego co wiem pojedyncze miejsca w europie, jeśli nie na świecie).

    Ale, jeśli nie szkoda komuś czasu, i ma chęć do zabawy, próbować i bawić się oczywiście można.
  • #35
    ftb
    Spec od GSM
    ele mid widać że pracujesz (pracowałeś) w takim centrum..
    ja nie ,,żyję ,, z napraw telefonów..to zajęcie bardziej hobbistyczne ale byłem chyba dwa razy na szkoleniach prowadzonych przez Nokię w Stolicy.Poza może poznaniem ludzi z powiedzmy branży specjalnie wiekszej wiedzy technicznej o GSM nie wyniosłem. Nie jestem jednak przeciwnikiem takich szkoleń.Było miło (zwłaszcza po zajęciach) miałem możliwość obejrzenia trochę sprzętu pomiarowego(stabilbloki ,analizatory itp).Tam też mówiono że zabrania się kategorycznie napraw w autoryzownym serwisie telafonów zawilgoconych i dlaczego.I to jest ok bo na takiego topielca nikt.. ale to nikt nie może dać gwarancji..a serwis powinien.Moim zdaniem (poza wiedzą) wiele procedur z takich centr nie przeniesie się niżej.

    Tu na forum zdecydowana wiekszość zajmuje sie telefonami albo dorywczo lub prowadzi punkty napraw ale małe,bez specjalnego oprzyrządowania (nieraz niestety nawet bez podstawowego) i reguły gry są nieco inne jak w dużych centrach.Np naprawa zalańców to podejrzewam 30% wszystkich napraw,zdejmowanie blokad itd czyli wypełniają powstałą niszę bo akurat serwisy autoryzowane tego nie robią.Najczęściej żądany układ wpierw trzeba zamówić ,to kosztuje,przesyłka więc czas..a jak masz dawcę to sprawa zaczyna się po prostu opłacać.
    Nie zgodze się z stwierdzeniem
    Cytat:
    Ale montując nowy układ, przynajmniej możesz być spokojny o to, że to nie wada elektroniczna, elektryczna czy też mechaniczna układu scalonego. A tak możesz pięć godzin ślęczeć nad fonem, i przyczyny nie dojdziesz,
    niezależnie gdzie robi się naprawę wpierw należy znależ usterkę a dopiero póżniej wymieniać co trzeba.Tu akurat jeśli N2600 nie wystawi napięcia dla mikrofonu to wymiana nie ma sensu..chyba że będziesz wymieniał po kolei aż dojdziesz do N2600..ale to też nie ma sensu..
    Ok..wolny czs mi się już kończy..zaczynam świętować więc wszystkom życzę zdrowych i udanych SWIĄT

    ftb
  • #36
    DJF1
    Poziom 22  
    Dziękuję Ci za to że stajesz w mojej obronie,rzeczywiście masz rację bo tak właśnie jest.Więc powróciłem do solucji z układem z T610,wstawiłem go jeszcze raz i według napięć N2600 podaje prąd na mikrofon i niby jest tak jak ma być.Pójdę pózniej załadować konto bo wszystko wydzwoniłem i nie mam jak sprawdzić czy działa ale jeśli chodzi o dzwięk to niestety nadal go nie ma.
  • #37
    MES Mariusz
    Poziom 36  
    ftb napisał:
    Nie zgodze się z stwierdzeniem
    Cytat:
    Ale montując nowy układ, przynajmniej możesz być spokojny o to, że to nie wada elektroniczna, elektryczna czy też mechaniczna układu scalonego. A tak możesz pięć godzin ślęczeć nad fonem, i przyczyny nie dojdziesz,
    niezależnie gdzie robi się naprawę wpierw należy znależ usterkę a dopiero póżniej wymieniać co trzeba.Tu akurat jeśli N2600 nie wystawi napięcia dla mikrofonu to wymiana nie ma sensu.

    Jeżeli prawdopodobną przyczyną awarii są układy BGA, nazwijmy je po kolei A, B, i C, i jeżeli prawdopodobieństwo przyczyny awarii jest mniej więcej równe we wszystkich elementach, to wymieniamy najpierw te, których wymiana jest najłatwiejsza, w ostateczności zaś wymieniamy układ który wiąże się z największym ryzykiem uszkodzenia padów na płycie głównej.

    Nie widzę tutaj potrzeby obrony kogokolwiek przed kimkolwiek. Dzielę się wiedzą i doświadczeniem, które mogą okazać sie użyteczne, choćby w ten sposób, że zaoszczędzą komuś jego, być może, cenny czas.

    Nie patrzę w tej chwili na solucje, nie patrzę w schematy, korzystam z tego, co mi jeszcze w głowie zostało. N2600 to zdaje się Vincene jest, i jego wymiana do najbezpieczniejszych, czy najprzyjemniejszych z pewnością nie należy, szczególnie w warunkach amatorskich.
  • #38
    DJF1
    Poziom 22  
    Ja Ciebie rozumiem i dziękuję ci za zainteresowanie się moim tematem ale problem jest tego typu że jak włożę pieniądze w nowe części i wsadzę te elementy a to mi dalej nie będzie działać to będę w plecy na kasę.Ja nie zamawiam nowych części jeśli nie jestem w 100% pewny że akurat ta część jest uszkodzona.Mikrofon dalej mi nie działa po wstawieniu tego układu z t610 a na bank wstawiłem go tak jak trzeba,dzwięk oczywiście też nie działają.Wnioskuję że prawdopodobnie telefon faktycznie przestawia się na zestaw słuchawkowy i dlatego tak się dzieje,nie mam takiego zestawu więc nie mogę sprawdzić a napięcie na mikrofon jest i idzie z układu N2600 na N2300,czyli N2600 jest sprawny ale nie widać na wyświetlaczu żeby telefon przełączał się na zestaw słuchawkowy.

    Dodano po 14 [minuty]:

    Zapomniałem jeszcze dodać,wcześniej mowa była o tym że telefon był zalany,niestety nie był zalany jak trafił do mnie to nie czytał karty sim bo jedna ścieżka nie łączyła i potem jak zdiołem simloka okazało się że nie ma dzwięków i nie działa mikrofon.Od mikrofonu to wiadomo co N2300 bo był cały popękany i brakowało kawałka z jednej strony ale to że układ od ładowania może blokować dzwięk i mikrofon bo przełącza na zestaw słuchawkowy to jeszcze się z czymś takim nie spotkałem i nie bardzo rozumiem w jaki sposób on to robi.Jeśli faktycznie tak jest to musi od niego lecieć któraś noga która odpowiedzialna jest za ten fakt
  • #39
    Fyszo
    Spec od GSM
    Jak ty sprawdzasz mikrofon jak głosniki nie działają? Zresetuj w menu profile jeśli po resecie przestawiają sie na inny niż podstawowy to masz to co mówiłem. Wylutuj N2400 (ładowanie) i wtedy jeśli to wina tego układu, dźwieki powinny się pojawić. Jeśli tak będzie musisz zastosować nowy/używany układ (sprawny) i wlutować. Jeśli mikrofon 'szumi' to spróbuj w testach w niego dmuchnąć (w otwór) wtedy powinno być to słyszalne (normalna rozmowa jest za cicha), jeśli tak sie dzieje to niestety drugi układ do wymiany (uszkodzona rezystancja w układzie). Sprawdź jeszcze otwór mikrofonu (czy zapchany), może to 'za łatwe' rozwiązanie ale w niektórych modelach to normalne (np. k310i, k510i).
  • #40
    DJF1
    Poziom 22  
    Właśnie przeczytałem to co napisałeś,ja już wcześniej wpadłem na to żeby tak zrobić jak piszesz czyli wylutować ten układ i zobaczyć czy będzie działać.Niestety nie ma dzwięków po wylutowaniu tego układu,więc to nie jest jego wina.Profil nie przestawia się na inny jest na podstawowym,co radzisz sprawdzić teraz czy to może być procesor bo skoro wychodzi jakiś szum z głośnika to wnioskuję że układ(końcówka mocy) jest sprawna.
  • #41
    Fyszo
    Spec od GSM
    No to sprawa staje sie trudniejsza. Zacząłbym szukać w obwodach wyjściowych. Z reguły są tam filtry (dławiki, rezystory, kondensatory), często uszkadzają sie dławiki, można skrosować, wylutuj kondensator sprzegający głośnik i odsprzęgające do masy (na wszelki wypadek - mogą zwierać). Jeśli to nie pomoże to już tylko układy BGA pozostaja.
  • #42
    DJF1
    Poziom 22  
    Ale które to są elementy bo ja nie mam schematu i niebardzo wiem które,dławiki to owszem i cewki ale te kondensatory to nie wiem które to są.
  • #43
    Fyszo
    Spec od GSM
    Zanim zaczniesz grzebać na poważnie upewnij sie że soft jest ok, oraz czy głośnik jest sprawny, napisałeś że głośnik sprawny i nic o tym jak go sprawdzałeś (czy przez pomiar oporu czy na nowym). Obwód filtru wyjściowego masz na zdjęciu. (z k300 ale to to samo)
    K500i-Problem z komunikacją
  • #44
    DJF1
    Poziom 22  
    Głośnik jest na 100% procent sprawny bo podstawiłem go do Noki 3100 i działa,te dwa układy które wymieniłem od zasilania i mikrofonu też są sprawne,dla pewności wstawiłem takie jakie były bo wymontowałem z K300i.Podejrzewam że jest uszkodzony procesor audio bo sprawdziłem wszystko co mogłem i na tyle ile moja wiedza pozwalała,bez schematu w takich przypadkach nie można zdiagnozować co tak naprawdę mogło się uszkodzić bez żadnych.Na dzień dzisiejszy dałem sobie spokój z nim i sprzedałem w takim stanie jakiem był za mniejszą kwotę.Dziękuję wszystkim za pomoc i za poświęcenie mi waszego czasu,szkoda że nie udało mi się go naprawić bo tyle czasu poszło na marne.Pozdrawiam
  • #45
    ftb
    Spec od GSM
    spójrz na to inaczej..zawsze to nowe doświadczenie i czegoś się nauczyłeś ..taką mam nadzieję a co do usterki to sądzę po twoim opisie iż problem leżał jednak w tych 2-ch chipach.Mikrofon zasilany jest jakby symetrycznie i dlatego napięcia powinny być mierzone na dwóch jego wyprowadzeniach.Dalej jeśli zasilanie ok to sam sygnał idzie przez dwa 100ohm rezystory (wew N2300) do C = 68nF i dalej już do N2600(schem) tu też jest często przerwa..no ale to juz na przyszłość..
    ftb
  • #46
    Mleczyk89
    Poziom 34  
    Ja się dołączę, póki założyciel nie zamknął tematu. Posiadam K700i.Pewnego dnia przestały mi działać słuchawki. Wogóle ich nie wykrywało. Pomyślałem cóż pewnie słuchawki się uszkodziły. Sprawdziłem na innych se (k700 k500)i śmigały normalnie. Gniazdo u siebie wyczyściłem i nic. Poczytałem poszperałem i nie doszedłem do czegokolwiek. Było to jakieś ponad pół roku temu. Teraz zacząłem się bawić troche tą serią se(simlock, soft etc)i chciałem ściągnąć simlock`a ze swojego k700 i podegrać soft`a z obsługą mp3 sms. Niestety telefon nie komunikuje się z komputerem przez żaden kabel (czy to usb czy kom dane/flash), poprostu zero reakcji. Rzeczy dotychczas na telefon zrzucałem przez Bluetooth`a wiec nawet nie wiedziałem ze nie działa komunikacja. Teraz pytanie do forumowiczów. Wszystko pozostałe działa dobrze. Telefon się ładuje. Mikrofon, głośnik,słuchawka etc działa dobrze. Myślałem ze to wina glass`a ale po przeczytaniu tego tematu uświadomiliście mi ze jednak nie. Teraz nie wiem od czego zacząć. Czy kupować pierw nowe złącze do telefonu(te wygląda na sprawne) bo nie wiem, co mam juz robić. Wszystkich którzy maja jakieś pomysły prosił bym o wypowieć. Pozdrawiam
  • #47
    koczy
    Poziom 13  
    Ja miałem taki problem z k300. Brak komunikacji to zazwyczaj wina lewego glassa. Spróbuj go podgrzać może jakaś kulka nie łączy. Jak to nie pomorze to go wyjmij, przeczyść i z powrotem na płytke. No chyba że masz nowy to wymień i będzie po sprawie.