Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Computer ControlsComputer Controls
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zegar VFD na radzieckiej lampie IW-18

ryborz 04 Sep 2009 14:34 37641 86
  • #61
    morswin89
    Level 23  
    Witam

    Może zamieszczę swoją wersję płytki do tego zegarka (bez żadnej zworki i o wiele mniejszą), w roli podtrzymywania zegarka zastosowałem kondensator podtrzymujący 1F (wytrzymał 3 dni dalej nie sprawdzałem ale spokojnie jeszcze parę dni by pociągnął). W załączniku płytka w formacie pdf i plik programu RimuPCB.

    Dodaje również skompilowany wsad w nowszej wersji (zauważyłem poprawę sterowania wyświetlaczem - nie miga teraz).

    Zegar VFD na radzieckiej lampie IW-18 Zegar VFD na radzieckiej lampie IW-18
    Attachments:
  • Computer ControlsComputer Controls
  • #62
    bajc
    Level 13  
    Złożyłem ten zegarek i jak włączę animacje to trwa ona jakieś 30-35 sekund a na filmiku jakieś 5 sekund, mam pierwszy wsad i nic nie zmieniałem w fusebitach, możecie powiedzieć czemu tak właśnie mam ?
  • #63
    ryborz
    Level 23  
    bajc -> Musisz zmienić częstotliwość wewnętrznego oscylatora na 2 albo 4 MHz, nie pamiętam już :-)
    Jeszcze poproszę kolegów, którzy skończyli projekty o dodawanie zdjęć swoich zegarów w tym wątku, ewentualnie linków jesli zdecydują się zaprezentować je w dziale DIY.
    Mam zamiar napisać nowszą wersję zegara z kodem w C (avr-gcc) jednak narazie nie mam czasu i mam pełno innych projektów w głowie.
    Pozdrawiam.
  • #64
    lukaszpc1
    Level 13  
    mógłby ktoś wrzucić spis elementów ??????
  • #65
    ST-44
    Level 14  
    Witam
    zbudowałem ten zegar i mam mały problem. Po włączeniu zasilania nie ma na początku żadnej animacji tylko wyświetla się 00-00-00 albo same myślniki ( - - ), po wejściu do menu nie można ustawić godziny nawet godzin ściemniania, resztę można coś ustawiać. po wyjściu z menu zegarek stoi w miejscu 00-00-00, luba jakaś wartość jeśli przy ustawianiu godziny wciskało się przycisk ustawiania. Aby przechodzić w menu muszę przytrzymać przycisk przechodzenia ponad 1s.
    Zamiast ULN2803 użyłem ULN2804.

    Co może być tego przyczyna? proszę o jakieś sugestie.

    Pozdrawiam
  • #66
    cassius17
    Level 17  
    Witam,
    Odświeżę temat.
    Właśnie skończyłem budować ten zegar i mam mały problem.
    Atmega zaprogramowana, nic się nie grzeje, wygląda wszystko okey, a lampa się nie zapala. Może źle ją wlutowałem. Bardzo było by pomocne, gdyby ktoś napisał mi jak liczyć wyprowadzenia lub które podłączyć do GND.

    Czy układ załączy się bez przycisków?

    Pozdrawiam
  • #68
    cassius17
    Level 17  
    Witam,

    Porównałem moje podłączenie z inną stroną i raczej pasuje. Nie załącza mi się wogóle przekaźnik. Jaka może być przyczyna?
  • #69
    1 Marcin
    Level 17  
    A dobrze wlutowałeś tranzystor i diodę ?
    Zegar VFD na radzieckiej lampie IW-18 sprawdzałeś co się dzieje jak zewrzesz styki przekaznika, aby przekaznik zaskoczył procek musi być zaprogramowany.
  • Computer ControlsComputer Controls
  • #70
    cassius17
    Level 17  
    Procesor wg PonyProga jest zaprogramowany. Może coś nie tak z fusebit-ami, bo tego nie zmieniałem. Załączając przekaźnik nic się nie dzieje. Na niektórych wyprowadzeniach lampy są napięcia od 0.4V do nawet 7V. W tym problem, że Atmega nie daje napięcia na 11 nożce, tej od tranzystora. Atmega zaprogramowana jeszcze raz i weryfikację przechodzi pomyślnie. Jaki sygnał musi dostać, aby program się załączył?
  • #71
    mxs
    Level 26  
    Super pomysł i wykonanie,ale kąt widoczności cyfr chyba trochę za mały.
  • #72
    1 Marcin
    Level 17  
    Wgrałeś oba wsady flash i hex w atmegę? Osobiście zrobiłem zegar na tej lampie choć według innego schematu i programu do procka.
    Nawet jeżeli przekaznik nie załączy się to zegar powinien działać , przekaznik odpowiada za zmianę napięcia zasilania lampy tj. jaśniejsze lub ciemniejsze świecenie.
  • #73
    cassius17
    Level 17  
    Właśnie do tego doszedłem, że jednak miałem błędnie przylutowaną lampę. Teraz tylko ją polutować i sprawdzić czy działa.

    Edit:

    Zegar działa, tzn. wyświetla godzinę, ale nie wszystkie segmenty tak samo święcą. Czy to może być wina lampy?

    Pozdrawiam
  • #74
    1 Marcin
    Level 17  
    j222 wrote:
    Właśnie do tego doszedłem, że jednak miałem błędnie przylutowaną lampę. Teraz tylko ją polutować i sprawdzić czy działa.

    Edit:

    Zegar działa, tzn. wyświetla godzinę, ale nie wszystkie segmenty tak samo święcą. Czy to może być wina lampy?

    Pozdrawiam

    Kiedyś przy okazji innego tematu związanego z lampą iw18 kolega "mirek36" napisał że przy multipleksacji lampy ww. trzeba zasilać ja napięciem około 60-70 volt co także jest poruszone w nocie katalogowej na rosyjskiej stronce wcześniej wymienionej w temacie.
  • #75
    cassius17
    Level 17  
    Tzn. co musiałbym teraz zrobić, bo w lampach to jestem zielony.
  • #77
    1 Marcin
    Level 17  
    blue_17 wrote:
    A ja jestem bardzo ciekawy bo mam 2 takie lampy gzie jest zaznaczona 1 noga :?:


    Popatrz na lampę 1 i 13 wyprowadzenie to żarzenie łatwo je poznać bo są połączone z włóknem żarnika. Licząc od 1 wyprowadzenia , wyprowadzenia 6, 7, 8, nie są nigdzie podłączone. Podłączasz np.+12v do kolejnych nóżek i pojedynczo odłączasz w zależności co zgaśnie czy cała cyfra lub segment to wiesz czy to anoda czy siatka- ta metoda jest trochę czasochłonna ale skuteczna. W razie problemów zajrzyj tu: http://www.radiolamp.ru/sprav/ind/iv18.html
    http://the-end.ep.com.pl/ivanek89.html

    Do j222 lampę masz nową czy używaną ? Spróbuj zwiększyć napięcie zasilania lampy.
  • #78
    blue_17
    Level 32  
    Serdecznie dziękuję za odpowiedź :)

    Jeszcze przed napisaniem postu próbowałem rak jak kolega radzi bo żarzenie znalazłem po oporności,

    ale zauważyłem coś dziwnego po podłączeniu żarzenia i dotykaniu palcami wyprowadzeń zaczęły świecić przypadkowe segmenty jestem ciekaw jak to wyjaśnić :)
  • #79
    1 Marcin
    Level 17  
    Nie spotkałem się jeszcze z czymś takim aby lampa świeciła sama z siebie , myślę że to nie jest wada i można tę lampkę do czegoś zastosować.
  • #80
    cassius17
    Level 17  
    Lampy wg aukcji są nowe, bo mam ich więcej. Zasilanie to znaczy przed rezystorami 68k podać większe napięcia, np 15V?
  • #81
    1 Marcin
    Level 17  
    Ja lampę w swoim zegarze zasilam z +30v i to też jest trochę mało bo widać lekkie duchy ale jasność świecenia raczej jest taka sama , daj wyższe napięcie niż 15v . Producent podaje że można dać nawet 70v.
  • #82
    cassius17
    Level 17  
    Zasilona z 30V. Obowiązkowo radiator na stabilizatory. Poza tym muszę chyba poprawić luty bo jeszcze nie wszystkie segmenty ładnie świecą. Pozdrawiam i dzięki za pomoc.
  • #83
    User removed account
    User removed account  
  • #84
    longer95
    Level 15  
    Witam! Gdzie mogę kupić taką lampę jaka została użyta w projekcie? Bo na allegro szukałem, ale niema. Pozdrawiam
  • #85
    Trabi
    Level 36  
    Tylko giełdy, aukcje lub od kogoś. Już sa nie produkowane.
  • #86
    Michal_b1
    Level 18  
    morswin89 wrote:
    Dodaje również skompilowany wsad w nowszej wersji (zauważyłem poprawę sterowania wyświetlaczem - nie miga teraz).


    Naprawiam teraz mój zegar (grzejący się stabilizator zabił kondensatory i atmegę) i wgrałem Twój poprawiony wsad. Rzeczywiście wyświetlacz przestał migotać ale zauważyłem inny problem. Zmiana cyfry sekund nie następuje co jednakowy odcinek czasu, raz zmieniają się cyfry szybciej raz wolniej a nawet widać takie prawie dwu-sekundowe "zawieszki". Jednak sam czas sumarycznie liczony jest poprawnie (porównywałem upływ czasu ze stoperem). U Ciebie też coś takiego występuje?

    EDIT:
    Teraz zauważyłem, że jeszcze przy zmianie cyfr godzin pojawia się wartość 94 i taka zostaje dalej.