Elektroda.pl
Elektroda.pl
X
AM TechnologiesAM Technologies
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Programator USBasp dla procesorów z rodziny AVR

Shanleaf 20 Wrz 2010 08:17 164868 371
  • #301
    ginar
    Poziom 21  
    Dodałem diodę (1n4148 - zakładam, że spadek 0.5V nic nie zmieni w porównaniu z tamtą schottkiego 0.3V) i większy kondensator, ale dalej weryfikacja często powoduje błąd.
  • AM TechnologiesAM Technologies
  • #302
    mirekk36
    Poziom 42  
    No to znaczy, że coś źle zrobiłeś... próbuj dalej
  • #303
    Użytkownik usunął konto
    Poziom 1  
  • AM TechnologiesAM Technologies
  • #304
    łuki_mar44
    Poziom 18  
    Witam!

    W 20 zł spokojnie się kolega zmieści. Kawałek laminatu zaledwie 15 elementów z czego najdroższy oczywiście procek. I programatorek gotowy.

    Pozdrawiam
  • #305
    Mateo18
    Poziom 11  
    witam wszystkich.
    polecałbym wszystkim zamienienie kondensatora C3 na jakiś większy (220uF)
    bo zauważyłem że podłączając niektóre układy do programatora to występuje zanik napięcia na procku i pewne w rodzaju odłączenie i ponowne podłączenie programatora i nie kiedy błędy w programowaniu po zmianie C3 nie na trafiłem ma żaden błąd.
    Pozdrawiam.
  • #306
    piatas5
    Poziom 9  
    Coś jest nie tak z tym złączem ISP czy mi się wydaje? Dlaczego w tym programatorze piny nie są ustawione tak jak w STK200?
    Nie można tego USBASP podłączyć do STK200 bo piny się nie zgadzają... Czy te złącze nie powinno mieć wcięcia skierowanego w stronę przeciwną do płytki? Pozdrawiam!
  • #307
    Mateo18
    Poziom 11  
    Programator USBasp dla procesorów z rodziny AVR Programator USBasp dla procesorów z rodziny AVR

    "piatas5" - musi działać, jeśli tak będziesz miał zrobione. Złącze ISP powinieneś mieć w standardzie KANDA, tak jak powyżej na obrazkach.
    Pozdrawiam.
  • #308
    Popak
    Moderator na urlopie...
    Witam
    Mam problem z programatorem. O tuż wyskakują mi dwa błędy
    Code:
    avrdude.exe: set SCK frequency to 93.75 kHz
    
    avrdude.exe: error: usbasp_transmit: usb_control_msg: sending control message failed, win error: Urządzenie dołączone do komputera nie działa.

    Pracuję na systemie winndows7 x64. Sprawdzałem połączenia i wszystkie są ok. Programator był kupiony a aukcji internetowej i nie robiłem go samemu. diody na lini danych mam na 3.6V. Sterowniki zainstalowały się poprawnie.
    Czy ktoś miał podobny problem?

    Pozdrawiam
  • #309
    mirekk36
    Poziom 42  
    DJpopak;) napisał:
    Witam
    Mam problem z programatorem. O tuż wyskakują mi dwa błędy
    Code:
    avrdude.exe: set SCK frequency to 93.75 kHz
    
    avrdude.exe: error: usbasp_transmit: usb_control_msg: sending control message failed, win error: Urządzenie dołączone do komputera nie działa.

    Pracuję na systemie winndows7 x64. Sprawdzałem połączenia i wszystkie są ok. Programator był kupiony a aukcji internetowej i nie robiłem go samemu. diody na lini danych mam na 3.6V. Sterowniki zainstalowały się poprawnie.
    Czy ktoś miał podobny problem?

    Pozdrawiam


    a czy ustawiałeś zworkę SLOW_SCK na czas prób ???
  • #310
    Popak
    Moderator na urlopie...
    Witam
    Zworka jak jest założona i ustawię na auto SLOW_SCK wyświetla mi powyższy błąd.
    Gdy zdejmę zworkę i ustawię auto SLOW_SCK terż mi wyświetla powyższy błąd.
    Czasami wyświetli mi takie coś:
    Code:
    avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

    Aha czy za każdym razem muszę wybierać z listy AVR układ?
  • #311
    Mateo18
    Poziom 11  
    DJpopak;) napisał:
    Witam
    Zworka jak jest założona i ustawię na auto SLOW_SCK wyświetla mi powyższy błąd.
    Gdy zdejmę zworkę i ustawię auto SLOW_SCK terż mi wyświetla powyższy błąd.
    Czasami wyświetli mi takie coś:
    Code:
    avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

    Aha czy za każdym razem muszę wybierać z listy AVR układ?

    Spróbuj zainstalować inną wersję sterownika pod Windowsa
  • #312
    Popak
    Moderator na urlopie...
    Witam
    Kupiłem nowy programator i on zadziałał :) ale uciecha nie trwała długo :( Po zaprogramowaniu atmegi16 i ponownym włożeniu wtyczki usb do komputer wyświetla mi się nieznane urządzenie. Dziwne bo za pierwszy razem pięknie komputer wykrył programator i zaprogramował procesor. Na innym komputerze normalnie system wyświetla jako USBasp. Czy ktoś spotkał się z taka usterką?
  • #313
    mirekk36
    Poziom 42  
    Być może masz system do wygenerowania od nowa i wtedy się może okazać, że niepotrzebnie kupowałeś bo i twój programator z powodzeniem może będzie działał ;)
  • #314
    Popak
    Moderator na urlopie...
    Już sobie poradziłem. Mój USBasp działa tylko na jednym porcie usb, na innym już. Ale ważne że działa heheh :)

    mirekk36 mam do ciebie takie pytanie. W programie mkAVR Calculator 57 jak się ustawia na zewnętrzne taktowanie AVR. Bo próbuje ustawić ale jak nie ma oscylatora to i tak działa na wewnętrznym. Możesz mi na PW wysłać mały instruktarz tego programu?
  • #315
    Sebastian.R
    Poziom 20  
    U mnie ten programator kiedyś działał (jakiś rok temu). Od tygodnia próbuje go uruchomić ponownie ale jedynie mam taki efekt że dioda od zasilania świeci a ta od komunikacji błyśnie raz i... avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc .
    Dlatego , mając na względzie swój cenny czas postanowiłem złożyć USBtiny i po wywaleniu rezystora 1k5 ,jednej diody z rezystorem oraz bufora 125 , programator spisuje mi się na razie dobrze. Oczywiście będę temat regularnie przeglądał by się dowiedzieć o co biega z tym "kulejącym" usbasp.
  • #316
    mirekk36
    Poziom 42  
    DJpopak;) napisał:


    mirekk36 mam do ciebie takie pytanie. W programie mkAVR Calculator 57 jak się ustawia na zewnętrzne taktowanie AVR. Bo próbuje ustawić ale jak nie ma oscylatora to i tak działa na wewnętrznym. Możesz mi na PW wysłać mały instruktarz tego programu?


    klikasz sobie w zakładce "Fusy uproszczone" i po prawej masz ramkę "Zewnętrzny kwarc" - i tam klikasz sobie ptaszka np że >8MHz - jeśli masz zewnętrzny rezonator kwarcowy (a nie zewnętrzny oscylator np RC - bo może mylisz te pojęcia)

    Następnie klikasz w zakładkę "Programator AVR" i zaznaczasz w ramce "Operacja AVR" ZAPIS , potem po prawej w ramce "rodzaje pamięci" zaznaczasz Fyse bity.

    A potem już klikasz na dole klawisz "WYKONAJ" - dopiero ta operacja spowoduje zaprogramowanie mikrokontrolera a nie samo klikanie w zakładkach.

    Oczywiście przed kliknięciem "WYKONAJ" musisz wybrać swój programator czyli USBASP i port USB

    to wszystko

    Dodano po 6 [minuty]:

    Sebastian.R napisał:
    U mnie ten programator kiedyś działał (jakiś rok temu). Od tygodnia próbuje go uruchomić ponownie ale jedynie mam taki efekt że dioda od zasilania świeci a ta od komunikacji błyśnie raz i... avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc .
    Dlatego , mając na względzie swój cenny czas postanowiłem złożyć USBtiny i po wywaleniu rezystora 1k5 ,jednej diody z rezystorem oraz bufora 125 , programator spisuje mi się na razie dobrze. Oczywiście będę temat regularnie przeglądał by się dowiedzieć o co biega z tym "kulejącym" usbasp.


    Oczywiście, że USBtiny jest równie dobrym programatorem co USBASP .... ale żeby nazwać USBASP "kulejący" ???? ;) to już przesada. To co ci się działo z tym programatorem i ten komunikat, który opisałeś oznacza tylko i wyłącznie, że nie do końca potrafiłeś sobie poradzić z rozwiązaniem takiego błahego problemu niestety :( ..... a ten komunikat oznacza jedynie, że USBASP jest niewidoczny w Windowsie. Dlaczego? Ano np dlatego, że miałeś coś nie tak ze sterownikami do niego, może z jego wsadem, może z samym windowsem, może z portem USB jak kolega wyżej albo jeszcze kilka innych takich niuansów.

    Ja ale nie tylko ja posługuję się w 99% programatorami USBASP różnej maści, zresztą wszystkie wykonane własnoręcznie i chciałbym zobaczyć chociaż jeden "kulejący" ;) ..... a dodam, że działają u mnie na wszystkich windowsach od XP począwszy poprzez Vista wo Win7 i to 32- czy 64-bitowych wersjach.

    Dlatego tylko uważam, że takie rozwiązanie problemu przez złożenie innego programatora bo ten akurat nie działał - to nie ROZWIĄZANIE a OBEJŚCIE problemu. A tym bardziej, że to prawie taki sam programator ;)

    poczytaj sobie tutaj o USBASP oraz zobacz FILMIK o instalacji USBASP w nowszych windowsach:

    http://mirekk36.blogspot.com/2011/05/wszystko-o-usbasp.html
  • #317
    Sebastian.R
    Poziom 20  
    Mylisz się. Programator jest widoczny w systemie. Zwróć uwagę że napisałem : zapala się dioda od zasilania a po wydaniu komendy odczytu w burn'o'macie (oczywiście w ustawieniach jest zaznaczone ze używam USBasp z USB) wywala błąd opisany wyżej. Menager urządzeń w windowsie widzi dobrze. Zainstalowane są sterowniki. Windows jest oryginalny z servicepackiem 2. Zainstalowany jest avrdude 5.5. USBasp wykonany jest według projektu Mirleya. Rok temu działał bardzo dobrze. Teraz nie wiem czemu się "zbiesił" . Urządzenie super.To soft kuleje.
    Samo to że nie widać urządzenia mimo że windows widzi świadczy o jakiejś niegodności. Nie wywala błędu że podłączony układ do programowania ma defekt a to że nie widoczny jest programator. Dziwne. Jak uruchamiam mkavrcalculator to wszystko jest elegancko do momentu gdy chcę odczytać programowany układ bo wywala błąd avrdude :) Z USBtiny nie ma problemu. Dlatego ominiecie problemu nie jest takie złe.
    PS
    Twój filmik dotyczy windowsów wyższych niż XP - a ja właśnie posiadam XP.
  • #318
    mirekk36
    Poziom 42  
    Ale ja już nie raz pomogłem osobom z takimi problemami jaki tu tutaj opisałeś. Ostatnio zresztą ktoś się uperał, że nie będzie wgrywał najnowszej wersji wsadu ze strony autora

    www.fischl.de/usbasp

    bo kiedyś mu wszystko działało a teraz nie....

    i co? CUD się okazał - po wgraniu wsadu z tej stronki, po załadowaniu AVRDUDE z MkAvrCalculatora (polecam sprawdzić tę wersję - zakładka "Ustawienia" i ramka "avrdude" + klawisz Instaluj) - to zainstaluje ci avrdude tylko na potrzeby MkAvrCalculatora. przy okazji zrobi kilka ważnych rzeczy w win XP. Zresztą w win XP wszystko chodzi jak brzytwa jeśli chodzi o USBASP.

    No chyba, że jeszcze się okaże, że może masz windows zainstalowany nie w domyślnym folderze o nazwie "Windows" tylko np "Win" albo jakiejś innej własnej - bo wtedy bywają problemy ze zmiennymi środowiskowymi dla BAT'chy odpalanych z konsoli DOS'a w procesie instalacji AVRDUDE....

    Generalnie z czystej ciekawości - mógłbyś spróbować zrobić to o czym wyżej piszę i sprawdzić czy pójdzie OK ten twój USBASP ;)

    .... a nawiasem mówiąc - to sam od dawna mam też ochotę "strzelić" sobie maluszka w postai USBtiny ;) .... tylko czasu jakoś mało zawsze ...
  • #319
    Quarz
    Poziom 43  
    mirekk36 napisał:
    Ale ja już nie raz pomogłem osobom z takimi problemami jaki tu tutaj opisałeś. Ostatnio zresztą ktoś się uperał, że nie będzie wgrywał najnowszej wersji wsadu ze strony autora

    www.fischl.de/usbasp

    bo kiedyś mu wszystko działało a teraz nie....

    i co? CUD się okazał - po wgraniu wsadu z tej stronki, po załadowaniu AVRDUDE z MkAvrCalculatora (polecam sprawdzić tę wersję - zakładka "Ustawienia" i ramka "avrdude" + klawisz Instaluj) - to zainstaluje ci avrdude tylko na potrzeby MkAvrCalculatora. przy okazji zrobi kilka ważnych rzeczy w win XP. Zresztą w win XP wszystko chodzi jak brzytwa jeśli chodzi o USBASP.

    No chyba, że jeszcze się okaże, że może masz windows zainstalowany nie w domyślnym folderze o nazwie "Windows" tylko np "Win" albo jakiejś innej własnej - bo wtedy bywają problemy ze zmiennymi środowiskowymi dla BAT'chy odpalanych z konsoli DOS'a w procesie instalacji AVRDUDE....

    Generalnie z czystej ciekawości - mógłbyś spróbować zrobić to o czym wyżej piszę i sprawdzić czy pójdzie OK ten twój USBASP ;)

    .... a nawiasem mówiąc - to sam od dawna mam też ochotę "strzelić" sobie maluszka w postai USBtiny ;) .... tylko czasu jakoś mało zawsze ...
    Bo Fischl to jest to jest Fischl , 'porządna L ryba' ... :idea: :lol: ... kupiłem sobie od niego oryginał;
    Programator USBasp dla procesorów z rodziny AVR
    zmontowałem, i działa bez zarzutu ... :!:
    Jakby kto chciał tam kupować, to mogę pośredniczyć w taniej przesyłce - ok. 20.- € za wszystko z przesyłką ...
  • #320
    mirekk36
    Poziom 42  
    Quarz napisał:

    Jakby kto chciał tam kupować, to mogę pośredniczyć w taniej przesyłce - ok. 20.- € za wszystko z przesyłką ...


    No, jeśli już ktoś ma kupować bo sam ma problemy ze złożeniem - to ja również uważam, że zdecydowanie lepiej kupić sobie u pana "Ryby eL" ;) .... nawet jeśli to wychodzi nieco drożej - niż kupować na allegro - gdzie ostatnio większość tych programatorków USBASP to po prostu LIPA jakich mało.... i tylko później ludzie narzekają na ten typ programatora, nie zdając sobie sprawy, że to nie wina sprzętu a cudownych producentów.
  • #321
    Quarz
    Poziom 43  
    mirekk36 napisał:
    Quarz napisał:

    Jakby kto chciał tam kupować, to mogę pośredniczyć w taniej przesyłce - ok. 20.- € za wszystko z przesyłką ...


    No, jeśli już ktoś ma kupować bo sam ma problemy ze złożeniem - to ja również uważam, że zdecydowanie lepiej kupić sobie u pana "Ryby eL" ;) .... nawet jeśli to wychodzi nieco drożej
    Tylko za tyle, to jest zestaw do zmontowania - zobacz TU i TAM ... :idea: :D ... czyli kompletny KIT.

    mirekk36 napisał:
    - niż kupować na allegro - gdzie ostatnio większość tych programatorków USBASP to po prostu LIPA jakich mało.... i tylko później ludzie narzekają na ten typ programatora, nie zdając sobie sprawy, że to nie wina sprzętu a cudownych producentów.
    Dokładnie ...
  • #322
    Sebastian.R
    Poziom 20  
    Ja nie twierdzę że źle złożyłem USBasp . Kiedyś działało , nie sądzę by coś jemu się stało od samego leżenia w szufladzie. Podłączyłem - wykrył windows , zassał sterowniki. Pół sukcesu. Druga połowa to po stronie softu do programowania. Coś jednak jest nie tak bo ten sam układ odczytuje za pomocą USBatiny i sukces.
    Poniżej dwa screeny z eksperymentu który przeprowadziłem przed chwilą.
    Płytka z atmega88 - jako ten do odczytu za pomocą Burn'o'matu.
    Podłączyłem najpierw USBasp i efekt :(
    Następnie podpiąłem USBtiny i efekt :) .
    Za każdym razem zmieniłem w ustawieniach. Jak korzystałem z USBasp to taki ustawiłem w typie programatora.

    Programator USBasp dla procesorów z rodziny AVR Programator USBasp dla procesorów z rodziny AVR Programator USBasp dla procesorów z rodziny AVR

    Jak widać coś się poprawiło bo już nie wypisuje że nie widzi USBasp , ale nie odczytało mi układu mimo ustawienia wolnego czytania.

    Quarz napisał:
    mirekk36 napisał:
    napisał:
    - niż kupować na allegro - gdzie ostatnio większość tych programatorków USBASP to po prostu LIPA jakich mało.... i tylko później ludzie narzekają na ten typ programatora, nie zdając sobie sprawy, że to nie wina sprzętu a cudownych producentów.

    Dokładnie ...

    Co do tej lipy to i USBtiny też nie ma 100% sukcesów wśród składających. Sam należę do tych co kłopoty były i musiałem zmodyfikować schemat by działało.
    Także , po równo w sumie jest zwolenników i przeciwników obu programatorów. Ja bym chciał by mi to USBasp ruszyło . Może dojdę co skaszaniłem , dam wtedy tu opis . Dzięki
  • #323
    Quarz
    Poziom 43  
    Sebastian.R napisał:
    [ ... ]
    Quarz napisał:
    mirekk36 napisał:
    napisał:
    - niż kupować na allegro - gdzie ostatnio większość tych programatorków USBASP to po prostu LIPA jakich mało.... i tylko później ludzie narzekają na ten typ programatora, nie zdając sobie sprawy, że to nie wina sprzętu a cudownych producentów.

    Dokładnie ...

    Co do tej lipy to i USBtiny też nie ma 100% sukcesów wśród składających. Sam należę do tych co kłopoty były i musiałem zmodyfikować schemat by działało.
    Także [spacja zbędna], po równo w sumie jest zwolenników i przeciwników obu programatorów. Ja bym chciał by mi to USBasp ruszyło [spacja zbędna]. Może dojdę co skaszaniłem [spacja zbędna], dam wtedy tu opis [spacja zbędna]. Dzięki
    Ale to tylko, i wyłącznie, wina kiepskiego "składacza" ... :idea: :cry:
  • #325
    mirekk36
    Poziom 42  
    Sebastian.R napisał:
    OK. USBasp ruszył jak wymieniłem złącze ISP. Było zwarcie. Dziwne że rok temu nie dawało znaku że jest z tym problem.


    No i widzi kolega - że bardzo nieuprawnione były słowa w pierwszej wypowiedzi, że:

    cytuję:

    Cytat:
    "kulejący USBASP"


    Tak samo jak domniemania, typu:

    "dlaczego mi przedtem działało a teraz nie? " ..... a skoro tak się stało to znaczy, że USBASP jest do kitu"

    ..... to właśnie świadczy tylko i wyłącznie o TYM KTO SKŁADA .... a tym bardziej, że tu jeszcze wyszło jakieś zwarcie. Myślę, że na podstawie takiej hmmm nauczki czy jak to nazwać, kolega na drugi raz zastanowi się co najmniej 10 razy zanim powie, że coś tam jest kulejące ;) ....

    Bo właśnie tą drogą najszybciej co niektórzy dochodzą także do przekonania, że np mikrokontrolery są w ogóle wadliwe bo im źle działają ;)

    a na zakończenie - widać, że udowodnione zostało, że w przypadku kolegi - zbudowanie USBtiny było jendak tylko OBEJŚCIEM problemu a nie jego rozwiązaniem. Co nie oznacza, żeby się miał USBtiny nie przydać ;) zawsze warto sobie zbudować kilka różnych programatorów. Nie zna człowiek dnia ani godziny kiedy się przydadzą.
  • #326
    Quarz
    Poziom 43  
    Sebastian.R napisał:
    OK. USBasp ruszył jak wymieniłem złącze ISP. Było zwarcie. Dziwne, że rok temu nie dawało znaku, że jest z tym problem.
    A jednak - miałem rację ... :idea: :lol: ... patrz wyżej ... :shocked!:
  • #327
    Sebastian.R
    Poziom 20  
    Ależ moje słowa były uzasadnione bo mi kulał USBasp. Znalazłem w "ostatnim rzucie na taśmę"usterkę i teraz ma się on rewelacyjnie. Nie uważam tego projektu wyżej czy niżej jak USBtiny, bo programatory w działaniu i w obsłudze identyczne , jednak jako pierwszego programatora użyłem właśnie USBasp. Mam go bez żadnych absolutnie przeróbek i pamietam, że nigdy nie miałem z nim kłopotów. Działał od pierwszego uruchomienia. To z USBtiny miałem kłopoty i je wyeliminowałem poprzez redukcję elementów.
    Teraz mam pytanie, które przed momentem mi się nasunęło : czy jest możliwe, by ten programator na USB znalazł się w systemie jako port LPT ? Chciałbym zastosować program do programatorów ISP pana Dybkowskiego, lecz niestety ten chce tylko współpracować z LPT i to najlepiej fizycznym (chińskie emulatory na usb czy PCMCIA raczej z nim nie chodzą).Taki trick z emulacją portu ma USBtiny
    Link
    PS.
    Strasznie się unosicie tym że napisałem "kulejący". Ja stwierdziłem tylko fakt (i tylko to co u mnie się zdarzyło a nie ogólnie). Nie miałem absolutnie chęci kogokolwiek tym urazić. Na potwierdzenie moich dobrych intencji cytat :
    Sebastian.R napisał:
    Ja bym chciał by mi to USBasp ruszyło . Może dojdę co skaszaniłem , dam wtedy tu opis .
  • #328
    mirekk36
    Poziom 42  
    Na LPT ??? hmm może znowu coś ci się pomyliło ? - może chodziło ci o COM ??

    Bo USBASP ale także i ten USBTiny nigdy nie będą ci pracować w trybie LPT....

    A co do "kulejącego" to nikogo nie uraziłeś ;) spokojnie - tylko chodzi o to, że wiesz? jak ktoś początkujący poczyta takie opinie to potem pomyśli z takiej niejasnej wypowiedzi składacza, że jednak te programatory USBASP mają jakieś tam problemy - a jak sam widzisz to nieprawda....

    A swoją drogą co takiego masz w tym swoim programie Dybkowskiego czego nie mają inne programy tego typu ? tak z ciekawości zapytam ?
  • #329
    Sebastian.R
    Poziom 20  
    Pod przyciskiem ERASE mam powrót do fabrycznych ustawień układu. Tego mi brakuje w BURN'o'macie i mkAVRcalculatorze - przydałoby się to bardzo :) .
    Nie chodzi mi o COM w tym konkretnie przypadku tylko by USBasp był widoczny w programie pana Dybkowskiego. OK. Jak się nie da, to nie ma co sobie zawracać głowy :) .
    Poniżej zamieszczam schemat po mojej przeróbce USBtiny.
    Co do tego, że ktoś przeczyta, że miałem kłopoty i się zniechęci? Hmm... Powinien chyba przeczytać do końca. Zapamiętać jakie potencjalnie czyhają niebezpieczeństwa podczas składania. Ja tak mam, zanim cokolwiek zrobię to czytam ,czytam, czytam. Zniechęcam się dosyć trudno :) i rzadko.

    Programator USBasp dla procesorów z rodziny AVR
  • #330
    mirekk36
    Poziom 42  
    Sebastian.R napisał:
    Pod przyciskiem ERASE mam powrót do fabrycznych ustawień układu. Tego mi brakuje w BURN'o'macie i mkAVRcalculatorze - przydałoby się to bardzo :) ..


    Ale przecież w MkAvrCalculatorze masz tą opcję i to od dawna ;)

    Ot po prostu zamiast wykrywać procka wybierasz go ponownie z rozwijanej listy i w tym momencie - masz w kalkulatorze domyślne fabryczne wartości fusków - wystarczy je teraz tylko zapisać do procka - więc w czym problem?