Elektroda.pl
Elektroda.pl
X
Metal Work Pneumatic
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Magnetowid SAMSUNG SV-651GX - nie działa klawiatura lokalna

Marek Matysek 05 Maj 2007 22:32 1553 3
  • #1 05 Maj 2007 22:32
    Marek Matysek
    Poziom 19  

    Tak jak w tytule. Sprzęt trafił do mnie z nieczynną całkowicie klawiaturą lokalną. Wszedłem w tryb serwisowy. Opcje były ustawione prawidłowo. Jedyna operacją jaką zrobiłem to zatwierdziłem (SAVE) to co było na ekranie i wyłączając wyszedłem z trybu. Klawiatura zaczęła działać jednak nie na długo. Już następnego dnia problem się powtórzył, tylko tym razem każdemu naciśnięciu dowolnego przycisku na klawiaturze lokalnej towarzyszyło wyświetlenie napisu TEST. Nie w trakcie, tylko tuż po naciśnięciu i puszczeniu. Sprawdziłem zasilanie (5,16 V) co do wartości napięcia i na zawartość tętnień. Wszystko było w porządku. Zdecydowałem się na wymianę pamięci. Zamontowałem czystą 24C08, ustawiłem opcje i sprzęt wystartował. Niestety po ok. dwóch godzinach odtwarzania nagle zaczął przewijać taśmę do tyłu na podglądzie. Naciśnięcie jakiegokolwiek przycisku na klawiaturze lokalnej stopowało na chwilę taśmę, a potem przewijanie trwało dalej. Proces ten można było przerwać jedynie pilotem. Zresztą przez cały czas sprzęt reaguje prawidłowo na pilota. Naciśnięcie któregokolwiek przycisku na klawiaturze lokalnej powodowało znowu tylko przewijanie do tyłu na podglądzie. Wszedłem ponownie w tryb serwisowy. Opcje były ustawione prawidłowo i jak za pierwszym razem po zatwierdzeniu wszystko zaczęło działać. Po kilku godzinach na wyświetlaczu zapalił się napis TEST i już wiedziałem, że historia zaczyna się od nowa, tylko tym razem nie pomogło już zatwierdzenie opcji w trybie serwisowym. Klawiatura lokalna nie działa. Każdy klawisz reaguje wyświetleniem na chwilę napisu TEST. Podkreślam, że z pilota jest w pełni sterowalny. Doczytałem się na forum, że mikrokontroler, który steruje tym magnetowidem jest bublem SAMSUNGA, ale w większości przypadków pomagało ustawienie opcji, bądź wymiana pamięci. W moim przypadku usterka powraca. Czy ktoś ma jakieś doświadczenia w tym temacie?

    0 3
  • Metal Work Pneumatic
  • #2 06 Maj 2007 00:07
    gart62
    Poziom 31  

    Witaj!
    Może być uszkodzony mikrokontroler ale dla pewności sprawdź jakość zasilań (tętnienia). Podejrzewam uszkodzenie któregoś z elektrolitów i zakłócenia pracy mikrokontrolera.
    Pozdrawiam.

    Dodano po 1 [minuty]:

    Coś podobnego miałem w Sony (w środku był właśnie Samsung).

    0
  • Metal Work Pneumatic
  • #3 06 Maj 2007 14:43
    oldboy
    VIP Zasłużony dla elektroda

    Przyczyna może również tkwić w niesprawności (upływności) jednego z przycisków klawiatury. Dobrym rozwiązaniem byłby pomiar napięć na wejściach procesora, do których jest podłączona matryca przycisków, w momencie zablokowania klawiatury. Wiem, że dostęp do pinów procesora jest utrudniony ale takie badanie wniosłoby wiele.
    W materiałach znajdujących się w bazie są podane napięcia na poszczególnych pinach tego procesora dla trybu STOP, PLAY i REC.

    0
  • #4 07 Maj 2007 13:01
    Marek Matysek
    Poziom 19  

    O tętnieniach pisałem, sprawdziłem "jakość" napięcia zasilającego na oscyloskopie, ale żeby uspokoić sumienie sprawdziłem wszystkie elektrolity w przetwornicy i są super. Na pomysł z upływnością mikrostyków też wpadłem, ale dopiero po ponownym wyczyszczeniu pamięci, więc spróbuję, jak usterka pojawi się ponownie.

    Wykasowałem starą pamięć, podstawiłem, ustawiłem opcje i od dwóch dni magnetowid pracuje bez zarzutu. Ale wcale przez to nie jestem ani pewniejszy naprawy, ani mądrzejszy.

    0