Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

flyback do samochodu z TDA7294 (albo jakikolwiek inny...)

22 Maj 2007 23:04 6784 31
  • Poziom 35  
    Własnie dzisiaj udało mi się odpalić przetworke w wersji flyback co najciekawsze da sie z flybacka wyciagnac zasilanie SYMETRYCZNE (jesli ktos powie ze sie nie da to sie najwidoczniej myli :P ) Z tego co zauwazylem rdzen mozna wziac taki jaki sie ma akurat pod ręką :D nie ma konkretnych wymagan :P Sama przetworka jest dosyc prosta w budowie...
    Co do schematu:
    -Generator wykonany na 4069 (najprosciej :))
    -Czestotliwosc generatora na oko 110kHz (malo wazne :), byle nie mniej niz 100kHz)
    -Mosfet dowolny (np IRF540, BUZ10, BUZ11A)
    -Rezystor 1,5R jest OPCJONALNY :) (u mnie go NIE MA )
    TRAFO:
    Pierwotne uzwojenie trzeba nawinac dosyc umiejetnie, na rysunku wyjasnione...
    Wtórne jest bardziej skomplikowane, jesli jest ktos zainteresowany to napisze dokladniej jakie sa metody...
    Co do prostownika chyba nie musze tłumaczyć :)
    flyback do samochodu z TDA7294 (albo jakikolwiek inny...)
    Jedyne co wymaga WYJASNIEN to:
    -Napiecie spoczynkowe bez obciazenia może byc wielokrotnie wieksze niż wynika z obliczeń, powód: kondensatory laduja sie impulsami szpilkowymi
    -Nie nalezy sie sugerowac napieciem wyjsciowym podczas gdy kondensatory filtrujace sa podlaczone do ukladu,
    -Napiecie wyjsciowe trzeba zmierzyć BEZ PODLACZONYCH KONDENSATORÓW FILTRUJĄCYCH (!!!)
    :)
  • Poziom 39  
    A kto mówił, że z przetwornicy w układzie flyback nie da się uzyskać napięcia symetrycznego?
    Taki układ bez sprzężenia zwrotnego (czyli bez stabilizacji napięcia wyjściowego) na pewno zniszczy wzmacniacz do niego podłączony.
    Zapomniałeś podać dane transformatora - rodzaj rdzenia, ilość zwoi, grubość szczeliny...
  • Poziom 31  
    nsvinc napisał:
    Jedyne co wymaga WYJASNIEN to:

    Wyjasnienia wymaga raczej fakt, że czytacie to na własną odpowiedzialnosć.

    nsvinc napisał:
    -Napiecie spoczynkowe bez obciazenia może byc wielokrotnie wieksze niż wynika z obliczeń, powód: kondensatory laduja sie impulsami szpilkowymi

    No to znaczy raczej, że moze warto zacząć sie uczyć jak takie obliczenia sie dokonuje. I o od czego zależy to napiecie wyjsciowe.

    nsvinc napisał:
    -Nie nalezy sie sugerowac napieciem wyjsciowym podczas gdy kondensatory filtrujace sa podlaczone do ukladu,
    -Napiecie wyjsciowe trzeba zmierzyć BEZ PODLACZONYCH KONDENSATORÓW FILTRUJĄCYCH (!!!)
    :)

    Moze wyjaśnisz czemu?

    Mi to wyglada na jakis rodzaj naturalnej selekcji odporności częsci na pomysły wynalazców.

    Juz pisałem to w innym poscie w ĸtorym sie wypowiedziałeś, na pewno to jest flyback? Czy jakies peseudo-mieszajace urzadzenie. Z opisu to raczej nic nie wynika. Jak należy robić flyback znajdziesz w nocie np uc3843.
  • Poziom 35  
    hehhehe to jest COS W RODZAJU flybacku :D rzecz w tym ze ja to PODLACZYLEM do tda7294 i GRA....gra praktycznie od zasilania 11v do 18v obliczenia i wszystko inne na OKO robione...ma sie rozumiec ze liczyc mi sie nic nie chcialo tylko zgrubsza policzyc jaki ma byc Tr trafka...12 pierwotny, 36 x 2 wtorny (chyba) fakt ze mocy to nie ma praktycznie zadnej ale dziala :)
    Co do rdzenia: szczelina 2mm, oznaczen na rdzeiu niema zadnych onjest wymontowany z niekompletnego modulu smps'a (brakowalo wielu czesci :D )
  • Poziom 31  
  • Poziom 35  
    o solidnosc nie chodzilo tylko o samo prowizoryczne odpalenie czegos zasilajacego :D padlo mi radyjo samochodowe a nie mialem pod reka TDA1562 wiec urynaprzetworka na 3-4 dni :D a tak wogóle mam pytanie jak zrobic NORMALNY flyback ale bez kombinacji stabilizacji, zabezpieczen itp? chodzi o najnizszy koszt, moc 100w tez mnie zadowoli...
  • Poziom 31  
    Sama idea flybacku to jest minimum które ty narysowałeś, czyli klucz, trafo, dioda, pojemnosć.

    A normalny to: jakis sterownik, stabilizacja, zabezpieczanie itp. inne elementy.
  • Poziom 35  
    stabilizacja raczej nie ma sensu przy koncowkach mocy (jak TDA dostanie +-35 zamiast +-40 to nic mu nie bedzie a i glosnosc malo spadnie) zabezpieczenie...tutaj troche inny motyw przetworka ma miec swoj aku w bagarzniku najwyrzej sie rozladuje do cna :) inaczej sformuuje pytanie: jak ulepszyc ten uklad co go narysowalem??
  • Poziom 31  
    Stabilizacja jest potrzebna nie TDA ale flybackowi. Ale i TDA tez nie zaszkodzi.

    Temat przetwornic jest tak duży ze nawet w 10 zdaniach ci tego nie wytłumacze. W pewnych konkretnych przypadakch można zrezygnowc ze stabilizacji na rzecz co namniej układu zabezpieczającego przed nadmiernym napieciem wyjsciowym. Ale już sam taki układ będzie nie robił nic innego jak w pewnym sensie stabilizował napiecie wyjsciowe.

    Jak napiecie siadzie z 40V do 35V, nie oznacza że przetworka nie ma stabilizacji. Może po prostu jest na takim marnym poziomie.

    Weźmy sytuacje z auta, masz 40V z 14,4 V pod jakimś obciązeniem siada ci do 35. Potem masz 12V i jescze siada ci do ok. 29-30. Nie wydaje ci sie to bez sensu?

    To że w ramach oszczędności mejsca, oraz faktu ze i tak końcowa moc tracona w standartowych wzmakach zasilanych z sieci poprezez trafo, jest i tak na stałym poziomie, nie oznacza ze tak jest w przypadku przetwornic.

    Moze dla ciebie, jakość docelowa przetwornicy czy sprawność nie interesuje, tylko fakt że przynajmniej cos gra, ale moim zdaniem to nie jest podejście które jest warte zaoszczędzeniem kilku elementów.
  • Poziom 35  
    Heh nie chodzi o fakt zaoszczedzenia kilku elementow...
    Znasz na pewno uklad TDA4605...posiadam taki (sam 4605 bez -x ) i prosilbym cie o pomoc jak go wykorzystac w samochodzie. Sama nota aplikacyjna Siemensa przedstawia przykladowa przetworke ale zasilana 220v, flyback ale z dodatkowym uzwojeniem zasilajacym tda na trafie (w tym przypadku chyba zbedne...) Nie wiem jak przerobic schemat....
  • Poziom 35  
    Uklad przestal dzialac. Sam z siebie. Nie wiem dlaczego, wszystkie elementy sa sprawne a przy trafie nie bylo nic ruszane tak samo jak i przy generatorku. I powiem w skrocie co sie dzieje:
    Po podlaczeniu trafa uklad pozera prad zwarcia zasilacza. [przypominam, to samo trafo co na schemacie, wogole nie ruszane]. Wtedy dzialalo a dwa dni puzniej juz nie dziala?? jak to mozliwe.....
  • Poziom 39  
    Pewnie tranzystor padł od przepięć wywołanych indukcyjnością rozproszoną transformatora. W Twoim układzie brakuje gasika, w przetwornicach zaporowych (flyback) jest wręcz niezbędny. Taki gasik najczęściej składa się z diody, rezystora i kondensatora - poszukaj w sieci i zobacz jak to robią inni...
  • Poziom 35  
    Aha :) chcesz mi powiedziec ze ja podmieniajac tranzystory (byl juz buz10, dwie sztuki buz11 i jeden nuwka irf540) spalilem je wszystkie?? Ale raczej nie, bo test zaruwkowy jest udany w 100%....
    A jest mozliwe ze to cos nie tak z kondensatorami?? Diody sa na pewno sprawne, mosfety tez...
    Bylo tak:
    Ten ww. "flyback" zasilal sobie TDA1514A. Robil to pół dnia, grala sobie muzyka i bylo ok. Na noc wylaczylem.
    Na drugi dzien wlaczam do pradu i:
    -w glosniku ryk 50Hz zmieszany z harmonicznymi i koncowka mocy pobiera prad zwarciowy
    -po odlaczeniu koncowki mocy wszystko jest w porzadku, znikomy prad pracy bez obciazenia, i stabilne napiecia na elektrolitach.
    Zaczalem kombinowac przy trafie, przewinalem pierwotne dajac zamiast jednego druta DNE1.0 trzy ciensze DNE0.5. Wtorne zostalo jak bylo.
    Podlaczylem to spowrotem do ukladu.
    Rozladowalem elektrolity rezystorem i wlaczylem zasilanie. Stabilna praca, wszystko OK. Po podlaczeniu PA to samo co bylo, koncowka mocy pobiera prad zwarciowy.
    Zostawilem to.
    Na nastepny dzien proboje jeszcze raz to rozpracowac, wlaczam zasilanie, i tym razem juz samo trafo pobieralo prad zwarciowy, na wtornym NIC...Przynajmniej teraz zaczne stosowac gasiki :) tyle ze caly G jest na plytce wtykowej reszta to pajak :D
    Dziwna sprawa troche, ale zadna wymiana tranzystora nie pomogla...Dalem nawet dwie sztuki rownolegle 2sc3039 z rez. na bazie 20kR i nadal zwarcie....:(
  • Poziom 35  
    555 kluczowal tranzystor przez jakies 5min po czym sam z siebie wyzional ducha. Tranzystor jest nadal sprawny. 4047 kluczowal tranzystor 10 sekund po czym przestal dzialac.
    G na 4069 wogole przestal chodzic, uklad jest uszkodzony,rzuca f od miedzy 100 a 180(??)kHz i zerowa wydajnosc pradowa, G siada nawet po podlaczeniu dowyjscia bramki kolejnej bramki.
    CZY JEST MOZLIWE ZE BRAK GASIKA (albo czegos innego) SPOWODOWAL USZKODZENIE GENERATOROW??
  • Poziom 20  
    Nie brak gasika (to już inna sprawa chociaż też ma wpływ) tylko brak rezystora ograniczającego prąd bramki mosfeta - jego pojemność wejściowa jest rzędu 1nF i taka pojemność potrafi bardzo szybko "unieszkodliwić" praktycznie każdy zwykły układ cyfrowy.
  • Poziom 35  
    Aha dzieki :) z tego co widzialem na schematach te ezystory na bramce maja 10R...? tyle sie stosuje? cZy jakie powinny byc te rez ograniczajace?
  • Poziom 20  
    Przy sterowniku który wytrzyma spore impulsy prądowe (0,5 - 1A) może być nawet mniejszy.
    Dla mniejszych częstotliwości stosuje się nawet rezystory rzędu 100Ω co bardzo upraszcza sterowanie mosfeta ale zwiększa trochę straty w nim.
    Jeśli nie chcesz wgłębiać się w szczegóły najlepiej potraktować mosfeta jako zwarcie dla sterownika i dać taki rezystor żeby sterownik to przeżył.
    O ile 555 poradzi sobie tylko z rezystorem właśnie 100Ω to reszta układów o których wspomniałeś musi mieć dodatkowy driver.
  • Poziom 35  
    Sytuacja jest taka:
    Podlaczylem jako G TL494 wg schematu
    flyback do samochodu z TDA7294 (albo jakikolwiek inny...)
    Z nozki 10 bralem sygnal sterujacy przez rez 820R do mosfeta.
    Efekt:
    Sam mosfet (wsadzilem nowke irf540) bez trafa chodzi, zmierzylem f, dalem rezystor 3.3R zamiast trafa, i wszystko ok. Rezystor grzeje sie tak jak powinien :)
    Podlaczylem trafo. Podlaczylem gasik. Ulamek sekundy po wlaczeniu zasilania ZANIKA SYGNAL KLUCZUJACY. Uklad ulegl spaleniu.
    Myslalem ze trefny '494 wiec wsadzilem INNY ktory zrobil dokladnie to samo. Mosfety nie ruszone, 2 TL494 zfajczone. Tak samo popalilo drivery na dwoch 555, spalilo 4047 z wtornikiem....
    Co sie dzieje ze mosfet po podlaczeniu trafa pali driver ale sam sie nie pali?

    Dodano po 2 [minuty]:

    btw. f=110kHz....
    Trafo:
    szczelina 2mm, flyback, 1x12 pierwotne, brak wtornego
    Gasik: Dioda FR302 zaporowo
    Vzas = 13,2v
  • Poziom 20  
    1 Układ nie miał prawa działać TL494 na wyjściu ma pojedynczy tranzystor który może jedynie w tym wypadku włączyć mosfeta - potrzebny jest dodatkowy tranzystor wyłączający go.
    Zobacz tu:
    http://sklep.avt.com.pl/photo/_pdf/AVT2732.pdf

    2. Na pewno sie spaliły te układy czy jedyny objaw to ten zanik sygnału kluczującego?
    Padnięcie ich byłoby co najmniej dziwne - czym zasilasz tę przetwornice? I rozrysuj najlepiej pełny schemat.


    --
    Nie pomyliłeś się przy Ct i Rt dla tych wartości to przetwornica pracowałaby na 11kHz.
    Przy takim gasiku jakbyś uruchomił tę przetwornicę to dioda i tranzystor by tego nie przeżyły.
  • Poziom 35  
    Heh TEORETYCZNIE sie spalily...Fakt ze jedyny objaw jest zanik przebiegu na wyjsciach. W ukladzie ktory odpalalem c=2.7n r=820R ale co wlaczylem zasilanie od nowa to f plywa
    pierwszy raz zasililem '494 i f=180KHz (?)
    za drugim i trzecim razem f=110kHz i tak zostalo
    Przetwornica jest zasilana 12 v z prostownika zamochodowego 10A
    Czy aplikacja 494 moze wygladac tak:
    flyback do samochodu z TDA7294 (albo jakikolwiek inny...)??
    Jaki dac gasik?
    Schemat wyglada tak:
    flyback do samochodu z TDA7294 (albo jakikolwiek inny...)
    Schematu G brak, poniewaz w to miejsce zostaly wstawione wszystkie wyzej wspomniane uklady...
    [CMOSy mialy drivery najprostsze na BC547/557]

    Dodano po 4 [minuty]:

    flyback do samochodu z TDA7294 (albo jakikolwiek inny...)
    w necie znalazlem cos takiego.....Da sie to uzyc?
  • Poziom 20  
    Te przetwornicę push-pull z poprzedniego tematu też tak zasilałeś? Prostownik jak wynika z nazwy tylko prostuje napięcie ale nie zawiera kondensatora przy takim zasilaniu to żadnej przetwornicy nie uruchomisz- dorzuć jakieś kondensatory na zasilanie chociaż 1000µF ale lepiej więcej.

    A schematy oprócz ostatniego nie mają szans na działanie - mają nieodpowiednie sterowanie mosfetów. Zobacz jak jest w tym linku co Ci podałem. Rezystor na bramce daj nie więcej niż 100Ω. Ten dławik na masie to też nie jest dobry pomysł. I radzę przerobić sterowanie mosfetów na takie jak w linku (dla TL-a).
  • Poziom 35  
    W tym linku sa na wyjsciach tranzystory z jakimis diodami :) opis uwaznie przestudiowalem ale za skomplikowany poniewaz nie chce odpalac fool-proof sps'a do zastosowan wojskowo-kosmicznych :)tylko cos co mi pochodzi pare tyg w samochodzie bo radio samochodowe padlo :D
    Czy te tranzystory z linka mozna zastapic jakimis BC5xx?? Tylko takie mam w chacie a sklep daleeeko (wies :( )
    Co zrobic zeby '494 na nowo zaczely generowac przebieg? (albo jak sprawdzic ich smierc...) :) :)
    Co do zasilania to fakt, push-pull rowniez byl zasilany wlasnie tak z prostownika.
    A czy 40mF wystarczy do filtracji tak zeby cos wreszcie zaczelo dzialac?? :D Akurat mam 4x10mF 63V (z zasilki do wzmaka)
  • Poziom 20  
    Kondensatory mogą być.
    Do wyjścia TL-a podłącz coś takiego:
    flyback do samochodu z TDA7294 (albo jakikolwiek inny...)
    Te tranzystory Bc jeśli są pnp to raczej tak ale mógłbyś podać coś dokładniej.
    Jak sprawdzić? Podłącz go do normalnego zasilania i sprawdź czy działa - czy jest sygnał na wyjściu :D
  • Poziom 35  
    Tranzystory to sa BC557 i 558 (ktore lepsze?) ale one sie chyba malo co roznia. Nrmalne zasilanie = mocno filtrowane? mam zasilacz o tetnieniach 8mV (hyba) ale tylko 0.5A wydajnosci...
  • Poziom 20  
    Daj ten 557 - ale przydał by się o większym prądzie - a rezystor bramkowy 100Ω.
    Co do zasilania - ważne żeby w ogóle było filtrowane :D , a wydajność 0,5 A do testu TL-a wystarczy aż za nadto. Możesz podłączyć go do prostownika tylko nie zapomnij o filtracji.
  • Poziom 15  
    w układach przetwornic eksperymentowanie kończy się źle. Trzeba to zrobić zgodnie ze sztuką według not katalogowych gotowych schematów. Twoje eksperymenty przypominają mi powtórne badania nad wynalezieniem koła. Zrób to tak jak inni. Są przyczyny dlaczego przetwornice robi się tak a nie inaczej.
  • Poziom 39  
    Minimalna wartość rezystora w obwodzie oscylatora TL494 to 1k8 - polecam lekturę noty katalogowej.
    Dla uzyskania 50kHz użyj RT=10k i CT=1n. Nie używaj kondensatorów ceramicznych jak CT gdyż są mało stabilne temperaturowo.
    Jeśli scalaki pochodziły z uszkodzonych zasilaczy ATX, to z dużym prawdopodobieństwem są popalone.
  • Poziom 35  
    1. gregxp
    557 podlaczony no i wszystko byloby spoko gdyby jeszcze kturys TL chcial dzialac :D jutro kupie pare sztuk nowych.....
    2. you-zek
    Experymenty dobrze robia na poszerzanie wiedzy...: a co do robienia zgodnie ze sztuka - fakt, sa zasady ale ja nie mam zamiaru ich lamac, tyle ze 99,9% przetworek jest zbyt rozbudowana jak dla mnie..potrzebuje cos prostego co bedzie "chodzic" i nic wiecej nie ma robic jak tylko dostarczac napiecie do koncowki mocy (niestabilizowane, wogole niech dostarcza JAKIEKOLWIEK napiecie byle symetryzne :))
    3.lechoo
    thx za podpowiedz Jesli to faktycznie wina rezystora to go wymienie....TLki pochodza z wylutu ale z dzialajacych zasilaczy, rzecz w tym ze oba pieknie generowaly przebieg po wylutowaniu a po podlaczeniu mosfeta (chyba) szlak jednego i drugiego trafil...
  • Poziom 40  
    zamiast tyle kombinowac to juz dawno wykonalbys prawdziwy uklad z prawdziwego schematu.
    A jak chcesz problemy to mozesz wykonac przetwornice samowzbudna, trafo plus dwa tranzystory i to wszystko! Takie uklady stosowane byly w starych magnatach ktorych schemat mozna sciagnac z elektrody.