Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Fleshowanie biosu laptopa programatorem - problem

10 Cze 2007 03:48 1545 2
  • Poziom 11  
    Problem wygląda następująco:
    Laptop Dell inspiron 4150 P4 1,6GHz Bios A6
    Laptop działał prawiłdowo, ale ponieważ był w obudowie Della C640, wpadłem na pomysł zmiany biosa na najnowszy do modelu C640.
    Płyta w jednym i drugim modelu jest bliźniacza, więc podejrzewam że oba modele różnią się jedynie biosem.
    Przełożyłem kość do programatora (Willem ver.4), który odczytał ją prawidłowo, natomiast przy programowaniu po około 20% wyrzucał błąd.
    Pomogła ingerencja w programator (wylutowałem kość 34063) i proces programowania przebiega bez błędów do końca. Weryfikacja też jest ok.

    Jednak po włożeniu kości do laptopa, laptop nie startuje, to znaczy na ok 2 sek zapalają się zielone lampki, mrugnie matryca i laptop sie wyłącza.
    Wygląda na to jakby nie było inicjacji wczytywania biosu.

    Moje pytanie: Czy w kości biosu jest zapisany również program inicjujący wczytywanie tego biosu przy uruchomieniu ?

    Robiłem próby z różnymi biosami (wyekstrachowanymi z plików exe) przeznaczonymi do C640 jak i do Inspiron 4150 i efekt za każdym razem był taki sam. Próbowałem też z wsadem wcześniej zgranym - efekt negatywny

    Powoli zaczyna brakować mi koncepcji, dlatego proszę o wsparcie i sugestie, jak ponownie ożywić tego laptopa

    Kość biosu 49LF0004A
    Napięcia programatora Vpp= 12,5V, Vcc=6,2
    opóźnienie = ok 150 us

    twp=6us
    twc=60us
  • Poziom 12  
    Programatorem tego nie zrobisz zanieś do serwisu będzie taniej
  • Poziom 11  
    Błąd polegał na ekstrakcji biosu z pliku exe (zły format zapisu piku - prawidłowy to ROM.
    Właściwa ekstrakcja, zafleshowanie i laptop działa jako C640.
    Zamykam wątek - problem rozwiązany