Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Trzaski podczas odtwarzania muzyki...

wydramax 07 Sie 2007 13:47 3814 17
  • #1 07 Sie 2007 13:47
    wydramax
    Poziom 16  

    Witam!

    Mam wieżę podłączoną do komputera i podczas odtwarzania muzyki gdy dam w miarę głośno zaczynają sie dziwne trzaski a czasem piszczenie.

    Co może być przyczyną i co mogę z tym zrobić?

  • Pomocny post
    #2 07 Sie 2007 14:48
    wiezlak
    Poziom 35  

    Dzieje się tak, gdy ustawisz suwak głośności w mikserze karty powyżej pewnego poziomu (ok. 60-70%)? Jeśli tak, to po prostu przesterowujesz przedwzmacniacz w wieży zbyt mocnym sygnałem niskopoziomowym. W takim przypadku ustawiasz globalny suwak głośności w mikserze karty na ok. 60% (a Wave, MIDI na maksimum) i poziomem głośności sterujesz w wieży. Aha - powyłączaj nieużywane wejścia (liniowe, analogowe CD, mikrofonowe) - będziesz miał mniej zakłóceń.

    Jeśli zaś problem nie jest związany z poziomem głośności ustawianym w PC, to przyczyną może być przesterowanie wzmacniacza wieży (za bardzo "odkręcona" gałka głośności), podłączenie kolumn o zbyt niskiej impedancji, uszkodzone zwrotnice kolumn itp.

  • #3 07 Sie 2007 19:08
    wydramax
    Poziom 16  

    Tak zrobiłem,
    jednak jeszcze przy większej głośności da się usłyszeć nieduże trzaski.
    Może to jest spowodowane przez jakieś zakłócenia?

    Z wieżą jest wszystko w porządku, jest to fabryczny zestaw Thomsona, nic nie było w nim zmieniane itp.
    Trzaski pojawiają się tylko jak puszczam muzykę z komputera, jak gra radio, magnetofon lub CD wszystko jest ok.

  • Pomocny post
    #4 07 Sie 2007 19:25
    447988
    Usunięty  
  • Pomocny post
    #5 07 Sie 2007 19:48
    wiezlak
    Poziom 35  

    Zatem problem nieco zelżał po obniżeniu poziomu głośności w PC i powyłączaniu zbędnych wejść? Jeżeli tak, to spróbuj jeszcze trochę niższego poziomu (zazwyczaj odpowiedni poziom sygnału zapewnia ustawienie w zakresie 40-60%). Muzyka z PC powinna grać z podobną głośnością, jak z pozostałych źródeł.

    Trzaski są losowe, czy pojawiają się w rytm muzyki lub przy większym natężeniu dźwięku? Jeśli losowe, to obstawiam na zakłócenia pochodzące z PC (łatwo to zweryfikować obniżając poziom głośności w mikserze karty do minimum). Kabel połączeniowy masz ekranowany a wtyczki dobrze polutowane? Trzaski występują w muzyce MP3 czy w CD Audio również? Próbowałeś dokonać odsłuchu na słuchawkach podłączonych bezpośrednio do karty dźwiękowej?

    Jeszcze jedno - czy nie masz ustawionej jakiejś programowej equalizacji dźwięku? Przy zbyt agresywnych ustawieniach wprowadzać będzie słyszalne zniekształcenia.

  • #6 07 Sie 2007 22:17
    wydramax
    Poziom 16  

    Mam:
    -karta dźwiękowa zintegrowana
    -Realtek AC97 Audio
    -odtwarzam przeważnie mp3
    -Windows Xp professional service pack 1
    -odtwarzacz Windows Media Player
    -kabel ok. 2,5m własnej produkcji jack-2chinch'e
    -Ustawienia equalizera - Techno

    Trzaski są losowe, ale pojawiają się przy większej głośności.

  • Pomocny post
    #7 08 Sie 2007 00:45
    447988
    Usunięty  
  • #8 08 Sie 2007 01:56
    miniu1
    Poziom 19  

    Podłączę się do tematu, bo mam podobny problem.

    ...ale trochę inny.

    Mam laptopa IBM 390x (PIII 450, 256 ram, HDD 9,1GB, XP sp2).
    Odtwarzając muzykę przez Winampa słychać zacięcia (i to w głośnikach samego laptopa, jak i w słuchawkach podłączonych do niego)... Kombinowałem z equalizerem, poziomami itd - nic.
    Zauważyłem, że zacięcia pojawiają się mniej więcej zgodnie z miganiem LED HDD - czyli zakłócenia pochodzą chyba od HDD ...
    Może ktoś spotkał się z takim problemem i zna rozwiązanie?

  • #9 08 Sie 2007 09:00
    wydramax
    Poziom 16  

    Dźwięk na słuchawkach jest czysty bez żadnych zakłóceń.

  • Pomocny post
    #10 08 Sie 2007 10:12
    wiezlak
    Poziom 35  

    Kolego wydramax - zrób jeszcze odsłuch na słuchawkach podłączonych do wieży. Jeśli będą trzaski, to wykluczymy kolumny - trzeba będzie się skupić na połączeniu karty z wieżą i poziomem sygnału. Przydałoby się wypróbować inny kabel połączeniowy. Spróbuj też ułożyć go tak, by nie biegł razem z kablami zasilającymi.

    Jak zachowuje się sprzęt w neutralnym ustawieniu equalizera w PC? Nie podbijasz jeszcze dodatkowo dźwięku z poziomu wieży? Zmniejszałeś jeszcze bardziej poziom głośności w mikserze? Czy to słuchanie "w miarę głośno" to nie jest już czasem kres możliwości wieży (zwłaszcza, że podbicia w equalizerze powodują oddawanie większych mocy, niż przy ustawieniu neutralnym)?


    Kolego miniu1 - zacięcia dźwięku, czy zakłócenia bez przerw w odtwarzaniu? Jeśli zacięcia, to upewnij się, że dysk pracuje w trybie DMA (panel sterowania -> właściwości systemu -> menedżer urządzeń -> kontrolery IDE). Jeśli zakłócenia, to na próbę powyłączaj w mikserze wszystkie zewnętrzne źródła dźwięku.

    Pod innym odtwarzaczem (np. systemowym WMP) dzieje się to samo? Jeśli tak, to sprawdź w menedżerze urządzeń, czy nie ma konfliktu zasobów karty dźwiękowej z innym urządzeniem (chodzi o przerwania IRQ - część urządzeń "nie lubi" pracować na współdzielonym z innym urządzeniem przerwaniu). Sterowniki dla karty zainstalował XP, czy Ty instalowałeś dedykowane od producenta?

  • #11 08 Sie 2007 14:45
    miniu1
    Poziom 19  

    Dzisiaj patrzyłem i dysk chodzi na PIO4 ... Nie umiem przestawić na DMA w tym pierońskim XP PRO. Konfliktów nie ma. Sterowniki te, które trzeba były od IBM-a.

  • #12 08 Sie 2007 14:58
    wiezlak
    Poziom 35  

    Zatem na winowajcę wygląda ustawiony tryb PIO4. Usuń kontroler IDE z poziomu menedżera urządzeń i zrestartuj PC - powinno pomóc (przy ponownym uruchomieniu system załaduje te sterowniki od nowa i powinien ustawić napędy na najwydajniejszy tryb). Jeśli problem z wymuszonym trybem PIO4 będzie istniał nadal, to trzeba zerknąć do BIOSu lub/i przyjrzeć się dyskowi, bo może szwankować zaczyna.

  • #13 08 Sie 2007 21:51
    wydramax
    Poziom 16  

    Zmniejszyłem trochę agresywne ustawienia equalizera i wszystko narazie jest ok. A wyjściowy sygnał mam na około 40-50%.

  • Pomocny post
    #14 08 Sie 2007 22:46
    wiezlak
    Poziom 35  

    Więc sytuację masz właściwie opanowaną. Przy podbijaniu pasma equalizerem powinno się jeszcze bardziej zmniejszyć poziom głośności (gdyż po takiej equalizacji poziom sygnału wyjściowego rośnie). Jeśli np. użyjesz jako odtwarzacza WinAmp, to przy manipulowaniu equalizerem pomagasz sobie suwakiem preamp, żeby pozbyć się przesterów.

  • #15 09 Sie 2007 00:38
    miniu1
    Poziom 19  

    Kolego Wiezlak, dzięki za dobrą radę. Było, jak mówisz: w sumie dwa restarty i wskoczył DMA2, choć dysk obsługuje DMA4, ale to chyba wina starego chipsetu BX/ZX. Muza chodzi teraz dobrze - dziękuję i zaraz poślę punkty.

  • #16 09 Sie 2007 08:27
    wiezlak
    Poziom 35  

    Tak, kontroler w chipsetach i440BX/ZX obsługuje tryby do Ultra DMA 2 włącznie (czyli 33,3MB/s). Taki tryb się ustawił, czy może Single Word DMA 2 (8,3MB/s) lub Multi Word DMA 2 (16,7MB/s)?

    Punktów mi nie potrzeba - cieszę się, że problem rozwiązany - oddaję koledze z odsetkami :).

  • #17 09 Sie 2007 09:45
    wydramax
    Poziom 16  

    Dziękuję wszystkim za pomoc w rozwiązaniu mojego problemu.

  • #18 09 Sie 2007 14:21
    miniu1
    Poziom 19  

    Dla dysku ustawiło DMA2, a dla CD Multi Word DMA 2. Dziękuję za punkty (tak dużo?!).

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME