Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Problem z uruchomieniem Win XP - brakujące pliki

holcer 18 Sie 2007 17:33 4861 22
  • #1 18 Sie 2007 17:33
    holcer
    VIP Zasłużony dla elektroda

    Witam. Wczoraj, podczas uruchamiania komputera nagle, przed tym pierwszym ekranem, gdy ma się pokazać logo XP i niebieski paseczek postępu pojawił mi się napis:

    Code:
    Brak pliku NTLDR
    
    Naciśnij Ctrl + Alt + Del, aby zrestartować


    Tak więc grzecznie naciskam ową kombinację, ale po ponownym uruchomieniu wyskakuje mi to samo. Można tak w kółko. Postanowiłem Spróbować Konsoli odzyskiwania (czy jakoś tak) z płyty Windowsa. Odpalam płytę, czekam, pokazuje się bluescreen i na dole teksty co to się nie ładuje, po chwili ekran gaśnie, potem znów się robi bluescreen i wyskakuje sam napis:

    Code:
    COOOO221 Hard disc error
    
    SystemRoot\System32\ntdll.dll


    O dziwo czasem (raz na 20 resetów) uda się włączyć z płyty tą konsole, ale szczerze mówiąc nie wiem co mam dalej zrobić. chkdsk nic nie daje, a w katalogu gł na dysku na którym mam zainstalowany sys jak byk widnieje plik ntdll.dll.

    Już nawet instalowałem Winde na 2-gim sysku, ale z tamtego też nie odpala, tylko pokazuje ten piekielny brak pliku NTLDR


    Proszę o jakieś sugestie. Chciałbym uniknąć formatu dysków, gdyż mam tam 450 GB danych.
    Pozdrawiam

    0 22
  • #2 18 Sie 2007 17:52
    kaczy99
    Poziom 23  

    Spróbuj przywrócić fabryczne ustawienia bios-a, u mnie to się nazywa "Load Default" jak nie podziała to uruchom konsole odzyskiwania i wpisz:

    Code:
    copy e:\i386\ntdlr c:\
    gdzie e: to litera napędu w którym jest płyta z winXP a c: to litera dysku z windowsem.

    0
  • #3 18 Sie 2007 18:06
    holcer
    VIP Zasłużony dla elektroda

    Może to się wyda dziwne, ale teraz zauważyłem, że mam system zainstalowany na partycji H, a zawsze był na C i jest to na 100% ta instalka co poprzednio chodziła z C, bo są tam inne foldery z moimi plikami :?. Czy to możliwe, żeby w jakiś sposób zmiana litery partycji z Windą na to wpłynała. Czy Winda musi być zainstalowana na 1-szej partycji z rzędu na dysku? (poprzednio gdy ta partycja nazywała się C, była pierwszą). Wreszcie - czy da się zmienić literę partycji z poziomu konsoli?
    Pozdrawiam

    kaczy99- ide sprawdzić Twój sposób.

    0
  • #5 18 Sie 2007 18:18
    am44
    Poziom 20  

    Podczas startu, pliki ntldr i ntdll.dll muszą załadować się do pamięci. Jeżeli są fizycznie na dysku, to może być problem z odczytem z dysku lub z pamięcią. Proponuję sprawdzić taśmę dysku oraz przeczyścić styki pamięci. Można też sprawdzić RAM programem Memtest, uruchomionym z dyskietki.

    0
  • #6 18 Sie 2007 18:28
    holcer
    VIP Zasłużony dla elektroda

    A można z Pendrive'a? Nie posiadam u siebie stacji dyskietek. Sprawdzę te taśmy dysków, bo ostatnio często przenosiłem swoje HDD, ale między ostatnim ich podłączeniem a tą awarią działały całkiem dobrze.

    0
  • #7 18 Sie 2007 18:35
    mat_ed
    Poziom 43  

    Cytat:
    A można z Pendrive'a?

    wszystko zalezy od tego czy masz taka mozliwosc ustawienia w BIOS-ie aby bootowal z PD.

    0
  • #8 18 Sie 2007 18:37
    kaczy99
    Poziom 23  

    holcer napisał:
    ... Czy to możliwe, żeby w jakiś sposób zmiana litery partycji z Windą na to wpłynała. Czy Winda musi być zainstalowana na 1-szej partycji z rzędu na dysku?...
    Windows nie musi być zainstalowany na pierwszej partycji, jednak nagła zmiana litery dysku mogła wywołać ten błąd podczas uruchamiania systemu.

    0
  • #9 18 Sie 2007 19:04
    am44
    Poziom 20  

    Zmiana liter dysków nie następuje samorzutnie. Podczas instalacji systemu na drugim dysku, Instalator zmienił kolejność. Można to zmienić, używając płyty instalacyjnej tz. wybieramy instalację na dysku H > pozostaw partycję bez zmian i wyłączamy komputer.

    0
  • #10 18 Sie 2007 19:09
    holcer
    VIP Zasłużony dla elektroda

    Czyli mam nagle wyłączyć zas. komputera zanim cokolwiek zainstaluje, czy pozwolić mu na zainstalowanie Windowsa? Nie chciałbym stracić swoich danych z tego dysku.

    0
  • #11 18 Sie 2007 19:26
    Krzyq
    Poziom 22  

    Będę brutalny, ale z tego co pamiętam ten błąd dotyczył głównie pirackiego oprogramowania. Może się mylę, ale zawsze spotykałem go na podróbach - bo tyczył się rozwalenia systemu obrony ingerencji w stabilność oraz doładowania kodów destrukcyjnych - jak to zawsze w piratach z gieudy bywa. No i były problemy aby go obejść - dopiero po użyciu wgraniu oryginału udawało się cokolwiek zrobić. Możliwe ale wątpliwe może być wymuszenie zmiany opisu wolumenów jeśli tylko wyciągałeś dysk lub podłączałeś nowe i zmieniłeś zworki, taśmy.

    XP powinien odpalać z płyty lub z dyskietki - oryginały zawsze dawały sobie z tym radę. Skoro mówisz że widać dysk na partycji H, to powinieneś zbotować kompa z orginalnego nośnika i na systemie ustawić parametry z powrotem - tak jak poradził mat_ed. System od biedy można uruchomić z PenDrive, ale musisz włączyć w biosie aktywację USB jako nośnika danych - to że USB działa pod Windowsem nic nie oznaczało.

    Tu miałbyś opis tego wszystkiego: https://www.elektroda.pl/rtvforum/topic400665.html , ale niestety Userzy się nie popisali.

    Więcej info o tworzeniu botowalnego USB z systemem tutaj: http://www.poradyit.pl/index.php?option=com_content&task=view&id=518&Itemid=34

    Natomiast z tego co pamiętam jeśli masz dyskietkę startową - to wystarczy jej pliki przenieść na sformatowany PenDrive i po aktywacji USB i ustawieniu go na FirsfBootDevice w Biosie na nowych płytach widziany powinien być jako zwykły dysk.

    Dodano po 7 [minuty]:

    holcer napisał:
    Czyli mam nagle wyłączyć zas. komputera zanim cokolwiek zainstaluje, czy pozwolić mu na zainstalowanie Windowsa? Nie chciałbym stracić swoich danych z tego dysku.


    XP jest instalowany inaczej niż Windows 95, nie ma wymagania pełnego formatu. W końcu programiści z MS, popatrzyli się na Linuxa, który kontynuował tradycję Norton Commandera. Windows można instalowac na tej samej wersji bez utraty danych, przynajminej znajomy tak zrobił kiedy pokaszniły mu się sterowniki. Przypominało to nałożenie od nowa paczek Debiana - system zainstalował się od nowa jak każdy inny program, poprawił łącza z jądrem, ale cała reszta poprostu została nie zmieniona. Oczywiście takie zachowanie powoduje faktycznie kupę problemów które wyjdą za jakieś pół roku, ale do tego czasu laboratorium MS zaleca format dysku (z tego co pamiętam wg zaleceń raz na miesiąc była defragmentacja, co pół roku format). ;)

    0
  • #13 19 Sie 2007 16:51
    holcer
    VIP Zasłużony dla elektroda

    Witam. Zrobiłem tak - odłączyłem tamten dysk, bo już nic nie mogłem wykombinować - niestety nie chciał się uruchomić na nim za chiny ludowe. Podłączyłem drugi i na nim zainstalowałem raz jeszcze winde. Komputer odpalił wreszcie. Mam tylko teraz taki problem -
    1. wyłączyłem go, podłączyłem poprzedni dysk, odpaliłem windows (ten nowozainstalowany) i w "Mój komputer" jest on widoczny, ale nie mogę przejść do swojedo dawnego folderu moje dokumenty w "documents and settings" na tym poprzednim dysku - wyświetla się okienko z inf. "Odmowa dostępu". Jak mogę się dostać do tamtych plików?

    2. Czy skopiowanie folderu "Program Files" z tamtego dysku wystarczy aby programy się odpalały na tyym windowsie?

    3. Podobno gdy zainstaluje się windows najlepiej umieścić foldery plików TMP na osobnym dysku, tak samo ze swap'em. Jak je przenieść, aby programy wiedziały gdzie ich szukać?

    Dodano po 15 [minuty]:

    Problem nr 4: - dysk na którym jest zainstalowany windows powinien mieć i miał 250 GB (oczywiście nie równe, ale prawie), a w "zarządzaniu dyskami" widnieje jako 128 GB. Jak to naprawić?

    0
  • #14 19 Sie 2007 17:21
    kaczy99
    Poziom 23  

    1. Niewiem
    2. Niektóre może zadziałają, ale większość raczej nie.
    3.Nie wiem jak przenieść Temp, a swap przenosisz w "Mój Komputer> Właściwości> Zaawansowane> Wydajność> Ustawienia> Zaawansowane> Pamięć Wirtualna> Zmień". I tam ustawiasz Wielkość dla poszczególnych partycji .
    4.Sprawdź to programem np. Paragon Partition Manager 7.0 Professional, tam będzie pisać jakie masz partycje i czy jest jakieś nieprzydzielone miejsce.

    0
  • #15 19 Sie 2007 17:29
    holcer
    VIP Zasłużony dla elektroda

    1. Kur... Z czego to może wynikać? Tamto konto miałem zabezpieczone hasłem, czy dlatego może mi nie chcieć udzielić dostępu do niego?
    2. Jak wyżej...
    3. Czyli usunąć swap z tej partyji całkowicie i stworzyć identyczny na innej (na 2-gim dysku) czy tą zostawić i stworzyć 2-gą na innym dysku?
    4. Ok co prawda pobrałem wersję 8.5, ale i tak rozwiązał on problem z dyskiem. Dzięki.

    0
  • Pomocny post
    #17 19 Sie 2007 17:38
    kaczy99
    Poziom 23  

    1. J.W.
    3. Tak, usunąć na tej i utworzyć (niekoniecznie) taki sam na innej.
    4. Nie ma sprawy :D

    0
  • #18 19 Sie 2007 18:26
    bomber
    Poziom 24  

    Ja tez ostatnimi czasy miałem taki dziwny przypadek ze mi znikło trochę plików z C: :D Było to około 20 plików ze sterownikami(zrobiłem zapisywanie uruchamiana i potem zobaczyłem w raporcie) i jeszcze jakieś inne systemowe . Dysk tez mam wiekszy niz 120 i byly problemy z widzeniem tej dodatkowej pojemnosci w awaryjnym po zabawie z konsola i doprowadzeniu systemu do uzytku w trybie awaryjnym... Uważam ze to wina jakiegos wirusa/robaka bo ściągnąłem własnie tamtego pieknego dnia program do sprawdzania czy ktos jest niewidoczny na gg bo mi bardzo zależało żeby kogos sprawdzic ... (dziewczyne :D ). Oczywiscie miałem wtedy antywria (avast) ale jak widac pliki i tak wcieło objawilo sie to zawieszeniem komputera który byl bardzo stabilny (zwiecha moze raz na 2 miechy miałem ...) i po restarcie juz sie system nie zaladował, a bardzo watpie ze akurat w tym momencie zapisywał te pliki i były one w buforze- nie robiłem defragmentacji w tym czasie. I dokladnie tak jak autor tematu probowałem roznymi sposobami (miałem 2 system zapasowy i z niego działałem i szukałem w necie porad i wykonywałem opercje..). Po zmarnowaniu na te zabowy około 5 godzin dałem sobie spokój bo ciągle czegos brakowało i format c: i po sprawie ... Jakbym nawet uzupełnił pliki to bym sie bał o taki system bo pewnie by były z czymś problemy.
    Wiec moim zdaniem isc do kolegi z dużym dyskiem skopiować dane w tym wypadku bo cos sie namieszalo z partycjami i zrobic od nowa cały dysk. Dla mnie bezawaryjnosc przede wszystkim nie ma co na tym oszczedzać czasu bo zapewne bedzie problem wtedy kiedy nie masz czasu i sprawa jest gardłowa...(np. chcesz szybko coś zainstalować bo musisz coś zrobić na jutro a tu error) i lipa ... :D

    0
  • #19 19 Sie 2007 20:20
    holcer
    VIP Zasłużony dla elektroda

    Niestety pomimo 2 krotnego formatowania problem znów się powtórzył :?. Zainstalowałem znów system na całkowicie wyczyszczonym dysku. Mam nadzieję, że teraz już mi nie wywinie jakichś figli. Teraz niestety muszę całą zabawę z optymalnym ustawieniem sterów i dopasowaniem wszystkiego zaczynać od nowa. Sprawdziłem RAM jak ktoś wcześniej radził i RAM jest ok. MEMTEST nie pokazał żadnych errorów. Podłączę ten drugi dysk i ściągne z niego swoje dane. Czy to możliwe, że to dysk tak namieszał? Partycja o której już wcześniej pisałem - ze starym systemem chyba już totalnie ogłupiała - najpierw się nazywała jak już pisałem "C" i zmieniła się sama na "H", a teraz znów ma literę "G" :?, nie wiem jakim cudem. W ustawieniach tego dysku nie grzebałem 8-O Pozdrawiam

    0
  • #20 19 Sie 2007 20:23
    bomber
    Poziom 24  

    Moze zrob test oprogramowaniem producenta (nie zapisu) oraz popróbuj wymiane taśmy, inne złącze itp..

    0
  • #21 19 Sie 2007 20:44
    holcer
    VIP Zasłużony dla elektroda

    Teraz, po formacie wrócił problem znikającej części dysku - dysk który ma w rzeczywistości 250 gb widnieje jako 128GB :? .Próbowałem znów go sprawdzić Partition Magic'iem, ale on tym razem pokazuje to samo.

    Dodano po 3 [minuty]:

    A HD Tune wykrywa oba (jeden 200, a drugi 250 GB) jako dyski 137 GB. Oszaleć można.

    0
  • #23 19 Sie 2007 22:02
    holcer
    VIP Zasłużony dla elektroda

    A widzi kolega, że się nie słyszało :D . Rzeczywiście - po formacie instalowałem WIN z płyty i nie zainstalowałem żadnych aktualizacji. Teraz już mam SP2 i wszystkie stery i śmiga :D . Dyski też już pokazuje normalnie.

    0