Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ATMega 8 i swietlowki....

rokoko 06 Wrz 2007 01:05 2083 7
  • #1 06 Wrz 2007 01:05
    rokoko
    Poziom 20  

    Witam serdecznie!
    Moj problem dotyczy centralki otwierania bramy na uC ATMega 8.... Otoz w momencie zalaczenia swietlowek (ktore nie sa sterowane tym ukladem, ale zasilane z tej samej fazy) atmega momentalnie sie resetuje. Zastosowane zasilanie do ukladu centralki bramy: Trafo 230/12V 0,84A->prostowanie 2-u polowkowe->kondensator->stabilizator 7805 wraz z aplikacjami na wejsciu i wyjsciu (po 2 kondziorki). Czy ktos mial podobny problem?? Co moze byc przyczyna resetu procka?? Jak mozna temu zapobiec?? Czy wstawienie kondziorka na wejsciu trafo (230V) mogloby przyniesc jakies rezultaty??
    Pozdrawiam....

    0 7
  • #2 06 Wrz 2007 09:20
    Dr_DEAD
    Poziom 28  

    Wymień świetlówki na żarówki :-).
    A tak na serio to spróbuj włożyć, pomiędzy wyjście stabilizatora a kondensatory, EMI filtr np. z serii BLM. Jeżeli to rzeczywiście przechodzi po zasilaniu to powinno pomóc no chyba że to są zakłucenia elektro-magnetyczne.

    0
  • #3 06 Wrz 2007 09:21
    janek1815
    Poziom 38  

    Taki kondensator może pomóc ale nie zawsze. Miałem podobny problem w pomieszczeniu jest 15 swietlówek procek sterujący to ATmega32 . Steruje on silnikami i zaworami dużo pomogły kondensatory podłączone równolegle z cewkami zaworów i silników po 100nf. Ale u ciebie tego nie ma co do resetu samego procka od tych nieszczęsnych świetlówek to ja stosuje rozdzielenie samej gałęzi zasilania procka na którą zakładam dławik 100uH i kodensator elektrolityczny i ceramiczny. Ewentualnie przed dławikiem zakładam diode 1N4148. U mnie się to sprawdza idealnie. Wcześniej każde załączenie powodowało restart

    0
  • #4 06 Wrz 2007 09:41
    rokoko
    Poziom 20  

    Dr_DEAD napisał:
    Wymień świetlówki na żarówki :-).
    A tak na serio to spróbuj włożyć, pomiędzy wyjście stabilizatora a kondensatory, EMI filtr np. z serii BLM. Jeżeli to rzeczywiście przechodzi po zasilaniu to powinno pomóc no chyba że to są zakłucenia elektro-magnetyczne.


    Zakłócenia EM raczej odpadaja gdyz swietlowki znajduja sie w innym pomieszczeniu wiec jedynie co moze przechodzic po zasilaniu....

    0
  • #5 06 Wrz 2007 09:47
    krollew
    Poziom 20  

    Mam nadzieję, że pin RESET ATMegi masz podpięty zgodnie z detasheet'em a nie wisi w powietrzu:?:
    Ja raz testując pewien układ pozostawiłem pin nie podłączony i wszystko działało dopóki nie podłączyłem tegoż układu pod zasilacz impulsowy.

    0
  • #6 06 Wrz 2007 09:53
    rokoko
    Poziom 20  

    Spojrzalem na projekt zastanawiajac sie jak wrzucic kondziorka i dlawik w zasilanie uC i zauwazylem ze pin RESETU wisi w powietrzu.... Sprobuje go podciagnac do +5V wtedy zobaczymy co sie bedzie dzialo..... Pozdrawiam

    Dodano po 4 [minuty]:

    krollew napisał:
    Mam nadzieję, że pin RESET ATMegi masz podpięty zgodnie z detasheet'em a nie wisi w powietrzu:?:
    Ja raz testując pewien układ pozostawiłem pin nie podłączony i wszystko działało dopóki nie podłączyłem tegoż układu pod zasilacz impulsowy.

    wykrakales:D podciagne reset i zobaczymy co bedzie.... a jesli juz mowimy o zasilaniu urzadzen, ktorymi steruje uC to u mnie sytuacja wygladala tak, ze w momencie gdy silniki od bram byly zasilane z trafo toroidalnego to ATMega miala problem z pomiarem napiecia (a dokladniem z pomiarem spadku napiecia na rezystorze pomiarowym do kontroli pradu), problem rozwiazal sie gdy zmienilem zasilanie na zasilacz impulsowy.... czyzby trafo toroidalne mialo az tak duze tetnienia??

    0
  • #7 10 Wrz 2007 18:27
    rokoko
    Poziom 20  

    Podciagniecie resetu do +5V poprzez rezystor 1,1kΩ nic nie dalo :cry: Przeszukalem note katalogowa i nie moge znalezc schematu podciagniecia resetu.... czy moglibyscie pomoc??

    Dodano po 5 [minuty]:

    janek1815 napisał:
    Taki kondensator może pomóc ale nie zawsze. Miałem podobny problem w pomieszczeniu jest 15 swietlówek procek sterujący to ATmega32 . Steruje on silnikami i zaworami dużo pomogły kondensatory podłączone równolegle z cewkami zaworów i silników po 100nf. Ale u ciebie tego nie ma co do resetu samego procka od tych nieszczęsnych świetlówek to ja stosuje rozdzielenie samej gałęzi zasilania procka na którą zakładam dławik 100uH i kodensator elektrolityczny i ceramiczny. Ewentualnie przed dławikiem zakładam diode 1N4148. U mnie się to sprawdza idealnie. Wcześniej każde załączenie powodowało restart

    Co masz na mysli piszac wydzielenie zasilania samego procka?? U mnie sprawa wyglada tak, ze zasilanie ukladu jest realizowane na innym transformatorze anizeli ten do zaislania silnikow. Moglbys dokladniej napisac w ktorym momencie dodajesz dlawik??

    0
  • #8 10 Wrz 2007 18:32
    janek1815
    Poziom 38  

    Oddzielam tylko zasilanie samego procka. Też kiedyś kombinowałem były kondensatory ,transile i inne takie pozostał sam dławik na lini zasilania i kondensatory jak pisałem powyżej. Bardziej odporne na zakłocenia sa procki serii 8051. O Microchip i Motoroli już nie wspomne.

    0
  Szukaj w 5mln produktów