Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

zmontowany L297 & L298N

fojta 06 Wrz 2007 19:05 4826 6
  • #1 06 Wrz 2007 19:05
    fojta
    Poziom 10  

    Witam.

    Poskładałem sterownik silnika krokowego i zabardzo nie chce on poruszyć mojego krokowca.

    W jaki sposób sprawdzić owy układ ...
    Vs = 12V
    Vcc = 5V

    Po podłączeniu obu napięć przy odpiętych uzwojeniach silnika na wyjściach A B C D mam wartości 12V 0V 12V 0 V.

    Gdy tylko podepne uzwojenia silnika na wszystkich wyjściach napięcia ABCD nie osiągają 12V a jest czasem 8 czasem 2 :/ na samym wejściu gdzie podpięte jest 12V z zasilacza napięcie znacznie spada.

    (zasilacz z którego pobieram 12V ma dane wyjściowe 12V 100mA )



    W jaki sposób najlepiej sprawdzić układ czy jest on elektrycznie sprawny ... ?

    BO nie wiem czy układ do bani czy też źle podaje stany sterujące na wejścia L297.

    Proszę o jakieś sugestie ...

    0 6
  • Pomocny post
    #2 06 Wrz 2007 20:24
    bogdan_p
    Poziom 39  

    podstawowe pytanie jaki prąd pobiera silnik krokowy , może wydajność prądowa zasilacza jest zbyt mała
    sprawdzenie l298 najlepiej wykonaj na podstawie tabeli stanów , polecam zastosowanie zamiast uzwojeń silnika 2 przeciwnie połączonych Led + opornik ograniczający , masz wizualną kontrolę stanów na wyjściu , wystarczy podawać odpowiednie stany logiczne według tabeli i sprawdzać ich poprawność http://boss.iele.polsl.gliwice.pl/pdf/STMicroelectronics/1773.pdf
    L297 można sprawdzić podając sygnały step i dir na wejściu , kontrolując stan wyjść częstotliwość sygnału step nie powinna być zbyt duża
    polecam temat o silnikach krokowych oba układy są dość dobrze opisane
    oraz opis gotowego modułu z tymi układami http://www.akcesoria.cnc.info.pl/sterownik_silnika_krokowego_sskb01.htm

    0
  • #3 09 Wrz 2007 23:55
    pukury
    Poziom 35  

    Witam !! Pamiętaj również aby napięcie zasilania logiki ( 5V ) podawać jako pierwsze ! . I oczywiście odpinać jako drugie . W innym przypadku możesz uszkodzić nieodwracalnie układy . pozdrawiam !!

    0
  • #4 12 Wrz 2007 00:31
    fojta
    Poziom 10  

    pukury napisał:
    Witam !! Pamiętaj również aby napięcie zasilania logiki ( 5V ) podawać jako pierwsze ! I oczywiście odpinać jako drugie . W innym przypadku możesz uszkodzić nieodwracalnie układy . pozdrawiam !!



    czy układ mikrokontrolera (atmega8) też sie do tego zalicza ? :(
    bo chyba tak spieprzyłem atmege8

    - na jednej płytce mam sterownik krokowca jak wyżej pokazany,
    - na drugiej płytce mam układ mikrokontrolera.
    - Logiki płytek zasilane są z tego samego układu stabilizatora.

    Dodatkowo dwa porty atmegi podpięte są pod wejścia CW i CLK w celu sterowania krokiem w lewo i prawo.

    no i atmega sie wysypła .... nie mozna z niej juz nic odczytac ani zapisać.

    czy opórcz kolejności podłaczenia napięć może być inny powód takiego zjawiska ?

    0
  • #5 12 Wrz 2007 17:15
    bogdan_p
    Poziom 39  

    Włączanie napięcia odnosi się do sterownika na L297 / L298 , włączając napięcie 5V podajesz je równocześnie również do układów sterowania w Twoim przypadku zasilasz uC

    Cytat:
    no i atmega sie wysypła .... nie mozna z niej juz nic odczytac ani zapisać.

    to że nie można programować ATmegi wcale nie musi mieć nic wspólnego z czym współpracuje , natomiast ważne jest które linie podłączyłeś do sterownika jeżeli to któraś z linii interfejsu ISP mogą pojawić się problemy , kolejna rzecz to jakiego używasz programatora oraz czy przypadkiem nie przestawiłeś któregoś z bitów konfiguracyjnych

    0
  • #6 12 Wrz 2007 18:16
    wawxx
    Poziom 16  

    Witam !
    1. na początek proponuję podłączyć 4 rezystory ca 300 ohmów, które będą symulować uzwojenia silnika krokowego.
    2. może być również problem z L297 i sposobem sterowania. Sam to przeżyłem. Jak włożyłem L297A to ruszyło bez pudła.
    3. muszą być szybkie diody z czasami ca 5 ns, wtedy przy podłączeniu silnika przebieg będzie idealnie prostokątny i pozwolą uzyskać większe szybkości obrotowe.
    4. oczywiście trzeba sprawdzić wydajność prądową zasilacza i pobór prądu przez silnik krokowy.
    pozdrawiam i życzę powodzenia !
    wojtek

    0
  • #7 19 Wrz 2007 19:50
    Krzysieksiek
    Poziom 20  

    Cześć
    Ja problemu szukałbym w zasilaniu. Wydajność zasilacza jest rzędu 100mA, a podłączenie silnika powoduje gwałtowny spadek napięcia.
    Druga sprawa to potencjometr (na twoim schemacie R5) służy do regulacji prądu fazy - czy próbowałeś nim "kręcić".
    Dla porównania załączam schemat sterownika, sprawdzony i działa.
    zmontowany L297 & L298N

    Odsyłam też do strony www.cnc.info.pl

    Ja swój sterownik tzn. logikę zasilam napięciem 5V a silniki z reguły ok 12V.
    Oba te napięcia podaje równocześnie, ale trochę ryzykuje.

    Wyjaśnij jeszcze sposób zasilania. Konkretnie czy z tego "małego" zasilacza zasilasz poprzez stabilizator ten sterownik, układ z Atmeg-ą i omijając stabilizator z tego samego zasilacza zasilasz silnik ?

    -1
  Szukaj w 5mln produktów