Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

wzmacniacz do subwoofera samochodowego na LM3886-problem

adamkaktus 21 Sep 2007 13:58 2367 5
Tespol
  • #1
    adamkaktus
    Level 16  
    Witam kolegów.Pozwoliłem sobie wziąć się za subwooferek do samochodu według jednego z kolegów.Jego układ składał się z przetwornicy Irka, filtru na tl072 i końcówki na TDA. Ja się troszkę wyłamałem i wyskoczyłem na LM3886-kupiłem oryginał w wersji izolowanej. No i tutaj mam mały problemik.Układ zasilany jest z tejże przetwornicy na napięcie +/- 27V(narazie-12V zasilanie przetwornicy).Aplikacja wzmacniacza to ta z AVT(dokładnie). Problem polega na sprzęganiu się końcówki na wysokich częstotliwościach(podejrzewam 40kHz-z przetwornicy)-układ wzmacniacza zaczyna się mocno grzać, słychać lekki szumopisk(ciężko to określić), i gra bardzo cicho. O dziwo jeśli się odłączy głośnik na chwilkę lub odłączy sygnał na moment i podłączy to układ zaczyna pracować poprawnie(przy dołączaniu sygnału oczywiście stuk jest niemiłosierny-ale pomaga).wyłączzy się układ na jakiś czas i znów to samo. I teraz potrzeba mi pomocy.Co może być ie tak?wzmacniacz zamykałem już w stalowym pudełku, prowadziłem masę itp. Czyżby miał być uszkodzony jakiś kondensator? Martwi mnie działanie opóźnionego załączania głośnika-wogóle nie działa-mogę podpiąć nawet gigantyczny kondensator -i tak od razu włącza się ze stukiem.Warto też dodać że przetwornic stopniowo zwiększa napięcie na wyjściu,może jakaś wina w tym jest? Proszę o pomoc, sugestie itd-zastanawiam się nad opóźnionym na przekaźniku, odseparowaniu masy Filtra od masy wzmacniacza kondensatorem na wejściu. Za pomoc będę wdzięczny.
  • Tespol
  • #2
    User removed account
    User removed account  
  • Tespol
  • #3
    adamkaktus
    Level 16  
    Hmm.No dobra, dzięi, spróbuję to zrobić w najbliższej wolnej chwili. A skąd może się to brać że takie rozłączenie sygnału, czy wyjścia pomaga?bo bez przyłączonego sygnału układ się nie sprzęga, może to po kablach sieje?Ciekawe jest to że jak sie podłączy sygnał z powrotem-jest uży stuk-i cisza, ukłąd pracuje normalnie.Postaram się sprawdzić z tymi kondziorami.Dam znać z jakim efektem.
  • #4
    adamkaktus
    Level 16  
    niestety nie pomogło.Nadal piszczy. narazie podpinam to do kolumienki.natomiast zauważyłem że jak się lekko poruszy membraną od basu to jakby ton piszczenia(na wysokim) się zmienia na chwilkę, czyżby to na wyprowadzeniach od głośnika?

    Dodano po 24 [minuty]:

    Acha jeszcze jedna rzecz.Jako że mam oscyloskop to troszkę się pobawiłem nim i się okazuje że tak: na wyjściu prostokąt, na pinie wejściowym prostokąt, ale bardziej podobny do sinusoidy, na zasilaniu na bardzo małym zakresie bardzo dziwny przebieg, ale nie prostokąt.Niestety wygląda na to, że to wina przetwornicy, ponieważ wystarczyło oscyloskop maśą do masy wzmacniacza podpiąć i na wiszącym (nie dotykanym) kablu sondy łapało około +/- 50 mV amplitudy prostokątu:/ no i co teraz z tym robić? Bo TDA miał element opto na wejściu i problemu aż takiego nie było a tu nie zabardzo wiem co poradzić.Za pomoc będę bardzo wdzięczny

    Dodano po 13 [minuty]:

    Acha jeszcze jedna rzecz.Jako że mam oscyloskop to troszkę się pobawiłem nim i się okazuje że tak: na wyjściu prostokąt, na pinie wejściowym prostokąt, ale bardziej podobny do sinusoidy, na zasilaniu na bardzo małym zakresie bardzo dziwny przebieg, ale nie prostokąt.Niestety wygląda na to, że to wina przetwornicy, ponieważ wystarczyło oscyloskop maśą do masy wzmacniacza podpiąć i na wiszącym (nie dotykanym) kablu sondy łapało około +/- 50 mV amplitudy prostokątu:/ no i co teraz z tym robić? Bo TDA miał element opto na wejściu i problemu aż takiego nie było a tu nie zabardzo wiem co poradzić.Za pomoc będę bardzo wdzięczny
  • #5
    andrew16
    Level 16  
    Witaj kolego

    Na początek to spróbuj zasilić wzmacniacz z innego źródła zasilania i go sprawdź jak będzie działał , możesz nawet podpiąć zasilanie +/- 12V gdyż chodzi tylko o sprawdzenie zakłóceń. Jeśli wynik będzie pozytywny ( brak zakłóceń ) to już wiesz gdzie szukać przyczyny zakłóceń.
    Na moją wiedzę , jeśli zakłócenia pochodzą z przetwornicy to musisz sprawdzić poprawność montażu takiej przetwornicy , prowadzenie masy ma tu istotne znaczenie jak i połączenie mas w jeden wspólny punkt , grubość ścieżek masy i ich doprowadzeń. Napisz czy płytki montażowe przetwornicy i wzmacniacza wykonałeś sam czy skorzystałeś z gotowców bo tam może tkwić przyczyna zakłóceń. Ekranowanie przetwornicy nie wiele może pomóc w chwili gdzie zakłócenia przedostają się poprzez linie zasilania a tak chyba u Ciebie się dzieje.
  • #6
    adamkaktus
    Level 16  
    Hmm. No więc przetwornica to jest gotowy projekt IRKA, płytka jest wykonana termotransferem(może niezbyt precyzyjnie mi wyszło ale daje poprawne napięcia),ogólnie to w przetwornicy wszystkie obwody odpowiedzialne za moc sa bardzo grubo pocynowane, masa wejściowa przetwornicy nie ma połączeniaa z masą wyjściową(separacja poprzez transformator W.CZ.), Wariactwo polega na tym że wystarczyło podpiąć masę oscyloskopu do masy wzmacniacza(i przetwornicy) i luźno puścić (daleeko od przetwornicy) sondę i na zakresie 50mV(po uwzględnienu sondy) siedział sobie bardzo ładny, prostokątny przebieg. Najgorzej że niebardzo mam skąd wziąć 2 razy 12V, myślę że będe musiał skołować dugi akumulator, bo jeden mam.Jeżeli trzeba schemat przetwornicy to podeślę... natomiast oprócz kondów na wyjści są też kondensatorki małe jako filtr natomiast słyszałem kiedyś coś że trzeba jakieś gasiki umieszczać w przetwornicach(hehe nie mam pojęcia niestety co i jak), atutaj nic takiego nie ma.Pozdrawiam i dziękuję Ci za pomoc:)

    Dodano po 1 [godziny] 25 [minuty]:

    acha, dowiedziałem sie co nieco że brak dłąwika na wyjściu to poważna wada więc chyba trzeba by zrobić taki, tylko jak? Rdzenie toroidalne to chyba mam gdzieś od dławików,ale potrzebował bym przepis jak wykonać i gdzie dokłądnie włączyć.