Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

SAA1057 w nadajniku FM i nieznośny przydźwięk.

czarutek 20 Paź 2007 19:51 13546 107
  • #31
    Driver-
    Poziom 38  
    :arrow: czarutku przeczytaj uważnie !!! Nie odfiltrujesz tak tych szpilek, mogą się sączyć gdzie będzie to tylko możliwe. Usuń przyczynę a nie objawy. Przyczyną jest prawdopodobnie generator kwarcowy, pisałeś że po zwarciu C49 sygnał był czysty, ale nie wyciągnąłeś z tego wniosków. Powyżej pisałem abyś sprawdził (wymienił) C49 lub zmienił na trymer. Układy cyfrowe mają taką przypadłość że w momencie gdy stany LH, na danych bramkach struktury zmieniają się, w pewnym zakresie napięć pomiędzy stanem L a H, powstają stany nieustalone. Od rozpoczęcia do zakończenia stanu nieustalonego płynie największy prąd. Przy odpowiedniej stromości zbocza stan ten trwa znikomo krótko i łatwiej jest takie szpilki wytłumić czy odfiltrować. To właśnie te stany są przyczyną zakłóceń jakie wnoszą układy cyfrowe (głównie przez zasilanie). Natomiast jeśli na skutek złego wysterowania sygnał odbiega od prostokąta, czyli stromość zboczy jest mała, stan przejściowy trwa o wiele dłużej. W kolejnych stopniach dzielnika stany te jeszcze się wydłużają i prowadzi to do powstawania coraz większych zakłóceń. Ponieważ prądy z poszczególnych bramek się sumują. W wyniku tego powstają właśnie duże zakłócenia jak w Twoim przypadku. Szpilki takie są praktycznie nie do odfiltrowania. Możliwe też że wejście FFM nie jest dobrze wysterowane. Sprawdź również czy napięcie z VCO na FFM zawiera się pomiędzy max min. napięciami dla tego wejścia, podanymi w nocie katalogowej.
  • PCBway
  • #32
    czarutek
    Poziom 34  
    Nienie, troszkę inaczej jest - jeśli zewrę C49, to częstotliwość spada o około 20kHz, ale przydźwięk się nie zmienia.
    Natomiast zauważyłem, że rzeczywiście poziom sygnału wpuszczany na FFM ma na ten przydźwięk spory wpływ. Piszą w nocie 10..500mV tylko nie wiem czy to mVpp?
    Teraz staram się dobrać optymalny rezystor i kondensator dla wejścia FFM w całym paśmie. W każdym razie walczę, jest coraz ciszej.
  • #33
    sq6ade
    Poziom 40  
    Rozkrawanie zapałki na czworo nie ma sensu - scalak jest przetestowany w licznych aplikacjach więc wg. noty powinien działać (oprócz noty można zobaczyć jak to jest we wspomnianym tunerze diory - kiepska konstrukcja a jakoś działa).
    czarutek - testujesz samo VCO i PLL ? czy całość ze stopniem mocy?
    Sprawdzałeś układ oscyloskopem?
  • #34
    czarutek
    Poziom 34  
    Teraz testuję całość (zasilam z 12V, moc wyjściowa jest 1.3W), ale na samym VCO było to samo. Sprawdzałem oscyloskopem wiele miejsc, o jakie Ci chodzi?
  • PCBway
  • #35
    sq6ade
    Poziom 40  
    Skoro scalak jest źródłem zakłóceń => chodzi o jego nogi :D

    Na czas poszukiwań parcha wyłącz dalsze stopnie.
    Zakładamy że stosujesz się do zaleceń producenta czipu np. poziom sygnału we. o czym Driver- wspominał. Inne też sprawdź - pisujący w Twoim temacie mają naprawde trudne zadanie jeśli zaniedbasz pewne pewniki na których bazują. :D
  • Pomocny post
    #36
    Faces
    VIP Zasłużony dla elektroda
    Witam.

    czarutek napisał:
    Teraz staram się dobrać optymalny rezystor i kondensator dla wejścia FFM w całym paśmie. W każdym razie walczę, jest coraz ciszej.


    O którym rezystorze mówisz?.
    Rezystor w syntezie na wejściu FFM (180ohm) musisz dobrać. Też kiedyś miałem przeboje z tym układem.

    Widzę, że u ciebie na schemacie sygnał do wejścia FFM idzie prosto z wyjścia generatora. Skutkiem takiego podłączenia może być przesterowanie generatora.
    Układ z tranzystorem T3 jest separatorem (driverem) między wyjściem generatora, a wejściem stopnia końcowego.
    W wielu aplikacjach widziałem, że sygnał na wejście FFM jest podawane z wyjścia separatora, a nie z WY generatora. Może to jest przyczyną twoich problemów. Spróbuj podać sygnał na syntezę z kolektora T3 (możliwe, że trzeba będzie dobrać rezystor 180ohm przy WE FFM).
    Pozdrawiam.
  • #37
    czarutek
    Poziom 34  
    Tak sq6ade, staram się jak tylko umiem. Na FFM mam obecnie 180mVpp. Nota podaje 10..500mV (nie wiem o jakie mV im chodzi).
    Faces, jak na razie próby ze 180Ω do masy nic nie dały. Mówię o R13. Obecnie mam R13=2k2, C15a=1n. Poziom na FFM cały czas kontroluję oscyloskopem. Ok, spróbuję brać FFM zza T3, choć tylko na próbę, bo na T3 chciałem później zrobić cięcie mocy przy "out of lock".
  • #38
    sq6ade
    Poziom 40  
    Wejście jest dla sygnału w.cz. więc sygnał 180mV V p-p jest jakby w środku okna - nie czepiał bym się tego.
  • #39
    Driver-
    Poziom 38  
    A może czepiamy się nie tego co trzeba. Spróbuj takiej akcji. Wyjmij SAA między scieżką +5V a masą podłącz opornik 250Ω sprawdź czy masz przydźwięk. Lub podaj zasilanie SAA nie z 7805 lecz z baterii 4,5V możliwie najkrótszymi przewodami. Może to nie SAA bruździ lecz np. wzbudza się 7805. Napisz czy to coś dało.
  • #40
    czarutek
    Poziom 34  
    Obciążenie 7805 oporasem 240Ω nic nie zmienia, cisza, czyli to nie wygląda na sprawkę 7805.
    Niestety, przy osobnym zasilaniu z akumulatora 6V nadal piszczy... :|
  • #41
    Driver-
    Poziom 38  
    Widzę że kończą się pomysły i nie dziwię się bo problem może być zarówno złozony jak i banalnie prosty, lecz z braku układu na stole trudny do określenia. Mnie jeszcze coś przyszło do głowy, mianowicie miałem kilka przypadków zanieczyszczenia laminatu pojedynczymi metalowymi opiłkami czy skrawkami, w jednej płytce był nawet cienki stalowy drucik. Po wytrawieniu i wlutowaniu elementów nie mogłem uruchomić układu. Od tego czasu zawsze sprawdzam omomierzem stan izolacji miedzy ścieżkami przed wlutowaniem elementów. Zdażyło mi sie również że po wytrawieniu zostawały na płytce niepożądane połączenia wykryte omomierzem, ale widoczne dopiero pod silną lupą. Myślę że sprawdałeś płytkę po wytrawieniu, lecz może mimo wszystko coś gdzieś jest przywarte, albo jest jakieś przebicie między ścieżkami w okolicy układu syntezy. Przede wszystkim uruchom część układu, generator plus synteza, bez wzmacniaczy, tak jak pisał sq6ade. Dopiero jak otrzymasz czysty sygnał włączaj kolejne stopnie po generatorze. W zasadzie płytka nie jest zła, lecz brakuje mi paru istotnych elementów, głównie kondensatorów odsprzęgających zasilanie bezpośrednio przy scalaku syntezy, są co prawda elektrolity ale przydały by się również ceramiczne. Przydały by się również dławiki w.cz. O ekranowaniu generatora i syntezy już pisano i z tym nie można się niezgodzić, jak najbardziej wskazane ekranowanie zarówno od góry jak i od spodu płytki. Są też miejsca w ścieżkach masy, które warto by ze sobą połączyć skracając przepływ prądu w.cz. i stałego po masie.
  • #42
    czarutek
    Poziom 34  
    No wiem Driverku, ogromnie Ci dziękuję za zaangażowanie, może kiedyś będę mógł się zrewanżować...
    Płytka z racji tych kłopotów jest wręcz sterylna...
    Wszystkie punkty zasilania SAA1057 zblokowałem już dodatkowo tymi kondami SMD, zgodnie z sugestią Sabotaża. To przyniosło już znaczną poprawę. Wartości dobrałem optymalne dla danej częstotliwości generatora, chyba 98MHz...
    Opiszę jeszcze pewne dziwne zjawisko. Jak widać na SCH1, w obwodzie rezonansowym generatora pojemnością jest podwójny warikap 2xBB809//trymer 22p//kondensator 10p. Kondensator 10p na razie wyjąłem i zostawiłem sam trymer i warikap. Zaprogramowałem SAA1057 na 87,6MHz. Regulując trymerem mogę więc regulować napięcie warikapowe bez zmiany częstotliwości. Praktyczny zakres tego napięcia wynosi z grubsza 1,4V..10,7V. I teraz ta ciekawostka. Najgłośniejszy pisk jest w granicy dolnej, ale w wyższym zakresie są jeszcze ze 3 minima i maksima: 2,50V - absolutna cisza; 2,60V - znów pisk; 2,85V..3,45V - absolutna cisza; 4,30V - straszny pisk i szumy; 5,3V..6,7V - przepiękna cisza; 7,30V..10,7V - lekki pisk, ale szum niski.
    Może to nam jeszcze coś POdPOwie...? :|
    Driverku, załączam SCH1.JPG, w których miejscach proponowałbyś wszczepić dławiki RF?

    SAA1057 w nadajniku FM i nieznośny przydźwięk.
  • #43
    sp8gsc
    Poziom 26  
    Pisałem, ze trzeba sprawdzić generatory. Jesli pisk zależy od napięcia na warikapach, to może po prostu jeden z warikapów jest uszkodzony, albo jest tak, że nie mogą pracować równolegle. Spróbuj wyjąć jeden na próbę i zastąpić pojemnością stałą. Oczywiście należy też sprawdzić oscyloskopem napięcie podawane na warikapy i na generator - nie może być żadnych szpilek. Najprościej dołączyć do napięcia sluchawki (przez potencjometr) i posluchać czy nie ma zadnych efektow. Dławiki i kondensaroy blokujące na zasilanu układow w.cz. to norma, której nie wolno pomijać. Sprawdzanie od razu, sygnału na wyjścu nadajnika, to "głupiego robota" należy sprawdzić wszystkie stopnie po kolei, zaczynajac od generatora oczywiście po upewnieniu się, że napiecia stałe są naprawdę stałe.
  • #44
    morph13
    Poziom 25  
    Zablokuj wejście FAM (11) kondensatorem 10n do GND. Prawdopodobnie wzbudza sie wzmacniacz AM i przenosi się to na zasilanie.
  • #45
    Driver-
    Poziom 38  
    Dopiero dzisiaj miałem chwilkę żeby się tym zająć. Na schemacie masz poprawki. Nie podejrzewam aby wzbudzał się wzmacniacz FAM, jest on programowo wyłączany, izolacja miedzy wejściami FAM a FFM w zależności, które jest wybrane, to aż -30 dB.
    Po tym co napisałeś podejrzewam że pętla robi się bardziej skłonna do wzbudzeń i pracuje niestabilnie ponieważ przesunięcie fazowe, pomiędzy przebiegiem VCO a wyjściem detektora fazy, zbliża się do 360°. Natomiast pracuje najbardziej stabilnie kiedy przesuniecie fazowe zbliża się do 180°. W tym układzie częstotliwość obwodu rezonansowego jest powielana x2. Przypuszczam więc że masz tak: 90° przesuniecie fazowe na VCO i 90° na detektorze fazy, już masz 180°, ale powielenie x2 na przeciwsobnym VFO odwraca fazę o kolejne 180°, wypadkowe odwrócenie fazy masz już 360° i maksymalnie niestabilną pętlę. Zmierz częstotliwość na bazie T2 i z bazy T2 weź w.cz. dla FFM. Jeśli podział syntezy masz programowany dla 88-108 MHz to prawdopodobie trzeba będzie go zmienić dla 44-54 MHz.
  • #46
    czarutek
    Poziom 34  
    Morph13, blokowanie FAM 10n do masy niestety nic nie daje. Niezależnie czy do zewnętrznej, czy do podbrzusza syntezy. Próbowałem też zwierać do masy na krótko, ale wtedy chyba staje też FFM, bo w ogóle zrywa PLL.
    Driver, z czytaniem f/2 z bazy T2 będzie o tyle problem, że przecież SAA1057 ma dla FM zakres 70..120MHz. Dzięki za schemat! W najbliższym czasie wszczepię te trzy dławiki. Zacznę od takich standardowych RF, a potem pokombinuję z innymi wartościami.
    Z kolei zupełnie nie czuję tych przesunięć fazowych. Może spytam tak - mamy załóżmy VCO i syntezę, i fazy są optymalne, więc wszystko jest ok. I teraz, jeśli na wyjściu VCO dałbym jeszcze tranzystor w układzie takim, że odwracałby fazę VCO i to z niego brałbym FFM dla syntezy, to synteza zaczęłaby pracować gorzej?
    To chyba nie na moją głowę... :cry:
    sp8gsc, wszystko zaczynałem właśnie od samego generatora. Na nim dobrałem pokrycie całego pasma, preemfazę, układ wejściowy. Ponieważ te piski też występowały, zwłaszcza przy podłączaniu do wyjścia kawałka antenki, postanowiłem rozszerzyć to o te kolejne dwa stopnie, które mam uruchomione w innym nadajniku, dokładnie w Veronice z PLLką na licznikach.

    Najbardziej wkurza mnie to, że jak przypomnę, po odłączeniu wyjścia syntezy i wyjęciu warikapów, czyli przy układzie VFO, ten przydźwięk też słychać i to tylko nieznacznie ciszej. No na moją głowę musi się on przenosić po masie albo po zasilaniu. Zasilacz mam impulsowy. Uruchamiałem też z akumulatora 12V. No starałem się już eliminować wszystkie znane mi przyczyny. Testuję różne łączenia mas. Znajdę zadowolony jedno super ciche, a tu guzik - zmienię częstotliwość i jest ono złe, pojawia się pisk, lepiej jest przy innym. Załamka. Zawziąłem się, tylko ciągle brak czasu na kolejne dłuższe posiedzenie... :|
  • #47
    Driver-
    Poziom 38  
    Faktycznie zapomniałem że 1057 pomiędzy 30 a 70 MHz ma dziurę :|
    Możesz spróbować odwrócić fazę, ale czuję przez skórę że to nie to. Przyczyną tego mogą być też zbyt duże szumy fazowe, lub harmoniczne powstajace przy przełączaniu tranzystorów VCO. Zastanawiam czemu uparłeś się na to przeciwsobne VCO na BF494. Spróbuj zrobić VCO takie jak na schemacie. Robiłem go jakiś czas temu i bardzo dobrze pracowało. Ma osobne wejście na modulację i dopasowanie wyjścia na 50Ω. Zamiast C3 C11 daj trymery i dobierz C1 aby dewiacja była odpowiednia. Cewki L3 i L5 są jednakowe a L1, L2 i L4 to dławiki. Na wyjsciu powinieneś mieć około 35 mV i 2Vpp na 50Ω. Jak byś potrzebował dopasowania do innej oporności wyjsciowej to moge Ci policzyć L6 i C14.
  • Pomocny post
    #48
    pukury
    Poziom 35  
    Witam !! Również zastanawiałem się - dlaczego taki generator ? zaproponowany ( gen - Seilera ) jest naprawdę jednym z lepszych . Myślę jednak że cewka w L4 ( o ile widzę ) powinna być nie 1µH a 1mH ( przynajmniej ja takie stosowałem w tym miejscu ) . I jeszcze - warto by spolaryzować odpowiednio diodę modulacyjną - chodzi o to żeby pracowała na " najliniowszym " kawałku charakterystyki - może przesadzam :D . pozdrawiam !! dodając- i jeszcze jako l5 dałbym jednak dławik
  • #49
    czarutek
    Poziom 34  
    Driver, bardzo podoba mi się ten schemat, mam do niego wszystkie elementy, jedynie warikapy mam BB809, na pewno go sobie złożę.
    Pukury, L5 z R1 to już robi za jakiś tam dławik chyba...

    A dlaczego uparłem się na tego "przeciwsoba" - po prostu mam oryginały Veronica 1W i NRG 4W. Działają one wręcz przepięknie. Nośna jest tak cicha, że dopiero po rozkręceniu wieży 2x85W na maksa słychać cichy szum. Jednak PLL mają dość toporne (na licznikach), więc chciałem zaadaptować do nich syntezę scaloną i wyświetlacz LED (niemultipleksowany). Bardzo ładnie pracowało na LMX2306 (tu służę G12.8MHz), ale ona ma tylko dwa prądy pompy i miałem kłopoty z szybkim ustalaniem in-lock. Nie podobało mi się również coś w TSA5511 (tu służę X3.2MHz). TSA6057 działała ładnie, ale nie miała sygnału in-lock, więc fast-lock był bardzo utrudniony. SAA1057 dzięki dwóm komparatorom fazy (digital i 32x wolniejszy S/H) wydaje mi się doskonała - po błyskawicznym zaskoczeniu PLL na komparatorze digital przełączamy się na komparator S/H i dźwięk robi się przepiękny, tylko te przydźwięki nieszczęsne... Nie wymaga też dodatkowego LPF na wyjściu, a przy przełączeniu z 87.5MHz na 108MHz, PLL ustala się w góra 1/4 sekundy. Spore szumy fazowe przy tak dość stromym nachyleniu VT do f są naturalne i na nie bym się godził, tylko ta szlifiera nieszczęsna. Powalczę jeszcze, powszczepiam dławiki, może jeszcze jakieś kondensatory. Potestuję też z innymi wartościami elementów, które widzę na różnych schematach, może się z tym uporam... Pośpiechu nie ma.
    W przyszłości, gdyby mi się udało, chciałbym dołożyć odrębne wariapy do modulacji i korygować ich napięcie tak, aby mieć identyczny dźwięk przy 87.5MHz i przy 108MHz, bo cichszy na 108MHz przy wspólnym warikapie mi się też nie podoba. Proste wpięcie warikapów dla modulacji powoduje zjawisko odwrotne - im wyżej, tym głośniej. Zjawisko oczywiste. VT musi też lekko korygować napięcie na warikapach modulatora.

    Dzięki Panowie za zaangażowanie, podpowiadajcie proszę w wolnych chwilach co tylko wyda się Wam istotne.
    Pozdrawiam!

    Dodano po 5 [godziny] 38 [minuty]:

    Driver, sorki za laickie pytanie - w tym BF245 drain jest na górze, czy na dole?
  • Pomocny post
    #50
    Driver-
    Poziom 38  
    Dren jest na górze, w źródle jest dławik i reszta. Daj mi na PW Twoje GG mam dla ciebie ciekawostkę.
  • #51
    czarutek
    Poziom 34  
    pukury napisał:
    ... I jeszcze - warto by spolaryzować odpowiednio diodę modulacyjną - chodzi o to żeby pracowała na " najliniowszym " kawałku charakterystyki ...

    Moim zdaniem korzystniej byłoby sprytnie uzależnić ją od napięcia VT tak, aby korygować jej udział w L//C w zależości od VT. Dałoby to identyczną dewiację przy 88, jak i przy 108MHz. Dla mnie ta różnica jest kolejną zmorą.
  • #52
    czarutek
    Poziom 34  
    Wyciszyłem to prawie całkowicie dla całego zakresu. No rozbieżność ze schematem aplikacyjnym z noty katalogowej powaliła mnie wręcz na kolana. Oto poprawki w obrębie SAA1057:

    SAA1057 w nadajniku FM i nieznośny przydźwięk.

    A oto widmo, ale na razie na komparatorze Digital. Po przejściu na S/H będzie jeszcze ciszej:

    SAA1057 w nadajniku FM i nieznośny przydźwięk.

    I jeszcze audio szumu/szlifierki:
  • #53
    czarutek
    Poziom 34  
    Zbuduję całą nową płytkę z trzema stopniami do blisko 2W i przedstawię efekty. Co ciekawe, to dziwaczne blokowanie napięć zasilania SAA, jakby uniezależniło całość od sposobu prowadzenia masy.
  • #54
    czarutek
    Poziom 34  
    Blisko, coraz bliżej...
    Dodatkowe zwory na masie, zasugerowane przez Drivera, wyciszyły szumy i przydźwięki jeszcze o kolejne kilka dB... :D
    Teraz walczę z równomiernością mocy w całym zakresie. Obecny szczyt, to przy 12V zasilania 1.74W przy 88MHz i tylko 1.15W przy 108MHz.
    Czy mielibyście jakieś sugestie jak, i którymi elementami to skorygować?

    Ciekawostki:
    1) Dławik w katodzie warikapu pomaga wyciszyć szlifierę, ale drastycznie zwiększa szumy.
  • #55
    czarutek
    Poziom 34  
    Okazało się, że dobre poprowadzenie masy i sprytniejsze umieszczanie kondensatorów przy cewkach na nowej płytce, wyeliminowały potrzebę użycia przy SAA1057 kondensatorów SMD i jeszcze kilku innych. Niebawem załączę ostateczny schemat i rysunek płytki.

    Borykam się natomiast z kolejnym problemem - włączaniem mocy po wykryciu stanu In-Lock.
    Podstawowy układ wygląda tak:

    SAA1057 w nadajniku FM i nieznośny przydźwięk.

    Niestety, takie ostre włączenie mocy zbyt nagle obciąża generator, co powoduje ponowne odjechanie częstotliwości o jakieś 2MHz.
    Rozmyślałem nad jakimś sprytnym układem spowalniającym. Zwykły kondensator nie załatwia sprawy, gdyż powoduje również opóźnienie, a to mi nie odpowiada.
    Zbudowałem i przetestowałem układ taki:

    SAA1057 w nadajniku FM i nieznośny przydźwięk.

    Czy zna ktoś może jakieś lepsze rozwiązanie?

    Dodam jeszcze, że uproszczony algorytm zmiany częstotliwości jest obecnie następujący:
    wyłączenie mocy -> wpisanie nowej f, prąd pompy maksymalny i komparator digital -> poczekanie na In-Lock -> włączenie mocy -> poczekanie na In-Lock -> prąd pompy minimalny i komparator S/H.
  • Pomocny post
    #56
    jedrzej1955
    Poziom 12  
    Operujesz na częstotliwościach wysokich.Płytka drukowana to nie nośnik mechaniczny elementów lecz tworzy z elementami integralną całość.Jest podstawowa zasada-dolna strona płytki (lutowanie) zawiera ścierzkę masy zaczynającą się od stabilizatora a kończy się na obwodach wejściowych. Ta sama zasada dotyczy zasilania (+),pamiętać trzeba o szeregowym dławiku ok. 100uH i kondensatorze 47nF do 100.Górna strona płytki drukowanej to na całej jej powierzchni miedz z otworami na elementy lekko rozwierconymi-aby nie było zwarcia.do niej lutujesz tylko masy stabilizatorów ,nie masy gretza ani elektrolitów zasilacza.Lutujesz do niej puszki ekranujące,przegrody itp.Zauwarz ze między ścierzkami dolnymi (lutowanie) a górną masą tworzą się małe pojemności około kilka pF,stanowią one doskonały i skomplikowany układ przeciw wzbudzrniowy i przeciw zakłuceniowy w.cz. i m.cz.Pozdrawiam.Porady praktyczne:andrzejr1955@wp.pl
  • #57
    czarutek
    Poziom 34  
    A w którym miejscu tej ścieżki masy najkorzystniej jest podłączyć się z masą sekcji cyfrowej?
  • #58
    niunio
    Poziom 15  
    Czarutek, dlaczego ubierdliwie poprawiasz coś co jest złe samo w sobie. Inny generator VCO.
  • #59
    czarutek
    Poziom 34  
    A dlaczego złe? To jest bardzo dobry generator.
    Przyślij mi próbkę jakiegoś swojego. Po przetestowaniu odeślę Ci z powrotem... :D
  • #60
    czarutek
    Poziom 34  
    Nie będę już zakładał nowego tematu, pozostańmy tu.
    Przydźwięki zwalczone całkowicie, natomiast ciągle niezadowolony jestem z tego odcinania mocy. Powyższe układy, które odłączały emiter tylko w T3 miały tę wadę, że o ile na 87.5MHz wszystko było perfekt, to na 108MHz przy wyłączonej mocy, na wyjściu było 120mW. Postanowiłem więc odłączać również emiter T4:

    SAA1057 w nadajniku FM i nieznośny przydźwięk.

    Na symulatorze zanosi się obiecująco, ale może ktoś miałby uwagi, zanim to złożę?
    Przypomnę, że chodzi mi o płynne, możliwie liniowe i bez opóźnień, wyłączanie i włączanie mocy RF na sygnał PwrDn z mikrokontrolera...
    Generalnie chciałbym tu uzyskać brak posiewu przy włączaniu nadajnika i przy zmianie częstotliwości. Z wyłączaniem już gorzej, w przyszłości zechcę chyba dorobić "stand by"...