Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

mPlayer + rozjechany obraz

02 Gru 2007 12:25 1341 6
  • Poziom 27  
    Witam.
    Posiadam Ubuntu 7.10PL wraz z zainstalowanymi sterownikami do karty graficznej i serwerem XGL (compiz i emeral dziala bez problemu).
    I teraz porblem, zainstalowalem mPlayera z paczek dostepnych w repozytoriach (1.0rc1) wraz z kodekami w32. Problem jest nastepujacy otwieram film i mam go rozciagnietego jakby na kilka pulpitow (widze tylko maly kawalek) a kiedy dam pelny ekram jest jeszcze gorzej. Dodam ze film odpalany z terminala (mplayer nazwa_filmu.rmvb) dziala dobrze. Co moge zrobic zeby wersja graficzna tez dzialala dobrze? (tj nie rozciagalo tak obrazu)
  • VIP Zasłużony dla elektroda
    Witam, podejrzewam że problem powoduje wyjście wideo jakiego używa mplayer. Kiedy uruchomisz z konsoli zwróć uwagę na linijkę podobną do tej:
    Code:
    VO: [xv] 512x384 => 512x384 Planar YV12

    Jest też bardzo wiele innych wyjść, np. gl, gl2 (OpenGL) a nawet aa i caca (AsciiArt). Zapamiętaj jakiego wyjścia użył mplayer i ustaw je w konfiguracji graficznej nakładki na niego, wtedy wszystko powinno działać.

    Pozdrawiam, Krzysztof.
  • Poziom 27  
    Wiec prosze wynik z konsoli:
    Code:
    MPlayer 2:1.0~rc2+pl-3 (C) 2000-2007 MPlayer Team
    
    CPU: AMD Athlon(tm) XP 3200+ (Family: 6, Model: 10, Stepping: 0)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Skompilowane z wykrywaniem procesora przy starcie.
    Nie mogę otworzyć dźojstika /dev/input/js0: No such file or directory
    Nie mogę zainicjować dżojstika
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Nie udało się uruchomić obsługi LIRC. Nie będziesz mogł używać swojego pilota.

    Odtwarzam /home/bullseye/Desktop/Filmy/Dziewczyny z drużyny 3.rmvb.
    Wykryto format pliku REAL.
    Stream description: Audio Stream
    Stream mimetype: audio/x-pn-realaudio
    [real] Audio stream found, -aid 0
    Stream description: Video Stream
    Stream mimetype: video/x-pn-realvideo
    [real] Video stream found, -vid 1
    Stream mimetype: logical-fileinfo
    VIDEO:  [RV40]  624x352  24bpp  30.000 fps    0.0 kbps ( 0.0 kbyte/s)
    Informacje o klipie:
     comment:
    Xlib:  extension "XFree86-VidModeExtension" missing on display ":1.0".
    xscreensaver_disable: Nie mogłem odnaleźć okna XScreenSaver.
    Wygaszacz ekranu GNOME wyłączony
    ==========================================================================
    Otwieram dekoder video: [realvid] RealVideo decoder
    Wybrany kodek video: [rv3040] vfm: realvid (Linux RealPlayer 10 RV30/40 decoder)
    ==========================================================================
    ==========================================================================
    Wymuszam kodek audio: mad
    Otwieram dekoder audio: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 44100 Hz, 2 ch, s16le, 64.1 kbit/4.54% (ratio: 8010->176400)
    Wybrany kodek audio: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
    ==========================================================================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Odtwarzam...
    VDec: wymagana konfiguracja vo - 624 x 352 (preferowana przestrzeń kolorów: Planar I420)
    Nie mogłem odnaleźć pasującej przestrzeni kolorów - próbuję ponownie z opcją -vf scale...
    Otwieram filtr video: [scale]
    VDec: using Planar I420 as output csp (no 0)
    Format filmu to 1.77:1 - zmieniam do poprawnego formatu filmu.
    [swscaler @ 0x892e4f0]SwScaler: using unscaled yuv420p -> yuv420p special converter
    VO: [xv] 624x352 => 624x352 Planar YV12

    W wersji graficznej mam ustawione wyjscie video na:
    Code:
    xv    X11/Xv

    I obraz na konsoli taki jak byc powinen na graficznym rozjechany.
  • VIP Zasłużony dla elektroda
    Dziwne. KMplayer wypisuje na konsoli polecenie jakim uruchamia mplayera (aby uruchomić go z takimi samymi ręcznie, wystarczy uciąć "-wid xxxxxx -slave"). Gmplayer wypisuje całe wyjście mplayera, tak jakby był uruchomiony spod konsoli.

    W jakiś sposób muszą się one różnić od tego co dostajesz kiedy uruchamiasz mplayera spod konsoli ręcznie. Zobacz co się różni i spróbuj zmienić odpowiadające temu opcje.

    BTW, jeśli możesz polecam zrezygnować z XGL na rzecz lepszych rozwiązań (AIGLX lub nVidia, jeśli posiadasz ich kartę).

    Pozdrawiam, Krzysztof.
  • Poziom 27  
    Posiadam Radeona, i zalezy mi na compiz-fuzionie. XGL jako sam w sobie nie przeszkadza w niczym pozaty tym nieszczesnym playerem.
    Ok wiec odpalam z pod konsoli poleceniem gmplayer (Gnome uzywam) i daje wynik:
    Code:
    bullseye@bullseye-desktop:~$ gmplayer
    
    MPlayer 2:1.0~rc2+pl-3 (C) 2000-2007 MPlayer Team
    CPU: AMD Athlon(tm) XP 3200+ (Family: 6, Model: 10, Stepping: 0)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Skompilowane z wykrywaniem procesora przy starcie.
    Xlib:  extension "XFree86-VidModeExtension" missing on display ":1.0".
    Nie mogę otworzyć dźojstika /dev/input/js0: No such file or directory
    Nie mogę zainicjować dżojstika
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Nie udało się uruchomić obsługi LIRC. Nie będziesz mogł używać swojego pilota.
    Xlib:  extension "XFree86-VidModeExtension" missing on display ":1.0".

    Odtwarzam /home/bullseye/High.School.Musical.2.PL.PDTV-TvTET [RmvBusterS]/High.School.Musical.2.PL.PDTV-TvTET.rmbus.rmvb.
    Wykryto format pliku REAL.
    Stream description: Audio Stream
    Stream mimetype: audio/x-pn-realaudio
    [real] Audio stream found, -aid 0
    Stream description: Video Stream
    Stream mimetype: video/x-pn-realvideo
    [real] Video stream found, -vid 1
    Stream mimetype: logical-fileinfo
    VIDEO:  [RV40]  512x384  24bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
    Informacje o klipie:
     comment:
    ==========================================================================
    Otwieram dekoder video: [realvid] RealVideo decoder
    Wybrany kodek video: [rv3040] vfm: realvid (Linux RealPlayer 10 RV30/40 decoder)
    ==========================================================================
    ==========================================================================
    Wymuszam kodek audio: mad
    Otwieram dekoder audio: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 44100 Hz, 2 ch, s16le, 64.1 kbit/4.54% (ratio: 8010->176400)
    Wybrany kodek audio: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
    ==========================================================================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Odtwarzam...
    VDec: wymagana konfiguracja vo - 512 x 384 (preferowana przestrzeń kolorów: Planar I420)
    Nie mogłem odnaleźć pasującej przestrzeni kolorów - próbuję ponownie z opcją -vf scale...
    Otwieram filtr video: [scale]
    VDec: using Planar I420 as output csp (no 0)
    Format filmu to 1.33:1 - zmieniam do poprawnego formatu filmu.
    [swscaler @ 0x892e4f0]SwScaler: using unscaled yuv420p -> yuv420p special converter
    VO: [xv] 512x384 => 512x384 Planar YV12

    Wyglada prawie identycznie. Pokombinuje ale tematu nie zamykam bo wciaz czekam na pomoc :)

    Dodano po 2 [minuty]:

    PS. z kad mplayer pobiera ustwienia przy odpalaniu poleceniem mplayer nazwafilmu.rmvb, a gmplayer?
  • Poziom 21  
    Mam dokładnie to samo. Tez mam Radeona i niestety ten sam problem. :) Compiz-Fusion nie współpracuje z XGLem tak dobrze, jak się wydawało. MAło tego w czasie oglądanie filmów, XGL obciąża procka niemiłosiernie :) CO ciekawe, na Feistym, gdzie działał Beryl na AIGLX problemu nie było. Problem "rozjechanego" obrazu rozwiązałem, instalując Xine :) niestety nie wiem jak poradzić sobie z ogromnym obciążeniem procesora.
    Kol. Bullseye, czy mógłbyś odpalić jakiś film i w konsoli odpalić polecenie "top" (w czasie odtwarzania filmu oczywiście) i napisac mi, jak wygląda sprawa z obciążeniem?