Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Regulator modelarski i sterowanie mosfetami

25 Gru 2007 20:46 2719 15
  • Poziom 15  
    Załączam schemat regulator który zrobiłem i jest problem przetwornica dziala oki ale za tranzystorami jest albo +15V z przetwornicy albo 0,7V a 0V znaczy masy niestety brakuje :( i za mosfetem jest 0.7V i robi sie niestety zwarcie :( znaczy dziala a za chwile spala sie jeden z mosfetów :( Prosze o pomoc może coś jest nie tak w tej chwili na bramkach mosfetów sa oporniki 4,7oma bo takie mialem a teraz swieta.
    Pozdrawiam
  • Poziom 22  
    Niestety w schemacie jest trochę błędów.

    Po pierwsze to, sterowanie samymi MOSFETami. Jak chcemy, żeby się zamknęły, to koniecznie trzeba rozładować ładunek bramki, czyli podłączyć chociaż na chwilę do masy, można przez jakiś rezystor. U Ciebie niby tak jest, ale...
    MOSFETy otwierają się po osiągnięciu odpowiedniego napięcia Bramka-Źródło. W mostku H napięcie Źródeł górnych transyt. jest inne niż dolnych (równe masie). Dlatego potrzeba innego napięcia do sterowania dolnymi i górnymi tranzystorami.
    Pogrzeb trochę na Elektrodzie, bo jest trochę takich tematów. Też kiedyś budowałem mostek i z braku wiedzy nic mi nie chciało działać. Podszkol się z zakresu wiedzy o MOSFETach, inaczej będzie ciężko.

    Z Twoją wiedzą o tranzystorach bipolarnych też chyba tak sobie jest :D, a mianowicie:
    Tranzystor bipolarny jest otwierany, gdy popłynie odpowiedni prąd przez bazę. Na przykład na Twoim schemacie
    - tr. Q2 jest typu NPN, jest on otwierany, gdy prąd popłynie wpływając na bazę (jakby z zewnątrz tranzystora) i wypływając przez emiter (tam, gdzie strzałka :-) )
    - tr. Q5 - PNP - otwierany gdy popłynie prąd z emitera do bazy (w Twoim przypadku w stronę tranzystora Q11).

    Tranzystory bipolarne Q2, Q5, Q4, Q6 masz podłączone źle, ponieważ aby się otworzyły prąd u Ciebie musi płynąć od obciążenia do bazy (dla PNP) lub od bazy do obciążenia). To powoduje, że nie wiadomo jaki będzie prąd bazy, (może się nawet zdążyć, że się nigdy nie otworzy), bo ciężko przewidzieć jaki będzie potencjał w punkcie z/do którego musi płynąć prąd bazy.
    Może trochę namieszałem, ale mam nadzieję, że łapiesz sens. Chodzi o to, że powinny być zamienione typy tranzystorów NPN na PNP i na odwrót.
    Poczytaj trochę też o tranzystorach bipolarnych, przyda się :-)

    A jeśli chodzi o sam mostek, to istnieją specjalne scalaki, które zawierają już w swojej strukturze odpowiednie przetwornice napięcia i służą specjalnie do sterowania mostka. np. IR2110, kosztuje kilka złotych, jak się sprawuje, niestety nie wiem, bo nie próbowałem jeszcze, ale w kilku postach widziałem, że jest polecany.
  • Poziom 15  
    witam
    niestety może moja wiedza za bogata nie jest ale te tranzystory sterujące mosfetem są w dobrą stronę podłączone :) ja tego nie wymyśliłem znalazłem kilka gotowych schematów z takim sterowaniem oraz na elektrodzie poczytałem i większość proponowała właśnie takie sterowanie to sie nazywa chyba wtórnik emiterowy. Co do innego napiecia górnych i dolny z tego co wiem to bramka jest jak by kondensatorem który musi być w potencjale wiekszym od źródła o daną wartość żeby otworzyć maksymalnie mosfet a u mnie napięcie górnych mosfetów jest o 7,8V większe od źródła za sprawą przetwornicy a dolnych o 15V a to chyba nie jest źle akurat pod obciążeniem 20A nawet się nie grzeją działają 15 sekund i nagle sie spalają :/ bezpiecznik mam 25A

    Dodano po 1 [minuty]:

    spala sie jeden czasami górny czasami dolny.
  • Poziom 28  
    zerpo -> układ jest poprawny, ale ja (i zapewne Ty też) zrobił bym ten układ całkiem inaczej.
    ziomal155 -> co to znaczy że tranzystor sie pali?? Przyczyny uszkodzenia tranzystora mogą być dwie:
    1. Obciążenie jest indukcyjne i tranzystor zostaje przebity. Podłącz na bociążenie żarówkę i sprawdz czy problem będzie nadal występował.
    2. Gałąź mostka sie zwiera co oznacza błąd w programie - szukaj błędu i przerób schemat tak aby wykluczyć podanie dwóch zer (jedynak) na sterowanie.
  • Poziom 15  
    no to tak błędu w programie nie ma bo jest prosty i sprawdzałem na oscyloskopie dwukanałowym, na pewno jest oki co do indukcji możliwe ale podtrawi spalić bez silnika bo za mosem jest jakieś 0,7V nie wiem gdzie ono sie odkłada na tym wtórniku jutro jadę po ICL7667 i na tym to już chyba musi działać:)
    Pozdrawiam
  • Poziom 28  
    ziomal155 napisał:
    jutro jadę po ICL7667 i na tym to już chyba musi działać:)

    Będzie działało, albo i nie. A jaką wydajność ma ta przetwornica na 12V? Uciągnie Ci tego ICL'a? Ten układ sterowania kóry masz w tej chwili jest nadzwyczaj oszczędny energetycznie. A może właśnie w tym jest problem że na przetwornicy w czasie pracy spada Ci napięcie?
  • Poziom 33  
    Czesc
    zapomnij o tym, skorzystaj z gotowych rozwiazań na forum Alexa
    http://forumrc.alexba.eu/ipw-web/bulletin/bb/index.php
    regulatory to specyficzne zagadnienie, albo trzeba sposobem, ale ten sposób oznacza sztuki układowe połączone ze sztukami programowymi, albo kup dedykowany driver do MOSów.
    Te sztuki to zmienna częstotliwość kluczowania, kluczowanie wyłącznie tranzystorów N a P wyłącznie do załączenia gałęzi itd. itp.
    Typowy driver do MOS jest w stanie wymusić sterowanie prądem ponad 1A a bramki tranzystorów mocy mają znaczne pojemności.
    Piotr
  • Poziom 15  
    Te sztuki to zmienna częstotliwość kluczowania, kluczowanie wyłącznie tranzystorów N a P wyłącznie do załączenia gałęzi itd. itp.

    hehe szkoda tylko ze w fabrycznych regulatorach sa tylko typu N tak jak u mnie a że jedna gałąź jest włączona to wiem ale brakło portów :p Wtedy bym zrobił też hamulec. A co za różnica czy steruje ICL czy Wtórnikiem?? Przecież pojemność jest taka sama bo mosów nie zmieniam. Przetwornica ma dość dużą cewkę więc problemów nie będzie narazie nie ma żądnych wachań napięcia(oscyloskop) kiedy steruje mosfetami wszystko działa dopiero jak podłączam większy silnik to sie sypie.
  • Poziom 28  
    ziomal155 napisał:
    dopiero jak podłączam większy silnik to sie sypie.

    Spróbuj zalutować równologle do zacisków silnika mały kondensator ceramiczny rzędu: 1n, 10n, 100n - złagodzi on trochę przepięcia.
    ziomal155 napisał:
    u mnie napięcie górnych mosfetów jest o 7,8V większe od źródła za sprawą przetwornicy a dolnych o 15V a to chyba nie jest źle akurat pod obciążeniem 20A nawet się nie grzeją działają 15 sekund i nagle sie spalają

    A wiesz że tranzystory SPMN004-25 na bramce wytrzymują +/-15V ?? Może nie to jest powodem uszkodzenia tranzystorów ale warto by wprowadzić jakiś margines bezpieczeństwa.
  • Poziom 41  
    Witam
    Ile jest tego VCC? Przepięcia zamykają i otwierają górne tranzystory, układ jest źle zaprojektowany. Górne tranzystory powinny korzystać z napięcia BOOTSTRAP, wszystkie IRy tak działają.
  • Poziom 33  
    Czesc
    A nie lepiej zamiast dużej cewki dać lepszy procesor i obsługiwać mostek optymalnie? Zyskasz na wadze, sprawności i możliwościach, wtórnik jest fajny, ale z pewnością też zajmuje więcej miejsca niż driver.
    Co do fabrycznych to wiele jest takich które mają P i N, pewnie przy prądach kilkadziesiąt amper królują N, bo łatwiej znaleźć takie o niskiej rezystancji kanału, ale przy 15-25A zwykle są i takie i takie
    Piotr
  • Poziom 15  
    dobra tylko ja tym chce sterowac 35A ciaglego pradu bo taki mam silnik, tak ps w jaki sposób lepszy procesor załatwi sprawę podwyższonego napiecia??
  • Poziom 33  
    Cześć
    Rozumiem że jak mostek to regulator jest dwukierunkowy, zerknij na to http://forumrc.alexba.eu/ipw-web/bulletin/bb/viewtopic.php?t=5628&postdays=0&postorder=asc&start=0
    jak przeczytasz cały wątek to może Ci sie kilka spraw rozjaśni.
    Co do pytania co ma większy procesor do wyższych napięć odpowiem że nic, tak samo jak te 35A, czy jest to silnik biorący 35A przy 12V czy przy 40V??.
    Stosując większy procesor masz możliwość optymalizowania zachowania sterowania w zależności od prądu, masz możliwość sterowania każdym tranzystorem z osobna przez co unikasz sytuacji w której tranzystory przy masie już załączyły a te przy zasilaniu jeszcze nie puściły...
    Przy takim założeniu możesz załączać tranzystorami P odpowiednią gałąź przez mały mosfet sterowany prosto z bramki i poprzez opornik drenie sterować tranzystorem mocy P, a kluczować wyłącznie tranzystorami N odpowiednio dobranymi tez bezpośrednio ( przez mały opornik ) z procesora.
    A co do tranzystorów mocy N kiedyś na tamtym forum pisałem o tranzystorku SMD o prądzie ciągłym 100A, nie pamiętam gdzie dokładnie to było, rezystancja kanału była tak niska że radził sobie z tym bez radiatora
    Piotr
  • Poziom 15  
    to tak mój ma 4miliomy i 75A i z grzaniem przy poborze 20A nie ma problemu, wersja na ICL7667 juz powstała i działa znakomicie prawie, problem jest jak zmieniamy kierunek bez silnika nie ma zwarc z silnikiem jak zmienimy kierunek kiedy silnik sie obraca robi sie zwarcie :( jak rozwiązać problem z indukcyjnoscia? mam fabryczny regulator i tam takiego problemu nie ma :(
    Pozdrawiam i prosze o odpowiedz.
  • Poziom 33  
    Witam,
    myślę że to nie problem ze zwarciem tylko silnik mając jakieś obciążenie inercyjne robi za prądnicę, generuję napięcie zbliżone do tego jakim był niedawno zasilony, jeśli nastąpi szybka zmiana to zamiast prądu 35A możesz dostać w impulsie koło 100.
    Musisz przed zmianą kierunku obrotów wyhamować silnik choć częściowo, zwarłbym go do masy przez włączenie obu dolnych tranzystorów, czas hamowania musisz wypraktykować.
    Piotr