Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Miernik ESR i mikrokontroler -ale jaki?

rubens 04 Maj 2008 11:56 103603 127
  • #91 04 Maj 2008 11:56
    bokuden
    Poziom 15  

    Witam
    HY-1602H-204,nie musialem zamieniac pinoutow zasilania.
    Wlutowalem wszystkie 14 kabelkow-ale chyba nie tu tkwi blad,bo reszta jest NC na plytce.
    Pozdrawiam

  • #92 04 Maj 2008 12:02
    Calineczka*
    Poziom 31  

    ...nie mam teraz czasu zeby szukac, sciagac i analizowac datasheeta twojego LCD z plytka...mam nadzieje, ze sam to zrobiles.Jak cos nie dziala a zaprogramowales PIC-a ok, sprawdzales obecnosc napiecia ujemnego(?)...to skoro nam dziala a Tobie nie to chyba jakas pomylka przy montazu i my tego nie sprawdzimy a jedynie Ty mozesz to zrobic..
    Czytales instrukcje jak uruchamiac?

  • #93 04 Maj 2008 12:42
    lukasb9
    Poziom 28  

    W willemie jest opcja programowania tego pic-a z offsetem trzeba ją odznaczyć, ja się na tym złapałem robiąc ten miernik.

  • #94 04 Maj 2008 12:58
    bokuden
    Poziom 15  

    Witam
    Napiecie ujemne jest,wynosi -4,7V.
    Nawet jak jest wypiete zasilanie PIC'a,tez mam taki sam efekt na lcd,wynika z tego,ze cos jest skopane wlasnie tutaj.
    Dzisiaj nie mam juz mozliwosci przeprogramowania z odhaczonym offfsetem,sprobuje jutro i dam znac.
    Pozdrawiam

  • #95 04 Maj 2008 21:46
    Calineczka*
    Poziom 31  

    Czekamy Bokuden na relacje z kolejnych chwil walk z niedzialajacym mierniczkiem...dzisiaj na gg wspolnie do czegos doszlismy...jutro testy ;-)

  • #96 04 Maj 2008 22:12
    rubens
    VIP Zasłużony dla elektroda

    Jeśli chodzi o programowanie to co za problem sczytać zawartość PIC-a i porównać z buforem.

  • #97 04 Maj 2008 22:22
    Calineczka*
    Poziom 31  

    Rubens, moze tak, moze nie...ja mam dwa willemy i na starszym, ktory niejedno przeszedl, wsio programowalo sie ok, weryfikacja OK a PIC w nim zaprogramowany nie dzialal, w tym drugim z kolei bez problemu.Chcesz miec pewnosc to trzeba sprawdzic wszystko...co jest mozliwe ;-)

  • #98 04 Maj 2008 22:32
    lukasb9
    Poziom 28  

    Jeśli wyświetlacz pokazuje tylko jedną linie prostokątów, oznacza to, że najprawdopodobniej jest sprawny i nic go nie inicjuje. A to z kolei oznacza, że albo z procesorem jest coś nie tak (program, uszkodzony procesor) lub z połączeniami do wyświetlacza. Skoro PIC się zaprogramował można uznać, że procesor jest ok. Pisałem o offsecie - nie wiem do czego ta opcja służy może przesuwa obszar danych dla jakiegoś bootloadera? - nie wiem... wiem natomiast, że z zaznaczoną ta opcją wszystko ładnie wchodzi do pic-a i się weryfikuje, tak samo dzieje się również przy odznaczonym "ptaszku" ale program w picu należy w grać po odznaczeniu tego ptaszka.

  • #99 05 Maj 2008 07:35
    rubens
    VIP Zasłużony dla elektroda

    -generalnie jak dla mnie to sprawa jest prosta
    Do tego aby wyświetlacz cokolwiek wyświetlał wystarczy aby miał połączenie z PIC-em, PIC był poprawnie zaprogramowany, miał zasilanie i masę, kwarc był sprawny i nie blokowany pojemnościami.
    Sprawdź czy masz +5V na 1 i 20-ce, masę na 19-ce.
    Jeśli masz oscyloskop trzeba by podpiąć się do kwarca i zobaczyć czy rezonuje.
    W układzie ważne jest (przy braku płytki dwustronnej) wykonanie kilkudziesięciu połączeń kynarem.
    Mi pierwsze trzy mierniki odpaliły od razu a czwarty nie mierzył - przyczyna prozaiczna - brak było jednego odcinka kynaru .
    Jeśli C5 i CC7 będą miały 22n a nie 22p to będą blokować kwarc.
    Stawiam albo faktycznie na błąd programowania albo brak zasilania pica.

    Jeśli chodzi o willema to u mnie po wybraniu wsadu automatycznie ustawiają się opcje.
    Jak do tej pory raz musiałem przestawiać opcje w willemie ale to było dla programowania PIC-a do testera ( miernika) parametrów tranzystorów i diod.

  • #101 05 Maj 2008 10:00
    Balu
    Poziom 38  

    górne cyfry? Czy górne pola? Bo to duża różnica:>
    Znaczy na górze same kwadraty są? Czy są jakieś cyfry tam?
    Jak cyfry to LCD z śmiesznie rozłożoną pamięcią:>

  • #102 05 Maj 2008 10:22
    bokuden
    Poziom 15  

    Witam
    Swieca sie wszystkie gorne pola wyswietlacza,nie ma zadnych cyfr.
    Ale juz jest wszystko O.K.,skorzystalem ze starszej wersji softu Willema i zaprogramowalem ponownie,pojawilo sie to,co powinno sie pojawic.
    Pozdrawiam

  • #103 05 Maj 2008 10:37
    lukasb9
    Poziom 28  

    No właśnie pisałęm o opcji "skip write 0x3FFF" pewnie starsza wersja softu willema niema takich bajerów - tak czy inaczej dobże , że się udało uruchomić miernik.

  • #104 05 Maj 2008 12:19
    bokuden
    Poziom 15  

    Witam
    Miernik odpala sie normalnie,wiec powinien dzialac.
    Teraz pytanie-gdzie kliknac "pomogl",aby wyrazic podziekowanie ludziom,ktorzy pomogli?
    Czy to moze zrobic tylko osoba,ktora zaklada temat?
    Poza tym-pare elementow ma inne wartosci-nie moglem dostac wlasciwych,kilka rezystorow i tranzystor mosfet.Jakie wkladaliscie mosfety do swoich miernikow?
    Pozdrawiam

  • #105 05 Maj 2008 13:00
    rubens
    VIP Zasłużony dla elektroda

    -może być IRF640 i 840
    Kluczowe są wartości elementów ustalających pracę wzmacniaczy i tu nie należy kombinować.

  • #106 05 Maj 2008 23:31
    bokuden
    Poziom 15  

    Witam
    Problem mam tylko ze zdobyciem rezystorow 2k smd i 360k smd,u rosjan jest to 330k,wiec tu nie problem.
    Przeczytalem opis kalibacji,ale nie bardzo kapuje go.
    Gdzie sa te punkty pomiarowe-TPA i TPDZ?
    Pozdrawiam

  • #107 07 Maj 2008 19:51
    bokuden
    Poziom 15  

    Witam
    Mam jeszcze jedno pytanko do osob,ktore zlozyly ten miernik.
    Mianowicie co trzeba zrobic z ekranami przewodow pomiarowych?
    I wogole do czego sluza dwa dolne zaciski?
    Miernik juz zaczyna pracowac,tzn. pokazuje wartosci,daje sie wejsc w tryby,ale czy wlasciwie?
    Pozdrawiam

  • #108 09 Maj 2008 08:23
    bokuden
    Poziom 15  

    Witam
    Kolejny dzien prob i chyba nie pracuje wlasciwie.
    Chodzi o to,ze pojemnosc pokazuje zawsze z napisu na obudowie x2.
    Po odpaleniuu nie pokazuje pojemnosci,natomiast esr=12,044 ohm.
    Po zwarciu zaciskow pokazuje 0,04 na wskazniku esr,kondensatory mierzy zawsze 2x,natomiast po podlaczeniu nowego kondensatora 1500uF pokazuje
    pojemnosc 4,12uF i esr 0,052.
    W czym moze tkwic blad?
    Montaz na 100% jest wlasciwy,sprawdzalem dwukrotnie.
    Pozdrawiam

  • #109 09 Maj 2008 11:07
    sq6fmy
    Poziom 22  

    Panowie, sprawdził ktoś czy PIC 876 ale z literką A na koncu działa?

  • #110 09 Maj 2008 11:17
    Calineczka*
    Poziom 31  

    Bokuden,czyli po uzyciu innej wersji softu willema, i to starszej, jest ok?
    Wydaje mi sie, ze gdzies masz jakis problem z montazem...moze zamieniles rezystorki...jakies mikrozwarcie czy przerwa....bo trzeba przyznac ze wszystko jest dobrze opracowane, bledow nie ma, instrukcja uruchamiania jest a kazdy z nas jak mial klopoty to byly to bledy montazowe...wiec cierpliwosci i do dziela;-)

  • #111 09 Maj 2008 13:39
    lukasb9
    Poziom 28  

    bokuden - kalibrowałeś miernik zgodnie z opisem?
    co do wyjśc miernika, dwa z nich to wyjścia prądowe, pozostale dwa to wejścia sygnałowe.

    Cytat:
    I wogole do czego sluza dwa dolne zaciski?

    Napisz jak podłączasz badany kondensator, powinieneś zewrzeć gniazdo 1 z 3 arków i 2 z 4 i dopiero podłączyć badany kondensator. Jeśli używasz przewodów pomiarowych te połączenia musisz wykonać na ich końcach.

  • #112 09 Maj 2008 13:49
    rubens
    VIP Zasłużony dla elektroda

    PIC 876 ale z literką A na końcu działa?
    ----------------------------------------------
    Działa

  • #113 09 Maj 2008 16:09
    sq6fmy
    Poziom 22  

    -> Rubens

    Dziekuje za informacje. Akurat mam taki więc biore się za wykonanie przyrządu.

  • #114 09 Maj 2008 23:20
    bokuden
    Poziom 15  

    Witanm
    Wydaje mi sie,ze popelnilem blad w rozumowaniu.
    Wychodzi mi na to,ze wspolczynnik korekcji nie powinien byc wysoki,jak zakladalem,ale niski.W tej chwili zrobilem dla cx wspolczynnik 0,360 i zaczyna to funkcjonowac tak,jak powinno.
    Nie mam co prawda wzorcowej pojemnosci,ale jestem chyba na dobrej drodze.Wzorcowe rezystancje mam,z tym nie problem.
    Pozdrawiam

  • #115 10 Maj 2008 09:04
    rubens
    VIP Zasłużony dla elektroda

    -bardzo kiepski współczynnik korekcji - oznacza że układ jest źle złożony
    -miałem jeden miernik gdzie współczynnik korekcji trzeba było zmienić tylko plus, minus 3
    -standardowo jest to wartość plus, minus kilka- kilkanaście

  • #116 10 Maj 2008 10:49
    bokuden
    Poziom 15  

    Witam
    Ten wspolczynnik jest taki kiepski tylko dla pomiaru pojemnosci,na pomiarze rezystancji jest w porzadku.Nie wiem,moze to wina mosfeta,bo wstawilem nieoryginalny,IRF840 zamiast IRF530.
    Zakupilem oryginaly,sa w drodze,sprobuje na nich.
    Pozdrawiam

  • #117 10 Maj 2008 10:51
    sq6fmy
    Poziom 22  

    Miernik uruchomiłem na pic16f876A (wsad w wersji 1.1). Działa poprawnie. Współczynniki korekcji raczej niewielkie (niespecjalnie mi zależy na dokładnej kalibracji). Elementy standardowe - zero nie pływa. Potwierdzam, że to udana konstrukcja.

    Przy podłączaniu LCD koniecznie zweryfikować nóżki 1 i 2 wyświetlacza. Typowo na 1 jest masa a na 2 Vcc. Płytka jest zaprojektowana pod wyświetlacz z Vcc na 1 i masą na 2 (esr_pcb_poprawiony.pdf z elektrody).

    W przypadku problemów z Willemem pod XP można użyć programu WinPIC800, który także obsługuje hardware Willema.

  • #118 10 Maj 2008 11:13
    0__0
    Poziom 30  

    Panowie jakie najnizsze esr moze mierzyc ten miernik?
    Na obudowie jest ze od 0 ale cos nie chce mi sie wierzyc.
    Chodzi o to czy nadaje sie on do pomiarow kondensatorow low esr ktore dobre maja esr rzedu miliomow np
    http://www.edc.sanyo.com/english/news/2003/sepc_e.pdf a niesprawne z 5 razy wieksza - czy czasami nie jest tak ze w obu przypadkach ten miernik pokaze zero? - to jest typowa wada wielu miernikow esr - słaba rozdzielczosc i brak niskich zakresow pomiarowych .

  • #119 10 Maj 2008 13:53
    rubens
    VIP Zasłużony dla elektroda

    -kolego - a ja nie wierzę że takich kondensatorów jakie opisujesz jest dużo na rynku w wielu układach
    -mogę zrobić Ci gratisowy test - przyślij do mnie kilka nowych low elek i kilka uszkodzonych :)

  • #120 11 Maj 2008 11:43
    bokuden
    Poziom 15  

    Witam
    Montaz byl wlasciwy,natomiast wartosci elementow nie zgadzaly sie z oznaczeniami.Zmierzylem wszystkie rezystory,dokonalem poprawek i dziala tak,jak ma dzialac.
    Dziekuje serdecznie wszystkim za pomoc.
    Pozdrawiam
    P.S.
    Czy ktos jest zainteresowany plytka z kompletem elementow do tego miernika?