Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Programowanie AT91SAM7S64

Dziekan 24 Sty 2008 23:25 1484 3
  • #1 24 Sty 2008 23:25
    Dziekan
    Poziom 13  

    Witam

    Mój problem polega na tym że muszę zaprogramować mikrokontroler AT91SAM7S64 zaprojektowałem płytkę na której mam moduł cc1000 który ma sterować robotem wszystko było ok do czasu programowania ARM-a, muszę go zaprogramować w taki sposób aby był skonfigurowany na odbiór z interfejsu UART, ponieważ do UART-a będzie podczepiony moduł bluetooth BT330 w celu odbierania danych, mam przykładowy program z obsługą tego modułu z USB bezpośrednio z komputera i wszystko jest ok ale nie bardzo znam sie na programowaniu w Eclipse, i w konfiguracji tego środowiska tez potrzebuje trochę pomocy.
    Jeśli ktoś byłby chętny mi pomóc będę bardzo wdzięczny.
    pozdrawiam Michał

    0 3
  • #2 27 Sty 2008 01:34
    Dziekan
    Poziom 13  

    czy ktoś na tym forum zna sie na tym o czym tutaj ludzie piszą? bo mam wrażenie że albo nikt elektrody nie odwiedza albo zadaje za trudne pytania?

    0
  • #3 27 Sty 2008 14:20
    adamusx
    Poziom 27  

    Sprecyzuj dokładniej pytanie. Nikt za Ciebie całego problemu nie rozwiąże. Napisałes tylko tyle, ze nie potafisz zaprogramnowac ARMa.. No i co z tym fantem teraz? Przeciez nikt Ci nie napisze krok po kroku co zrobic . Na forum jest sporo postów na ten temat. Radze sie najpierw z nimi zapoznac. Zacznij od skonfigurowania srodowiska Eclipse z WinARem czy GnuARMem. Jest pelno instrukcji do tego, trzeba tylko poszukac. Jak juz poinstalujesz i skonfigurujesz a nie bedzie działało to dopiero pytaj o konkretny problem.
    KIlka pierwszych postow na ten temat:
    https://www.elektroda.pl/rtvforum/viewtopic.ph...e+winarm&sid=becaa4cd3120f5ce31d0ad67295fb4dc
    https://www.elektroda.pl/rtvforum/viewtopic.ph...e+winarm&sid=becaa4cd3120f5ce31d0ad67295fb4dc
    a także konfiguracja troche innego srodowiska: http://www.adamusx.ovh.org/index.php?url=uC_1

    0
  • #4 27 Sty 2008 19:44
    Dziekan
    Poziom 13  

    nie mogłem skonfigurować środowiska ale chyba sie udało mimo że wywala jakiś błąd po dodaniu openOCD do eclipsa tworzy mi jakiś plik .bin ale jak przerobić program żeby działał uart to nie wiem, dobrze piszesz że nikt za mnie nie zrobi a temat to moge sprecyzować jeśli ktoś sie tym bardziej zainteresuje bo to nie jest chyba takie proste.

    pozdrawiam i dzieki za odp

    0